TIBCO.SMARTSOCKETS

SmartSockets .NET Class Library

TIBCO.SMARTSOCKETS Namespace

Namespace hierarchy

Classes

Class | Description
TipcAccessDeniedException | Thrown when the RTserver denies access to this process. Typically the processes' ss.unique_subject option is not unique.
TipcAlreadyExistsException | Thrown when the object already exists. For example, when createMt is used to create a new message type.
TipcAlreadySubscribedException | Thrown when subscribing to a subject to which the client has already subscribed.
TipcAssertionException | Thrown when a fatal runtime exception occurs and by assert when the condition fails.
TipcBadArgumentException | Thrown when a bad argument is passed to a method.
TipcCache

Provides methods to access the messages cached by the SmartSockets Cache daemon.

TipcCb Holds a reference to a callback entry. This class cannot be directly created by the user. Instead, instances are returned when adding, looking up, and destroying callbacks from the TipcConnClient and TipcSrv classes.

This class allows the properties of the callback to be altered.

TipcConnClient Handles client end of peer-to-peer connections.

An instance of this class is created through a factory class by createConnClient method.

The server created with createConnServer must be running before the client is created, otherwise the client has no one to connect to, and will fail.

The implementing class for client connections uses 2 internal threads to send and receive messages. A reader thread constantly fills an inbound queue of message as traffic arrives. Calling next will pop the messages from the queue. A writer thread sends messages pushed onto the outbound queue by send when flush is called.

Any TipcIOException thrown by the methods of this class should be considered fatal. The connection instance should be discarded, and a new connection made in its place. The responsibility for maintaining a connection is up to the user application.

TipcConnServer | Handles the server end of peer-to-peer connection. This class only allows a "listening post" to be created for accepting new connections. All actual communication is done using the TipcConnClient class returned by the accept method.
TipcErrorEventArgs | This class contains event data for the TipcErrorEvent.
TipcException Superclass of all SmartSockets exceptions.

This class defines an error number which may be set for some errors.

TipcFileNotFoundException | Thrown when a file does not exist or is inaccessible.
TipcInterruptedException Thrown when a thread is interrupted by Thread.interrupt while waiting for a message to arrive.

This exception can be thrown by check, next, check, sendRpc, mainLoop, read, next, search, searchType, searchType

TipcIOException | Thrown when a low-level IOException occurs, such as a socket connection is refused or a socket connection is lost.
TipcMalformedURLException | Thrown to indicate an invalid URL.
TipcMon This class provides a set of static methods that allow a RTclient to monitor a SmartSockets application.

Note: There are two versions of each method in this class. When multiple RTserver connections are created by the createSrv method, then the version that requires a TipcSrv object as its first argument should be used. If the RTserver connection was created using the Srv property, then use the version that does not take a TipcSrv object as its first argument.

The publish-subscribe architecture of SmartSockets allows RTclient process to easily send messages to each other, independent of where they reside on the network. In addition to enabling easy development of distributed applications, RTserver, RTmon, and RTclient processes also have monitoring capabilities built in. These additional services help to examine detailed information about your project, as well as determining where processes are located in your network.

From within an RTclient, hundreds of pieces of information can be gathered in real time about all parts of a running SmartSockets project, including:

  • RTclients -- names, message buffers, message traffic statistics, message types, options, node they are on, subjects subscribed to, and so on
  • RTservers -- names, message buffers, message traffic statistics, connections, options, CPU usage, memory usage, node they are on, options, current time, and so on
  • Subjects -- names, RTclients that are subscribing, and so on
  • Projects -- names

This information can be either polled once to provide a one-time snapshot of information or watched to provide asynchronous updates when changes occur. A monitoring request can specify either a specific object or all objects matching a wildcard scope filter. The information is delivered to the requesting program in standard message types TipcMt_Fields.MON_* The fields of these message types contain the information the RTclient is interested in.

All monitoring of a SmartSockets project goes through RTserver. Typically, a request for particular information is sent to RTserver, then RTserver proceeds in one of these ways:

  • RTserver accesses the information in its internal tables and sends it back to the requesting RTclient.
  • RTserver forwards the request to another RTclient or RTserver, which retrieves the information and sends it back to the first RTserver (to be delivered back to the requesting RTclient).
  • RTserver notifies RTclient or RTserver to send the information whenever it changes. When it does change, RTserver receives the information and sends it to the RTclient that made the original request.

To initiate a monitoring request in an RTclient, call one of the functions in the TipcMon class. This sends a message of type TipcMt_Fields.MON_*_POLL_CALL or TipcMt_Fields.MON_*_SET_WATCH to the RTserver. The information is returned to the program by an RTserver using a TipcMt_Fields.MON_*_POLL_RESULT or TipcMt_Fields.MON_*_STATUS message. When the information returns, an RTclient message process callback (created with addProcessCb can be used to process the message.

The ss.monitor_scope option specifies the level of interest for SmartSockets monitoring in those monitoring categories with no parameters (such as RTclient names poll) or an RTclient or RTserver parameter of ALL (such as subject subscribe watch). ss.monitor_scope acts as a filter that prevents a large project from overloading a monitoring program. The default is "/*", which matches all subject names at the first level of the hierarchical subject namespace. All monitoring information is enabled (all filtering is disabled) if ss.monitor_scope is set to "/...", which matches all names. The value "/..." should be used with caution on large projects, as this gathers monitoring information for the entire project, and may cause noticeable peformance degradation.

Polling for information allows you to receive a one-time snapshot of information. Polling can be done at regular time intervals by issuing poll requests repeatedly. All polling of a project goes through RTserver. Typically, a request for particular information is sent to RTserver, then RTserver retrieves the information from its internal tables, from other RTservers, or from RTclients and sends it back to the requesting program.

When the results of a poll are returned in a TipcMt_Fields.MON_*_POLL_RESULT message, the message is processed in one of these two ways:

  • blocking and using the searchType method to search for the message containing the poll results
  • using an RTclient message process callback (created with addProcessCb

Typically, after performing a one-time poll for information, the program blocks and waits for the result before continuing. An example of this is to find out if any RTclients are subscribing to a subject before sending a message. When polling often, or watching for information, using callbacks is usually the preferred method, as it is unclear when the monitoring results may be returned to the program.

Watching information is very different from polling. When watching information, the RTclient that initiated the watch is notified asynchronously, through a message, whenever the item(s) of interest changes. All watching of a project goes through RTserver. Typically, a request to watch particular information is sent to RTserver. RTserver then notifies the process holding the information (the same RTserver, a different RTserver, or an RTclient) that a program is interested in watching the specified information. Then, whenever the information changes, the process holding the information sends it back to the requesting program in a message. Unlike polling, which is a one time request for information, watching causes status messages to continue to be sent until watching is turned off for that particular information.

To set up watching in your program, you set the watch status for the type of information of interest to true. In a similar fashion, watching is turned off by setting the watch status to false.

When the results of a watch are returned in a TipcMt_Fields.MON_*_STATUS message, the message can be processed using an RTclient message process callback (created with addProcessCb). Using callbacks to process the status messages that are returned as the result of a watch being enabled is the recommended method for processing watch results. The main reason for this is that the messages arrive asynchronously. It is often unclear as to when or how often the information may change.

TipcMonExt This class provides a set of static methods that provide the monitoring extensions for an RTclient.

Note: There are two versions of each method in this class. When multiple RTserver connections are created by the createSrv method, then the version that requires a TipcSrv object as its first argument should be used. If the RTserver connection was created using the Srv property, then use the version that does not take a TipcSrv object as its first argument.

TipcMsg Provides access to message objects.

Messages can only be created from the TipcSvc factory class with createMsg.

A message consists of a type TipcMt, properties, and zero or more fields. The field types are used to convert the field data from the format used by the sending platform to the format used by the receiving platform (byte order, etc.). These types are:

BINARY - an array of uninterpreted bytes (byte[])
CHAR   - a character (char)
STR    - an array of signed bytes representing a string (String)
INT2   - a signed 2 byte integer (short)
INT4   - a signed 4 byte integer (int)
INT8   - a signed 8 byte integer (long)
REAL4  - a 4 byte real number (float)
REAL8  - an 8 byte real number (double)
REAL16 - a 16 byte real number (unsupported by .NET)
MSG    - an embedded SmartSockets message (TipcMsg)
BOOL   - a boolean value (boolean)
BYTE   - a single byte (byte)
UTF8   - an array of bytes representing a UTF-8 encoded string (String)
XML    - a XML object (TutXml)
OBJECT - a .NET object (Object)

TipcMsgBadFieldException | Thrown when attempting to access a TipcMsg field using the incorrect type.
TipcMsgEnumerator

A helper class that implements the Enumeration interface and returns TipcMsgEnumeratorElement when the nextElement method is invoked.

TipcMsgEnumeratorElement

This is the Object that is returned when nextElement is invoked. This object can then be used to retrieve the appropriate field based on type.

TipcMsg msg = null;
char c = 'a';
short short_value = 10;
TipcMsgEnumerator msgEnumerator = null;
try {
  msg = TipcSvc.createMsg(TipcMt_Fields.INFO);
  msg.appendChar(c);
  msg.appendUnknown(TipcMsg_Fields.FT_INT4);
  msg.appendInt2(short_value);
  msg.addNamedStr("test str name", "test str value");

  msgEnumerator = msg.Enumerator;

  TipcMsgEnumeratorElement enum_element = null;
  while(msgEnumerator.hasMoreElements()) {
    enum_element = (TipcMsgEnumeratorElement)msgEnumerator.nextElement();

    System.out.println("index = " + enum_element.Index);
    System.out.println("isNamed = " + enum_element.Named);
    if (enum_element.Named) {
      System.out.println("Named field's name = " + enum_element.Name);
    }
    if (enum_element.Type == TipcMsg_Fields.FT_CHAR) {
      System.out.println("CHAR VALUE = " + enum_element.Char);
    }
    if (enum_element.Type == TipcMsg_Fields.FT_INT2) {
      System.out.println("INT2 VALUE = " + enum_element.Int2);
    }
    if (enum_element.Type == TipcMsg_Fields.FT_STR) {
      System.out.println("STR VALUE = " + enum_element.Str);
    }
  }
}  catch (TipcException e) { System.out.println(e.Message); }
TipcMsgEomException | Thrown when attempting to read past the end of a TipcMsg.
TipcMsgEventArgs | This class contains event data for the TipcMsgEvent.
TipcMsgException | Thrown when an error occurs parsing a TipcMsg.
TipcMsgUnknownFieldException | Thrown during an attempt to read a TipcMsg field that is marked as "unknown".
TipcMt Provides access to the message type class.

This interface is used by TipcMt objects returned from the TipcSvc factory class to createMt user-defined message types and to lookupMt both user-defined messages types and standard SmartSockets message types.

The identifiers for the standard SmartSockets message types are contained in the TipcMt_Fields structure.

Note: All user-defined message type numbers must be greater than zero. All SmartSockets-defined message type numbers are less than zero. Zero is not a valid message type number.

TipcNotFoundException | Thrown when the requested object is not found by a method.
TipcNotSubscribedException | Thrown when unsubscribing from a subject not currently subscribed to by the client.
TipcOption Represents one option setting. This class may not be created directly, but is instead returned by Tut.createOption, Tut.getOption, and Tut.removeOption.

The options database consists of a table of these objects. When a Property database is loaded, these objects are automatically created.

The value of all options is a String. However, these may be extracted as a boolean, an int, a double, or a Vector of Strings if the value contains a comma-separated list. Also, String values can be verified against a list of legal values (Enum), or mapped to a list of integers (EnumMap).

To set the value of a standard SmartSockets option, you may either get the TipcOption instance for that option, or you can use a convenience method:

TipcOption opt = Tut.getOption("ss.project");
opt.setValue("foo");
- or -
Tut.setOption("ss.project", "foo");

Options must be created before they can be set, retrieved, or removed. All of the standard SmartSockets options are created when the process starts up. If you wish to add your own options, you must use Tut.createOption to create the option and add it to the options table:

TipcOption opt = Tut.createOption("foo", "bar");
...
TipcOption opt = Tut.getOption("foo");
String s = opt.getValueStr();
- or -
String s = Tut.getOptionStr("foo");

If you wish to create an Enum or EnumMap option, you must then add a list of legal values to the option with addEnumLegalValue and addEnumMapLegalValue. Enums and EnumMaps cannot be intermixed; a given option must support one or the other, not both:

TipcOption opt = Tut.createOption("enum_foo", "baz");
opt.addEnumMapLegalValue("baz", 0);
opt.addEnumMapLegalValue("bat", 1);
opt.addEnumMapLegalValue("bark", 2);
...
TipcOption opt = Tut.getOption("enum_foo");
int i = opt.getValueEnumMap();

TipcProperties | Table of TipcOption objects, which can contain another table as its defaults; this second collection is searched if the TipcOption is not found in the original table.
TipcProtocolMismatchException | Thrown trying to send a message to an incompatible peer or server.
TipcProxyException | Thrown when a proxy server returns an error.
TipcQueueEventArgs | This class contains event data for the TipcQueueEvent.
TipcReadEventArgs | This class contains event data for the TipcReadEvent.
TipcReadOnlyException | Thrown when the requested object is readonly by a method.
TipcRuntimeException | Superclass of all SmartSockets runtime exceptions.
TipcSrv Provides an interface to RTserver connections.

The single, global RTserver connection instance of this class is returned through Srv.

This is a subclass of TipcConnClient, and much of the interesting functionality is provided by that class.

An RTserver must be running before any attempt is made to connect to it. This class will automatically try to connect to any RTservers that appear in the"ss.server_names" option, trying each RTserver in turn until it successfully connects to one.

TipcSrvAlreadyConnectedException | Thrown when a method requires no connection to the RTserver and a connection already exists.
TipcSrvCreateEventArgs | This class contains event data for the TipcSrvCreateEvent.
TipcSrvDestroyEventArgs | This class contains event data for the TipcSrvDestroyEvent.
TipcSrvNotConnectedException | Thrown when a method requires a connection to the RTserver and the connection does not exist.
TipcSvc

A static factory class for the TipcMt, TipcMsg, TipcConnClient, TipcConnServer, and TipcSrv interfaces. Objects of the required concrete classes that implement these interfaces are created with this class.

For example, to create a connection to the RTserver and to create and send a SmartSockets message on the connection, you would do the following:

// get the connection to the RTserver from the factory
TipcSrv srv = TipcSvc.Srv;

// create an INFO message from the factory
TipcMsg msg = TipcSvc.createMsg(TipcMt_Fields.INFO);

// publish the INFO message to the "/foo" subject on the connection
msg.setDest("/foo");
srv.send(msg);
TipcTimeoutException | Thrown if a timeout occurs while attempting to establish a connection.
TipcUtf8Buffer | A holder class for return object from the Tut.convertUcs2ToUtf8Ex method
TipcWouldBlockException | Thrown if an attempt to send or flush would block and the non-blocking mode is set.
TipcWriteBufferChangeEventArgs | This class contains event data for the TipcWriteBufferChangeEvent.
TipcWriteEventArgs | This class contains event data for the TipcWriteEvent.
Trace | Trace encapsulates the tracing facility, allowing users to associate trace levels with their log messages.
Tut A collection of static utility methods.

All handling of settable global options is done here and in the TipcOption class. Options may also be set on a per connection basis through the TipcConnClient interface.

Options are loaded using the Properties mechanism, which requires text files containing key/value pairs. These files can either be loaded from the local filesystem, or remotely via a URL.

The keys in a property file are, by convention, stated in a heirarchy using dots as a separator. All SmartSockets options are in the "ss" hierarchy, so all of them start with "ss.". An example of an options file would be:

ss.project: sat1
ss.server_auto_connect: false
ss.unique_subject: node1
Option names and values are case-sensitive. There are methods in this class to extract values as strings, integers, doubles, booleans, and enumerated values. For enumerations, there are methods to set the list of valid values, and their corresponding int values.

TutXml | Represents an XML object that can be sent within a SmartSockets message.
Version | SmartSockets version class.

Interfaces

Interface | Description
TipcCreateCb The user interface for the RTclient's server create callbacks.

Server create callbacks are called when an RTclient creates either a full or warm connection to the RTserver. If an RTclient creates and destoys its connection to the RTserver many times, it should use server create callbacks to create the other callbacks needed in the connection to RTserver.

TipcDefaultCb The user interface for connection default callbacks.

Connection default callbacks are executed while processing a message if a process callback specific to the message type and/or destination has not been called. Default callbacks are useful for processing unexpected messages or for generic processing of most message types. For example, you have a client process to manage and display alarm messages. The only process callback you would want for that client process would be for messages of type "alarm". You could then write a default callback to process any other type of data received and display a warning.

TipcDestroyCb The user interface for the RTclient's server destroy callbacks.

Server destroy callbacks are called when an RTclient destroys its connection to the RTserver, leaving either a warm connection or no connection. Server destroy callbacks are the opposite of server create callbacks.

Server destroy callbacks are useful for RTclients that need to know when the connection to the RTserver no longer has a valid socket, such as RTclients that are also GUI programs.

TipcErrorCb The user interface for connection error callbacks.

Connection error callbacks are executed when an unrecoverable error occurs. These errors include socket problems and network failures such as:

  • A read timeout has occured and the keep-alive then failed.
  • A write timeout has occured.
  • A read operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.
  • A write operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.

TipcSrv automatically registers a default error callback that attempts to reconnect to the RTserver when the connection is lost. This default error callback may be replaced by first getting the default error callback with DefaultErrorCb, removing it with removeErrorCb, and adding your own error callback with addErrorCb.

TipcProcessCb The user interface for connection process callbacks.

Connection process callbacks are executed while processing a message. This callback type is the most frequently used. A process callback can be called for a specific type of message, on a specific subject (destination), or created globally and called for all messages. For example, a process callback can be created for the INFO message type. When any message of that type is processed by calling process or mainLoop, the process callback is called. If the process callback is created globally, it is called for all INFO messages as well as any other type of message.

TipcQueueCb The user interface for connection queue callbacks.

Connection queue callbacks are executed when a message is inserted into or deleted from a connection's message queue. Queue callbacks are useful for watching the messages that have been read in from a connection's socket and inserted into the message queue, but not yet processed.

TipcReadCb The user interface for connection read callbacks.

Connection read callbacks are executed when an incoming message is read from a connection's socket into the read buffer and first unpacked into a message. Read callbacks are most commonly used for writing incoming messages to message files.

TipcSearcher | The user interface for the search function required by search. This method will be called as the connection's message queue is traversed. This method should return true if the message matches the required criteria, false if it does not.
TipcWriteBufferChangeCb The user interface for write buffer change callbacks.

Write buffer change callbacks are executed when data is either flushed from the write buffer or written into write buffer THROUGH the message interface (i.e. with send(msg)) ONLY.

The TipcDataOutput write() methods themselves are accessible throughout this package. If data is added to write buffer by calling them directly, this will NOT trigger the write buffer change callbacks. This is because the purpose of the write buffer change callback is to allow the sending of client congestion messages. When the callback is triggered, if the congestion threshold has now been met, a congestion message will be sent out. This means that triggering the callbacks may result in data being written into the write buffer.

This, of course, cannot be allowed to happen in the middle of a message write. A congestion message must only be allowed to be written into the buffer when the logical write (not just the write() method call-- a logical write can consist of more than one call to the write() method; see TipcMsgImpl.writeWire() for an example) has been completed. Therefore, the writing of a message will trigger the write buffer change callback only AFTER the full message has been written (which involves possibly mutliple calls to the write() method).

By contrast, if the write() methods are invoked directly, outside of the message writing framework, there is no way to know, at the end of the write() method, whether or not the logical write has been completed. Therefore, there is no way to know if congestion message data may be safely added to the buffer at that time.

TipcWriteCb The user interface for connection write callbacks.

Connection write callbacks are executed when an outgoing message is sent to a connection (that is, copied to a connection's write buffer). Write callbacks are most commonly used for writing outgoing messages to message files.

Structures

Structure | Description
TipcDefs | Constants common to several interfaces.
TipcMsg_Fields Provides access to message objects.

Messages can only be created from the TipcSvc factory class with createMsg.

A message consists of a type TipcMt, properties, and zero or more fields. The field types are used to convert the field data from the format used by the sending platform to the format used by the receiving platform (byte order, etc.). These types are:

BINARY - an array of uninterpreted bytes (byte[])
CHAR   - a character (char)
STR    - an array of signed bytes representing a string (String)
INT2   - a signed 2 byte integer (short)
INT4   - a signed 4 byte integer (int)
INT8   - a signed 8 byte integer (long)
REAL4  - a 4 byte real number (float)
REAL8  - an 8 byte real number (double)
REAL16 - a 16 byte real number (unsupported by .NET)
MSG    - an embedded SmartSockets message (TipcMsg)
BOOL   - a boolean value (boolean)
BYTE   - a single byte (byte)
UTF8   - an array of bytes representing a UTF-8 encoded string (String)
XML    - a XML object (TutXml)
OBJECT - a .NET object (Object)

TipcMt_Fields | Provides access to the identifiers for the standard SmartSockets message types.

Delegates

Delegate | Description
TipcErrorHandler | Represents the method that will handle the TipcErrorEvent event.
TipcMsgHandler | Represents the method that will handle the TipcMsgEvent event.
TipcQueueHandler | Represents the method that will handle the TipcQueueEvent event.
TipcReadHandler | Represents the method that will handle the TipcReadEvent event.
TipcSrvCreateHandler | Represents the method that will handle the TipcSrvCreateEvent event.
TipcSrvDestroyHandler | Represents the method that will handle the TipcSrvDestroyEvent event.
TipcWriteBufferChangeHandler | Represents the method that will handle the TipcWriteBufferChangeEvent event.
TipcWriteHandler | Represents the method that will handle the TipcWriteEvent event.


TipcAccessDeniedException Class

Thrown when the RTserver denies access to this process. Typically the processes' ss.unique_subject option is not unique.

For a list of all members of this type, see TipcAccessDeniedException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcAccessDeniedException

public class TipcAccessDeniedException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcAccessDeniedException Members | TIBCO.SMARTSOCKETS Namespace


TipcAccessDeniedException Members

TipcAccessDeniedException overview

Public Instance Constructors

TipcAccessDeniedException Overloaded. Initializes a new instance of the TipcAccessDeniedException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcAccessDeniedException Class | TIBCO.SMARTSOCKETS Namespace


TipcAccessDeniedException Constructor

Constructs a TipcAccessDeniedException with null as its error message string.

Overload List

Constructs a TipcAccessDeniedException with null as its error message string.

public TipcAccessDeniedException();

Constructs a TipcAccessDeniedException with an error message.

public TipcAccessDeniedException(string);

See Also

TipcAccessDeniedException Class | TIBCO.SMARTSOCKETS Namespace


TipcAccessDeniedException Constructor ()

Constructs a TipcAccessDeniedException with null as its error message string.

public TipcAccessDeniedException();

See Also

TipcAccessDeniedException Class | TIBCO.SMARTSOCKETS Namespace | TipcAccessDeniedException Constructor Overload List


TipcAccessDeniedException Constructor (String)

Constructs a TipcAccessDeniedException with an error message.

public TipcAccessDeniedException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcAccessDeniedException Class | TIBCO.SMARTSOCKETS Namespace | TipcAccessDeniedException Constructor Overload List


TipcAlreadyExistsException Class

Thrown when the object already exists. For example, when createMt is used to create a new message type.

For a list of all members of this type, see TipcAlreadyExistsException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcAlreadyExistsException

public class TipcAlreadyExistsException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcAlreadyExistsException Members | TIBCO.SMARTSOCKETS Namespace


TipcAlreadyExistsException Members

TipcAlreadyExistsException overview

Public Instance Constructors

TipcAlreadyExistsException Overloaded. Initializes a new instance of the TipcAlreadyExistsException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcAlreadyExistsException Class | TIBCO.SMARTSOCKETS Namespace


TipcAlreadyExistsException Constructor

Constructs a TipcAlreadyExistsException with null as its error message string.

Overload List

Constructs a TipcAlreadyExistsException with null as its error message string.

public TipcAlreadyExistsException();

Constructs a TipcAlreadyExistsException with an error message.

public TipcAlreadyExistsException(string);

See Also

TipcAlreadyExistsException Class | TIBCO.SMARTSOCKETS Namespace


TipcAlreadyExistsException Constructor ()

Constructs a TipcAlreadyExistsException with null as its error message string.

public TipcAlreadyExistsException();

See Also

TipcAlreadyExistsException Class | TIBCO.SMARTSOCKETS Namespace | TipcAlreadyExistsException Constructor Overload List


TipcAlreadyExistsException Constructor (String)

Constructs a TipcAlreadyExistsException with an error message.

public TipcAlreadyExistsException(
string s
);

Parameters

s
the detailed error string.

See Also

TipcAlreadyExistsException Class | TIBCO.SMARTSOCKETS Namespace | TipcAlreadyExistsException Constructor Overload List


TipcAlreadySubscribedException Class

Thrown when subscribing to a subject to which the client has already subscribed.

For a list of all members of this type, see TipcAlreadySubscribedException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcAlreadySubscribedException

public class TipcAlreadySubscribedException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcAlreadySubscribedException Members | TIBCO.SMARTSOCKETS Namespace |


TipcAlreadySubscribedException Members

TipcAlreadySubscribedException overview

Public Instance Constructors

TipcAlreadySubscribedException Overloaded. Initializes a new instance of the TipcAlreadySubscribedException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcAlreadySubscribedException Class | TIBCO.SMARTSOCKETS Namespace |


TipcAlreadySubscribedException Constructor

Constructs a TipcAlreadySubscribedException with null as its error message string.

Overload List

Constructs a TipcAlreadySubscribedException with null as its error message string.

public TipcAlreadySubscribedException();

Constructs a TipcAlreadySubscribedException with an error message.

public TipcAlreadySubscribedException(string);

See Also

TipcAlreadySubscribedException Class | TIBCO.SMARTSOCKETS Namespace


TipcAlreadySubscribedException Constructor ()

Constructs a TipcAlreadySubscribedException with null as its error message string.

public TipcAlreadySubscribedException();

See Also

TipcAlreadySubscribedException Class | TIBCO.SMARTSOCKETS Namespace | TipcAlreadySubscribedException Constructor Overload List


TipcAlreadySubscribedException Constructor (String)

Constructs a TipcAlreadySubscribedException with an error message.

public TipcAlreadySubscribedException(
string s
);

Parameters

s
the detailed error string.

See Also

TipcAlreadySubscribedException Class | TIBCO.SMARTSOCKETS Namespace | TipcAlreadySubscribedException Constructor Overload List


TipcAssertionException Class

Thrown when a fatal runtime exception occurs and by assert when the condition fails.

For a list of all members of this type, see TipcAssertionException Members.

System.Object
System.Exception
System.SystemException
TIBCO.SMARTSOCKETS.TipcRuntimeException
TIBCO.SMARTSOCKETS.TipcAssertionException

public class TipcAssertionException : TipcRuntimeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcAssertionException Members | TIBCO.SMARTSOCKETS Namespace


TipcAssertionException Members

TipcAssertionException overview

Public Instance Constructors

TipcAssertionException Overloaded. Initializes a new instance of the TipcAssertionException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcAssertionException Class | TIBCO.SMARTSOCKETS Namespace


TipcAssertionException Constructor

Constructs a TipcAssertionException with null as its error message string.

Overload List

Constructs a TipcAssertionException with null as its error message string.

public TipcAssertionException();

Constructs a TipcAssertionException with an error message.

public TipcAssertionException(string);

See Also

TipcAssertionException Class | TIBCO.SMARTSOCKETS Namespace


TipcAssertionException Constructor ()

Constructs a TipcAssertionException with null as its error message string.

public TipcAssertionException();

See Also

TipcAssertionException Class | TIBCO.SMARTSOCKETS Namespace | TipcAssertionException Constructor Overload List


TipcAssertionException Constructor (String)

Constructs a TipcAssertionException with an error message.

public TipcAssertionException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcAssertionException Class | TIBCO.SMARTSOCKETS Namespace | TipcAssertionException Constructor Overload List


TipcBadArgumentException Class

Thrown when a bad argument is passed to a method.

For a list of all members of this type, see TipcBadArgumentException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcBadArgumentException

public class TipcBadArgumentException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcBadArgumentException Members | TIBCO.SMARTSOCKETS Namespace


TipcBadArgumentException Members

TipcBadArgumentException overview

Public Instance Constructors

TipcBadArgumentException Overloaded. Initializes a new instance of the TipcBadArgumentException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcBadArgumentException Class | TIBCO.SMARTSOCKETS Namespace


TipcBadArgumentException Constructor

Constructs a TipcBadArgumentException with null as its error message string.

Overload List

Constructs a TipcBadArgumentException with null as its error message string.

public TipcBadArgumentException();

Constructs a TipcBadArgumentException with an error message.

public TipcBadArgumentException(string);

See Also

TipcBadArgumentException Class | TIBCO.SMARTSOCKETS Namespace


TipcBadArgumentException Constructor ()

Constructs a TipcBadArgumentException with null as its error message string.

public TipcBadArgumentException();

See Also

TipcBadArgumentException Class | TIBCO.SMARTSOCKETS Namespace | TipcBadArgumentException Constructor Overload List


TipcBadArgumentException Constructor (String)

Constructs a TipcBadArgumentException with an error message.

public TipcBadArgumentException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcBadArgumentException Class | TIBCO.SMARTSOCKETS Namespace | TipcBadArgumentException Constructor Overload List


TipcCache Class

Provides methods to access the messages cached by the SmartSockets Cache daemon.

For a list of all members of this type, see TipcCache Members.

System.Object
TIBCO.SMARTSOCKETS.TipcCache

public class TipcCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcCache Members | TIBCO.SMARTSOCKETS Namespace


TipcCache Members

TipcCache overview

Public Instance Constructors

TipcCache Overloaded. Initializes a new instance of the TipcCache class.

Public Instance Properties

Version Get the Version number.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GMDFinish | GMDFinish: Performs clean up procedure required to when SmartCache stops to cache GMD message for this RTclient. It sends a message to smartcacheGroup to stop the GMD message caching.
GMDFlush | GMDFlush: This function is used to flush the SmartCache for cached messages from senders. This function sends a message to SmartCache to delete cached messages for specified subject from specified RTclient. The value reqSubj or reqSender (but not both) can be set to T_CACHE_FLUSH_ALL to flush all the subjects or senders.
GMDInit | GMDInit: Performs initializations required to use SmartCache to cache GMD message from this RTclient. This function must be called prior to any other SmartCache API call and prior to parsing a configuration/command file. It sends a message to smartcacheGroup to start the GMD message caching.
requestMsgs | Overloaded. Requests 'numMsgs' messages from the SmartCache daemon within 'deltaTime' number of seconds. The response messages will be automatically processed as they come in from SmartCache. If a connection to RTserver doesn't exist at this time, one will be created.
requestMsgsRpc | Requests 'numMsgs' messages from the SmartCache daemon within 'deltaTime' number of seconds. The response message will be returned to the caller. If a connection to RTserver doesn't exist at this time, one will be created.
requestStart | Overloaded. Submits a message to the SmartCache daemon to start storing up to 'numMsgs' messages being published to the given subject within 'deltaTime' seconds. If a connection to RTserver doesn't exist, one will be created.
requestStop | Submits a message to the SmartCache daemon to stop storing messages being published to the given subject. If a connection to RTserver doesn't exist, one will be created.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace


TipcCache Constructor

Initializes the SmartCache options for request_subject and request_timeout and therefore, should be called before any command files are read. The request_subject (default = /smartcache) is the subject used to send requests to the SmartCache daemon. The request_timeout (default = 10.0) is the amount of time (in seconds) a client waits to receive the cached messages after a request is made to the SmartCache Daemon.

Overload List

Initializes the SmartCache options for request_subject and request_timeout and therefore, should be called before any command files are read. The request_subject (default = /smartcache) is the subject used to send requests to the SmartCache daemon. The request_timeout (default = 10.0) is the amount of time (in seconds) a client waits to receive the cached messages after a request is made to the SmartCache Daemon.

public TipcCache();

Initializes the SmartCache options for request_subject and request_timeout

public TipcCache(TipcSrv,string,string);

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace


TipcCache Constructor ()

Initializes the SmartCache options for request_subject and request_timeout and therefore, should be called before any command files are read. The request_subject (default = /smartcache) is the subject used to send requests to the SmartCache daemon. The request_timeout (default = 10.0) is the amount of time (in seconds) a client waits to receive the cached messages after a request is made to the SmartCache Daemon.

public TipcCache();

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace | TipcCache Constructor Overload List


TipcCache Constructor (TipcSrv, String, String)

Initializes the SmartCache options for request_subject and request_timeout

public TipcCache(
TipcSrv serverSession,
string smartCacheSubject,
string requestTimeout
);

Parameters

serverSession
--- The TipcSrv instance to use.
smartCacheSubject
--- The Subject to send requests to SmartCache.
requestTimeout
--- The timeout value for a request to SmartCache. ("10.0")

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace | TipcCache Constructor Overload List


TipcCache Properties

The properties of the TipcCache class are listed below. For a complete list of TipcCache class members, see the TipcCache Members topic.

Public Instance Properties

Version Get the Version number.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace


Version Property

SmartSockets .NET Class Library

TipcCache.Version Property

Get the Version number.

public virtual float Version {get;}

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace


TipcCache Methods

The methods of the TipcCache class are listed below. For a complete list of TipcCache class members, see the TipcCache Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GMDFinish | GMDFinish: Performs clean up procedure required to when SmartCache stops to cache GMD message for this RTclient. It sends a message to smartcacheGroup to stop the GMD message caching.
GMDFlush | GMDFlush: This function is used to flush the SmartCache for cached messages from senders. This function sends a message to SmartCache to delete cached messages for specified subject from specified RTclient. The value reqSubj or reqSender (but not both) can be set to T_CACHE_FLUSH_ALL to flush all the subjects or senders.
GMDInit | GMDInit: Performs initializations required to use SmartCache to cache GMD message from this RTclient. This function must be called prior to any other SmartCache API call and prior to parsing a configuration/command file. It sends a message to smartcacheGroup to start the GMD message caching.
requestMsgs | Overloaded. Requests 'numMsgs' messages from the SmartCache daemon within 'deltaTime' number of seconds. The response messages will be automatically processed as they come in from SmartCache. If a connection to RTserver doesn't exist at this time, one will be created.
requestMsgsRpc | Requests 'numMsgs' messages from the SmartCache daemon within 'deltaTime' number of seconds. The response message will be returned to the caller. If a connection to RTserver doesn't exist at this time, one will be created.
requestStart | Overloaded. Submits a message to the SmartCache daemon to start storing up to 'numMsgs' messages being published to the given subject within 'deltaTime' seconds. If a connection to RTserver doesn't exist, one will be created.
requestStop | Submits a message to the SmartCache daemon to stop storing messages being published to the given subject. If a connection to RTserver doesn't exist, one will be created.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace


TipcCache.GMDFinish Method

GMDFinish: Performs clean up procedure required to when SmartCache stops to cache GMD message for this RTclient. It sends a message to smartcacheGroup to stop the GMD message caching.

public virtual void GMDFinish(
string smartCacheGroup
);

Parameters

smartCacheGroup
Subject of the smartcache group.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace


TipcCache.GMDFlush Method

GMDFlush: This function is used to flush the SmartCache for cached messages from senders. This function sends a message to SmartCache to delete cached messages for specified subject from specified RTclient. The value reqSubj or reqSender (but not both) can be set to T_CACHE_FLUSH_ALL to flush all the subjects or senders.

public virtual void GMDFlush(
string reqSubj,
string reqSender,
string smartCacheGroup
);

Parameters

reqSubj
subject name to flush.
reqSender
sender to flush.
smartCacheGroup
Subject of the smartcache group.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace


TipcCache.GMDInit Method

GMDInit: Performs initializations required to use SmartCache to cache GMD message from this RTclient. This function must be called prior to any other SmartCache API call and prior to parsing a configuration/command file. It sends a message to smartcacheGroup to start the GMD message caching.

public virtual void GMDInit(
string smartCacheGroup
);

Parameters

smartCacheGroup
Subject of the smartcache group.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace


requestMsgs Method

SmartSockets .NET Class Library

TipcCache.requestMsgs Method

Requests all messages from the SmartCache daemon without any time contraints. The response messages will be automatically processed as they come in from SmartCache. If a connection to RTserver doesn't exist at this time, one will be created.

Overload List

Requests all messages from the SmartCache daemon without any time contraints. The response messages will be automatically processed as they come in from SmartCache. If a connection to RTserver doesn't exist at this time, one will be created.

public virtual void requestMsgs(string);

Requests all the messages from the SmartCache daemon within 'deltaTime' number of seconds. The response messages will be automatically processed as they come in from SmartCache. If a connection to RTserver doesn't exist at this time, one will be created.

public virtual void requestMsgs(string,double);

Requests 'numMsgs' messages from the SmartCache daemon without any time contraints. The response messages will be automatically processed as they come in from SmartCache. If a connection to RTserver doesn't exist at this time, one will be created.

public virtual void requestMsgs(string,int);

Requests 'numMsgs' messages from the SmartCache daemon within 'deltaTime' number of seconds. The response messages will be automatically processed as they come in from SmartCache. If a connection to RTserver doesn't exist at this time, one will be created.

public virtual void requestMsgs(string,int,double);

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace


TipcCache.requestMsgs Method (String)

Requests all messages from the SmartCache daemon without any time contraints. The response messages will be automatically processed as they come in from SmartCache. If a connection to RTserver doesn't exist at this time, one will be created.

public virtual void requestMsgs(
string requestSubject
);

Parameters

requestSubject
subject name to retrieve messages.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace | TipcCache.requestMsgs Overload List


TipcCache.requestMsgs Method (String, Double)

Requests all the messages from the SmartCache daemon within 'deltaTime' number of seconds. The response messages will be automatically processed as they come in from SmartCache. If a connection to RTserver doesn't exist at this time, one will be created.

public virtual void requestMsgs(
string requestSubject,
double deltaTime
);

Parameters

requestSubject
subject name to retrieve messages.
deltaTime
amount of time in seconds to retrieve the message history.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace | TipcCache.requestMsgs Overload List


TipcCache.requestMsgs Method (String, Int32)

Requests 'numMsgs' messages from the SmartCache daemon without any time contraints. The response messages will be automatically processed as they come in from SmartCache. If a connection to RTserver doesn't exist at this time, one will be created.

public virtual void requestMsgs(
string requestSubject,
int numMsgs
);

Parameters

requestSubject
subject name to retrieve messages.
numMsgs
number of messages to be retrieved.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace | TipcCache.requestMsgs Overload List


TipcCache.requestMsgs Method (String, Int32, Double)

Requests 'numMsgs' messages from the SmartCache daemon within 'deltaTime' number of seconds. The response messages will be automatically processed as they come in from SmartCache. If a connection to RTserver doesn't exist at this time, one will be created.

public virtual void requestMsgs(
string requestSubject,
int numMsgs,
double deltaTime
);

Parameters

requestSubject
subject name to retrieve messages.
numMsgs
number of messages to be retrieved.
deltaTime
amount of time in seconds to retrieve the message history.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace | TipcCache.requestMsgs Overload List


TipcCache.requestMsgsRpc Method

Requests 'numMsgs' messages from the SmartCache daemon within 'deltaTime' number of seconds. The response message will be returned to the caller. If a connection to RTserver doesn't exist at this time, one will be created.

public virtual TipcMsg requestMsgsRpc(
string requestSubject,
int numMsgs,
double deltaTime
);

Parameters

requestSubject
subject name to retrieve messages.
numMsgs
number of messages to be retrieved.
deltaTime
amount of time in seconds to retrieve the message history.

Return Value

The response message from SmartCache. This is the bundled message of type T_MT_CACHE_RESPONSE. If no message from SmartCache has been received, this method returns null.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace


requestStart Method

SmartSockets .NET Class Library

TipcCache.requestStart Method

Submits a message to the SmartCache daemon to start storing all messages being published to the given subject. If a connection to RTserver doesn't exist, one will be created.

Overload List

Submits a message to the SmartCache daemon to start storing all messages being published to the given subject. If a connection to RTserver doesn't exist, one will be created.

public virtual void requestStart(string);

Submits a message to the SmartCache daemon to start storing all messages being published to the given subject within 'deltaTime' seconds. If a connection to RTserver doesn't exist, one will be created.

public virtual void requestStart(string,double);

Submits a message to the SmartCache daemon to start storing up to 'numMsgs' messages being published to the given subject. If a connection to RTserver doesn't exist, one will be created.

public virtual void requestStart(string,int);

Submits a message to the SmartCache daemon to start storing up to 'numMsgs' messages being published to the given subject within 'deltaTime' seconds. If a connection to RTserver doesn't exist, one will be created.

public virtual void requestStart(string,int,double);

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace


TipcCache.requestStart Method (String)

Submits a message to the SmartCache daemon to start storing all messages being published to the given subject. If a connection to RTserver doesn't exist, one will be created.

public virtual void requestStart(
string cacheSubject
);

Parameters

cacheSubject
name of subject for which messages will be stored.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace | TipcCache.requestStart Overload List


TipcCache.requestStart Method (String, Double)

Submits a message to the SmartCache daemon to start storing all messages being published to the given subject within 'deltaTime' seconds. If a connection to RTserver doesn't exist, one will be created.

public virtual void requestStart(
string cacheSubject,
double deltaTime
);

Parameters

cacheSubject
name of subject for which messages will be stored.
deltaTime
maximum amount of time in seconds that messages will be stored.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace | TipcCache.requestStart Overload List


TipcCache.requestStart Method (String, Int32)

Submits a message to the SmartCache daemon to start storing up to 'numMsgs' messages being published to the given subject. If a connection to RTserver doesn't exist, one will be created.

public virtual void requestStart(
string cacheSubject,
int numMsgs
);

Parameters

cacheSubject
name of subject for which messages will be stored.
numMsgs
maximum number of messages to be stored for 'cacheSubject'.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace | TipcCache.requestStart Overload List


TipcCache.requestStart Method (String, Int32, Double)

Submits a message to the SmartCache daemon to start storing up to 'numMsgs' messages being published to the given subject within 'deltaTime' seconds. If a connection to RTserver doesn't exist, one will be created.

public virtual void requestStart(
string cacheSubject,
int numMsgs,
double deltaTime
);

Parameters

cacheSubject
name of subject for which messages will be stored.
numMsgs
maximum number of messages to be stored for 'cacheSubject'.
deltaTime
maximum amount of time in seconds that messages will be stored.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace | TipcCache.requestStart Overload List


TipcCache.requestStop Method

Submits a message to the SmartCache daemon to stop storing messages being published to the given subject. If a connection to RTserver doesn't exist, one will be created.

public virtual void requestStop(
string cacheSubject
);

Parameters

cacheSubject
name of subject for which messages will be stored.

See Also

TipcCache Class | TIBCO.SMARTSOCKETS Namespace


TipcCb Class

Holds a reference to a callback entry. This class cannot be directly created by the user. Instead, instances are returned when adding, looking up, and destroying callbacks from the TipcConnClient and TipcSrv classes.

This class allows the properties of the callback to be altered.

For a list of all members of this type, see TipcCb Members.

System.Object
TIBCO.SMARTSOCKETS.TipcCb

public class TipcCb

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcCb Members | TIBCO.SMARTSOCKETS Namespace


TipcCb Members

TipcCb overview

Public Instance Properties

Argument | Gets/Sets the callback argument.
Cb | Gets/Sets the callback object. The callback object will be one of TipcCreateCb, TipcDefaultCb, TipcDestroyCb, TipcErrorCb, TipcProcessCb, TipcQueueCb, TipcReadCb, or TipcWriteCb
Priority | Gets/Sets the callback priority.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
key | Key defining this object as a SortableObject.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcCb Class | TIBCO.SMARTSOCKETS Namespace


TipcCb Properties

The properties of the TipcCb class are listed below. For a complete list of TipcCb class members, see the TipcCb Members topic.

Public Instance Properties

Argument | Gets/Sets the callback argument.
Cb | Gets/Sets the callback object. The callback object will be one of TipcCreateCb, TipcDefaultCb, TipcDestroyCb, TipcErrorCb, TipcProcessCb, TipcQueueCb, TipcReadCb, or TipcWriteCb
Priority | Gets/Sets the callback priority.

See Also

TipcCb Class | TIBCO.SMARTSOCKETS Namespace


Argument Property

SmartSockets .NET Class Library

TipcCb.Argument Property

Gets/Sets the callback argument.

public virtual object Argument {get; set;}

See Also

TipcCb Class | TIBCO.SMARTSOCKETS Namespace


Cb Property

SmartSockets .NET Class Library

TipcCb.Cb Property

Gets/Sets the callback object. The callback object will be one of TipcCreateCb, TipcDefaultCb, TipcDestroyCb, TipcErrorCb, TipcProcessCb, TipcQueueCb, TipcReadCb, or TipcWriteCb

public virtual object Cb {get; set;}

See Also

TipcCb Class | TIBCO.SMARTSOCKETS Namespace


Priority Property

SmartSockets .NET Class Library

TipcCb.Priority Property

Gets/Sets the callback priority.

public virtual int Priority {get; set;}

See Also

TipcCb Class | TIBCO.SMARTSOCKETS Namespace


TipcCb Methods

The methods of the TipcCb class are listed below. For a complete list of TipcCb class members, see the TipcCb Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
key | Key defining this object as a SortableObject.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcCb Class | TIBCO.SMARTSOCKETS Namespace


TipcCb.key Method

Key defining this object as a SortableObject.

public virtual int key();

Return Value

this object's SortableObject key.

See Also

TipcCb Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient Class

Handles client end of peer-to-peer connections.

An instance of this class is created through a factory class by createConnClient method.

The server created with createConnServer must be running before the client is created, otherwise the client has no one to connect to, and will fail.

The implementing class for client connections uses 2 internal threads to send and receive messages. A reader thread constantly fills an inbound queue of message as traffic arrives. Calling next will pop the messages from the queue. A writer thread sends messages pushed onto the outbound queue by send when flush is called.

Any TipcIOException thrown by the methods of this class should be considered fatal. The connection instance should be discarded, and a new connection made in its place. The responsibility for maintaining a connection is up to the user application.

For a list of all members of this type, see TipcConnClient Members.

System.Object
TIBCO.SMARTSOCKETS.TipcConnClient
TIBCO.SMARTSOCKETS.TipcSrv

public class TipcConnClient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcConnClient Members | TIBCO.SMARTSOCKETS Namespace | |


TipcConnClient Members

TipcConnClient overview

Public Instance Properties

Arch | Returns the architecture this client is running on.
AutoFlushSize | Gets/Sets the number of bytes buffered before the outbound queue is automatically flushed, or 0 if this behavior is disabled, in which case manual calls to flush are required to empty the outbound queue.
BlockMode | Gets/Sets the blocking mode. This is true (i.e., block) by default.
DefaultControlCb | Gets the default callback for CONTROL messages.
DefaultGmdFailureCb | Gets the default callback for GMD_FAILURE messages.
GmdNumPending | Gets the number of GMD messages that have been sent but not ack'd or deleted.
LocalPid | Gets/Sets the local pid for this connection.
Node | Gets the node (host) name for the remote machine.
NumQueued | Get the number of messages queued for reading.
Pid | Get the pid (process id) for the remote machine.
Properties | Get this connection's properties.
QueueSize | Gets the size of the read queue, in bytes.
ReadBufferSize | Gets the total number of bytes in the connection's read buffer.
TrafficBytesRecv | Gets the total number of bytes received on this connection Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficBytesRecv8.
TrafficBytesRecv8 | Gets the total number of bytes received on this connection
TrafficBytesSent | Gets the total number of bytes written to the write buffer on a connection. This number usually is the same as the total number of bytes actually sent on the connection, but sometimes the retrieved number is larger than the number of bytes sent when the write buffer is not frequently flushed. Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficBytesSent8.
TrafficBytesSent8 | Gets the total number of bytes written to the write buffer on a connection. This number usually is the same as the total number of bytes actually sent on the connection, but sometimes the retrieved number is larger than the number of bytes sent when the write buffer is not frequently flushed.
TrafficMsgsRecv | Gets the total number of messages received on this connection Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficMsgsRecv8.
TrafficMsgsRecv8 | Gets the total number of messages received on this connection
TrafficMsgsSent | Gets the total number of messages written to the write buffer on a connection. This number usually is the same as the total number of messages actually sent on the connection, but sometimes the retrieved number is larger than the number of messages sent when the write buffer is not frequently flushed. Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficMsgsSent8.
TrafficMsgsSent8 | Gets the total number of messages written to the write buffer on a connection. This number usually is the same as the total number of messages actually sent on the connection, but sometimes the retrieved number is larger than the number of messages sent when the write buffer is not frequently flushed.
UniqueSubject | Retrieve the unique subject of the peer we are connected to. The unique subject is, as the name suggests, a name unique to a process. This method returns the unique subject for the process at the other end of the connection.
User | Get user id of client process.
WriteBufferSize | Gets the total number of bytes in the connection's write buffer.

Public Instance Methods

addDefaultCb | Overloaded. Adds a default callback class with given priority. This callback is called if there are no other callbacks defined for a given message type.
addErrorCb | Overloaded. Adds an error callback class with given priority. The error callback is called when certian types of errors occur.
addProcessCb | Overloaded. Adds a process callback class with given priority. The process callback is called when process is called with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.
addQueueCb | Overloaded. Adds a queue callback class for message type with given priority. The queue callback is called when a message is inserted or removed from the connection's queue. The queue callback is called when a message is inserted or removed and message has a callback registered with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.
addReadCb | Overloaded. Adds a read callback class for message type with given priority. The read callback is called when a message is read. It is called before the message is returned by the next method. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.
addWriteBufferChangeCb | Overloaded. Adds a write buffer change callback class with given priority. The write buffer callbacks are called when the write buffer is either flushed or written to THROUGH the message interface ONLY.
addWriteCb | Overloaded. Adds a write callback class for message type with given priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.
check | Checks for traffic on the connection. If check_mode is IO_CHECK_READ, this method will return true if there is data available to be read. If IO_CHECK_WRITE, true will be returned if data can be written to the connection without blocking. If the timeout_read option is 0.0, this method will block for up to timeout seconds. Otherwise, this method will return immediately. Note: this method is also called by the next and search methods. This method is rarely used by end-user programs.
destroy | Destroys the connection.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
flush | Flushed queued data to the connection. This ensures all buffered data is written immediately. The outbound queue will be flushed automatically when it reaches a set size, set by AutoFlushSize property, unless the auto flush size is set to 0, in which case explicit calls to this method are required.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getOption | Convenience method to get an option by name. Typically one would use the getOption method. This method is available for when an option needs to be different for each connection.
getOptionBool | Convenience method to get an option's boolean value. Typically one would use the getOptionBool method. This method is available for when an option needs to be different for each connection.
getOptionDouble | Convenience method to get an option's double value. Typically one would use the getOptionDouble method. This method is available for when an option needs to be different for each connection.
getOptionInt | Convenience method to get an option's int value. Typically one would use the getOptionInt method. This method is available for when an option needs to be different for each connection.
getOptionStr | Convenience method to get an option's String value. Typically one would use the getOptionStr method. This method is available for when an option needs to be different for each connection.
getTimeout | Get a timeout value. There are several timeout properties associated with a connection: TIMEOUT_READ, TIMEOUT_WRITE, TIMEOUT_KEEP_ALIVE, and TIMEOUT_DELIVERY, all of which are used to check for network failures. This method allows the values of these timeout properties to be inspected. All timeout values are in seconds. The TIMEOUT_READ property specifies the length of time that no data is read on the connection before a keep alive message is exchanged with remote end. If this is set to 0.0, the connection will block forever waiting for data to arrive and no keep alives will be generated. The TIMEOUT_KEEP_ALIVE property is the length of time the client will wait for a reply to a keep alive request. If this timeout expires, the error callback will be called with a timeout error code. The TIMEOUT_DELIVERY property is the length of time the client will wait for an ack to arrive for amessage sent with GMD. If this expires, a GMD_FAILURE message will be generated and processed by the client. The TIMEOUT_WRITE property is not implemented in this release.
GetType (inherited from Object) | Gets the Type of the current instance.
gmdFileDelete | Removes GMD files from disk.
gmdMsgAck | Acknowledges a message sent with GMD.
gmdMsgDelete | Delete a message from the local spool.
gmdMsgResend | Resends a message previously sent with GMD. This should only be used within a GMD_FAILURE callback.
gmdResend | Resends all spooled messages. For Rtserver connections, method will be called automatically when a connection is re-made, so there is no need to call it yourself. Caution: this method should only be used when a connection is first created. This method resends messages with GMD, but does not explicitly flush the messags. You may need to invoke flush.
insert | Insert a message into the inbound queue. For inserting messages to be processed as though they were received from the socket, or re-inserting messages that have been removed, but cannot be processed immediately.
keepAlive | Send a keep alive message to the other end and wait synchronously for a response. The amount of time to wait is set by the KEEP_ALIVE timeout. If the keep alive timeout expires before the other end of the connection responds, this method will fail.
loadOptionsStream | Loads an option file from an InputStream. Loaded options override existing options with the same key. Typically one would use the loadOptionsStream method. This method is available for when an option needs to be different for each connection.
lookupDefaultCb | Looks up callback for default message processing.
lookupErrorCb | Looks up callback for error processing.
lookupProcessCb | Overloaded. Looks up callback for process message processing.
lookupQueueCb | Overloaded. Looks up callback for queued message processing.
lookupReadCb | Overloaded. Looks up callback for message reading.
lookupWriteBufferChangeCb | Looks up callback for write buffer change processing.
lookupWriteCb | Overloaded. Looks up callback for message writing.
mainLoop | Loop for the specified timeout, reading and processing messages from the connection. This is a convenience method, which employs a loop doing next, process, and ack. To specify an infinite loop, pass TIMEOUT_FOREVER.
makeSubjectAbsolute | If the subject isn't absolute (doesn't start with "/"), tack on the default subject prefix, if is exists. If the prefix isn't set to anything, it simply returns the original name untouched.
next | Get messages from the inbound queue. If no messages are waiting in the inbound queue this method will block waiting for a message to arrive from the connection.
process | Process a message by calling the process callbacks for that mesage's type. A callback may be setup to process mesages as they arrive. This method calls those callbacks.
read | Read traffic. This is functionally equivalent to calling check with IO_CHECK_READ mode. The background reader thread will fill the inbound message queue with any messages that arrive during the timeout period.
removeDefaultCb | Remove a default callback class.
removeErrorCb | Remove a error callback class.
removeProcessCb | Remove a process callback class.
removeQueueCb | Remove a queue callback class.
removeReadCb | Remove a read callback class.
removeTrafficCb | Remove a traffic callback class.
removeWriteBufferChangeCb | Remove a write buffer change callback class.
removeWriteCb | Remove a write callback class.
search | Find a message in the inbound queue, using a user-provided matching method. This method scans the inbound queue, calling a user-provided method that is handed each message in turn to see if it matches the desired criteria. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.
searchType | Overloaded. Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.
searchTypeNoFlush | Searches for a message of a particular type without flushing the outbound queue first.
send | Send a message. This method actually queues the data for later transmission. It is not actually sent until flush is called, either by the user directly, or by the auto-flush mechanism, based on the buffer size.
sendRpc | Send a message and synchronously wait for the result. The expected result message will have a message type with a number one greater than the sent message type. If a message with the expected type is not received before the timeout expires, this method will fail.
setOption | Convenience method to set an option by name. Typically one would use the setOption method. This method is available for when an option needs to be different for each connection.
setTimeout | Set a timeout value. See the getTimeout method for an explanation of connection timeout properties.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

TipcErrorEvent Occurs when an error occurs on a connection. Connection Error events are raised when an unrecoverable error occurs. These errors include socket problems and network failures such as:
  • A read timeout has occured and the keep-alive then failed.
  • A write timeout has occured.
  • A read operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.
  • A write operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.
TipcMsgEvent | Occurs when a message is processed. Connection process events are raised while processing a message. This callback type is the most frequently used. A process delegate method is called for every of message received. When any message of any type is processed by calling process or mainLoop, the process callback is called.
TipcQueueEvent | Occurs with message queue events. Connection queue events are raised when a message is inserted into or deleted from a connection's message queue. Queue events are useful for watching the messages that have been read in from a connection's socket and inserted into the message queue, but not yet processed.
TipcReadEvent | Occurs when a message is read from a connection. Connection read events are raised when an incoming message is read from a connection's socket into the read buffer and first unpacked into a message. Read events are most commonly used for writing incoming messages to message files.
TipcWriteBufferChangeEvent | Occurs when the write buffer is accessed. Write buffer change events are raised when data is either flushed from the write buffer or written into write buffer THROUGH the message interface (i.e. with send(msg)) ONLY.
TipcWriteEvent | Occurs when a message is written to a connection. Connection write events are raised when an outgoing message is sent to a connection (that is, copied to a connection's write buffer). Write events are most commonly used for writing outgoing messages to message files.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | |


TipcConnClient Properties

The properties of the TipcConnClient class are listed below. For a complete list of TipcConnClient class members, see the TipcConnClient Members topic.

Public Instance Properties

Arch | Returns the architecture this client is running on.
AutoFlushSize | Gets/Sets the number of bytes buffered before the outbound queue is automatically flushed, or 0 if this behavior is disabled, in which case manual calls to flush are required to empty the outbound queue.
BlockMode | Gets/Sets the blocking mode. This is true (i.e., block) by default.
DefaultControlCb | Gets the default callback for CONTROL messages.
DefaultGmdFailureCb | Gets the default callback for GMD_FAILURE messages.
GmdNumPending | Gets the number of GMD messages that have been sent but not ack'd or deleted.
LocalPid | Gets/Sets the local pid for this connection.
Node | Gets the node (host) name for the remote machine.
NumQueued | Get the number of messages queued for reading.
Pid | Get the pid (process id) for the remote machine.
Properties | Get this connection's properties.
QueueSize | Gets the size of the read queue, in bytes.
ReadBufferSize | Gets the total number of bytes in the connection's read buffer.
TrafficBytesRecv | Gets the total number of bytes received on this connection Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficBytesRecv8.
TrafficBytesRecv8 | Gets the total number of bytes received on this connection
TrafficBytesSent | Gets the total number of bytes written to the write buffer on a connection. This number usually is the same as the total number of bytes actually sent on the connection, but sometimes the retrieved number is larger than the number of bytes sent when the write buffer is not frequently flushed. Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficBytesSent8.
TrafficBytesSent8 | Gets the total number of bytes written to the write buffer on a connection. This number usually is the same as the total number of bytes actually sent on the connection, but sometimes the retrieved number is larger than the number of bytes sent when the write buffer is not frequently flushed.
TrafficMsgsRecv | Gets the total number of messages received on this connection Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficMsgsRecv8.
TrafficMsgsRecv8 | Gets the total number of messages received on this connection
TrafficMsgsSent | Gets the total number of messages written to the write buffer on a connection. This number usually is the same as the total number of messages actually sent on the connection, but sometimes the retrieved number is larger than the number of messages sent when the write buffer is not frequently flushed. Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficMsgsSent8.
TrafficMsgsSent8 | Gets the total number of messages written to the write buffer on a connection. This number usually is the same as the total number of messages actually sent on the connection, but sometimes the retrieved number is larger than the number of messages sent when the write buffer is not frequently flushed.
UniqueSubject | Retrieve the unique subject of the peer we are connected to. The unique subject is, as the name suggests, a name unique to a process. This method returns the unique subject for the process at the other end of the connection.
User | Get user id of client process.
WriteBufferSize | Gets the total number of bytes in the connection's write buffer.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | |


Arch Property

SmartSockets .NET Class Library

TipcConnClient.Arch Property

Returns the architecture this client is running on.

public virtual string Arch {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


AutoFlushSize Property

SmartSockets .NET Class Library

TipcConnClient.AutoFlushSize Property

Gets/Sets the number of bytes buffered before the outbound queue is automatically flushed, or 0 if this behavior is disabled, in which case manual calls to flush are required to empty the outbound queue.

public virtual int AutoFlushSize {get; set;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


BlockMode Property

SmartSockets .NET Class Library

TipcConnClient.BlockMode Property

Gets/Sets the blocking mode. This is true (i.e., block) by default.

public virtual bool BlockMode {get; set;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


DefaultControlCb Property

SmartSockets .NET Class Library

TipcConnClient.DefaultControlCb Property

Gets the default callback for CONTROL messages.

public virtual TipcCb DefaultControlCb {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


DefaultGmdFailureCb Property

SmartSockets .NET Class Library

TipcConnClient.DefaultGmdFailureCb Property

Gets the default callback for GMD_FAILURE messages.

public virtual TipcCb DefaultGmdFailureCb {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


GmdNumPending Property

SmartSockets .NET Class Library

TipcConnClient.GmdNumPending Property

Gets the number of GMD messages that have been sent but not ack'd or deleted.

public virtual int GmdNumPending {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


LocalPid Property

SmartSockets .NET Class Library

TipcConnClient.LocalPid Property

Gets/Sets the local pid for this connection.

public virtual int LocalPid {get; set;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


Node Property

SmartSockets .NET Class Library

TipcConnClient.Node Property

Gets the node (host) name for the remote machine.

public virtual string Node {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


NumQueued Property

SmartSockets .NET Class Library

TipcConnClient.NumQueued Property

Get the number of messages queued for reading.

public virtual int NumQueued {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


Pid Property

SmartSockets .NET Class Library

TipcConnClient.Pid Property

Get the pid (process id) for the remote machine.

public virtual int Pid {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


Properties Property

SmartSockets .NET Class Library

TipcConnClient.Properties Property

Get this connection's properties.

public virtual TipcProperties Properties {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


QueueSize Property

SmartSockets .NET Class Library

TipcConnClient.QueueSize Property

Gets the size of the read queue, in bytes.

public virtual int QueueSize {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


ReadBufferSize Property

SmartSockets .NET Class Library

TipcConnClient.ReadBufferSize Property

Gets the total number of bytes in the connection's read buffer.

public virtual int ReadBufferSize {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TrafficBytesRecv Property

SmartSockets .NET Class Library

TipcConnClient.TrafficBytesRecv Property

Gets the total number of bytes received on this connection

Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficBytesRecv8.

public virtual int TrafficBytesRecv {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TrafficBytesRecv8 Property

SmartSockets .NET Class Library

TipcConnClient.TrafficBytesRecv8 Property

Gets the total number of bytes received on this connection

public virtual long TrafficBytesRecv8 {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TrafficBytesSent Property

SmartSockets .NET Class Library

TipcConnClient.TrafficBytesSent Property

Gets the total number of bytes written to the write buffer on a connection. This number usually is the same as the total number of bytes actually sent on the connection, but sometimes the retrieved number is larger than the number of bytes sent when the write buffer is not frequently flushed.

Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficBytesSent8.

public virtual int TrafficBytesSent {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TrafficBytesSent8 Property

SmartSockets .NET Class Library

TipcConnClient.TrafficBytesSent8 Property

Gets the total number of bytes written to the write buffer on a connection. This number usually is the same as the total number of bytes actually sent on the connection, but sometimes the retrieved number is larger than the number of bytes sent when the write buffer is not frequently flushed.

public virtual long TrafficBytesSent8 {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TrafficMsgsRecv Property

SmartSockets .NET Class Library

TipcConnClient.TrafficMsgsRecv Property

Gets the total number of messages received on this connection

Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficMsgsRecv8.

public virtual int TrafficMsgsRecv {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TrafficMsgsRecv8 Property

SmartSockets .NET Class Library

TipcConnClient.TrafficMsgsRecv8 Property

Gets the total number of messages received on this connection

public virtual long TrafficMsgsRecv8 {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TrafficMsgsSent Property

SmartSockets .NET Class Library

TipcConnClient.TrafficMsgsSent Property

Gets the total number of messages written to the write buffer on a connection. This number usually is the same as the total number of messages actually sent on the connection, but sometimes the retrieved number is larger than the number of messages sent when the write buffer is not frequently flushed.

Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficMsgsSent8.

public virtual int TrafficMsgsSent {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TrafficMsgsSent8 Property

SmartSockets .NET Class Library

TipcConnClient.TrafficMsgsSent8 Property

Gets the total number of messages written to the write buffer on a connection. This number usually is the same as the total number of messages actually sent on the connection, but sometimes the retrieved number is larger than the number of messages sent when the write buffer is not frequently flushed.

public virtual long TrafficMsgsSent8 {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


UniqueSubject Property

SmartSockets .NET Class Library

TipcConnClient.UniqueSubject Property

Retrieve the unique subject of the peer we are connected to. The unique subject is, as the name suggests, a name unique to a process. This method returns the unique subject for the process at the other end of the connection.

public virtual string UniqueSubject {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


User Property

SmartSockets .NET Class Library

TipcConnClient.User Property

Get user id of client process.

public virtual string User {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


WriteBufferSize Property

SmartSockets .NET Class Library

TipcConnClient.WriteBufferSize Property

Gets the total number of bytes in the connection's write buffer.

public virtual int WriteBufferSize {get;}

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient Methods

The methods of the TipcConnClient class are listed below. For a complete list of TipcConnClient class members, see the TipcConnClient Members topic.

Public Instance Methods

addDefaultCb | Overloaded. Adds a default callback class with given priority. This callback is called if there are no other callbacks defined for a given message type.
addErrorCb | Overloaded. Adds an error callback class with given priority. The error callback is called when certian types of errors occur.
addProcessCb | Overloaded. Adds a process callback class with given priority. The process callback is called when process is called with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.
addQueueCb | Overloaded. Adds a queue callback class for message type with given priority. The queue callback is called when a message is inserted or removed from the connection's queue. The queue callback is called when a message is inserted or removed and message has a callback registered with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.
addReadCb | Overloaded. Adds a read callback class for message type with given priority. The read callback is called when a message is read. It is called before the message is returned by the next method. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.
addWriteBufferChangeCb | Overloaded. Adds a write buffer change callback class with given priority. The write buffer callbacks are called when the write buffer is either flushed or written to THROUGH the message interface ONLY.
addWriteCb | Overloaded. Adds a write callback class for message type with given priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.
check | Checks for traffic on the connection. If check_mode is IO_CHECK_READ, this method will return true if there is data available to be read. If IO_CHECK_WRITE, true will be returned if data can be written to the connection without blocking. If the timeout_read option is 0.0, this method will block for up to timeout seconds. Otherwise, this method will return immediately. Note: this method is also called by the next and search methods. This method is rarely used by end-user programs.
destroy | Destroys the connection.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
flush | Flushed queued data to the connection. This ensures all buffered data is written immediately. The outbound queue will be flushed automatically when it reaches a set size, set by AutoFlushSize property, unless the auto flush size is set to 0, in which case explicit calls to this method are required.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getOption | Convenience method to get an option by name. Typically one would use the getOption method. This method is available for when an option needs to be different for each connection.
getOptionBool | Convenience method to get an option's boolean value. Typically one would use the getOptionBool method. This method is available for when an option needs to be different for each connection.
getOptionDouble | Convenience method to get an option's double value. Typically one would use the getOptionDouble method. This method is available for when an option needs to be different for each connection.
getOptionInt | Convenience method to get an option's int value. Typically one would use the getOptionInt method. This method is available for when an option needs to be different for each connection.
getOptionStr | Convenience method to get an option's String value. Typically one would use the getOptionStr method. This method is available for when an option needs to be different for each connection.
getTimeout | Get a timeout value. There are several timeout properties associated with a connection: TIMEOUT_READ, TIMEOUT_WRITE, TIMEOUT_KEEP_ALIVE, and TIMEOUT_DELIVERY, all of which are used to check for network failures. This method allows the values of these timeout properties to be inspected. All timeout values are in seconds. The TIMEOUT_READ property specifies the length of time that no data is read on the connection before a keep alive message is exchanged with remote end. If this is set to 0.0, the connection will block forever waiting for data to arrive and no keep alives will be generated. The TIMEOUT_KEEP_ALIVE property is the length of time the client will wait for a reply to a keep alive request. If this timeout expires, the error callback will be called with a timeout error code. The TIMEOUT_DELIVERY property is the length of time the client will wait for an ack to arrive for amessage sent with GMD. If this expires, a GMD_FAILURE message will be generated and processed by the client. The TIMEOUT_WRITE property is not implemented in this release.
GetType (inherited from Object) | Gets the Type of the current instance.
gmdFileDelete | Removes GMD files from disk.
gmdMsgAck | Acknowledges a message sent with GMD.
gmdMsgDelete | Delete a message from the local spool.
gmdMsgResend | Resends a message previously sent with GMD. This should only be used within a GMD_FAILURE callback.
gmdResend | Resends all spooled messages. For Rtserver connections, method will be called automatically when a connection is re-made, so there is no need to call it yourself. Caution: this method should only be used when a connection is first created. This method resends messages with GMD, but does not explicitly flush the messags. You may need to invoke flush.
insert | Insert a message into the inbound queue. For inserting messages to be processed as though they were received from the socket, or re-inserting messages that have been removed, but cannot be processed immediately.
keepAlive | Send a keep alive message to the other end and wait synchronously for a response. The amount of time to wait is set by the KEEP_ALIVE timeout. If the keep alive timeout expires before the other end of the connection responds, this method will fail.
loadOptionsStream | Loads an option file from an InputStream. Loaded options override existing options with the same key. Typically one would use the loadOptionsStream method. This method is available for when an option needs to be different for each connection.
lookupDefaultCb | Looks up callback for default message processing.
lookupErrorCb | Looks up callback for error processing.
lookupProcessCb | Overloaded. Looks up callback for process message processing.
lookupQueueCb | Overloaded. Looks up callback for queued message processing.
lookupReadCb | Overloaded. Looks up callback for message reading.
lookupWriteBufferChangeCb | Looks up callback for write buffer change processing.
lookupWriteCb | Overloaded. Looks up callback for message writing.
mainLoop | Loop for the specified timeout, reading and processing messages from the connection. This is a convenience method, which employs a loop doing next, process, and ack. To specify an infinite loop, pass TIMEOUT_FOREVER.
makeSubjectAbsolute | If the subject isn't absolute (doesn't start with "/"), tack on the default subject prefix, if is exists. If the prefix isn't set to anything, it simply returns the original name untouched.
next | Get messages from the inbound queue. If no messages are waiting in the inbound queue this method will block waiting for a message to arrive from the connection.
process | Process a message by calling the process callbacks for that mesage's type. A callback may be setup to process mesages as they arrive. This method calls those callbacks.
read | Read traffic. This is functionally equivalent to calling check with IO_CHECK_READ mode. The background reader thread will fill the inbound message queue with any messages that arrive during the timeout period.
removeDefaultCb | Remove a default callback class.
removeErrorCb | Remove a error callback class.
removeProcessCb | Remove a process callback class.
removeQueueCb | Remove a queue callback class.
removeReadCb | Remove a read callback class.
removeTrafficCb | Remove a traffic callback class.
removeWriteBufferChangeCb | Remove a write buffer change callback class.
removeWriteCb | Remove a write callback class.
search | Find a message in the inbound queue, using a user-provided matching method. This method scans the inbound queue, calling a user-provided method that is handed each message in turn to see if it matches the desired criteria. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.
searchType | Overloaded. Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.
searchTypeNoFlush | Searches for a message of a particular type without flushing the outbound queue first.
send | Send a message. This method actually queues the data for later transmission. It is not actually sent until flush is called, either by the user directly, or by the auto-flush mechanism, based on the buffer size.
sendRpc | Send a message and synchronously wait for the result. The expected result message will have a message type with a number one greater than the sent message type. If a message with the expected type is not received before the timeout expires, this method will fail.
setOption | Convenience method to set an option by name. Typically one would use the setOption method. This method is available for when an option needs to be different for each connection.
setTimeout | Set a timeout value. See the getTimeout method for an explanation of connection timeout properties.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | |


addDefaultCb Method

SmartSockets .NET Class Library

TipcConnClient.addDefaultCb Method

Adds a default callback class with given priority. This callback is called if there are no other callbacks defined for a given message type.

Overload List

Adds a default callback class with given priority. This callback is called if there are no other callbacks defined for a given message type.

public virtual TipcCb addDefaultCb(TipcDefaultCb,short,object);

Adds a default callback class with default priority. This callback is called if there are no other callbacks defined for a given message type.

public virtual TipcCb addDefaultCb(TipcDefaultCb,object);

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace |


TipcConnClient.addDefaultCb Method (TipcDefaultCb, Int16, Object)

Adds a default callback class with given priority. This callback is called if there are no other callbacks defined for a given message type.

public virtual TipcCb addDefaultCb(
TipcDefaultCb l,
short priority,
object arg
);

Parameters

l
The class to add.
priority
The priority of the callback.
arg
Argument to pass to the callback.

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addDefaultCb Overload List |


TipcConnClient.addDefaultCb Method (TipcDefaultCb, Object)

Adds a default callback class with default priority. This callback is called if there are no other callbacks defined for a given message type.

public virtual TipcCb addDefaultCb(
TipcDefaultCb l,
object arg
);

Parameters

l
The class to add.
arg
Argument to pass to the callback.

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addDefaultCb Overload List |


addErrorCb Method

SmartSockets .NET Class Library

TipcConnClient.addErrorCb Method

Adds an error callback class with given priority. The error callback is called when certian types of errors occur.

Overload List

Adds an error callback class with given priority. The error callback is called when certian types of errors occur.

public virtual TipcCb addErrorCb(TipcErrorCb,short,object);

Adds an error callback class with default priority. The error callback is called when certian types of errors occur.

public virtual TipcCb addErrorCb(TipcErrorCb,object);

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace |


TipcConnClient.addErrorCb Method (TipcErrorCb, Int16, Object)

Adds an error callback class with given priority. The error callback is called when certian types of errors occur.

public virtual TipcCb addErrorCb(
TipcErrorCb l,
short priority,
object arg
);

Parameters

l
The class to add
priority
The priority of the callback
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addErrorCb Overload List |


TipcConnClient.addErrorCb Method (TipcErrorCb, Object)

Adds an error callback class with default priority. The error callback is called when certian types of errors occur.

public virtual TipcCb addErrorCb(
TipcErrorCb l,
object arg
);

Parameters

l
The class to add
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addErrorCb Overload List |


addProcessCb Method

SmartSockets .NET Class Library

TipcConnClient.addProcessCb Method

Adds a process callback class with given priority for a message type number. The process callback is called when process is called with a message matching the provided message type.

Overload List

Adds a process callback class with given priority for a message type number. The process callback is called when process is called with a message matching the provided message type.

public virtual TipcCb addProcessCb(TipcProcessCb,int,short,object);

Adds a process callback class with default priority for a message type number. The process callback is called when process is called with a message matching the provided message type.

public virtual TipcCb addProcessCb(TipcProcessCb,int,object);

Adds a process callback class with given priority. The process callback is called when process is called with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addProcessCb(TipcProcessCb,TipcMt,short,object);

Adds a process callback class with default priority. The process callback is called when process is called with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addProcessCb(TipcProcessCb,TipcMt,object);

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace |


TipcConnClient.addProcessCb Method (TipcProcessCb, Int32, Int16, Object)

Adds a process callback class with given priority for a message type number. The process callback is called when process is called with a message matching the provided message type.

public virtual TipcCb addProcessCb(
TipcProcessCb l,
int mtNum,
short priority,
object arg
);

Parameters

l
The class to add
mtNum
The number of the message type this callback is interested in. If this is 0, the process callback will be called for messages of any type.
priority
The priority of the callback.
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If mtNum is not a valid message type.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addProcessCb Overload List |


TipcConnClient.addProcessCb Method (TipcProcessCb, Int32, Object)

Adds a process callback class with default priority for a message type number. The process callback is called when process is called with a message matching the provided message type.

public virtual TipcCb addProcessCb(
TipcProcessCb l,
int mtNum,
object arg
);

Parameters

l
The class to add
mtNum
The number of the message type this callback is interested in. If this is 0, the process callback will be called for messages of any type.
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If mtNum is not a valid message type.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addProcessCb Overload List |


TipcConnClient.addProcessCb Method (TipcProcessCb, TipcMt, Int16, Object)

Adds a process callback class with given priority. The process callback is called when process is called with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addProcessCb(
TipcProcessCb l,
TipcMt mt,
short priority,
object arg
);

Parameters

l
The class to add
mt
The message type this callback is interested in
priority
The priority of the callback.
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addProcessCb Overload List |


TipcConnClient.addProcessCb Method (TipcProcessCb, TipcMt, Object)

Adds a process callback class with default priority. The process callback is called when process is called with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addProcessCb(
TipcProcessCb l,
TipcMt mt,
object arg
);

Parameters

l
The class to add
mt
The message type this callback is interested in
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addProcessCb Overload List |


addQueueCb Method

SmartSockets .NET Class Library

TipcConnClient.addQueueCb Method

Adds a queue callback class for message type with given priority. The queue callback is called ever a message is inserted or removed from the connection's queue. The queue callback is called when a message is inserted or removed and message has a callback registered with a message matching the provided message type.

Overload List

Adds a queue callback class for message type with given priority. The queue callback is called ever a message is inserted or removed from the connection's queue. The queue callback is called when a message is inserted or removed and message has a callback registered with a message matching the provided message type.

public virtual TipcCb addQueueCb(TipcQueueCb,int,short,object);

Adds a queue callback class for message type with default priority. The queue callback is called when a message is inserted or removed from the connection's queue. The queue callback is called when a message is inserted or removed and message has a callback registered with a message matching the provided message type.

public virtual TipcCb addQueueCb(TipcQueueCb,int,object);

Adds a queue callback class for message type with given priority. The queue callback is called when a message is inserted or removed from the connection's queue. The queue callback is called when a message is inserted or removed and message has a callback registered with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addQueueCb(TipcQueueCb,TipcMt,short,object);

Adds a queue callback class for message type with default priority. The queue callback is called when a message is inserted or removed from the connection's queue. The queue callback is called when a message is inserted or removed and message has a callback registered with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addQueueCb(TipcQueueCb,TipcMt,object);

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace |


TipcConnClient.addQueueCb Method (TipcQueueCb, Int32, Int16, Object)

Adds a queue callback class for message type with given priority. The queue callback is called ever a message is inserted or removed from the connection's queue. The queue callback is called when a message is inserted or removed and message has a callback registered with a message matching the provided message type.

public virtual TipcCb addQueueCb(
TipcQueueCb l,
int mtNum,
short priority,
object arg
);

Parameters

l
The class to add
mtNum
The number of the message type this callback is interested in. If this is 0, the process callback will be called for messages of any type.
priority
The priority of the callback
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addQueueCb Overload List |


TipcConnClient.addQueueCb Method (TipcQueueCb, Int32, Object)

Adds a queue callback class for message type with default priority. The queue callback is called when a message is inserted or removed from the connection's queue. The queue callback is called when a message is inserted or removed and message has a callback registered with a message matching the provided message type.

public virtual TipcCb addQueueCb(
TipcQueueCb l,
int mtNum,
object arg
);

Parameters

l
The class to add
mtNum
The number of the message type this callback is interested in. If this is 0, the process callback will be called for messages of any type.
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addQueueCb Overload List |


TipcConnClient.addQueueCb Method (TipcQueueCb, TipcMt, Int16, Object)

Adds a queue callback class for message type with given priority. The queue callback is called when a message is inserted or removed from the connection's queue. The queue callback is called when a message is inserted or removed and message has a callback registered with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addQueueCb(
TipcQueueCb l,
TipcMt mt,
short priority,
object arg
);

Parameters

l
The class to add
mt
The message type this callback is interested in
priority
The priority of the callback
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addQueueCb Overload List |


TipcConnClient.addQueueCb Method (TipcQueueCb, TipcMt, Object)

Adds a queue callback class for message type with default priority. The queue callback is called when a message is inserted or removed from the connection's queue. The queue callback is called when a message is inserted or removed and message has a callback registered with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addQueueCb(
TipcQueueCb l,
TipcMt mt,
object arg
);

Parameters

l
The class to add
mt
The message type this callback is interested in
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addQueueCb Overload List |


addReadCb Method

SmartSockets .NET Class Library

TipcConnClient.addReadCb Method

Adds a read callback class with default priority. The read callback is called when a message is read. It is called before the message is returned by the next method.

Overload List

Adds a read callback class with default priority. The read callback is called when a message is read. It is called before the message is returned by the next method.

public virtual TipcCb addReadCb(TipcReadCb,short,object);

Adds a read callback class for message type with given priority. The read callback is called when a message is read. It is called before the message is returned by the next method.

public virtual TipcCb addReadCb(TipcReadCb,int,short,object);

Adds a read callback class for message type with default priority. The read callback is called when a message is read. It is called before the message is returned by the next method.

public virtual TipcCb addReadCb(TipcReadCb,int,object);

Adds a read callback class with default priority. The read callback is called when a message is read. It is called before the message is returned by the next method.

public virtual TipcCb addReadCb(TipcReadCb,object);

Adds a read callback class for message type with given priority. The read callback is called when a message is read. It is called before the message is returned by the next method. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addReadCb(TipcReadCb,TipcMt,short,object);

Adds a read callback class for message type with default priority. The read callback is called when a message is read. It is called before the message is returned by the next method. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addReadCb(TipcReadCb,TipcMt,object);

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace |


TipcConnClient.addReadCb Method (TipcReadCb, Int16, Object)

Adds a read callback class with default priority. The read callback is called when a message is read. It is called before the message is returned by the next method.

public virtual TipcCb addReadCb(
TipcReadCb l,
short priority,
object arg
);

Parameters

l
The class to add
priority
The priority of the callback
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addReadCb Overload List |


TipcConnClient.addReadCb Method (TipcReadCb, Int32, Int16, Object)

Adds a read callback class for message type with given priority. The read callback is called when a message is read. It is called before the message is returned by the next method.

public virtual TipcCb addReadCb(
TipcReadCb l,
int mtNum,
short priority,
object arg
);

Parameters

l
The class to add
mtNum
The number of the message type this callback is interested in. If this is 0, the read callback will be called for messages of any type.
priority
The priority of the callback
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addReadCb Overload List |


TipcConnClient.addReadCb Method (TipcReadCb, Int32, Object)

Adds a read callback class for message type with default priority. The read callback is called when a message is read. It is called before the message is returned by the next method.

public virtual TipcCb addReadCb(
TipcReadCb l,
int mtNum,
object arg
);

Parameters

l
The class to add
mtNum
The number of the message type this callback is interested in. If this is 0, the read callback will be called for messages of any type.
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addReadCb Overload List |


TipcConnClient.addReadCb Method (TipcReadCb, Object)

Adds a read callback class with default priority. The read callback is called when a message is read. It is called before the message is returned by the next method.

public virtual TipcCb addReadCb(
TipcReadCb l,
object arg
);

Parameters

l
The class to add
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addReadCb Overload List |


TipcConnClient.addReadCb Method (TipcReadCb, TipcMt, Int16, Object)

Adds a read callback class for message type with given priority. The read callback is called when a message is read. It is called before the message is returned by the next method. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addReadCb(
TipcReadCb l,
TipcMt mt,
short priority,
object arg
);

Parameters

l
The class to add
mt
The message type this callback is interested in
priority
The priority of the callback
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addReadCb Overload List |


TipcConnClient.addReadCb Method (TipcReadCb, TipcMt, Object)

Adds a read callback class for message type with default priority. The read callback is called when a message is read. It is called before the message is returned by the next method. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addReadCb(
TipcReadCb l,
TipcMt mt,
object arg
);

Parameters

l
The class to add
mt
The message type this callback is interested in
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addReadCb Overload List |


addWriteBufferChangeCb Method

SmartSockets .NET Class Library

TipcConnClient.addWriteBufferChangeCb Method

Adds a write buffer change callback class with given priority. The write buffer callbacks are called when the write buffer is either flushed or written to THROUGH the message interface ONLY.

Overload List

Adds a write buffer change callback class with given priority. The write buffer callbacks are called when the write buffer is either flushed or written to THROUGH the message interface ONLY.

public virtual TipcCb addWriteBufferChangeCb(TipcWriteBufferChangeCb,short,object);

Adds a write buffer change callback class with default priority. The write buffer callbacks are called when the write buffer is either flushed or written to THROUGH the message interface ONLY.

public virtual TipcCb addWriteBufferChangeCb(TipcWriteBufferChangeCb,object);

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace |


TipcConnClient.addWriteBufferChangeCb Method (TipcWriteBufferChangeCb, Int16, Object)

Adds a write buffer change callback class with given priority. The write buffer callbacks are called when the write buffer is either flushed or written to THROUGH the message interface ONLY.

public virtual TipcCb addWriteBufferChangeCb(
TipcWriteBufferChangeCb l,
short priority,
object arg
);

Parameters

l
The class to add
priority
The priority of the callback
arg
Argument to pass to the callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addWriteBufferChangeCb Overload List |


TipcConnClient.addWriteBufferChangeCb Method (TipcWriteBufferChangeCb, Object)

Adds a write buffer change callback class with default priority. The write buffer callbacks are called when the write buffer is either flushed or written to THROUGH the message interface ONLY.

public virtual TipcCb addWriteBufferChangeCb(
TipcWriteBufferChangeCb l,
object arg
);

Parameters

l
The class to add
arg
Argument to pass to the callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addWriteBufferChangeCb Overload List |


addWriteCb Method

SmartSockets .NET Class Library

TipcConnClient.addWriteCb Method

Adds a write callback class with given priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called.

Overload List

Adds a write callback class with given priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called.

public virtual TipcCb addWriteCb(TipcWriteCb,short,object);

Adds a write callback class for message type with given priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called.

public virtual TipcCb addWriteCb(TipcWriteCb,int,short,object);

Adds a write callback class for message type with default priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called.

public virtual TipcCb addWriteCb(TipcWriteCb,int,object);

Adds a write callback class with default priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called.

public virtual TipcCb addWriteCb(TipcWriteCb,object);

Adds a write callback class for message type with given priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addWriteCb(TipcWriteCb,TipcMt,short,object);

Adds a write callback class for message type with default priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addWriteCb(TipcWriteCb,TipcMt,object);

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace |


TipcConnClient.addWriteCb Method (TipcWriteCb, Int16, Object)

Adds a write callback class with given priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called.

public virtual TipcCb addWriteCb(
TipcWriteCb l,
short priority,
object arg
);

Parameters

l
The class to add
priority
The priority of the callback
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addWriteCb Overload List |


TipcConnClient.addWriteCb Method (TipcWriteCb, Int32, Int16, Object)

Adds a write callback class for message type with given priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called.

public virtual TipcCb addWriteCb(
TipcWriteCb l,
int mtNum,
short priority,
object arg
);

Parameters

l
The class to add
mtNum
The number of the message type this callback is interested in. If this is 0, the write callback will be called for messages of any type.
priority
The priority of the callback
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addWriteCb Overload List |


TipcConnClient.addWriteCb Method (TipcWriteCb, Int32, Object)

Adds a write callback class for message type with default priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called.

public virtual TipcCb addWriteCb(
TipcWriteCb l,
int mtNum,
object arg
);

Parameters

l
The class to add
mtNum
The number of the message type this callback is interested in. If this is 0, the write callback will be called for messages of any type.
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addWriteCb Overload List |


TipcConnClient.addWriteCb Method (TipcWriteCb, Object)

Adds a write callback class with default priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called.

public virtual TipcCb addWriteCb(
TipcWriteCb l,
object arg
);

Parameters

l
The class to add
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addWriteCb Overload List |


TipcConnClient.addWriteCb Method (TipcWriteCb, TipcMt, Int16, Object)

Adds a write callback class for message type with given priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addWriteCb(
TipcWriteCb l,
TipcMt mt,
short priority,
object arg
);

Parameters

l
The class to add
mt
The message type this callback is interested in
priority
The priority of the callback
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addWriteCb Overload List |


TipcConnClient.addWriteCb Method (TipcWriteCb, TipcMt, Object)

Adds a write callback class for message type with default priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.

public virtual TipcCb addWriteCb(
TipcWriteCb l,
TipcMt mt,
object arg
);

Parameters

l
The class to add
mt
The message type this callback is interested in
arg
argument to pass to callback

Return Value

An opaque TipcCb object, used to remove the callback later.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.addWriteCb Overload List |


TipcConnClient.check Method

Checks for traffic on the connection.

If check_mode is IO_CHECK_READ, this method will return true if there is data available to be read. If IO_CHECK_WRITE, true will be returned if data can be written to the connection without blocking.

If the timeout_read option is 0.0, this method will block for up to timeout seconds. Otherwise, this method will return immediately.

Note: this method is also called by the next and search methods. This method is rarely used by end-user programs.

public virtual bool check(
int check_mode,
double timeout
);

Parameters

check_mode
either IO_CHECK_READ or IO_CHECK_WRITE, for checking check the read or write sides of the connection.
timeout
the length of time to wait for traffic (in seconds). If timeout it 0.0, the connection will be polled, and not waiting will be done. If timeout is TIMEOUT_FOREVER, the connection will block until traffic is available.

Return Value

true if traffic has occured, false if timed out.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.destroy Method

Destroys the connection.

public virtual void destroy();

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.flush Method

Flushed queued data to the connection. This ensures all buffered data is written immediately. The outbound queue will be flushed automatically when it reaches a set size, set by AutoFlushSize property, unless the auto flush size is set to 0, in which case explicit calls to this method are required.

public virtual void flush();

Exceptions

Exception Type | Condition
TipcIOException | For lower-level errors.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.getOption Method

Convenience method to get an option by name.

Typically one would use the getOption method. This method is available for when an option needs to be different for each connection.

public virtual TipcOption getOption(
string name
);

Parameters

name
The name of the option.

Return Value

The option

Exceptions

Exception Type | Condition
TipcNotFoundException | If the named option doesn't exist.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.getOptionBool Method

Convenience method to get an option's boolean value.

Typically one would use the getOptionBool method. This method is available for when an option needs to be different for each connection.

public virtual bool getOptionBool(
string name
);

Parameters

name
The name of the option.

Return Value

The value of the option as a boolean

Exceptions

Exception Type | Condition
TipcNotFoundException | If the named option doesn't exist.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.getOptionDouble Method

Convenience method to get an option's double value.

Typically one would use the getOptionDouble method. This method is available for when an option needs to be different for each connection.

public virtual double getOptionDouble(
string name
);

Parameters

name
The name of the option.

Return Value

The value of the option as a double

Exceptions

Exception Type | Condition
TipcNotFoundException | If the named option doesn't exist.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.getOptionInt Method

Convenience method to get an option's int value.

Typically one would use the getOptionInt method. This method is available for when an option needs to be different for each connection.

public virtual int getOptionInt(
string name
);

Parameters

name
The name of the option.

Return Value

The value of the option as a int

Exceptions

Exception Type | Condition
TipcNotFoundException | If the named option doesn't exist.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.getOptionStr Method

Convenience method to get an option's String value.

Typically one would use the getOptionStr method. This method is available for when an option needs to be different for each connection.

public virtual string getOptionStr(
string name
);

Parameters

name
The name of the option.

Return Value

The value of the option as a String

Exceptions

Exception Type | Condition
TipcNotFoundException | If the named option doesn't exist.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.getTimeout Method

Get a timeout value.

There are several timeout properties associated with a connection: TIMEOUT_READ, TIMEOUT_WRITE, TIMEOUT_KEEP_ALIVE, and TIMEOUT_DELIVERY, all of which are used to check for network failures. This method allows the values of these timeout properties to be inspected. All timeout values are in seconds.

The TIMEOUT_READ property specifies the length of time that no data is read on the connection before a keep alive message is exchanged with remote end. If this is set to 0.0, the connection will block forever waiting for data to arrive and no keep alives will be generated.

The TIMEOUT_KEEP_ALIVE property is the length of time the client will wait for a reply to a keep alive request. If this timeout expires, the error callback will be called with a timeout error code.

The TIMEOUT_DELIVERY property is the length of time the client will wait for an ack to arrive for amessage sent with GMD. If this expires, a GMD_FAILURE message will be generated and processed by the client.

The TIMEOUT_WRITE property is not implemented in this release.

public virtual double getTimeout(
int timeout_type
);

Parameters

timeout_type
the type of timeout.

Return Value

The requested timeout, as a second-based double.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If timeout_type is not one of the allowed values.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | setTimeout


TipcConnClient.gmdFileDelete Method

Removes GMD files from disk.

public virtual void gmdFileDelete();

Exceptions

Exception Type | Condition
TipcException | If the GMD files are already open.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.gmdMsgAck Method

Acknowledges a message sent with GMD.

public virtual void gmdMsgAck(
TipcMsg msg
);

Parameters

msg
The message to ack.

Exceptions

Exception Type | Condition
TipcIOException | For low-level errors.
TipcMsgException | If the message is not GMD

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.gmdMsgDelete Method

Delete a message from the local spool.

public virtual void gmdMsgDelete(
TipcMsg msg
);

Parameters

msg
The message to delete.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the message is not present in the spool.
TipcMsgException | If the message is not GMD

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.gmdMsgResend Method

Resends a message previously sent with GMD. This should only be used within a GMD_FAILURE callback.

public virtual void gmdMsgResend(
TipcMsg msg
);

Parameters

msg
The message to resend.

Exceptions

Exception Type | Condition
TipcIOException | For low-level errors.
TipcMsgException | If the message is not GMD

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.gmdResend Method

Resends all spooled messages. For Rtserver connections, method will be called automatically when a connection is re-made, so there is no need to call it yourself. Caution: this method should only be used when a connection is first created. This method resends messages with GMD, but does not explicitly flush the messags. You may need to invoke flush.

public virtual void gmdResend();

Exceptions

Exception Type | Condition
TipcIOException | For low-level errors.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.insert Method

Insert a message into the inbound queue. For inserting messages to be processed as though they were received from the socket, or re-inserting messages that have been removed, but cannot be processed immediately.

public virtual void insert(
TipcMsg msg,
int position
);

Parameters

msg
The message to insert.
position
Where to insert it (zero-based). If the position is beyond the end of the list, the message will be appended to the end of the list.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If position is negative.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.keepAlive Method

Send a keep alive message to the other end and wait synchronously for a response. The amount of time to wait is set by the KEEP_ALIVE timeout. If the keep alive timeout expires before the other end of the connection responds, this method will fail.

public virtual bool keepAlive();

Return Value

true if the other is alive, false otherwise.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.loadOptionsStream Method

Loads an option file from an InputStream. Loaded options override existing options with the same key.

Typically one would use the loadOptionsStream method. This method is available for when an option needs to be different for each connection.

public virtual void loadOptionsStream(
Stream In
);

Parameters

In
The stream from which to read the options.

Exceptions

Exception Type | Condition
TipcIOException | If an error occurs when reading.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.lookupDefaultCb Method

Looks up callback for default message processing.

public virtual TipcCb lookupDefaultCb(
TipcDefaultCb l,
object arg
);

Parameters

l
The callback.
arg
The user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the callback table is corrupt.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.lookupErrorCb Method

Looks up callback for error processing.

public virtual TipcCb lookupErrorCb(
TipcErrorCb l,
object arg
);

Parameters

l
The callback.
arg
The user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the callback table is corrupt.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


lookupProcessCb Method

SmartSockets .NET Class Library

TipcConnClient.lookupProcessCb Method

Looks up callback for process message processing.

Overload List

Looks up callback for process message processing.

public virtual TipcCb lookupProcessCb(TipcProcessCb,int,object);

Looks up callback for process message processing.

public virtual TipcCb lookupProcessCb(TipcProcessCb,TipcMt,object);

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.lookupProcessCb Method (TipcProcessCb, Int32, Object)

Looks up callback for process message processing.

public virtual TipcCb lookupProcessCb(
TipcProcessCb l,
int mtNum,
object arg
);

Parameters

l
The callback.
mtNum
The message type number being processed.
arg
The user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the callback table is corrupt, or the message type number does not refer to a valid message type.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.lookupProcessCb Overload List


TipcConnClient.lookupProcessCb Method (TipcProcessCb, TipcMt, Object)

Looks up callback for process message processing.

public virtual TipcCb lookupProcessCb(
TipcProcessCb l,
TipcMt mt,
object arg
);

Parameters

l
The callback.
mt
The message type being processed.
arg
The user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the callback table is corrupt.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.lookupProcessCb Overload List


lookupQueueCb Method

SmartSockets .NET Class Library

TipcConnClient.lookupQueueCb Method

Looks up callback for queued message processing.

Overload List

Looks up callback for queued message processing.

public virtual TipcCb lookupQueueCb(TipcQueueCb,int,object);

Looks up callback for queued message processing.

public virtual TipcCb lookupQueueCb(TipcQueueCb,TipcMt,object);

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.lookupQueueCb Method (TipcQueueCb, Int32, Object)

Looks up callback for queued message processing.

public virtual TipcCb lookupQueueCb(
TipcQueueCb l,
int mtNum,
object arg
);

Parameters

l
The callback.
mtNum
The message type number being processed.
arg
The user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the callback table is corrupt, or the message type number does not refer to a valid message type.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.lookupQueueCb Overload List


TipcConnClient.lookupQueueCb Method (TipcQueueCb, TipcMt, Object)

Looks up callback for queued message processing.

public virtual TipcCb lookupQueueCb(
TipcQueueCb l,
TipcMt mt,
object arg
);

Parameters

l
The callback.
mt
The message type being processed.
arg
The user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the callback table is corrupt.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.lookupQueueCb Overload List


lookupReadCb Method

SmartSockets .NET Class Library

TipcConnClient.lookupReadCb Method

Looks up callback for message reading.

Overload List

Looks up callback for message reading.

public virtual TipcCb lookupReadCb(TipcReadCb,int,object);

Looks up callback for message reading.

public virtual TipcCb lookupReadCb(TipcReadCb,object);

Looks up callback for message reading.

public virtual TipcCb lookupReadCb(TipcReadCb,TipcMt,object);

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.lookupReadCb Method (TipcReadCb, Int32, Object)

Looks up callback for message reading.

public virtual TipcCb lookupReadCb(
TipcReadCb l,
int mtNum,
object arg
);

Parameters

l
The callback.
mtNum
The message type number being processed.
arg
The user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the callback table is corrupt, or the message type number does not refer to a valid message type.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.lookupReadCb Overload List


TipcConnClient.lookupReadCb Method (TipcReadCb, Object)

Looks up callback for message reading.

public virtual TipcCb lookupReadCb(
TipcReadCb l,
object arg
);

Parameters

l
The callback.
arg
The user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the callback table is corrupt.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.lookupReadCb Overload List


TipcConnClient.lookupReadCb Method (TipcReadCb, TipcMt, Object)

Looks up callback for message reading.

public virtual TipcCb lookupReadCb(
TipcReadCb l,
TipcMt mt,
object arg
);

Parameters

l
The callback.
mt
The message type being processed.
arg
The user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the callback table is corrupt.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.lookupReadCb Overload List


TipcConnClient.lookupWriteBufferChangeCb Method

Looks up callback for write buffer change processing.

public virtual TipcCb lookupWriteBufferChangeCb(
TipcWriteBufferChangeCb l,
object arg
);

Parameters

l
The callback.
arg
The user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the callback table is corrupt.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


lookupWriteCb Method

SmartSockets .NET Class Library

TipcConnClient.lookupWriteCb Method

Looks up callback for message writing.

Overload List

Looks up callback for message writing.

public virtual TipcCb lookupWriteCb(TipcWriteCb,int,object);

Looks up callback for message writing.

public virtual TipcCb lookupWriteCb(TipcWriteCb,object);

Looks up callback for message writing.

public virtual TipcCb lookupWriteCb(TipcWriteCb,TipcMt,object);

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.lookupWriteCb Method (TipcWriteCb, Int32, Object)

Looks up callback for message writing.

public virtual TipcCb lookupWriteCb(
TipcWriteCb l,
int mtNum,
object arg
);

Parameters

l
The callback.
mtNum
The message type number being processed.
arg
The user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the callback table is corrupt, or the message type number does not refer to a valid message type.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.lookupWriteCb Overload List


TipcConnClient.lookupWriteCb Method (TipcWriteCb, Object)

Looks up callback for message writing.

public virtual TipcCb lookupWriteCb(
TipcWriteCb l,
object arg
);

Parameters

l
The callback.
arg
The user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the callback table is corrupt.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.lookupWriteCb Overload List


TipcConnClient.lookupWriteCb Method (TipcWriteCb, TipcMt, Object)

Looks up callback for message writing.

public virtual TipcCb lookupWriteCb(
TipcWriteCb l,
TipcMt mt,
object arg
);

Parameters

l
The callback.
mt
The message type being processed.
arg
The user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the callback table is corrupt.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.lookupWriteCb Overload List


TipcConnClient.mainLoop Method

Loop for the specified timeout, reading and processing messages from the connection. This is a convenience method, which employs a loop doing next, process, and ack. To specify an infinite loop, pass TIMEOUT_FOREVER.

public virtual bool mainLoop(
double timeout
);

Parameters

timeout
time to wait for traffic to arrive.

Return Value

False when timed out or when unable to make a connection.

Exceptions

Exception Type | Condition
TipcIOException | For low-level errors.
TipcException | For all other errors.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.makeSubjectAbsolute Method

If the subject isn't absolute (doesn't start with "/"), tack on the default subject prefix, if is exists. If the prefix isn't set to anything, it simply returns the original name untouched.

public virtual string makeSubjectAbsolute(
string subject
);

Parameters

subject
The subject to make absolute.

Return Value

The new subject

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.next Method

Get messages from the inbound queue. If no messages are waiting in the inbound queue this method will block waiting for a message to arrive from the connection.

public virtual TipcMsg next(
double timeout
);

Parameters

timeout
length of time (in seconds) to wait for a message to arrive.

Return Value

the message read, or null if timeout expires.

Exceptions

Exception Type | Condition
TipcIOException | For low-level errors.
TipcException | For all other errors.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.process Method

Process a message by calling the process callbacks for that mesage's type. A callback may be setup to process mesages as they arrive. This method calls those callbacks.

public virtual void process(
TipcMsg msg
);

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the message is invalid.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.read Method

Read traffic. This is functionally equivalent to calling check with IO_CHECK_READ mode. The background reader thread will fill the inbound message queue with any messages that arrive during the timeout period.

public virtual bool read(
double timeout
);

Parameters

timeout
length of time (in seconds) to wait for traffic

Exceptions

Exception Type | Condition
TipcIOException | For low-level errors.
TipcException | For all other errors.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.removeDefaultCb Method

Remove a default callback class.

public virtual void removeDefaultCb(
TipcCb cb
);

Parameters

cb
The class to remove.

Exceptions

Exception Type | Condition
TipcNotFoundException | If cb is not in the list

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.removeErrorCb Method

Remove a error callback class.

public virtual void removeErrorCb(
TipcCb cb
);

Parameters

cb
The class to remove.

Exceptions

Exception Type | Condition
TipcNotFoundException | If cb is not in the list

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.removeProcessCb Method

Remove a process callback class.

public virtual void removeProcessCb(
TipcCb cb
);

Parameters

cb
The class to remove.

Exceptions

Exception Type | Condition
TipcNotFoundException | If cb is not in the list

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.removeQueueCb Method

Remove a queue callback class.

public virtual void removeQueueCb(
TipcCb cb
);

Parameters

cb
The class to remove.

Exceptions

Exception Type | Condition
TipcNotFoundException | If cb is not in the list

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.removeReadCb Method

Remove a read callback class.

public virtual void removeReadCb(
TipcCb cb
);

Parameters

cb
The class to remove.

Exceptions

Exception Type | Condition
TipcNotFoundException | If cb is not in the list

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.removeTrafficCb Method

Remove a traffic callback class.

public virtual void removeTrafficCb(
TipcCb cb
);

Parameters

cb
The class to remove.

Exceptions

Exception Type | Condition
TipcNotFoundException | If cb is not in the list

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.removeWriteBufferChangeCb Method

Remove a write buffer change callback class.

public virtual void removeWriteBufferChangeCb(
TipcCb cb
);

Parameters

cb
The class to remove.

Exceptions

Exception Type | Condition
TipcNotFoundException | If cb is not in the list

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.removeWriteCb Method

Remove a write callback class.

public virtual void removeWriteCb(
TipcCb cb
);

Parameters

cb
The class to remove.

Exceptions

Exception Type | Condition
TipcNotFoundException | If cb is not in the list

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.search Method

Find a message in the inbound queue, using a user-provided matching method. This method scans the inbound queue, calling a user-provided method that is handed each message in turn to see if it matches the desired criteria. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.

public virtual TipcMsg search(
double timeout,
TipcSearcher searcher,
object arg
);

Parameters

timeout
length of time (in seconds) to wait for a message to arrive.
searcher
Class implementing the TipcSearcher to match messages.
arg
An arbitrary Object that is passed to the searcher along with the message.

Return Value

the matching message, or null if no message is found before the timeout expires.

Exceptions

Exception Type | Condition
TipcIOException | For low-level errors.
TipcException | For all other errors.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcSearcher


searchType Method

SmartSockets .NET Class Library

TipcConnClient.searchType Method

Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.

Overload List

Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.

public virtual TipcMsg searchType(double,int);

Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.

public virtual TipcMsg searchType(double,TipcMt);

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.searchType Method (Double, Int32)

Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.

public virtual TipcMsg searchType(
double timeout,
int mtNum
);

Parameters

timeout
Length of time (in seconds) to wait for a message to arrive.
mtNum
The message type to look for.

Return Value

the matching message, or null if no message is found before the timeout expires.

Exceptions

Exception Type | Condition
TipcIOException | For low-level errors.
TipcException | For all other errors.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.searchType Overload List


TipcConnClient.searchType Method (Double, TipcMt)

Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.

public virtual TipcMsg searchType(
double timeout,
TipcMt mt
);

Parameters

timeout
Length of time (in seconds) to wait for a message to arrive.
mt
The message type to look for.

Return Value

the matching message, or null if no message is found before the timeout expires.

Exceptions

Exception Type | Condition
TipcIOException | For low-level errors.
TipcException | For all other errors.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | TipcConnClient.searchType Overload List


TipcConnClient.searchTypeNoFlush Method

Searches for a message of a particular type without flushing the outbound queue first.

public virtual TipcMsg searchTypeNoFlush(
double to,
int mtNum
);

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.send Method

Send a message. This method actually queues the data for later transmission. It is not actually sent until flush is called, either by the user directly, or by the auto-flush mechanism, based on the buffer size.

public virtual void send(
TipcMsg msg
);

Parameters

msg
The message to send.

Exceptions

Exception Type | Condition
TipcIOException | For low-level errors.
TipcException | For all other errors.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.sendRpc Method

Send a message and synchronously wait for the result. The expected result message will have a message type with a number one greater than the sent message type. If a message with the expected type is not received before the timeout expires, this method will fail.

public virtual TipcMsg sendRpc(
TipcMsg msg,
double timeout
);

Parameters

msg
The message to send
timeout
The amount of time (in seconds) to wait for the result.

Return Value

The result message, or null if the timeout expires.

Exceptions

Exception Type | Condition
TipcIOException | For low-level errors.
TipcNotFoundException | If the result message type doesn't exist.
TipcException | For all other errors.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.setOption Method

Convenience method to set an option by name.

Typically one would use the setOption method. This method is available for when an option needs to be different for each connection.

public virtual TipcOption setOption(
string Name,
string Value
);

Parameters

Name
The name of the option.
Value
The oluef the option.

Return Value

The option

Exceptions

Exception Type | Condition
TipcNotFoundException | If the named option doesn't exist.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.setTimeout Method

Set a timeout value. See the getTimeout method for an explanation of connection timeout properties.

public virtual void setTimeout(
int timeout_type,
double timeout
);

Parameters

timeout_type
the type of timeout.
timeout
the value of the timeout (in seconds).

Exceptions

Exception Type | Condition
TipcBadArgumentException | If timeout_type is not one of the allowed values, or timeout is negative.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | getTimeout


TipcConnClient Events

The events of the TipcConnClient class are listed below. For a complete list of TipcConnClient class members, see the TipcConnClient Members topic.

Public Instance Events

TipcErrorEvent Occurs when an error occurs on a connection. Connection Error events are raised when an unrecoverable error occurs. These errors include socket problems and network failures such as:
  • A read timeout has occured and the keep-alive then failed.
  • A write timeout has occured.
  • A read operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.
  • A write operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.
TipcMsgEvent | Occurs when a message is processed. Connection process events are raised while processing a message. This callback type is the most frequently used. A process delegate method is called for every of message received. When any message of any type is processed by calling process or mainLoop, the process callback is called.
TipcQueueEvent | Occurs with message queue events. Connection queue events are raised when a message is inserted into or deleted from a connection's message queue. Queue events are useful for watching the messages that have been read in from a connection's socket and inserted into the message queue, but not yet processed.
TipcReadEvent | Occurs when a message is read from a connection. Connection read events are raised when an incoming message is read from a connection's socket into the read buffer and first unpacked into a message. Read events are most commonly used for writing incoming messages to message files.
TipcWriteBufferChangeEvent | Occurs when the write buffer is accessed. Write buffer change events are raised when data is either flushed from the write buffer or written into write buffer THROUGH the message interface (i.e. with send(msg)) ONLY.
TipcWriteEvent | Occurs when a message is written to a connection. Connection write events are raised when an outgoing message is sent to a connection (that is, copied to a connection's write buffer). Write events are most commonly used for writing outgoing messages to message files.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace | |


TipcConnClient.TipcErrorEvent Event

Occurs when an error occurs on a connection.

Connection Error events are raised when an unrecoverable error occurs. These errors include socket problems and network failures such as:

  • A read timeout has occured and the keep-alive then failed.
  • A write timeout has occured.
  • A read operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.
  • A write operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.

public event TipcErrorHandler TipcErrorEvent;

Event Data

The event handler receives an argument of type TipcErrorEventArgs containing data related to this event. The following TipcErrorEventArgs properties provide information specific to this event.

Property | Description
errNum | Returns the error number.
errString | Returns the error string.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.TipcMsgEvent Event

Occurs when a message is processed.

Connection process events are raised while processing a message. This callback type is the most frequently used. A process delegate method is called for every of message received. When any message of any type is processed by calling process or mainLoop, the process callback is called.

public event TipcMsgHandler TipcMsgEvent;

Event Data

The event handler receives an argument of type TipcMsgEventArgs containing data related to this event. The following TipcMsgEventArgs property provides information specific to this event.

Property | Description
Msg | Retrieves the TipcMsg from the event arg object.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.TipcQueueEvent Event

Occurs with message queue events.

Connection queue events are raised when a message is inserted into or deleted from a connection's message queue. Queue events are useful for watching the messages that have been read in from a connection's socket and inserted into the message queue, but not yet processed.

public event TipcQueueHandler TipcQueueEvent;

Event Data

The event handler receives an argument of type TipcQueueEventArgs containing data related to this event. The following TipcQueueEventArgs properties provide information specific to this event.

Property | Description
insertFlag | Returns the boolean flag. True for insert.
Msg | Returns the message
position | Returns the position in queue where message is either inserted or deleted.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.TipcReadEvent Event

Occurs when a message is read from a connection.

Connection read events are raised when an incoming message is read from a connection's socket into the read buffer and first unpacked into a message. Read events are most commonly used for writing incoming messages to message files.

public event TipcReadHandler TipcReadEvent;

Event Data

The event handler receives an argument of type TipcReadEventArgs containing data related to this event. The following TipcReadEventArgs property provides information specific to this event.

Property | Description
Msg | Returns the message.

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.TipcWriteBufferChangeEvent Event

Occurs when the write buffer is accessed.

Write buffer change events are raised when data is either flushed from the write buffer or written into write buffer THROUGH the message interface (i.e. with send(msg)) ONLY.

public event TipcWriteBufferChangeHandler TipcWriteBufferChangeEvent;

Event Data

The event handler receives an argument of type TipcWriteBufferChangeEventArgs containing data related to this event. The following TipcWriteBufferChangeEventArgs properties provide information specific to this event.

Property | Description
Flushed | Return flushed value.
Mt | Return message type of WriteBuffer

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnClient.TipcWriteEvent Event

Occurs when a message is written to a connection.

Connection write events are raised when an outgoing message is sent to a connection (that is, copied to a connection's write buffer). Write events are most commonly used for writing outgoing messages to message files.

public event TipcWriteHandler TipcWriteEvent;

Event Data

The event handler receives an argument of type TipcWriteEventArgs containing data related to this event. The following TipcWriteEventArgs property provides information specific to this event.

Property | Description
Msg | Returns message of the TipcWriteHandler

See Also

TipcConnClient Class | TIBCO.SMARTSOCKETS Namespace


TipcConnServer Class

Handles the server end of peer-to-peer connection. This class only allows a "listening post" to be created for accepting new connections. All actual communication is done using the TipcConnClient class returned by the accept method.

For a list of all members of this type, see TipcConnServer Members.

System.Object
TIBCO.SMARTSOCKETS.TipcConnServer

public class TipcConnServer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcConnServer Members | TIBCO.SMARTSOCKETS Namespace


TipcConnServer Members

TipcConnServer overview

Public Instance Methods

accept | Listens for the connection to be made and accepts it.
destroy | Destroys the server connection "listening post".
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcConnServer Class | TIBCO.SMARTSOCKETS Namespace


TipcConnServer Methods

The methods of the TipcConnServer class are listed below. For a complete list of TipcConnServer class members, see the TipcConnServer Members topic.

Public Instance Methods

accept | Listens for the connection to be made and accepts it.
destroy | Destroys the server connection "listening post".
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcConnServer Class | TIBCO.SMARTSOCKETS Namespace


TipcConnServer.accept Method

Listens for the connection to be made and accepts it.

public virtual TipcConnClient accept();

Exceptions

Exception Type | Condition
TipcIOException | For socket errors.
TipcException | For all other errors.

See Also

TipcConnServer Class | TIBCO.SMARTSOCKETS Namespace |


TipcConnServer.destroy Method

Destroys the server connection "listening post".

public virtual void destroy();

Exceptions

Exception Type | Condition
TipcIOException | For socket errors.
TipcException | For all other errors.

See Also

TipcConnServer Class | TIBCO.SMARTSOCKETS Namespace


TipcCreateCb Interface

The user interface for the RTclient's server create callbacks.

Server create callbacks are called when an RTclient creates either a full or warm connection to the RTserver. If an RTclient creates and destoys its connection to the RTserver many times, it should use server create callbacks to create the other callbacks needed in the connection to RTserver.

For a list of all members of this type, see TipcCreateCb Members.

public interface TipcCreateCb

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcCreateCb Members | TIBCO.SMARTSOCKETS Namespace |


TipcCreateCb Members

TipcCreateCb overview

Public Instance Methods

create Method invoked by the RTclient once a connection to the RTserver has been established.

See Also

TipcCreateCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcCreateCb Methods

The methods of the TipcCreateCb interface are listed below. For a complete list of TipcCreateCb interface members, see the TipcCreateCb Members topic.

Public Instance Methods

create Method invoked by the RTclient once a connection to the RTserver has been established.

See Also

TipcCreateCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcCreateCb.create Method

Method invoked by the RTclient once a connection to the RTserver has been established.

void create(
object arg
);

Parameters

arg
The user-defined argument.

See Also

TipcCreateCb Interface | TIBCO.SMARTSOCKETS Namespace


TipcDefaultCb Interface

The user interface for connection default callbacks.

Connection default callbacks are executed while processing a message if a process callback specific to the message type and/or destination has not been called. Default callbacks are useful for processing unexpected messages or for generic processing of most message types. For example, you have a client process to manage and display alarm messages. The only process callback you would want for that client process would be for messages of type "alarm". You could then write a default callback to process any other type of data received and display a warning.

For a list of all members of this type, see TipcDefaultCb Members.

public interface TipcDefaultCb

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcDefaultCb Members | TIBCO.SMARTSOCKETS Namespace |


TipcDefaultCb Members

TipcDefaultCb overview

Public Instance Methods

handle Method invoked by the connection when processing a message and no message type/destination specific callback exists for the message.

See Also

TipcDefaultCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcDefaultCb Methods

The methods of the TipcDefaultCb interface are listed below. For a complete list of TipcDefaultCb interface members, see the TipcDefaultCb Members topic.

Public Instance Methods

handle Method invoked by the connection when processing a message and no message type/destination specific callback exists for the message.

See Also

TipcDefaultCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcDefaultCb.handle Method

Method invoked by the connection when processing a message and no message type/destination specific callback exists for the message.

void handle(
TipcMsg msg,
object arg
);

Parameters

msg
The message.
arg
The user-defined argument.

See Also

TipcDefaultCb Interface | TIBCO.SMARTSOCKETS Namespace


TipcDefs Structure

Constants common to several interfaces.

For a list of all members of this type, see TipcDefs Members.

System.Object
System.ValueType
TIBCO.SMARTSOCKETS.TipcDefs

public struct TipcDefs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcDefs Members | TIBCO.SMARTSOCKETS Namespace


TipcDefs Members

TipcDefs overview

Public Static Fields

CHAR_US_ASCII | char format - US ASCII
CHAR_US_EBCDIC | char format - EBCDIC
CONN_FULL | Connection Type - full connection
CONN_NONE | Connection Type - no connection
CONN_WARM | Connection Type - warm connection
DELIVERY_ALL | GMD Delivery Mode - GMD succeeds only if all clients respond
DELIVERY_BEST_EFFORT | GMD Delivery Mode - GMD will not be used
DELIVERY_ORDERED | GMD Delivery Mode - Source ordered delivery, GMD will not be used
DELIVERY_SOME | GMD Delivery Mode - GMD succeeds if only some clients respond
DELIVERY_TIMEOUT_UNSET | Used for internal processing only.
ERROR_FAILURE_DETECTED | Error Number - network failure detected
ERROR_GMD_SENDER_TIMEOUT | Error Number - sender timeout
ERROR_TIMEOUT | Error Number - timeout
GMD_FAILURE | Server Disconnect Mode - fail any pending GMD if disconnected
GMD_SUCCESS | Server Disconnect Mode - pending GMD succeeds if disconnected
INT_BIG_ENDIAN | int format - big endian (msb first)
INT_LITTLE_ENDIAN | int format - little endian (lsb first)
IO_CHECK_READ | IO check mode - Check if inbound traffic will block
IO_CHECK_WRITE | IO check mode - Check if outbound traffic will block
IOCTL_EXEC | IOCTL commands - Execute command
IOCTL_GETPROP | IOCTL commands - Get properties
IOCTL_SETPROP | IOCTL commands - Set properties
LB_NONE | Load Balancing Mode - No load balancing
LB_ROUND_ROBIN | Load Balancing Mode - Round robin
LB_SORTED | Load Balancing Mode - Sorted by name
LB_WEIGHTED | Load Balancing Mode - Weighted by load
LOG_DATA | Message Logging Type - data-related messages
LOG_INTERNAL | Message Logging Type - internal messages
LOG_STATUS | Message Logging Type - status messages
NO_AUTO_FLUSH | Never auto-flush the connection setting
POS_PRIORITY | Used to insert a message in priority order into the connection's message queue.
REAL_370 | real format - IBM 370 format
REAL_DEC_D | real format - DEC 'D' format
REAL_DEC_G | real format - DEC 'G' format
REAL_IEEE | real format - IEEE format
SUBEX_CACHE_FLAG_INITIAL_LOAD | subscribeEx flag for type cache - Initial load
SUBEX_CACHE_FLAG_LATEST_MSG | subscribeEx flag for type cache - Latest Message
SUBEX_TYPE_CACHE | subscribeEx type - Caching subscribe (see SUBEX_CACHE flags)
SUBEX_TYPE_NONE | subscribeEx type - none: Normal subscribe
SUBJECT_DELIM | Subjects - Delimiter string
SUBJECT_DELIM_CHAR | Subjects - Delimiter character
SUBJECT_MULTI_WILD_CARD | Subjects - Multi-level wildcard string
SUBJECT_SINGLE_WILD_CARD | Subjects - Single-level wildcard string
SUBJECT_WILD_CARD_CHAR | Subjects - Single-level wildcard character
TIMEOUT_DELIVERY | Timeout Type - delivery timeout, seconds before GMD failure
TIMEOUT_FOREVER | Wait forever marker
TIMEOUT_KEEP_ALIVE | Timeout Type - keep alive timeout, seconds before keep alive failure
TIMEOUT_READ | Timeout Type - read timeout, seconds before a keep alive is sent
TIMEOUT_WRITE | Timeout Type - write timeout, seconds before failure
WARM | Server Disconnect Mode - keep connection warm

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs Fields

The fields of the TipcDefs structure are listed below. For a complete list of TipcDefs structure members, see the TipcDefs Members topic.

Public Static Fields

CHAR_US_ASCII | char format - US ASCII
CHAR_US_EBCDIC | char format - EBCDIC
CONN_FULL | Connection Type - full connection
CONN_NONE | Connection Type - no connection
CONN_WARM | Connection Type - warm connection
DELIVERY_ALL | GMD Delivery Mode - GMD succeeds only if all clients respond
DELIVERY_BEST_EFFORT | GMD Delivery Mode - GMD will not be used
DELIVERY_ORDERED | GMD Delivery Mode - Source ordered delivery, GMD will not be used
DELIVERY_SOME | GMD Delivery Mode - GMD succeeds if only some clients respond
DELIVERY_TIMEOUT_UNSET | Used for internal processing only.
ERROR_FAILURE_DETECTED | Error Number - network failure detected
ERROR_GMD_SENDER_TIMEOUT | Error Number - sender timeout
ERROR_TIMEOUT | Error Number - timeout
GMD_FAILURE | Server Disconnect Mode - fail any pending GMD if disconnected
GMD_SUCCESS | Server Disconnect Mode - pending GMD succeeds if disconnected
INT_BIG_ENDIAN | int format - big endian (msb first)
INT_LITTLE_ENDIAN | int format - little endian (lsb first)
IO_CHECK_READ | IO check mode - Check if inbound traffic will block
IO_CHECK_WRITE | IO check mode - Check if outbound traffic will block
IOCTL_EXEC | IOCTL commands - Execute command
IOCTL_GETPROP | IOCTL commands - Get properties
IOCTL_SETPROP | IOCTL commands - Set properties
LB_NONE | Load Balancing Mode - No load balancing
LB_ROUND_ROBIN | Load Balancing Mode - Round robin
LB_SORTED | Load Balancing Mode - Sorted by name
LB_WEIGHTED | Load Balancing Mode - Weighted by load
LOG_DATA | Message Logging Type - data-related messages
LOG_INTERNAL | Message Logging Type - internal messages
LOG_STATUS | Message Logging Type - status messages
NO_AUTO_FLUSH | Never auto-flush the connection setting
POS_PRIORITY | Used to insert a message in priority order into the connection's message queue.
REAL_370 | real format - IBM 370 format
REAL_DEC_D | real format - DEC 'D' format
REAL_DEC_G | real format - DEC 'G' format
REAL_IEEE | real format - IEEE format
SUBEX_CACHE_FLAG_INITIAL_LOAD | subscribeEx flag for type cache - Initial load
SUBEX_CACHE_FLAG_LATEST_MSG | subscribeEx flag for type cache - Latest Message
SUBEX_TYPE_CACHE | subscribeEx type - Caching subscribe (see SUBEX_CACHE flags)
SUBEX_TYPE_NONE | subscribeEx type - none: Normal subscribe
SUBJECT_DELIM | Subjects - Delimiter string
SUBJECT_DELIM_CHAR | Subjects - Delimiter character
SUBJECT_MULTI_WILD_CARD | Subjects - Multi-level wildcard string
SUBJECT_SINGLE_WILD_CARD | Subjects - Single-level wildcard string
SUBJECT_WILD_CARD_CHAR | Subjects - Single-level wildcard character
TIMEOUT_DELIVERY | Timeout Type - delivery timeout, seconds before GMD failure
TIMEOUT_FOREVER | Wait forever marker
TIMEOUT_KEEP_ALIVE | Timeout Type - keep alive timeout, seconds before keep alive failure
TIMEOUT_READ | Timeout Type - read timeout, seconds before a keep alive is sent
TIMEOUT_WRITE | Timeout Type - write timeout, seconds before failure
WARM | Server Disconnect Mode - keep connection warm

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.CHAR_US_ASCII Field

char format - US ASCII

public const int CHAR_US_ASCII = 437;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.CHAR_US_EBCDIC Field

char format - EBCDIC

public const int CHAR_US_EBCDIC = 37;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.CONN_FULL Field

Connection Type - full connection

public const int CONN_FULL = 2;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.CONN_NONE Field

Connection Type - no connection

public const int CONN_NONE = 0;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.CONN_WARM Field

Connection Type - warm connection

public const int CONN_WARM = 1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.DELIVERY_ALL Field

GMD Delivery Mode - GMD succeeds only if all clients respond

public const int DELIVERY_ALL = 2;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace |


TipcDefs.DELIVERY_BEST_EFFORT Field

GMD Delivery Mode - GMD will not be used

public const int DELIVERY_BEST_EFFORT = 0;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace |


TipcDefs.DELIVERY_ORDERED Field

GMD Delivery Mode - Source ordered delivery, GMD will not be used

public const int DELIVERY_ORDERED = 3;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace |


TipcDefs.DELIVERY_SOME Field

GMD Delivery Mode - GMD succeeds if only some clients respond

public const int DELIVERY_SOME = 1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace |


TipcDefs.DELIVERY_TIMEOUT_UNSET Field

Used for internal processing only.

public const double DELIVERY_TIMEOUT_UNSET = -666;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.ERROR_FAILURE_DETECTED Field

Error Number - network failure detected

public const int ERROR_FAILURE_DETECTED = 514;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.ERROR_GMD_SENDER_TIMEOUT Field

Error Number - sender timeout

public const int ERROR_GMD_SENDER_TIMEOUT = 518;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.ERROR_TIMEOUT Field

Error Number - timeout

public const int ERROR_TIMEOUT = 9;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.GMD_FAILURE Field

Server Disconnect Mode - fail any pending GMD if disconnected

public const short GMD_FAILURE = 0;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.GMD_SUCCESS Field

Server Disconnect Mode - pending GMD succeeds if disconnected

public const short GMD_SUCCESS = 2;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.INT_BIG_ENDIAN Field

int format - big endian (msb first)

public const int INT_BIG_ENDIAN = 1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.INT_LITTLE_ENDIAN Field

int format - little endian (lsb first)

public const int INT_LITTLE_ENDIAN = 0;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.IO_CHECK_READ Field

IO check mode - Check if inbound traffic will block

public const int IO_CHECK_READ = 0;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace | |


TipcDefs.IO_CHECK_WRITE Field

IO check mode - Check if outbound traffic will block

public const int IO_CHECK_WRITE = 1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace | |


TipcDefs.IOCTL_EXEC Field

IOCTL commands - Execute command

public const int IOCTL_EXEC = 2;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.IOCTL_GETPROP Field

IOCTL commands - Get properties

public const int IOCTL_GETPROP = 0;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.IOCTL_SETPROP Field

IOCTL commands - Set properties

public const int IOCTL_SETPROP = 1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.LB_NONE Field

Load Balancing Mode - No load balancing

public const int LB_NONE = 0;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace |


TipcDefs.LB_ROUND_ROBIN Field

Load Balancing Mode - Round robin

public const int LB_ROUND_ROBIN = 1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace |


TipcDefs.LB_SORTED Field

Load Balancing Mode - Sorted by name

public const int LB_SORTED = 3;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace |


TipcDefs.LB_WEIGHTED Field

Load Balancing Mode - Weighted by load

public const int LB_WEIGHTED = 2;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace |


TipcDefs.LOG_DATA Field

Message Logging Type - data-related messages

public const int LOG_DATA = 0;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.LOG_INTERNAL Field

Message Logging Type - internal messages

public const int LOG_INTERNAL = 2;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.LOG_STATUS Field

Message Logging Type - status messages

public const int LOG_STATUS = 1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.NO_AUTO_FLUSH Field

Never auto-flush the connection setting

public const int NO_AUTO_FLUSH = -1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace |


TipcDefs.POS_PRIORITY Field

Used to insert a message in priority order into the connection's message queue.

public const int POS_PRIORITY = -1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace |


TipcDefs.REAL_370 Field

real format - IBM 370 format

public const int REAL_370 = 3;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.REAL_DEC_D Field

real format - DEC 'D' format

public const int REAL_DEC_D = 1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.REAL_DEC_G Field

real format - DEC 'G' format

public const int REAL_DEC_G = 0;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.REAL_IEEE Field

real format - IEEE format

public const int REAL_IEEE = 2;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.SUBEX_CACHE_FLAG_INITIAL_LOAD Field

subscribeEx flag for type cache - Initial load

public const int SUBEX_CACHE_FLAG_INITIAL_LOAD = 1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.SUBEX_CACHE_FLAG_LATEST_MSG Field

subscribeEx flag for type cache - Latest Message

public const int SUBEX_CACHE_FLAG_LATEST_MSG = 2;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.SUBEX_TYPE_CACHE Field

subscribeEx type - Caching subscribe (see SUBEX_CACHE flags)

public const int SUBEX_TYPE_CACHE = 1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.SUBEX_TYPE_NONE Field

subscribeEx type - none: Normal subscribe

public const int SUBEX_TYPE_NONE = 0;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.SUBJECT_DELIM Field

Subjects - Delimiter string

public const string SUBJECT_DELIM = "/";

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.SUBJECT_DELIM_CHAR Field

Subjects - Delimiter character

public const char SUBJECT_DELIM_CHAR = /;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.SUBJECT_MULTI_WILD_CARD Field

Subjects - Multi-level wildcard string

public const string SUBJECT_MULTI_WILD_CARD = "...";

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.SUBJECT_SINGLE_WILD_CARD Field

Subjects - Single-level wildcard string

public const string SUBJECT_SINGLE_WILD_CARD = "*";

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.SUBJECT_WILD_CARD_CHAR Field

Subjects - Single-level wildcard character

public const char SUBJECT_WILD_CARD_CHAR = *;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.TIMEOUT_DELIVERY Field

Timeout Type - delivery timeout, seconds before GMD failure

public const sbyte TIMEOUT_DELIVERY = 3;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.TIMEOUT_FOREVER Field

Wait forever marker

public const double TIMEOUT_FOREVER = -1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace | | | | | | | |


TipcDefs.TIMEOUT_KEEP_ALIVE Field

Timeout Type - keep alive timeout, seconds before keep alive failure

public const sbyte TIMEOUT_KEEP_ALIVE = 2;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.TIMEOUT_READ Field

Timeout Type - read timeout, seconds before a keep alive is sent

public const sbyte TIMEOUT_READ = 0;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.TIMEOUT_WRITE Field

Timeout Type - write timeout, seconds before failure

public const sbyte TIMEOUT_WRITE = 1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDefs.WARM Field

Server Disconnect Mode - keep connection warm

public const short WARM = 1;

See Also

TipcDefs Class | TIBCO.SMARTSOCKETS Namespace


TipcDestroyCb Interface

The user interface for the RTclient's server destroy callbacks.

Server destroy callbacks are called when an RTclient destroys its connection to the RTserver, leaving either a warm connection or no connection. Server destroy callbacks are the opposite of server create callbacks.

Server destroy callbacks are useful for RTclients that need to know when the connection to the RTserver no longer has a valid socket, such as RTclients that are also GUI programs.

For a list of all members of this type, see TipcDestroyCb Members.

public interface TipcDestroyCb

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcDestroyCb Members | TIBCO.SMARTSOCKETS Namespace |


TipcDestroyCb Members

TipcDestroyCb overview

Public Instance Methods

destroy Method invoked by the RTclient once a connection to the RTserver has been lost.

See Also

TipcDestroyCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcDestroyCb Methods

The methods of the TipcDestroyCb interface are listed below. For a complete list of TipcDestroyCb interface members, see the TipcDestroyCb Members topic.

Public Instance Methods

destroy Method invoked by the RTclient once a connection to the RTserver has been lost.

See Also

TipcDestroyCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcDestroyCb.destroy Method

Method invoked by the RTclient once a connection to the RTserver has been lost.

void destroy(
object arg
);

Parameters

arg
The user-defined argument.

See Also

TipcDestroyCb Interface | TIBCO.SMARTSOCKETS Namespace


TipcErrorCb Interface

The user interface for connection error callbacks.

Connection error callbacks are executed when an unrecoverable error occurs. These errors include socket problems and network failures such as:

  • A read timeout has occured and the keep-alive then failed.
  • A write timeout has occured.
  • A read operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.
  • A write operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.

TipcSrv automatically registers a default error callback that attempts to reconnect to the RTserver when the connection is lost. This default error callback may be replaced by first getting the default error callback with DefaultErrorCb, removing it with removeErrorCb, and adding your own error callback with addErrorCb.

For a list of all members of this type, see TipcErrorCb Members.

public interface TipcErrorCb

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcErrorCb Members | TIBCO.SMARTSOCKETS Namespace | |


TipcErrorCb Members

TipcErrorCb overview

Public Instance Methods

error Method invoked by the connection when an unrecoverable error has occured.

See Also

TipcErrorCb Interface | TIBCO.SMARTSOCKETS Namespace | |


TipcErrorCb Methods

The methods of the TipcErrorCb interface are listed below. For a complete list of TipcErrorCb interface members, see the TipcErrorCb Members topic.

Public Instance Methods

error Method invoked by the connection when an unrecoverable error has occured.

See Also

TipcErrorCb Interface | TIBCO.SMARTSOCKETS Namespace | |


TipcErrorCb.error Method

Method invoked by the connection when an unrecoverable error has occured.

void error(
int errNum,
string errStr,
object arg
);

Parameters

errNum
The error number.
errStr
The string representation of the error.
arg
The user-defined argument.

See Also

TipcErrorCb Interface | TIBCO.SMARTSOCKETS Namespace


TipcErrorEventArgs Class

This class contains event data for the TipcErrorEvent.

For a list of all members of this type, see TipcErrorEventArgs Members.

System.Object
System.EventArgs
TIBCO.SMARTSOCKETS.TipcErrorEventArgs

public class TipcErrorEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcErrorEventArgs Members | TIBCO.SMARTSOCKETS Namespace


TipcErrorEventArgs Members

TipcErrorEventArgs overview

Public Instance Properties

errNum | Returns the error number.
errString | Returns the error string.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcErrorEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcErrorEventArgs Properties

The properties of the TipcErrorEventArgs class are listed below. For a complete list of TipcErrorEventArgs class members, see the TipcErrorEventArgs Members topic.

Public Instance Properties

errNum | Returns the error number.
errString | Returns the error string.

See Also

TipcErrorEventArgs Class | TIBCO.SMARTSOCKETS Namespace


errNum Property

SmartSockets .NET Class Library

TipcErrorEventArgs.errNum Property

Returns the error number.

public int errNum {get;}

See Also

TipcErrorEventArgs Class | TIBCO.SMARTSOCKETS Namespace


errString Property

SmartSockets .NET Class Library

TipcErrorEventArgs.errString Property

Returns the error string.

public string errString {get;}

See Also

TipcErrorEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcErrorHandler Delegate

Represents the method that will handle the TipcErrorEvent event.

public delegate void TipcErrorHandler(
object sender,
TipcErrorEventArgs e
);

Parameters

sender
The source of the event.
e
The TipcErrorEventArgs that contains the event data.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TIBCO.SMARTSOCKETS Namespace


TipcException Class

Superclass of all SmartSockets exceptions.

This class defines an error number which may be set for some errors.

For a list of all members of this type, see TipcException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
Derived types

public class TipcException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcException Members | TIBCO.SMARTSOCKETS Namespace


TipcException Members

TipcException overview

Public Instance Constructors

TipcException Overloaded. Initializes a new instance of the TipcException class.

Public Instance Properties

ErrNum | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcException Class | TIBCO.SMARTSOCKETS Namespace


TipcException Constructor

Constructs a TipcException with default values.

Overload List

Constructs a TipcException with default values.

public TipcException();

Constructs a TipcException with an error number and an error message.

public TipcException(int,string);

Constructs a TipcException with an error message.

public TipcException(string);

See Also

TipcException Class | TIBCO.SMARTSOCKETS Namespace


TipcException Constructor ()

Constructs a TipcException with default values.

public TipcException();

See Also

TipcException Class | TIBCO.SMARTSOCKETS Namespace | TipcException Constructor Overload List


TipcException Constructor (String)

Constructs a TipcException with an error message.

public TipcException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcException Class | TIBCO.SMARTSOCKETS Namespace | TipcException Constructor Overload List


TipcException Constructor (Int32, String)

Constructs a TipcException with an error number and an error message.

public TipcException(
int num,
string s
);

Parameters

num
the error number.
s
the detailed error message.

See Also

TipcException Class | TIBCO.SMARTSOCKETS Namespace | TipcException Constructor Overload List |


TipcException Properties

The properties of the TipcException class are listed below. For a complete list of TipcException class members, see the TipcException Members topic.

Public Instance Properties

ErrNum | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

TipcException Class | TIBCO.SMARTSOCKETS Namespace


ErrNum Property

SmartSockets .NET Class Library

TipcException.ErrNum Property

Returns the error number of this TipcException object.

public virtual int ErrNum {get; set;}

See Also

TipcException Class | TIBCO.SMARTSOCKETS Namespace |


TipcFileNotFoundException Class

Thrown when a file does not exist or is inaccessible.

For a list of all members of this type, see TipcFileNotFoundException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcFileNotFoundException

public class TipcFileNotFoundException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcFileNotFoundException Members | TIBCO.SMARTSOCKETS Namespace


TipcFileNotFoundException Members

TipcFileNotFoundException overview

Public Instance Constructors

TipcFileNotFoundException Overloaded. Initializes a new instance of the TipcFileNotFoundException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcFileNotFoundException Class | TIBCO.SMARTSOCKETS Namespace


TipcFileNotFoundException Constructor

Constructs a TipcFileNotFoundException with null as its error message string.

Overload List

Constructs a TipcFileNotFoundException with null as its error message string.

public TipcFileNotFoundException();

Constructs a TipcFileNotFoundException with an error message.

public TipcFileNotFoundException(string);

See Also

TipcFileNotFoundException Class | TIBCO.SMARTSOCKETS Namespace


TipcFileNotFoundException Constructor ()

Constructs a TipcFileNotFoundException with null as its error message string.

public TipcFileNotFoundException();

See Also

TipcFileNotFoundException Class | TIBCO.SMARTSOCKETS Namespace | TipcFileNotFoundException Constructor Overload List


TipcFileNotFoundException Constructor (String)

Constructs a TipcFileNotFoundException with an error message.

public TipcFileNotFoundException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcFileNotFoundException Class | TIBCO.SMARTSOCKETS Namespace | TipcFileNotFoundException Constructor Overload List


TipcInterruptedException Class

Thrown when a thread is interrupted by Thread.interrupt while waiting for a message to arrive.

This exception can be thrown by check, next, check, sendRpc, mainLoop, read, next, search, searchType, searchType

For a list of all members of this type, see TipcInterruptedException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcInterruptedException

public class TipcInterruptedException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcInterruptedException Members | TIBCO.SMARTSOCKETS Namespace


TipcInterruptedException Members

TipcInterruptedException overview

Public Instance Constructors

TipcInterruptedException Overloaded. Initializes a new instance of the TipcInterruptedException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcInterruptedException Class | TIBCO.SMARTSOCKETS Namespace


TipcInterruptedException Constructor

Constructs a TipcInterruptedException with null as its error message string.

Overload List

Constructs a TipcInterruptedException with null as its error message string.

public TipcInterruptedException();

Constructs a TipcInterruptedException with an error message.

public TipcInterruptedException(string);

See Also

TipcInterruptedException Class | TIBCO.SMARTSOCKETS Namespace


TipcInterruptedException Constructor ()

Constructs a TipcInterruptedException with null as its error message string.

public TipcInterruptedException();

See Also

TipcInterruptedException Class | TIBCO.SMARTSOCKETS Namespace | TipcInterruptedException Constructor Overload List


TipcInterruptedException Constructor (String)

Constructs a TipcInterruptedException with an error message.

public TipcInterruptedException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcInterruptedException Class | TIBCO.SMARTSOCKETS Namespace | TipcInterruptedException Constructor Overload List


TipcIOException Class

Thrown when a low-level IOException occurs, such as a socket connection is refused or a socket connection is lost.

For a list of all members of this type, see TipcIOException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcIOException

public class TipcIOException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcIOException Members | TIBCO.SMARTSOCKETS Namespace


TipcIOException Members

TipcIOException overview

Public Instance Constructors

TipcIOException Overloaded. Initializes a new instance of the TipcIOException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcIOException Class | TIBCO.SMARTSOCKETS Namespace


TipcIOException Constructor

Constructs a TipcIOException with null as its error message string.

Overload List

Constructs a TipcIOException with null as its error message string.

public TipcIOException();

Constructs a TipcIOException with an error message.

public TipcIOException(string);

See Also

TipcIOException Class | TIBCO.SMARTSOCKETS Namespace


TipcIOException Constructor ()

Constructs a TipcIOException with null as its error message string.

public TipcIOException();

See Also

TipcIOException Class | TIBCO.SMARTSOCKETS Namespace | TipcIOException Constructor Overload List


TipcIOException Constructor (String)

Constructs a TipcIOException with an error message.

public TipcIOException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcIOException Class | TIBCO.SMARTSOCKETS Namespace | TipcIOException Constructor Overload List


TipcMalformedURLException Class

Thrown to indicate an invalid URL.

For a list of all members of this type, see TipcMalformedURLException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcMalformedURLException

public class TipcMalformedURLException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMalformedURLException Members | TIBCO.SMARTSOCKETS Namespace


TipcMalformedURLException Members

TipcMalformedURLException overview

Public Instance Constructors

TipcMalformedURLException Overloaded. Initializes a new instance of the TipcMalformedURLException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMalformedURLException Class | TIBCO.SMARTSOCKETS Namespace


TipcMalformedURLException Constructor

Constructs a TipcMalformedURLException with null as its error message string.

Overload List

Constructs a TipcMalformedURLException with null as its error message string.

public TipcMalformedURLException();

Constructs a TipcMalformedURLException with an error message.

public TipcMalformedURLException(string);

See Also

TipcMalformedURLException Class | TIBCO.SMARTSOCKETS Namespace


TipcMalformedURLException Constructor ()

Constructs a TipcMalformedURLException with null as its error message string.

public TipcMalformedURLException();

See Also

TipcMalformedURLException Class | TIBCO.SMARTSOCKETS Namespace | TipcMalformedURLException Constructor Overload List


TipcMalformedURLException Constructor (String)

Constructs a TipcMalformedURLException with an error message.

public TipcMalformedURLException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcMalformedURLException Class | TIBCO.SMARTSOCKETS Namespace | TipcMalformedURLException Constructor Overload List


TipcMon Class

This class provides a set of static methods that allow a RTclient to monitor a SmartSockets application.

Note: There are two versions of each method in this class. When multiple RTserver connections are created by the createSrv method, then the version that requires a TipcSrv object as its first argument should be used. If the RTserver connection was created using the Srv property, then use the version that does not take a TipcSrv object as its first argument.

The publish-subscribe architecture of SmartSockets allows RTclient process to easily send messages to each other, independent of where they reside on the network. In addition to enabling easy development of distributed applications, RTserver, RTmon, and RTclient processes also have monitoring capabilities built in. These additional services help to examine detailed information about your project, as well as determining where processes are located in your network.

From within an RTclient, hundreds of pieces of information can be gathered in real time about all parts of a running SmartSockets project, including:

  • RTclients -- names, message buffers, message traffic statistics, message types, options, node they are on, subjects subscribed to, and so on
  • RTservers -- names, message buffers, message traffic statistics, connections, options, CPU usage, memory usage, node they are on, options, current time, and so on
  • Subjects -- names, RTclients that are subscribing, and so on
  • Projects -- names

This information can be either polled once to provide a one-time snapshot of information or watched to provide asynchronous updates when changes occur. A monitoring request can specify either a specific object or all objects matching a wildcard scope filter. The information is delivered to the requesting program in standard message types TipcMt_Fields.MON_* The fields of these message types contain the information the RTclient is interested in.

All monitoring of a SmartSockets project goes through RTserver. Typically, a request for particular information is sent to RTserver, then RTserver proceeds in one of these ways:

  • RTserver accesses the information in its internal tables and sends it back to the requesting RTclient.
  • RTserver forwards the request to another RTclient or RTserver, which retrieves the information and sends it back to the first RTserver (to be delivered back to the requesting RTclient).
  • RTserver notifies RTclient or RTserver to send the information whenever it changes. When it does change, RTserver receives the information and sends it to the RTclient that made the original request.

To initiate a monitoring request in an RTclient, call one of the functions in the TipcMon class. This sends a message of type TipcMt_Fields.MON_*_POLL_CALL or TipcMt_Fields.MON_*_SET_WATCH to the RTserver. The information is returned to the program by an RTserver using a TipcMt_Fields.MON_*_POLL_RESULT or TipcMt_Fields.MON_*_STATUS message. When the information returns, an RTclient message process callback (created with addProcessCb can be used to process the message.

The ss.monitor_scope option specifies the level of interest for SmartSockets monitoring in those monitoring categories with no parameters (such as RTclient names poll) or an RTclient or RTserver parameter of ALL (such as subject subscribe watch). ss.monitor_scope acts as a filter that prevents a large project from overloading a monitoring program. The default is "/*", which matches all subject names at the first level of the hierarchical subject namespace. All monitoring information is enabled (all filtering is disabled) if ss.monitor_scope is set to "/...", which matches all names. The value "/..." should be used with caution on large projects, as this gathers monitoring information for the entire project, and may cause noticeable peformance degradation.

Polling for information allows you to receive a one-time snapshot of information. Polling can be done at regular time intervals by issuing poll requests repeatedly. All polling of a project goes through RTserver. Typically, a request for particular information is sent to RTserver, then RTserver retrieves the information from its internal tables, from other RTservers, or from RTclients and sends it back to the requesting program.

When the results of a poll are returned in a TipcMt_Fields.MON_*_POLL_RESULT message, the message is processed in one of these two ways:

  • blocking and using the searchType method to search for the message containing the poll results
  • using an RTclient message process callback (created with addProcessCb

Typically, after performing a one-time poll for information, the program blocks and waits for the result before continuing. An example of this is to find out if any RTclients are subscribing to a subject before sending a message. When polling often, or watching for information, using callbacks is usually the preferred method, as it is unclear when the monitoring results may be returned to the program.

Watching information is very different from polling. When watching information, the RTclient that initiated the watch is notified asynchronously, through a message, whenever the item(s) of interest changes. All watching of a project goes through RTserver. Typically, a request to watch particular information is sent to RTserver. RTserver then notifies the process holding the information (the same RTserver, a different RTserver, or an RTclient) that a program is interested in watching the specified information. Then, whenever the information changes, the process holding the information sends it back to the requesting program in a message. Unlike polling, which is a one time request for information, watching causes status messages to continue to be sent until watching is turned off for that particular information.

To set up watching in your program, you set the watch status for the type of information of interest to true. In a similar fashion, watching is turned off by setting the watch status to false.

When the results of a watch are returned in a TipcMt_Fields.MON_*_STATUS message, the message can be processed using an RTclient message process callback (created with addProcessCb). Using callbacks to process the status messages that are returned as the result of a watch being enabled is the recommended method for processing watch results. The main reason for this is that the messages arrive asynchronously. It is often unclear as to when or how often the information may change.

For a list of all members of this type, see TipcMon Members.

System.Object
TIBCO.SMARTSOCKETS.TipcMon

public class TipcMon

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMon Members | TIBCO.SMARTSOCKETS Namespace


TipcMon Members

TipcMon overview

Public Static Fields

ALL Wildcard to identify all monitorable objects. Used in monitoring methods as a wildcard where names, subjects, etc., are required. For example, to send a client general poll to all RTclients:
TipcMon.clientGeneralPoll(TipcMon.ALL);

Public Static Methods

clientBufferPoll | Overloaded. Sends a MON_CLIENT_BUFFER_POLL_CALL message to the target client. This poll returns data concerning the client's message buffers in a MON_CLIENT_BUFFER_POLL_RESULT message.
clientCbPoll | Overloaded. Sends a MON_CLIENT_CB_POLL_CALL message to the target client. This poll returns data concerning the client's callbacks in a MON_CLIENT_CB_POLL_RESULT message.
clientCpuPoll | Overloaded. Sends a MON_CLIENT_CPU_POLL_CALL message to the target client. This poll returns CPU utilizaion information about the client in a MON_CLIENT_INFO_CPU_RESULT message.
clientExtPoll | Overloaded. Sends a MON_EXT_INFO_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_EXT_POLL_RESULT message.
clientGeneralPoll | Overloaded. Sends a MON_CLIENT_GENERAL_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_GENERAL_POLL_RESULT message.
clientInfoPoll | Overloaded. Sends a MON_CLIENT_INFO_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_INFO_POLL_RESULT message.
clientMsgTrafficPoll | Overloaded. Sends a MON_CLIENT_MSG_TRAFFIC_POLL_CALL message to the target client. This poll returns data about the amount of message traffic transferred by the client in a MON_CLIENT_MSG_TRAFFIC_POLL_RESULT message.
clientMsgTypeExPoll | Overloaded. Sends a MON_CLIENT_MSG_TYPE_EX_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_EX_POLL_RESULT message.
clientMsgTypePoll | Overloaded. Sends a MON_CLIENT_MSG_TYPE_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_POLL_RESULT message. Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientMsgTypeExPoll.
clientNamesNumPoll | Overloaded. Sends a MON_CLIENT_NAMES_NUM_POLL_CALL message to RTserver. This poll returns the number of clients in the current project in a MON_CLIENT_NAMES_NUM_POLL_RESULT message.
clientNamesPoll | Overloaded. Sends a MON_CLIENT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the clients in the current project in a MON_CLIENT_NAMES_POLL_RESULT message.
clientOptionPoll | Overloaded. Sends a MON_CLIENT_OPTION_POLL_CALL message to the target client. This poll returns the value of a specific option in the client in a MON_CLIENT_OPTION_POLL_RESULT message.
clientSubjectExPoll | Overloaded. Sends a MON_CLIENT_SUBJECT_EX_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_EX_POLL_RESULT message.
clientSubjectPoll | Overloaded. Sends a MON_CLIENT_SUBJECT_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_POLL_RESULT message. Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientSubjectExPoll.
clientSubscribeNumPoll | Overloaded. Sends a MON_CLIENT_SUBSCRIBE_NUM_POLL_CALL message to the target client. This poll returns the number of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_NUM_POLL_RESULT message.
clientSubscribePoll | Overloaded. Sends a MON_CLIENT_SUBSCRIBE_POLL_CALL message to the target client. This poll returns a list of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_POLL_RESULT message.
clientTimePoll | Overloaded. Sends a MON_CLIENT_TIME_POLL_CALL message to the target client. This poll returns the time according to the client in a MON_CLIENT_TIME_POLL_RESULT message.
clientVersionPoll | Overloaded. Sends a MON_CLIENT_VERSION_POLL_CALL message to the target client. This poll returns version information about the client in a MON_CLIENT_VERSION_POLL_RESULT message.
getClientBufferWatch | Overloaded. Gets the status of a client buffer watch.
getClientCongestionWatch | Overloaded. Gets the status of a client congestion watch.
getClientMsgRecvWatch | Overloaded. Gets the status of a client message receive watch.
getClientMsgSendWatch | Overloaded. Gets the status of a client message send watch.
getClientNamesWatch | Overloaded. Gets the status of a client names watch.
getClientSubscribeWatch | Overloaded. Gets the status of a client subscribe watch.
getClientTimeWatch | Overloaded. Gets the status of a client time watch.
getIdentStr | Gets the string that identifies this client's "type". This string is entirely user defined, and not processed by SmartSockets.
getProjectNamesWatch | Overloaded. Gets the status of a project names watch.
getServerCongestionWatch | Overloaded. Gets the status of a server congestion watch.
getServerConnWatch | Overloaded. Gets the status of a server conn watch.
getServerMaxClientLicensesWatch | Overloaded. Gets the status of a server max client licenses watch.
getServerNamesWatch | Overloaded. Gets the status of a server names watch.
getSubjectNamesWatch | Overloaded. Gets the status of a subject names watch.
getSubjectSubscribeWatch | Overloaded. Gets the status of a subject subscribe watch.
projectNamesPoll | Overloaded. Sends a MON_PROJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of all current projects in a MON_PROJECT_NAMES_POLL_RESULT message.
serverBufferPoll | Overloaded. Sends a MON_SERVER_BUFFER_POLL_CALL message to a particular RTserver. This poll returns message buffer data between given RTserver and some other client or server in a MON_SERVER_BUFFER_POLL_RESULT message.
serverConnPoll | Overloaded. Sends a MON_SERVER_CONN_POLL_CALL message to RTserver. This poll returns a list of the connections RTserver is maintaining in a MON_SERVER_CONN_POLL_RESULT message.
serverCpuPoll | Overloaded. Sends a MON_SERVER_CPU_POLL_CALL message to a particular RTserver. This poll returns CPU utilization information about a given RTserver in a MON_SERVER_CPU_POLL_RESULT message.
serverGeneralPoll | Overloaded. Sends a MON_SERVER_GENERAL_POLL_CALL message to a particular RTserver. This poll returns general information about a given RTserver in a MON_SERVER_GENERAL_POLL_RESULT message.
serverMsgTrafficExPoll | Overloaded. Sends a MON_SERVER_MSG_TRAFFIC_EX_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_EX_POLL_RESULT message.
serverMsgTrafficPoll | Overloaded. Sends a MON_SERVER_MSG_TRAFFIC_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_POLL_RESULT message. Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use serverMsgTrafficExPoll.
serverNamesPoll | Overloaded. Sends a MON_SERVER_NAMES_POLL_CALL message to RTserver. This poll returns a list of the server names in the current project in a MON_SERVER_NAMES_POLL_RESULT message.
serverOptionPoll | Overloaded. Sends a MON_SERVER_OPTION_POLL_CALL message to a particular RTserver. This poll returns the value of a specific option in a given RTserver in a MON_SERVER_OPTION_POLL_RESULT message.
serverRoutePoll | Overloaded. Sends a MON_SERVER_ROUTE_POLL_CALL message to a particular RTserver. This poll returns routing information between two RTservers in a MON_SERVER_ROUTE_POLL_RESULT message.
serverStartTimePoll | Overloaded. Sends a MON_SERVER_START_TIME_POLL_CALL message to a particular RTserver. This poll returns the starting time and elapsed time of a given RTserver in a MON_SERVER_START_TIME_POLL_RESULT message.
serverTimePoll | Overloaded. Sends a MON_SERVER_TIME_POLL_CALL message to a particular RTserver. This poll returns the time according to a given RTserver in a MON_SERVER_TIME_POLL_RESULT message.
serverVersionPoll | Overloaded. Sends a MON_SERVER_VERSION_POLL_CALL message to the target server. This poll returns version information about the server in a MON_SERVER_VERSION_POLL_RESULT message.
setClientBufferWatch | Overloaded. Sets a watch on the buffer statistics in a particular client. A MON_CLIENT_BUFFER_STATUS message is returned.
setClientCongestionWatch | Overloaded. Sets a watch on the buffer congestion in a particular client. A MON_CLIENT_CONGESTION_STATUS message is returned.
setClientMsgRecvWatch | Overloaded. Sets a watch on the messages received by a particular client matching a given message type. A MON_CLIENT_MSG_RECV_STATUS message is returned.
setClientMsgSendWatch | Overloaded. Sets a watch on the messages sent by a particular client matching a given message type. A MON_CLIENT_MSG_SEND_STATUS message is returned.
setClientNamesWatch | Overloaded. Sets a watch on client names in the current project. A MON_CLIENT_NAMES_STATUS message is returned.
setClientSubscribeWatch | Overloaded. Sets a watch on the client's subscription table. A MON_CLIENT_SUBSCRIBE_STATUS message is returned.
setClientTimeWatch | Overloaded. Sets a watch on the time according to a particular client. A MON_CLIENT_TIME_STATUS message is returned.
setIdentStr | Sets a string that identifies this client's "type". This string is entirely user defined, and not processed by SmartSockets.
setProjectNamesWatch | Overloaded. Sets a watch on the projects seen by RTserver. A MON_PROJECT_NAMES_STATUS message is returned.
setServerCongestionWatch | Overloaded. Sets a watch on RTserver connection congestion. A MON_SERVER_CONGETSTION_STATUS message is returned.
setServerConnWatch | Overloaded. Sets a watch on the connections maintained by RTserver. A MON_SERVER_CONN_STATUS message is returned.
setServerMaxClientLicensesWatch | Overloaded. Sets a watch on an RTserver rejecting a client connection due to the maximum number of client licenses allowed being exceeded. A MON_SERVER_MAX_CLIENT_LICENSES_STATUS message is returned.
setServerNamesWatch | Overloaded. Sets a watch on the RTservers in the current project. A MON_SERVER_NAMES_STATUS message is returned.
setSubjectNamesWatch | Overloaded. Sets a watch on the subjects in the current project. A MON_SUBJECT_NAMES_STATUS message is returned.
setSubjectSubscribeWatch | Overloaded. Sets a watch on the subject subscription statistics in the current project. A MON_SUBJECT_SUBSCRIBE_STATUS message is returned.
subjectNamesPoll | Overloaded. Sends a MON_SUBJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the subjects in the current project in a MON_SUBJECT_NAMES_POLL_RESULT message.
subjectSubscribePoll | Overloaded. Sends a MON_SUBJECT_SUBSCRIBE_POLL_CALL message to RTserver. This poll returns data on a particular subject in the current project in a MON_SUBJECT_SUBSCRIBE_POLL_RESULT message.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon Fields

The fields of the TipcMon class are listed below. For a complete list of TipcMon class members, see the TipcMon Members topic.

Public Static Fields

ALL Wildcard to identify all monitorable objects. Used in monitoring methods as a wildcard where names, subjects, etc., are required. For example, to send a client general poll to all RTclients:
TipcMon.clientGeneralPoll(TipcMon.ALL);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.ALL Field

Wildcard to identify all monitorable objects. Used in monitoring methods as a wildcard where names, subjects, etc., are required.

For example, to send a client general poll to all RTclients:

TipcMon.clientGeneralPoll(TipcMon.ALL);

public const string ALL = "@";

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon Methods

The methods of the TipcMon class are listed below. For a complete list of TipcMon class members, see the TipcMon Members topic.

Public Static Methods

clientBufferPoll | Overloaded. Sends a MON_CLIENT_BUFFER_POLL_CALL message to the target client. This poll returns data concerning the client's message buffers in a MON_CLIENT_BUFFER_POLL_RESULT message.
clientCbPoll | Overloaded. Sends a MON_CLIENT_CB_POLL_CALL message to the target client. This poll returns data concerning the client's callbacks in a MON_CLIENT_CB_POLL_RESULT message.
clientCpuPoll | Overloaded. Sends a MON_CLIENT_CPU_POLL_CALL message to the target client. This poll returns CPU utilizaion information about the client in a MON_CLIENT_INFO_CPU_RESULT message.
clientExtPoll | Overloaded. Sends a MON_EXT_INFO_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_EXT_POLL_RESULT message.
clientGeneralPoll | Overloaded. Sends a MON_CLIENT_GENERAL_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_GENERAL_POLL_RESULT message.
clientInfoPoll | Overloaded. Sends a MON_CLIENT_INFO_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_INFO_POLL_RESULT message.
clientMsgTrafficPoll | Overloaded. Sends a MON_CLIENT_MSG_TRAFFIC_POLL_CALL message to the target client. This poll returns data about the amount of message traffic transferred by the client in a MON_CLIENT_MSG_TRAFFIC_POLL_RESULT message.
clientMsgTypeExPoll | Overloaded. Sends a MON_CLIENT_MSG_TYPE_EX_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_EX_POLL_RESULT message.
clientMsgTypePoll | Overloaded. Sends a MON_CLIENT_MSG_TYPE_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_POLL_RESULT message. Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientMsgTypeExPoll.
clientNamesNumPoll | Overloaded. Sends a MON_CLIENT_NAMES_NUM_POLL_CALL message to RTserver. This poll returns the number of clients in the current project in a MON_CLIENT_NAMES_NUM_POLL_RESULT message.
clientNamesPoll | Overloaded. Sends a MON_CLIENT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the clients in the current project in a MON_CLIENT_NAMES_POLL_RESULT message.
clientOptionPoll | Overloaded. Sends a MON_CLIENT_OPTION_POLL_CALL message to the target client. This poll returns the value of a specific option in the client in a MON_CLIENT_OPTION_POLL_RESULT message.
clientSubjectExPoll | Overloaded. Sends a MON_CLIENT_SUBJECT_EX_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_EX_POLL_RESULT message.
clientSubjectPoll | Overloaded. Sends a MON_CLIENT_SUBJECT_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_POLL_RESULT message. Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientSubjectExPoll.
clientSubscribeNumPoll | Overloaded. Sends a MON_CLIENT_SUBSCRIBE_NUM_POLL_CALL message to the target client. This poll returns the number of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_NUM_POLL_RESULT message.
clientSubscribePoll | Overloaded. Sends a MON_CLIENT_SUBSCRIBE_POLL_CALL message to the target client. This poll returns a list of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_POLL_RESULT message.
clientTimePoll | Overloaded. Sends a MON_CLIENT_TIME_POLL_CALL message to the target client. This poll returns the time according to the client in a MON_CLIENT_TIME_POLL_RESULT message.
clientVersionPoll | Overloaded. Sends a MON_CLIENT_VERSION_POLL_CALL message to the target client. This poll returns version information about the client in a MON_CLIENT_VERSION_POLL_RESULT message.
getClientBufferWatch | Overloaded. Gets the status of a client buffer watch.
getClientCongestionWatch | Overloaded. Gets the status of a client congestion watch.
getClientMsgRecvWatch | Overloaded. Gets the status of a client message receive watch.
getClientMsgSendWatch | Overloaded. Gets the status of a client message send watch.
getClientNamesWatch | Overloaded. Gets the status of a client names watch.
getClientSubscribeWatch | Overloaded. Gets the status of a client subscribe watch.
getClientTimeWatch | Overloaded. Gets the status of a client time watch.
getIdentStr | Gets the string that identifies this client's "type". This string is entirely user defined, and not processed by SmartSockets.
getProjectNamesWatch | Overloaded. Gets the status of a project names watch.
getServerCongestionWatch | Overloaded. Gets the status of a server congestion watch.
getServerConnWatch | Overloaded. Gets the status of a server conn watch.
getServerMaxClientLicensesWatch | Overloaded. Gets the status of a server max client licenses watch.
getServerNamesWatch | Overloaded. Gets the status of a server names watch.
getSubjectNamesWatch | Overloaded. Gets the status of a subject names watch.
getSubjectSubscribeWatch | Overloaded. Gets the status of a subject subscribe watch.
projectNamesPoll | Overloaded. Sends a MON_PROJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of all current projects in a MON_PROJECT_NAMES_POLL_RESULT message.
serverBufferPoll | Overloaded. Sends a MON_SERVER_BUFFER_POLL_CALL message to a particular RTserver. This poll returns message buffer data between given RTserver and some other client or server in a MON_SERVER_BUFFER_POLL_RESULT message.
serverConnPoll | Overloaded. Sends a MON_SERVER_CONN_POLL_CALL message to RTserver. This poll returns a list of the connections RTserver is maintaining in a MON_SERVER_CONN_POLL_RESULT message.
serverCpuPoll | Overloaded. Sends a MON_SERVER_CPU_POLL_CALL message to a particular RTserver. This poll returns CPU utilization information about a given RTserver in a MON_SERVER_CPU_POLL_RESULT message.
serverGeneralPoll | Overloaded. Sends a MON_SERVER_GENERAL_POLL_CALL message to a particular RTserver. This poll returns general information about a given RTserver in a MON_SERVER_GENERAL_POLL_RESULT message.
serverMsgTrafficExPoll | Overloaded. Sends a MON_SERVER_MSG_TRAFFIC_EX_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_EX_POLL_RESULT message.
serverMsgTrafficPoll | Overloaded. Sends a MON_SERVER_MSG_TRAFFIC_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_POLL_RESULT message. Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use serverMsgTrafficExPoll.
serverNamesPoll | Overloaded. Sends a MON_SERVER_NAMES_POLL_CALL message to RTserver. This poll returns a list of the server names in the current project in a MON_SERVER_NAMES_POLL_RESULT message.
serverOptionPoll | Overloaded. Sends a MON_SERVER_OPTION_POLL_CALL message to a particular RTserver. This poll returns the value of a specific option in a given RTserver in a MON_SERVER_OPTION_POLL_RESULT message.
serverRoutePoll | Overloaded. Sends a MON_SERVER_ROUTE_POLL_CALL message to a particular RTserver. This poll returns routing information between two RTservers in a MON_SERVER_ROUTE_POLL_RESULT message.
serverStartTimePoll | Overloaded. Sends a MON_SERVER_START_TIME_POLL_CALL message to a particular RTserver. This poll returns the starting time and elapsed time of a given RTserver in a MON_SERVER_START_TIME_POLL_RESULT message.
serverTimePoll | Overloaded. Sends a MON_SERVER_TIME_POLL_CALL message to a particular RTserver. This poll returns the time according to a given RTserver in a MON_SERVER_TIME_POLL_RESULT message.
serverVersionPoll | Overloaded. Sends a MON_SERVER_VERSION_POLL_CALL message to the target server. This poll returns version information about the server in a MON_SERVER_VERSION_POLL_RESULT message.
setClientBufferWatch | Overloaded. Sets a watch on the buffer statistics in a particular client. A MON_CLIENT_BUFFER_STATUS message is returned.
setClientCongestionWatch | Overloaded. Sets a watch on the buffer congestion in a particular client. A MON_CLIENT_CONGESTION_STATUS message is returned.
setClientMsgRecvWatch | Overloaded. Sets a watch on the messages received by a particular client matching a given message type. A MON_CLIENT_MSG_RECV_STATUS message is returned.
setClientMsgSendWatch | Overloaded. Sets a watch on the messages sent by a particular client matching a given message type. A MON_CLIENT_MSG_SEND_STATUS message is returned.
setClientNamesWatch | Overloaded. Sets a watch on client names in the current project. A MON_CLIENT_NAMES_STATUS message is returned.
setClientSubscribeWatch | Overloaded. Sets a watch on the client's subscription table. A MON_CLIENT_SUBSCRIBE_STATUS message is returned.
setClientTimeWatch | Overloaded. Sets a watch on the time according to a particular client. A MON_CLIENT_TIME_STATUS message is returned.
setIdentStr | Sets a string that identifies this client's "type". This string is entirely user defined, and not processed by SmartSockets.
setProjectNamesWatch | Overloaded. Sets a watch on the projects seen by RTserver. A MON_PROJECT_NAMES_STATUS message is returned.
setServerCongestionWatch | Overloaded. Sets a watch on RTserver connection congestion. A MON_SERVER_CONGETSTION_STATUS message is returned.
setServerConnWatch | Overloaded. Sets a watch on the connections maintained by RTserver. A MON_SERVER_CONN_STATUS message is returned.
setServerMaxClientLicensesWatch | Overloaded. Sets a watch on an RTserver rejecting a client connection due to the maximum number of client licenses allowed being exceeded. A MON_SERVER_MAX_CLIENT_LICENSES_STATUS message is returned.
setServerNamesWatch | Overloaded. Sets a watch on the RTservers in the current project. A MON_SERVER_NAMES_STATUS message is returned.
setSubjectNamesWatch | Overloaded. Sets a watch on the subjects in the current project. A MON_SUBJECT_NAMES_STATUS message is returned.
setSubjectSubscribeWatch | Overloaded. Sets a watch on the subject subscription statistics in the current project. A MON_SUBJECT_SUBSCRIBE_STATUS message is returned.
subjectNamesPoll | Overloaded. Sends a MON_SUBJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the subjects in the current project in a MON_SUBJECT_NAMES_POLL_RESULT message.
subjectSubscribePoll | Overloaded. Sends a MON_SUBJECT_SUBSCRIBE_POLL_CALL message to RTserver. This poll returns data on a particular subject in the current project in a MON_SUBJECT_SUBSCRIBE_POLL_RESULT message.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


clientBufferPoll Method

SmartSockets .NET Class Library

TipcMon.clientBufferPoll Method

Sends a MON_CLIENT_BUFFER_POLL_CALL message to the target client. This poll returns data concerning the client's message buffers in a MON_CLIENT_BUFFER_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_BUFFER_POLL_CALL message to the target client. This poll returns data concerning the client's message buffers in a MON_CLIENT_BUFFER_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientBufferPoll(string);

Sends a MON_CLIENT_BUFFER_POLL_CALL message to the target client. This poll returns data concerning the client's message buffers in a MON_CLIENT_BUFFER_POLL_RESULT message.

public static void clientBufferPoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientBufferPoll Method (String)

Sends a MON_CLIENT_BUFFER_POLL_CALL message to the target client. This poll returns data concerning the client's message buffers in a MON_CLIENT_BUFFER_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientBufferPoll(
string client
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientBufferPoll Overload List


TipcMon.clientBufferPoll Method (TipcSrv, String)

Sends a MON_CLIENT_BUFFER_POLL_CALL message to the target client. This poll returns data concerning the client's message buffers in a MON_CLIENT_BUFFER_POLL_RESULT message.

public static void clientBufferPoll(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientBufferPoll Overload List


clientCbPoll Method

SmartSockets .NET Class Library

TipcMon.clientCbPoll Method

Sends a MON_CLIENT_CB_POLL_CALL message to the target client. This poll returns data concerning the client's callbacks in a MON_CLIENT_CB_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_CB_POLL_CALL message to the target client. This poll returns data concerning the client's callbacks in a MON_CLIENT_CB_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientCbPoll(string);

Sends a MON_CLIENT_CB_POLL_CALL message to the target client. This poll returns data concerning the client's callbacks in a MON_CLIENT_CB_POLL_RESULT message.

public static void clientCbPoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientCbPoll Method (String)

Sends a MON_CLIENT_CB_POLL_CALL message to the target client. This poll returns data concerning the client's callbacks in a MON_CLIENT_CB_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientCbPoll(
string client
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientCbPoll Overload List


TipcMon.clientCbPoll Method (TipcSrv, String)

Sends a MON_CLIENT_CB_POLL_CALL message to the target client. This poll returns data concerning the client's callbacks in a MON_CLIENT_CB_POLL_RESULT message.

public static void clientCbPoll(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientCbPoll Overload List


clientCpuPoll Method

SmartSockets .NET Class Library

TipcMon.clientCpuPoll Method

Sends a MON_CLIENT_CPU_POLL_CALL message to the target client. This poll returns CPU utilization information about the client in a MON_CLIENT_CPU_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_CPU_POLL_CALL message to the target client. This poll returns CPU utilization information about the client in a MON_CLIENT_CPU_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientCpuPoll(string);

Sends a MON_CLIENT_CPU_POLL_CALL message to the target client. This poll returns CPU utilizaion information about the client in a MON_CLIENT_INFO_CPU_RESULT message.

public static void clientCpuPoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientCpuPoll Method (String)

Sends a MON_CLIENT_CPU_POLL_CALL message to the target client. This poll returns CPU utilization information about the client in a MON_CLIENT_CPU_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientCpuPoll(
string client
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientCpuPoll Overload List


TipcMon.clientCpuPoll Method (TipcSrv, String)

Sends a MON_CLIENT_CPU_POLL_CALL message to the target client. This poll returns CPU utilizaion information about the client in a MON_CLIENT_INFO_CPU_RESULT message.

public static void clientCpuPoll(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientCpuPoll Overload List


clientExtPoll Method

SmartSockets .NET Class Library

TipcMon.clientExtPoll Method

Sends a MON_CLIENT_EXT_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_EXT_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_EXT_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_EXT_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientExtPoll(string);

Sends a MON_EXT_INFO_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_EXT_POLL_RESULT message.

public static void clientExtPoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientExtPoll Method (String)

Sends a MON_CLIENT_EXT_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_EXT_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientExtPoll(
string client
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientExtPoll Overload List


TipcMon.clientExtPoll Method (TipcSrv, String)

Sends a MON_EXT_INFO_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_EXT_POLL_RESULT message.

public static void clientExtPoll(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientExtPoll Overload List


clientGeneralPoll Method

SmartSockets .NET Class Library

TipcMon.clientGeneralPoll Method

Sends a MON_CLIENT_GENERAL_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_GENERAL_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_GENERAL_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_GENERAL_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientGeneralPoll(string);

Sends a MON_CLIENT_GENERAL_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_GENERAL_POLL_RESULT message.

public static void clientGeneralPoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientGeneralPoll Method (String)

Sends a MON_CLIENT_GENERAL_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_GENERAL_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientGeneralPoll(
string client
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientGeneralPoll Overload List


TipcMon.clientGeneralPoll Method (TipcSrv, String)

Sends a MON_CLIENT_GENERAL_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_GENERAL_POLL_RESULT message.

public static void clientGeneralPoll(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientGeneralPoll Overload List


clientInfoPoll Method

SmartSockets .NET Class Library

TipcMon.clientInfoPoll Method

Sends a MON_CLIENT_INFO_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_INFO_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_INFO_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_INFO_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientInfoPoll(string);

Sends a MON_CLIENT_INFO_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_INFO_POLL_RESULT message.

public static void clientInfoPoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientInfoPoll Method (String)

Sends a MON_CLIENT_INFO_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_INFO_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientInfoPoll(
string client
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientInfoPoll Overload List


TipcMon.clientInfoPoll Method (TipcSrv, String)

Sends a MON_CLIENT_INFO_POLL_CALL message to the target client. This poll returns general information about the client in a MON_CLIENT_INFO_POLL_RESULT message.

public static void clientInfoPoll(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientInfoPoll Overload List


clientMsgTrafficPoll Method

SmartSockets .NET Class Library

TipcMon.clientMsgTrafficPoll Method

Sends a MON_CLIENT_MSG_TRAFFIC_POLL_CALL message to the target client. This poll returns data about the amount of message traffic transferred by the client in a MON_CLIENT_MSG_TRAFFIC_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_MSG_TRAFFIC_POLL_CALL message to the target client. This poll returns data about the amount of message traffic transferred by the client in a MON_CLIENT_MSG_TRAFFIC_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientMsgTrafficPoll(string);

Sends a MON_CLIENT_MSG_TRAFFIC_POLL_CALL message to the target client. This poll returns data about the amount of message traffic transferred by the client in a MON_CLIENT_MSG_TRAFFIC_POLL_RESULT message.

public static void clientMsgTrafficPoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientMsgTrafficPoll Method (String)

Sends a MON_CLIENT_MSG_TRAFFIC_POLL_CALL message to the target client. This poll returns data about the amount of message traffic transferred by the client in a MON_CLIENT_MSG_TRAFFIC_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientMsgTrafficPoll(
string client
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientMsgTrafficPoll Overload List


TipcMon.clientMsgTrafficPoll Method (TipcSrv, String)

Sends a MON_CLIENT_MSG_TRAFFIC_POLL_CALL message to the target client. This poll returns data about the amount of message traffic transferred by the client in a MON_CLIENT_MSG_TRAFFIC_POLL_RESULT message.

public static void clientMsgTrafficPoll(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientMsgTrafficPoll Overload List


clientMsgTypeExPoll Method

SmartSockets .NET Class Library

TipcMon.clientMsgTypeExPoll Method

Sends a MON_CLIENT_MSG_TYPE_EX_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_EX_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_MSG_TYPE_EX_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_EX_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientMsgTypeExPoll(string,string);

Sends a MON_CLIENT_MSG_TYPE_EX_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_EX_POLL_RESULT message.

public static void clientMsgTypeExPoll(TipcSrv,string,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientMsgTypeExPoll Method (String, String)

Sends a MON_CLIENT_MSG_TYPE_EX_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_EX_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientMsgTypeExPoll(
string client,
string mtName
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL
mtName
the name of the desired message type in the client, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientMsgTypeExPoll Overload List


TipcMon.clientMsgTypeExPoll Method (TipcSrv, String, String)

Sends a MON_CLIENT_MSG_TYPE_EX_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_EX_POLL_RESULT message.

public static void clientMsgTypeExPoll(
TipcSrv srv,
string client,
string mtName
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL
mtName
the name of the desired message type in the client, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientMsgTypeExPoll Overload List


clientMsgTypePoll Method

SmartSockets .NET Class Library

TipcMon.clientMsgTypePoll Method

Sends a MON_CLIENT_MSG_TYPE_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientMsgTypeExPoll.

Overload List

Sends a MON_CLIENT_MSG_TYPE_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method. Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientMsgTypeExPoll.

public static void clientMsgTypePoll(string,string);

Sends a MON_CLIENT_MSG_TYPE_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_POLL_RESULT message. Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientMsgTypeExPoll.

public static void clientMsgTypePoll(TipcSrv,string,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientMsgTypePoll Method (String, String)

Sends a MON_CLIENT_MSG_TYPE_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientMsgTypeExPoll.

public static void clientMsgTypePoll(
string client,
string mtName
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL
mtName
the name of the desired message type in the client, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientMsgTypePoll Overload List


TipcMon.clientMsgTypePoll Method (TipcSrv, String, String)

Sends a MON_CLIENT_MSG_TYPE_POLL_CALL message to the target client. This poll returns data about a specific message type in the client in a MON_CLIENT_MSG_TYPE_POLL_RESULT message.

Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientMsgTypeExPoll.

public static void clientMsgTypePoll(
TipcSrv srv,
string client,
string mtName
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL
mtName
the name of the desired message type in the client, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientMsgTypePoll Overload List


clientNamesNumPoll Method

SmartSockets .NET Class Library

TipcMon.clientNamesNumPoll Method

Sends a MON_CLIENT_NAMES_POLL_CALL message to RTserver. This poll returns the number of clients in the current project in a MON_CLIENT_NAMES_NUM_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_NAMES_POLL_CALL message to RTserver. This poll returns the number of clients in the current project in a MON_CLIENT_NAMES_NUM_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientNamesNumPoll();

Sends a MON_CLIENT_NAMES_NUM_POLL_CALL message to RTserver. This poll returns the number of clients in the current project in a MON_CLIENT_NAMES_NUM_POLL_RESULT message.

public static void clientNamesNumPoll(TipcSrv);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientNamesNumPoll Method ()

Sends a MON_CLIENT_NAMES_POLL_CALL message to RTserver. This poll returns the number of clients in the current project in a MON_CLIENT_NAMES_NUM_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientNamesNumPoll();

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientNamesNumPoll Overload List


TipcMon.clientNamesNumPoll Method (TipcSrv)

Sends a MON_CLIENT_NAMES_NUM_POLL_CALL message to RTserver. This poll returns the number of clients in the current project in a MON_CLIENT_NAMES_NUM_POLL_RESULT message.

public static void clientNamesNumPoll(
TipcSrv srv
);

Parameters

srv
the RTserver connection issuing the poll.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientNamesNumPoll Overload List


clientNamesPoll Method

SmartSockets .NET Class Library

TipcMon.clientNamesPoll Method

Sends a MON_CLIENT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the clients in the current project in a MON_CLIENT_NAMES_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the clients in the current project in a MON_CLIENT_NAMES_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientNamesPoll();

Sends a MON_CLIENT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the clients in the current project in a MON_CLIENT_NAMES_POLL_RESULT message.

public static void clientNamesPoll(TipcSrv);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientNamesPoll Method ()

Sends a MON_CLIENT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the clients in the current project in a MON_CLIENT_NAMES_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientNamesPoll();

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientNamesPoll Overload List


TipcMon.clientNamesPoll Method (TipcSrv)

Sends a MON_CLIENT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the clients in the current project in a MON_CLIENT_NAMES_POLL_RESULT message.

public static void clientNamesPoll(
TipcSrv srv
);

Parameters

srv
the RTserver connection issuing the poll.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientNamesPoll Overload List


clientOptionPoll Method

SmartSockets .NET Class Library

TipcMon.clientOptionPoll Method

Sends a MON_CLIENT_OPTION_POLL_CALL message to the target client. This poll returns the value of a specific option in the client in a MON_CLIENT_OPTION_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_OPTION_POLL_CALL message to the target client. This poll returns the value of a specific option in the client in a MON_CLIENT_OPTION_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientOptionPoll(string,string);

Sends a MON_CLIENT_OPTION_POLL_CALL message to the target client. This poll returns the value of a specific option in the client in a MON_CLIENT_OPTION_POLL_RESULT message.

public static void clientOptionPoll(TipcSrv,string,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientOptionPoll Method (String, String)

Sends a MON_CLIENT_OPTION_POLL_CALL message to the target client. This poll returns the value of a specific option in the client in a MON_CLIENT_OPTION_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientOptionPoll(
string client,
string optionName
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL
optionName
the option to retrieve the value of, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientOptionPoll Overload List


TipcMon.clientOptionPoll Method (TipcSrv, String, String)

Sends a MON_CLIENT_OPTION_POLL_CALL message to the target client. This poll returns the value of a specific option in the client in a MON_CLIENT_OPTION_POLL_RESULT message.

public static void clientOptionPoll(
TipcSrv srv,
string client,
string optionName
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL
optionName
the option to retrieve the value of, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientOptionPoll Overload List


clientSubjectExPoll Method

SmartSockets .NET Class Library

TipcMon.clientSubjectExPoll Method

Sends a MON_CLIENT_SUBJECT_EX_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_EX_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_SUBJECT_EX_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_EX_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientSubjectExPoll(string,string);

Sends a MON_CLIENT_SUBJECT_EX_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_EX_POLL_RESULT message.

public static void clientSubjectExPoll(TipcSrv,string,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientSubjectExPoll Method (String, String)

Sends a MON_CLIENT_SUBJECT_EX_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_EX_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientSubjectExPoll(
string client,
string subject
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL
subject
the subject to retrieve the traffic data for, or ALL

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the subject is invalid
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientSubjectExPoll Overload List


TipcMon.clientSubjectExPoll Method (TipcSrv, String, String)

Sends a MON_CLIENT_SUBJECT_EX_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_EX_POLL_RESULT message.

public static void clientSubjectExPoll(
TipcSrv srv,
string client,
string subject
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL
subject
the subject to retrieve the traffic data for, or ALL

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the subject is invalid
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientSubjectExPoll Overload List


clientSubjectPoll Method

SmartSockets .NET Class Library

TipcMon.clientSubjectPoll Method

Sends a MON_CLIENT_SUBJECT_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientSubjectExPoll.

Overload List

Sends a MON_CLIENT_SUBJECT_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method. Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientSubjectExPoll.

public static void clientSubjectPoll(string,string);

Sends a MON_CLIENT_SUBJECT_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_POLL_RESULT message. Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientSubjectExPoll.

public static void clientSubjectPoll(TipcSrv,string,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientSubjectPoll Method (String, String)

Sends a MON_CLIENT_SUBJECT_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientSubjectExPoll.

public static void clientSubjectPoll(
string client,
string subject
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL
subject
the subject to retrieve the traffic data for, or ALL

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the subject is invalid
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientSubjectPoll Overload List


TipcMon.clientSubjectPoll Method (TipcSrv, String, String)

Sends a MON_CLIENT_SUBJECT_POLL_CALL message to the target client. This poll returns traffic data on a specific subject in the client in a MON_CLIENT_SUBJECT_POLL_RESULT message.

Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use clientSubjectExPoll.

public static void clientSubjectPoll(
TipcSrv srv,
string client,
string subject
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL
subject
the subject to retrieve the traffic data for, or ALL

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the subject is invalid
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientSubjectPoll Overload List


clientSubscribeNumPoll Method

SmartSockets .NET Class Library

TipcMon.clientSubscribeNumPoll Method

Sends a MON_CLIENT_SUBSCRIBE_NUM_POLL_CALL message to the target client. This poll returns the number of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_NUM_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_SUBSCRIBE_NUM_POLL_CALL message to the target client. This poll returns the number of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_NUM_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientSubscribeNumPoll(string);

Sends a MON_CLIENT_SUBSCRIBE_NUM_POLL_CALL message to the target client. This poll returns the number of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_NUM_POLL_RESULT message.

public static void clientSubscribeNumPoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientSubscribeNumPoll Method (String)

Sends a MON_CLIENT_SUBSCRIBE_NUM_POLL_CALL message to the target client. This poll returns the number of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_NUM_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientSubscribeNumPoll(
string client
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientSubscribeNumPoll Overload List


TipcMon.clientSubscribeNumPoll Method (TipcSrv, String)

Sends a MON_CLIENT_SUBSCRIBE_NUM_POLL_CALL message to the target client. This poll returns the number of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_NUM_POLL_RESULT message.

public static void clientSubscribeNumPoll(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientSubscribeNumPoll Overload List


clientSubscribePoll Method

SmartSockets .NET Class Library

TipcMon.clientSubscribePoll Method

Sends a MON_CLIENT_SUBSCRIBE_POLL_CALL message to the target client. This poll returns a list of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_SUBSCRIBE_POLL_CALL message to the target client. This poll returns a list of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientSubscribePoll(string);

Sends a MON_CLIENT_SUBSCRIBE_POLL_CALL message to the target client. This poll returns a list of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_POLL_RESULT message.

public static void clientSubscribePoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientSubscribePoll Method (String)

Sends a MON_CLIENT_SUBSCRIBE_POLL_CALL message to the target client. This poll returns a list of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientSubscribePoll(
string client
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientSubscribePoll Overload List


TipcMon.clientSubscribePoll Method (TipcSrv, String)

Sends a MON_CLIENT_SUBSCRIBE_POLL_CALL message to the target client. This poll returns a list of subjects the client is subscribed to in a MON_CLIENT_SUBSCRIBE_POLL_RESULT message.

public static void clientSubscribePoll(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientSubscribePoll Overload List


clientTimePoll Method

SmartSockets .NET Class Library

TipcMon.clientTimePoll Method

Sends a MON_CLIENT_TIME_POLL_CALL message to the target client. This poll returns the time according to the client in a MON_CLIENT_TIME_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_TIME_POLL_CALL message to the target client. This poll returns the time according to the client in a MON_CLIENT_TIME_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientTimePoll(string);

Sends a MON_CLIENT_TIME_POLL_CALL message to the target client. This poll returns the time according to the client in a MON_CLIENT_TIME_POLL_RESULT message.

public static void clientTimePoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientTimePoll Method (String)

Sends a MON_CLIENT_TIME_POLL_CALL message to the target client. This poll returns the time according to the client in a MON_CLIENT_TIME_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientTimePoll(
string client
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientTimePoll Overload List


TipcMon.clientTimePoll Method (TipcSrv, String)

Sends a MON_CLIENT_TIME_POLL_CALL message to the target client. This poll returns the time according to the client in a MON_CLIENT_TIME_POLL_RESULT message.

public static void clientTimePoll(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientTimePoll Overload List


clientVersionPoll Method

SmartSockets .NET Class Library

TipcMon.clientVersionPoll Method

Sends a MON_CLIENT_VERSION_POLL_CALL message to the target client. This poll returns version information about the client in a MON_CLIENT_VERSION_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_CLIENT_VERSION_POLL_CALL message to the target client. This poll returns version information about the client in a MON_CLIENT_VERSION_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientVersionPoll(string);

Sends a MON_CLIENT_VERSION_POLL_CALL message to the target client. This poll returns version information about the client in a MON_CLIENT_VERSION_POLL_RESULT message.

public static void clientVersionPoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.clientVersionPoll Method (String)

Sends a MON_CLIENT_VERSION_POLL_CALL message to the target client. This poll returns version information about the client in a MON_CLIENT_VERSION_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void clientVersionPoll(
string client
);

Parameters

client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientVersionPoll Overload List


TipcMon.clientVersionPoll Method (TipcSrv, String)

Sends a MON_CLIENT_VERSION_POLL_CALL message to the target client. This poll returns version information about the client in a MON_CLIENT_VERSION_POLL_RESULT message.

public static void clientVersionPoll(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.clientVersionPoll Overload List


getClientBufferWatch Method

SmartSockets .NET Class Library

TipcMon.getClientBufferWatch Method

Gets the status of a client buffer watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a client buffer watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientBufferWatch(string);

Gets the status of a client buffer watch.

public static bool getClientBufferWatch(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getClientBufferWatch Method (String)

Gets the status of a client buffer watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientBufferWatch(
string client
);

Parameters

client
the client to check the watch for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientBufferWatch Overload List


TipcMon.getClientBufferWatch Method (TipcSrv, String)

Gets the status of a client buffer watch.

public static bool getClientBufferWatch(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the client to check the watch for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientBufferWatch Overload List


getClientCongestionWatch Method

SmartSockets .NET Class Library

TipcMon.getClientCongestionWatch Method

Gets the status of a client congestion watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a client congestion watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientCongestionWatch(string);

Gets the status of a client congestion watch.

public static bool getClientCongestionWatch(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getClientCongestionWatch Method (String)

Gets the status of a client congestion watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientCongestionWatch(
string client
);

Parameters

client
the client to check the watch for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientCongestionWatch Overload List


TipcMon.getClientCongestionWatch Method (TipcSrv, String)

Gets the status of a client congestion watch.

public static bool getClientCongestionWatch(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the client to check the watch for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientCongestionWatch Overload List


getClientMsgRecvWatch Method

SmartSockets .NET Class Library

TipcMon.getClientMsgRecvWatch Method

Gets the status of a client message receive watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a client message receive watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientMsgRecvWatch(string,string);

Gets the status of a client message receive watch.

public static bool getClientMsgRecvWatch(TipcSrv,string,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getClientMsgRecvWatch Method (String, String)

Gets the status of a client message receive watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientMsgRecvWatch(
string client,
string mtName
);

Parameters

client
the client to check the watch for.
mtName
the name of the message type to check for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientMsgRecvWatch Overload List


TipcMon.getClientMsgRecvWatch Method (TipcSrv, String, String)

Gets the status of a client message receive watch.

public static bool getClientMsgRecvWatch(
TipcSrv srv,
string client,
string mtName
);

Parameters

srv
the RTserver connection issuing the poll.
client
the client to check the watch for.
mtName
the name of the message type to check for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientMsgRecvWatch Overload List


getClientMsgSendWatch Method

SmartSockets .NET Class Library

TipcMon.getClientMsgSendWatch Method

Gets the status of a client message send watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a client message send watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientMsgSendWatch(string,string);

Gets the status of a client message send watch.

public static bool getClientMsgSendWatch(TipcSrv,string,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getClientMsgSendWatch Method (String, String)

Gets the status of a client message send watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientMsgSendWatch(
string client,
string mtName
);

Parameters

client
the client to check the watch for.
mtName
the name of the message type to check for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientMsgSendWatch Overload List


TipcMon.getClientMsgSendWatch Method (TipcSrv, String, String)

Gets the status of a client message send watch.

public static bool getClientMsgSendWatch(
TipcSrv srv,
string client,
string mtName
);

Parameters

srv
the RTserver connection issuing the poll.
client
the client to check the watch for.
mtName
the name of the message type to check for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientMsgSendWatch Overload List


getClientNamesWatch Method

SmartSockets .NET Class Library

TipcMon.getClientNamesWatch Method

Gets the status of a client names watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a client names watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientNamesWatch();

Gets the status of a client names watch.

public static bool getClientNamesWatch(TipcSrv);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getClientNamesWatch Method ()

Gets the status of a client names watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientNamesWatch();

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientNamesWatch Overload List


TipcMon.getClientNamesWatch Method (TipcSrv)

Gets the status of a client names watch.

public static bool getClientNamesWatch(
TipcSrv srv
);

Parameters

srv
the RTserver connection issuing the poll.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientNamesWatch Overload List


getClientSubscribeWatch Method

SmartSockets .NET Class Library

TipcMon.getClientSubscribeWatch Method

Gets the status of a client subscribe watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a client subscribe watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientSubscribeWatch(string);

Gets the status of a client subscribe watch.

public static bool getClientSubscribeWatch(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getClientSubscribeWatch Method (String)

Gets the status of a client subscribe watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientSubscribeWatch(
string client
);

Parameters

client
the client to check the watch for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientSubscribeWatch Overload List


TipcMon.getClientSubscribeWatch Method (TipcSrv, String)

Gets the status of a client subscribe watch.

public static bool getClientSubscribeWatch(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the client to check the watch for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientSubscribeWatch Overload List


getClientTimeWatch Method

SmartSockets .NET Class Library

TipcMon.getClientTimeWatch Method

Gets the status of a client time watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a client time watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientTimeWatch(string);

Gets the status of a client time watch.

public static bool getClientTimeWatch(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getClientTimeWatch Method (String)

Gets the status of a client time watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getClientTimeWatch(
string client
);

Parameters

client
the client to check the watch for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientTimeWatch Overload List


TipcMon.getClientTimeWatch Method (TipcSrv, String)

Gets the status of a client time watch.

public static bool getClientTimeWatch(
TipcSrv srv,
string client
);

Parameters

srv
the RTserver connection issuing the poll.
client
the client to check the watch for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getClientTimeWatch Overload List


TipcMon.getIdentStr Method

Gets the string that identifies this client's "type". This string is entirely user defined, and not processed by SmartSockets.

public static string getIdentStr();

Return Value

the client's identifier string.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


getProjectNamesWatch Method

SmartSockets .NET Class Library

TipcMon.getProjectNamesWatch Method

Gets the status of a project names watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a project names watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getProjectNamesWatch();

Gets the status of a project names watch.

public static bool getProjectNamesWatch(TipcSrv);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getProjectNamesWatch Method ()

Gets the status of a project names watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getProjectNamesWatch();

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getProjectNamesWatch Overload List


TipcMon.getProjectNamesWatch Method (TipcSrv)

Gets the status of a project names watch.

public static bool getProjectNamesWatch(
TipcSrv srv
);

Parameters

srv
the RTserver connection issuing the poll.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getProjectNamesWatch Overload List


getServerCongestionWatch Method

SmartSockets .NET Class Library

TipcMon.getServerCongestionWatch Method

Gets the status of a server congesetion watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a server congesetion watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getServerCongestionWatch(string,string);

Gets the status of a server congestion watch.

public static bool getServerCongestionWatch(TipcSrv,string,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getServerCongestionWatch Method (String, String)

Gets the status of a server congesetion watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getServerCongestionWatch(
string server,
string connectedProcess
);

Parameters

server
the server on which to check the watch.
connectedProcess
the server conn for which to check the watch.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getServerCongestionWatch Overload List


TipcMon.getServerCongestionWatch Method (TipcSrv, String, String)

Gets the status of a server congestion watch.

public static bool getServerCongestionWatch(
TipcSrv srv,
string server,
string connectedProcess
);

Parameters

srv
the RTserver connection issuing the poll.
server
the server to check the watch for.
connectedProcess
the server conn to check the watch for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getServerCongestionWatch Overload List


getServerConnWatch Method

SmartSockets .NET Class Library

TipcMon.getServerConnWatch Method

Gets the status of a server conn watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a server conn watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getServerConnWatch();

Gets the status of a server conn watch.

public static bool getServerConnWatch(TipcSrv);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getServerConnWatch Method ()

Gets the status of a server conn watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getServerConnWatch();

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getServerConnWatch Overload List


TipcMon.getServerConnWatch Method (TipcSrv)

Gets the status of a server conn watch.

public static bool getServerConnWatch(
TipcSrv srv
);

Parameters

srv
the RTserver connection issuing the poll.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getServerConnWatch Overload List


getServerMaxClientLicensesWatch Method

SmartSockets .NET Class Library

TipcMon.getServerMaxClientLicensesWatch Method

Gets the status of a server max client licenses watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a server max client licenses watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getServerMaxClientLicensesWatch(string);

Gets the status of a server max client licenses watch.

public static bool getServerMaxClientLicensesWatch(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getServerMaxClientLicensesWatch Method (String)

Gets the status of a server max client licenses watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getServerMaxClientLicensesWatch(
string server
);

Parameters

server
the server on which to check the watch.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getServerMaxClientLicensesWatch Overload List


TipcMon.getServerMaxClientLicensesWatch Method (TipcSrv, String)

Gets the status of a server max client licenses watch.

public static bool getServerMaxClientLicensesWatch(
TipcSrv srv,
string server
);

Parameters

srv
the RTserver connection issuing the poll.
server
the server to check the watch for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getServerMaxClientLicensesWatch Overload List


getServerNamesWatch Method

SmartSockets .NET Class Library

TipcMon.getServerNamesWatch Method

Gets the status of a server names watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a server names watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getServerNamesWatch();

Gets the status of a server names watch.

public static bool getServerNamesWatch(TipcSrv);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getServerNamesWatch Method ()

Gets the status of a server names watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getServerNamesWatch();

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getServerNamesWatch Overload List


TipcMon.getServerNamesWatch Method (TipcSrv)

Gets the status of a server names watch.

public static bool getServerNamesWatch(
TipcSrv srv
);

Parameters

srv
the RTserver connection issuing the poll.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getServerNamesWatch Overload List


getSubjectNamesWatch Method

SmartSockets .NET Class Library

TipcMon.getSubjectNamesWatch Method

Gets the status of a subject names watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a subject names watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getSubjectNamesWatch();

Gets the status of a subject names watch.

public static bool getSubjectNamesWatch(TipcSrv);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getSubjectNamesWatch Method ()

Gets the status of a subject names watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getSubjectNamesWatch();

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getSubjectNamesWatch Overload List


TipcMon.getSubjectNamesWatch Method (TipcSrv)

Gets the status of a subject names watch.

public static bool getSubjectNamesWatch(
TipcSrv srv
);

Parameters

srv
the RTserver connection issuing the poll.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcException | If an error occurs.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getSubjectNamesWatch Overload List


getSubjectSubscribeWatch Method

SmartSockets .NET Class Library

TipcMon.getSubjectSubscribeWatch Method

Gets the status of a subject subscribe watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Gets the status of a subject subscribe watch. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getSubjectSubscribeWatch(string);

Gets the status of a subject subscribe watch.

public static bool getSubjectSubscribeWatch(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.getSubjectSubscribeWatch Method (String)

Gets the status of a subject subscribe watch.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static bool getSubjectSubscribeWatch(
string subject
);

Parameters

subject
the subject to check the watch for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the subject is invalid
TipcException | For all other errors.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getSubjectSubscribeWatch Overload List


TipcMon.getSubjectSubscribeWatch Method (TipcSrv, String)

Gets the status of a subject subscribe watch.

public static bool getSubjectSubscribeWatch(
TipcSrv srv,
string subject
);

Parameters

srv
the RTserver connection issuing the poll.
subject
the subject to check the watch for.

Return Value

true if the watch is set, false if it isn't.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the subject is invalid
TipcException | For all other errors.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.getSubjectSubscribeWatch Overload List


projectNamesPoll Method

SmartSockets .NET Class Library

TipcMon.projectNamesPoll Method

Sends a MON_PROJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of all current projects in a MON_PROJECT_NAMES_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_PROJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of all current projects in a MON_PROJECT_NAMES_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void projectNamesPoll();

Sends a MON_PROJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of all current projects in a MON_PROJECT_NAMES_POLL_RESULT message.

public static void projectNamesPoll(TipcSrv);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.projectNamesPoll Method ()

Sends a MON_PROJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of all current projects in a MON_PROJECT_NAMES_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void projectNamesPoll();

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.projectNamesPoll Overload List


TipcMon.projectNamesPoll Method (TipcSrv)

Sends a MON_PROJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of all current projects in a MON_PROJECT_NAMES_POLL_RESULT message.

public static void projectNamesPoll(
TipcSrv srv
);

Parameters

srv
the RTserver connection issuing the poll.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.projectNamesPoll Overload List


serverBufferPoll Method

SmartSockets .NET Class Library

TipcMon.serverBufferPoll Method

Sends a MON_SERVER_BUFFER_POLL_CALL message to a particular RTserver. This poll returns message buffer data between given RTserver and some other client or server in a MON_SERVER_BUFFER_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_SERVER_BUFFER_POLL_CALL message to a particular RTserver. This poll returns message buffer data between given RTserver and some other client or server in a MON_SERVER_BUFFER_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverBufferPoll(string,string);

Sends a MON_SERVER_BUFFER_POLL_CALL message to a particular RTserver. This poll returns message buffer data between given RTserver and some other client or server in a MON_SERVER_BUFFER_POLL_RESULT message.

public static void serverBufferPoll(TipcSrv,string,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.serverBufferPoll Method (String, String)

Sends a MON_SERVER_BUFFER_POLL_CALL message to a particular RTserver. This poll returns message buffer data between given RTserver and some other client or server in a MON_SERVER_BUFFER_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverBufferPoll(
string server,
string connectedProcess
);

Parameters

server
the unique subject of the RTserver that is to receive the poll, or ALL
connectedProcess
the unique subject of the other process, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverBufferPoll Overload List


TipcMon.serverBufferPoll Method (TipcSrv, String, String)

Sends a MON_SERVER_BUFFER_POLL_CALL message to a particular RTserver. This poll returns message buffer data between given RTserver and some other client or server in a MON_SERVER_BUFFER_POLL_RESULT message.

public static void serverBufferPoll(
TipcSrv srv,
string server,
string connectedProcess
);

Parameters

srv
the RTserver connection issuing the poll.
server
the unique subject of the RTserver that is to receive the poll, or ALL
connectedProcess
the unique subject of the other process, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverBufferPoll Overload List


serverConnPoll Method

SmartSockets .NET Class Library

TipcMon.serverConnPoll Method

Sends a MON_SERVER_CONN_POLL_CALL message to RTserver. This poll returns a list of the connections RTserver is maintaining in a MON_SERVER_CONN_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_SERVER_CONN_POLL_CALL message to RTserver. This poll returns a list of the connections RTserver is maintaining in a MON_SERVER_CONN_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverConnPoll();

Sends a MON_SERVER_CONN_POLL_CALL message to RTserver. This poll returns a list of the connections RTserver is maintaining in a MON_SERVER_CONN_POLL_RESULT message.

public static void serverConnPoll(TipcSrv);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.serverConnPoll Method ()

Sends a MON_SERVER_CONN_POLL_CALL message to RTserver. This poll returns a list of the connections RTserver is maintaining in a MON_SERVER_CONN_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverConnPoll();

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverConnPoll Overload List


TipcMon.serverConnPoll Method (TipcSrv)

Sends a MON_SERVER_CONN_POLL_CALL message to RTserver. This poll returns a list of the connections RTserver is maintaining in a MON_SERVER_CONN_POLL_RESULT message.

public static void serverConnPoll(
TipcSrv srv
);

Parameters

srv
the RTserver connection issuing the poll.

Exceptions

Exception Type | Condition
TipcException | IF an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverConnPoll Overload List


serverCpuPoll Method

SmartSockets .NET Class Library

TipcMon.serverCpuPoll Method

Sends a MON_SERVER_CPU_POLL_CALL message to a particular RTserver. This poll returns CPU utlization information about a given RTserver in a in a MON_SERVER_CPU_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_SERVER_CPU_POLL_CALL message to a particular RTserver. This poll returns CPU utlization information about a given RTserver in a in a MON_SERVER_CPU_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverCpuPoll(string);

Sends a MON_SERVER_CPU_POLL_CALL message to a particular RTserver. This poll returns CPU utilization information about a given RTserver in a MON_SERVER_CPU_POLL_RESULT message.

public static void serverCpuPoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.serverCpuPoll Method (String)

Sends a MON_SERVER_CPU_POLL_CALL message to a particular RTserver. This poll returns CPU utlization information about a given RTserver in a in a MON_SERVER_CPU_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverCpuPoll(
string server
);

Parameters

server
the unique subject of the RTserver that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverCpuPoll Overload List


TipcMon.serverCpuPoll Method (TipcSrv, String)

Sends a MON_SERVER_CPU_POLL_CALL message to a particular RTserver. This poll returns CPU utilization information about a given RTserver in a MON_SERVER_CPU_POLL_RESULT message.

public static void serverCpuPoll(
TipcSrv srv,
string server
);

Parameters

srv
the RTserver connection issuing the poll.
server
the unique subject of the RTserver that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverCpuPoll Overload List


serverGeneralPoll Method

SmartSockets .NET Class Library

TipcMon.serverGeneralPoll Method

Sends a MON_SERVER_GENERAL_POLL_CALL message to a particular RTserver. This poll returns general information about a given RTserver in a MON_SERVER_GENERAL_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_SERVER_GENERAL_POLL_CALL message to a particular RTserver. This poll returns general information about a given RTserver in a MON_SERVER_GENERAL_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverGeneralPoll(string);

Sends a MON_SERVER_GENERAL_POLL_CALL message to a particular RTserver. This poll returns general information about a given RTserver in a MON_SERVER_GENERAL_POLL_RESULT message.

public static void serverGeneralPoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.serverGeneralPoll Method (String)

Sends a MON_SERVER_GENERAL_POLL_CALL message to a particular RTserver. This poll returns general information about a given RTserver in a MON_SERVER_GENERAL_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverGeneralPoll(
string server
);

Parameters

server
the unique subject of the RTserver that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverGeneralPoll Overload List


TipcMon.serverGeneralPoll Method (TipcSrv, String)

Sends a MON_SERVER_GENERAL_POLL_CALL message to a particular RTserver. This poll returns general information about a given RTserver in a MON_SERVER_GENERAL_POLL_RESULT message.

public static void serverGeneralPoll(
TipcSrv srv,
string server
);

Parameters

srv
the RTserver connection issuing the poll.
server
the unique subject of the RTserver that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverGeneralPoll Overload List


serverMsgTrafficExPoll Method

SmartSockets .NET Class Library

TipcMon.serverMsgTrafficExPoll Method

Sends a MON_SERVER_MSG_TRAFFIC_EX_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_EX_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_SERVER_MSG_TRAFFIC_EX_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_EX_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverMsgTrafficExPoll(string,string);

Sends a MON_SERVER_MSG_TRAFFIC_EX_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_EX_POLL_RESULT message.

public static void serverMsgTrafficExPoll(TipcSrv,string,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.serverMsgTrafficExPoll Method (String, String)

Sends a MON_SERVER_MSG_TRAFFIC_EX_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_EX_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverMsgTrafficExPoll(
string server,
string connectedProcess
);

Parameters

server
the unique subject of the RTserver that is to receive the poll, or ALL
connectedProcess
the unique subject of the other process, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverMsgTrafficExPoll Overload List


TipcMon.serverMsgTrafficExPoll Method (TipcSrv, String, String)

Sends a MON_SERVER_MSG_TRAFFIC_EX_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_EX_POLL_RESULT message.

public static void serverMsgTrafficExPoll(
TipcSrv srv,
string server,
string connectedProcess
);

Parameters

srv
the RTserver connection issuing the poll.
server
the unique subject of the RTserver that is to receive the poll, or ALL
connectedProcess
the unique subject of the other process, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverMsgTrafficExPoll Overload List


serverMsgTrafficPoll Method

SmartSockets .NET Class Library

TipcMon.serverMsgTrafficPoll Method

Sends a MON_SERVER_MSG_TRAFFIC_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use serverMsgTrafficExPoll.

Overload List

Sends a MON_SERVER_MSG_TRAFFIC_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method. Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use serverMsgTrafficExPoll.

public static void serverMsgTrafficPoll(string,string);

Sends a MON_SERVER_MSG_TRAFFIC_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_POLL_RESULT message. Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use serverMsgTrafficExPoll.

public static void serverMsgTrafficPoll(TipcSrv,string,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.serverMsgTrafficPoll Method (String, String)

Sends a MON_SERVER_MSG_TRAFFIC_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use serverMsgTrafficExPoll.

public static void serverMsgTrafficPoll(
string server,
string connectedProcess
);

Parameters

server
the unique subject of the RTserver that is to receive the poll, or ALL
connectedProcess
the unique subject of the other process, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverMsgTrafficPoll Overload List


TipcMon.serverMsgTrafficPoll Method (TipcSrv, String, String)

Sends a MON_SERVER_MSG_TRAFFIC_POLL_CALL message to a particular RTserver. This poll returns message traffic data between a given RTserver and some other client or server in a MON_SERVER_MSG_TRAFFIC_POLL_RESULT message.

Note: The traffic statistics presented in the result message from this poll are truncated to 31 bits, and may contain an incorrect sign bit on some older servers. This method is provided for compatibility with pre-6.7 servers. When polling newer servers, you should use serverMsgTrafficExPoll.

public static void serverMsgTrafficPoll(
TipcSrv srv,
string server,
string connectedProcess
);

Parameters

srv
the RTserver connection issuing the poll.
server
the unique subject of the RTserver that is to receive the poll, or ALL
connectedProcess
the unique subject of the other process, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverMsgTrafficPoll Overload List


serverNamesPoll Method

SmartSockets .NET Class Library

TipcMon.serverNamesPoll Method

Sends a MON_SERVER_NAMES_POLL_CALL message to RTserver. This poll returns a list of the server names in the current project in a MON_SERVER_NAMES_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_SERVER_NAMES_POLL_CALL message to RTserver. This poll returns a list of the server names in the current project in a MON_SERVER_NAMES_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverNamesPoll();

Sends a MON_SERVER_NAMES_POLL_CALL message to RTserver. This poll returns a list of the server names in the current project in a MON_SERVER_NAMES_POLL_RESULT message.

public static void serverNamesPoll(TipcSrv);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.serverNamesPoll Method ()

Sends a MON_SERVER_NAMES_POLL_CALL message to RTserver. This poll returns a list of the server names in the current project in a MON_SERVER_NAMES_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverNamesPoll();

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverNamesPoll Overload List


TipcMon.serverNamesPoll Method (TipcSrv)

Sends a MON_SERVER_NAMES_POLL_CALL message to RTserver. This poll returns a list of the server names in the current project in a MON_SERVER_NAMES_POLL_RESULT message.

public static void serverNamesPoll(
TipcSrv srv
);

Parameters

srv
the RTserver connection issuing the poll.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverNamesPoll Overload List


serverOptionPoll Method

SmartSockets .NET Class Library

TipcMon.serverOptionPoll Method

Sends a MON_SERVER_OPTION_POLL_CALL message to a particular RTserver. This poll returns the value of a specific option in a given RTserver in a MON_SERVER_OPTION_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_SERVER_OPTION_POLL_CALL message to a particular RTserver. This poll returns the value of a specific option in a given RTserver in a MON_SERVER_OPTION_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverOptionPoll(string,string);

Sends a MON_SERVER_OPTION_POLL_CALL message to a particular RTserver. This poll returns the value of a specific option in a given RTserver in a MON_SERVER_OPTION_POLL_RESULT message.

public static void serverOptionPoll(TipcSrv,string,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.serverOptionPoll Method (String, String)

Sends a MON_SERVER_OPTION_POLL_CALL message to a particular RTserver. This poll returns the value of a specific option in a given RTserver in a MON_SERVER_OPTION_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverOptionPoll(
string server,
string optionName
);

Parameters

server
the unique subject of the RTserver that is to receive the poll, or ALL
optionName
the name of the option to get the value of, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverOptionPoll Overload List


TipcMon.serverOptionPoll Method (TipcSrv, String, String)

Sends a MON_SERVER_OPTION_POLL_CALL message to a particular RTserver. This poll returns the value of a specific option in a given RTserver in a MON_SERVER_OPTION_POLL_RESULT message.

public static void serverOptionPoll(
TipcSrv srv,
string server,
string optionName
);

Parameters

srv
the RTserver connection issuing the poll.
server
the unique subject of the RTserver that is to receive, or ALL the poll
optionName
the name of the option to get the value of, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverOptionPoll Overload List


serverRoutePoll Method

SmartSockets .NET Class Library

TipcMon.serverRoutePoll Method

Sends a MON_SERVER_ROUTE_POLL_CALL message to a particular RTserver. This poll returns routing information between two RTservers in a MON_SERVER_ROUTE_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_SERVER_ROUTE_POLL_CALL message to a particular RTserver. This poll returns routing information between two RTservers in a MON_SERVER_ROUTE_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverRoutePoll(string,string);

Sends a MON_SERVER_ROUTE_POLL_CALL message to a particular RTserver. This poll returns routing information between two RTservers in a MON_SERVER_ROUTE_POLL_RESULT message.

public static void serverRoutePoll(TipcSrv,string,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.serverRoutePoll Method (String, String)

Sends a MON_SERVER_ROUTE_POLL_CALL message to a particular RTserver. This poll returns routing information between two RTservers in a MON_SERVER_ROUTE_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverRoutePoll(
string server,
string destServer
);

Parameters

server
the unique subject of the RTserver that is to receive the poll, or ALL
destServer
the unique subject of the other RTserver, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverRoutePoll Overload List


TipcMon.serverRoutePoll Method (TipcSrv, String, String)

Sends a MON_SERVER_ROUTE_POLL_CALL message to a particular RTserver. This poll returns routing information between two RTservers in a MON_SERVER_ROUTE_POLL_RESULT message.

public static void serverRoutePoll(
TipcSrv srv,
string server,
string destServer
);

Parameters

srv
the RTserver connection issuing the poll.
server
the unique subject of the RTserver that is to receive the poll, or ALL
destServer
the unique subject of the other RTserver, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverRoutePoll Overload List


serverStartTimePoll Method

SmartSockets .NET Class Library

TipcMon.serverStartTimePoll Method

Sends a MON_SERVER_START_TIME_POLL_CALL message to a particular RTserver. This poll returns the starting time and elapsed time of a given RTserver in a MON_SERVER_START_TIME_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_SERVER_START_TIME_POLL_CALL message to a particular RTserver. This poll returns the starting time and elapsed time of a given RTserver in a MON_SERVER_START_TIME_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverStartTimePoll(string);

Sends a MON_SERVER_START_TIME_POLL_CALL message to a particular RTserver. This poll returns the starting time and elapsed time of a given RTserver in a MON_SERVER_START_TIME_POLL_RESULT message.

public static void serverStartTimePoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.serverStartTimePoll Method (String)

Sends a MON_SERVER_START_TIME_POLL_CALL message to a particular RTserver. This poll returns the starting time and elapsed time of a given RTserver in a MON_SERVER_START_TIME_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverStartTimePoll(
string server
);

Parameters

server
the unique subject of the RTserver that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverStartTimePoll Overload List


TipcMon.serverStartTimePoll Method (TipcSrv, String)

Sends a MON_SERVER_START_TIME_POLL_CALL message to a particular RTserver. This poll returns the starting time and elapsed time of a given RTserver in a MON_SERVER_START_TIME_POLL_RESULT message.

public static void serverStartTimePoll(
TipcSrv srv,
string server
);

Parameters

srv
the RTserver connection issuing the poll.
server
the unique subject of the RTserver that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverStartTimePoll Overload List


serverTimePoll Method

SmartSockets .NET Class Library

TipcMon.serverTimePoll Method

Sends a MON_SERVER_TIME_POLL_CALL message to a particular RTserver. This poll returns the time according to a given RTserver in a MON_SERVER_TIME_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_SERVER_TIME_POLL_CALL message to a particular RTserver. This poll returns the time according to a given RTserver in a MON_SERVER_TIME_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverTimePoll(string);

Sends a MON_SERVER_TIME_POLL_CALL message to a particular RTserver. This poll returns the time according to a given RTserver in a MON_SERVER_TIME_POLL_RESULT message.

public static void serverTimePoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.serverTimePoll Method (String)

Sends a MON_SERVER_TIME_POLL_CALL message to a particular RTserver. This poll returns the time according to a given RTserver in a MON_SERVER_TIME_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverTimePoll(
string server
);

Parameters

server
the unique subject of the RTserver that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverTimePoll Overload List


TipcMon.serverTimePoll Method (TipcSrv, String)

Sends a MON_SERVER_TIME_POLL_CALL message to a particular RTserver. This poll returns the time according to a given RTserver in a MON_SERVER_TIME_POLL_RESULT message.

public static void serverTimePoll(
TipcSrv srv,
string server
);

Parameters

srv
the RTserver connection issuing the poll.
server
the unique subject of the RTserver that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverTimePoll Overload List


serverVersionPoll Method

SmartSockets .NET Class Library

TipcMon.serverVersionPoll Method

Sends a MON_SERVER_VERSION_POLL_CALL message to the target server. This poll returns version information about the server in a MON_SERVER_VERSION_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_SERVER_VERSION_POLL_CALL message to the target server. This poll returns version information about the server in a MON_SERVER_VERSION_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverVersionPoll(string);

Sends a MON_SERVER_VERSION_POLL_CALL message to the target server. This poll returns version information about the server in a MON_SERVER_VERSION_POLL_RESULT message.

public static void serverVersionPoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.serverVersionPoll Method (String)

Sends a MON_SERVER_VERSION_POLL_CALL message to the target server. This poll returns version information about the server in a MON_SERVER_VERSION_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void serverVersionPoll(
string server
);

Parameters

server
the unique subject of the server that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverVersionPoll Overload List


TipcMon.serverVersionPoll Method (TipcSrv, String)

Sends a MON_SERVER_VERSION_POLL_CALL message to the target server. This poll returns version information about the server in a MON_SERVER_VERSION_POLL_RESULT message.

public static void serverVersionPoll(
TipcSrv srv,
string server
);

Parameters

srv
the RTserver connection issuing the poll.
server
the unique subject of the server that is to receive the poll, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.serverVersionPoll Overload List


setClientBufferWatch Method

SmartSockets .NET Class Library

TipcMon.setClientBufferWatch Method

Sets a watch on the buffer statistics in a particular client. A MON_CLIENT_BUFFER_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on the buffer statistics in a particular client. A MON_CLIENT_BUFFER_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientBufferWatch(string,bool);

Sets a watch on the buffer statistics in a particular client. A MON_CLIENT_BUFFER_STATUS message is returned.

public static void setClientBufferWatch(TipcSrv,string,bool);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setClientBufferWatch Method (String, Boolean)

Sets a watch on the buffer statistics in a particular client. A MON_CLIENT_BUFFER_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientBufferWatch(
string client,
bool status
);

Parameters

client
the unique subject of the client to receive the watch, or ALL
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientBufferWatch Overload List


TipcMon.setClientBufferWatch Method (TipcSrv, String, Boolean)

Sets a watch on the buffer statistics in a particular client. A MON_CLIENT_BUFFER_STATUS message is returned.

public static void setClientBufferWatch(
TipcSrv srv,
string client,
bool status
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client to receive the watch, or ALL
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientBufferWatch Overload List


setClientCongestionWatch Method

SmartSockets .NET Class Library

TipcMon.setClientCongestionWatch Method

Sets a watch on the buffer congestion in a particular client. A MON_CLIENT_CONGESTION_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on the buffer congestion in a particular client. A MON_CLIENT_CONGESTION_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientCongestionWatch(bool,string,int,int);

Sets a watch on the buffer congestion in a particular client. A MON_CLIENT_CONGESTION_STATUS message is returned.

public static void setClientCongestionWatch(TipcSrv,string,bool,int,int);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setClientCongestionWatch Method (Boolean, String, Int32, Int32)

Sets a watch on the buffer congestion in a particular client. A MON_CLIENT_CONGESTION_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientCongestionWatch(
bool status,
string client,
int highWater,
int lowWater
);

Parameters

status
true to set the watch, false to clear it.
client
the unique subject of the client to receive the watch, or ALL
highWater
the number of bytes constituting the high water threshold of the buffer
lowWater
the number of bytes constituting the high water threshold of the buffer

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientCongestionWatch Overload List


TipcMon.setClientCongestionWatch Method (TipcSrv, String, Boolean, Int32, Int32)

Sets a watch on the buffer congestion in a particular client. A MON_CLIENT_CONGESTION_STATUS message is returned.

public static void setClientCongestionWatch(
TipcSrv srv,
string client,
bool status,
int highWater,
int lowWater
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client to receive the watch, or ALL
status
true to set the watch, false to clear it.
highWater
the number of bytes constituting the high water threshold of the buffer
lowWater
the number of bytes constituting the high water threshold of the buffer

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientCongestionWatch Overload List


setClientMsgRecvWatch Method

SmartSockets .NET Class Library

TipcMon.setClientMsgRecvWatch Method

Sets a watch on the messages received by a particular client matching a given message type. A MON_CLIENT_MSG_RECV_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on the messages received by a particular client matching a given message type. A MON_CLIENT_MSG_RECV_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientMsgRecvWatch(string,string,bool);

Sets a watch on the messages received by a particular client matching a given message type. A MON_CLIENT_MSG_RECV_STATUS message is returned.

public static void setClientMsgRecvWatch(TipcSrv,string,string,bool);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setClientMsgRecvWatch Method (String, String, Boolean)

Sets a watch on the messages received by a particular client matching a given message type. A MON_CLIENT_MSG_RECV_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientMsgRecvWatch(
string client,
string mtName,
bool status
);

Parameters

client
the unique subject of the client to receive the watch, or ALL
mtName
the name of the message type to watch, or ALL
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientMsgRecvWatch Overload List


TipcMon.setClientMsgRecvWatch Method (TipcSrv, String, String, Boolean)

Sets a watch on the messages received by a particular client matching a given message type. A MON_CLIENT_MSG_RECV_STATUS message is returned.

public static void setClientMsgRecvWatch(
TipcSrv srv,
string client,
string mtName,
bool status
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client to receive the watch, or ALL
mtName
the name of the message type to watch, or ALL
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientMsgRecvWatch Overload List


setClientMsgSendWatch Method

SmartSockets .NET Class Library

TipcMon.setClientMsgSendWatch Method

Sets a watch on the messages sent by a particular client matching a given message type. A MON_CLIENT_MSG_SEND_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on the messages sent by a particular client matching a given message type. A MON_CLIENT_MSG_SEND_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientMsgSendWatch(string,string,bool);

Sets a watch on the messages sent by a particular client matching a given message type. A MON_CLIENT_MSG_SEND_STATUS message is returned.

public static void setClientMsgSendWatch(TipcSrv,string,string,bool);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setClientMsgSendWatch Method (String, String, Boolean)

Sets a watch on the messages sent by a particular client matching a given message type. A MON_CLIENT_MSG_SEND_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientMsgSendWatch(
string client,
string mtName,
bool status
);

Parameters

client
the unique subject of the client to receive the watch, or ALL
mtName
the name of the message type to watch, or ALL
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientMsgSendWatch Overload List


TipcMon.setClientMsgSendWatch Method (TipcSrv, String, String, Boolean)

Sets a watch on the messages sent by a particular client matching a given message type. A MON_CLIENT_MSG_SEND_STATUS message is returned.

public static void setClientMsgSendWatch(
TipcSrv srv,
string client,
string mtName,
bool status
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client to receive the watch, or ALL
mtName
the name of the message type to watch, or ALL
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientMsgSendWatch Overload List


setClientNamesWatch Method

SmartSockets .NET Class Library

TipcMon.setClientNamesWatch Method

Sets a watch on client names in the current project. A MON_CLIENT_NAMES_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on client names in the current project. A MON_CLIENT_NAMES_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientNamesWatch(bool);

Sets a watch on client names in the current project. A MON_CLIENT_NAMES_STATUS message is returned.

public static void setClientNamesWatch(TipcSrv,bool);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setClientNamesWatch Method (Boolean)

Sets a watch on client names in the current project. A MON_CLIENT_NAMES_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientNamesWatch(
bool status
);

Parameters

status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientNamesWatch Overload List


TipcMon.setClientNamesWatch Method (TipcSrv, Boolean)

Sets a watch on client names in the current project. A MON_CLIENT_NAMES_STATUS message is returned.

public static void setClientNamesWatch(
TipcSrv srv,
bool status
);

Parameters

srv
the RTserver connection issuing the poll.
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientNamesWatch Overload List


setClientSubscribeWatch Method

SmartSockets .NET Class Library

TipcMon.setClientSubscribeWatch Method

Sets a watch on the client's subscription table. A MON_CLIENT_SUBSCRIBE_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on the client's subscription table. A MON_CLIENT_SUBSCRIBE_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientSubscribeWatch(string,bool);

Sets a watch on the client's subscription table. A MON_CLIENT_SUBSCRIBE_STATUS message is returned.

public static void setClientSubscribeWatch(TipcSrv,string,bool);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setClientSubscribeWatch Method (String, Boolean)

Sets a watch on the client's subscription table. A MON_CLIENT_SUBSCRIBE_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientSubscribeWatch(
string client,
bool status
);

Parameters

client
the unique subject of the client to receive the watch, or ALL
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientSubscribeWatch Overload List


TipcMon.setClientSubscribeWatch Method (TipcSrv, String, Boolean)

Sets a watch on the client's subscription table. A MON_CLIENT_SUBSCRIBE_STATUS message is returned.

public static void setClientSubscribeWatch(
TipcSrv srv,
string client,
bool status
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client to receive the watch, or ALL
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientSubscribeWatch Overload List


setClientTimeWatch Method

SmartSockets .NET Class Library

TipcMon.setClientTimeWatch Method

Sets a watch on the time according to a particular client. A MON_CLIENT_NAMES_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on the time according to a particular client. A MON_CLIENT_NAMES_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientTimeWatch(string,bool);

Sets a watch on the time according to a particular client. A MON_CLIENT_TIME_STATUS message is returned.

public static void setClientTimeWatch(TipcSrv,string,bool);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setClientTimeWatch Method (String, Boolean)

Sets a watch on the time according to a particular client. A MON_CLIENT_NAMES_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setClientTimeWatch(
string client,
bool status
);

Parameters

client
the unique subject of the client to receive the watch, or ALL
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientTimeWatch Overload List


TipcMon.setClientTimeWatch Method (TipcSrv, String, Boolean)

Sets a watch on the time according to a particular client. A MON_CLIENT_TIME_STATUS message is returned.

public static void setClientTimeWatch(
TipcSrv srv,
string client,
bool status
);

Parameters

srv
the RTserver connection issuing the poll.
client
the unique subject of the client to receive the watch, or ALL
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setClientTimeWatch Overload List


TipcMon.setIdentStr Method

Sets a string that identifies this client's "type". This string is entirely user defined, and not processed by SmartSockets.

public static void setIdentStr(
string ident
);

Parameters

ident
the new identifier string.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


setProjectNamesWatch Method

SmartSockets .NET Class Library

TipcMon.setProjectNamesWatch Method

Sets a watch on the projects seen by RTserver. A MON_PROJECT_NAMES_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on the projects seen by RTserver. A MON_PROJECT_NAMES_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setProjectNamesWatch(bool);

Sets a watch on the projects seen by RTserver. A MON_PROJECT_NAMES_STATUS message is returned.

public static void setProjectNamesWatch(TipcSrv,bool);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setProjectNamesWatch Method (Boolean)

Sets a watch on the projects seen by RTserver. A MON_PROJECT_NAMES_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setProjectNamesWatch(
bool status
);

Parameters

status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setProjectNamesWatch Overload List


TipcMon.setProjectNamesWatch Method (TipcSrv, Boolean)

Sets a watch on the projects seen by RTserver. A MON_PROJECT_NAMES_STATUS message is returned.

public static void setProjectNamesWatch(
TipcSrv srv,
bool status
);

Parameters

srv
the RTserver connection issuing the poll.
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setProjectNamesWatch Overload List


setServerCongestionWatch Method

SmartSockets .NET Class Library

TipcMon.setServerCongestionWatch Method

Sets a watch on RTserver connection congestion. A MON_SERVER_CONGESTION_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on RTserver connection congestion. A MON_SERVER_CONGESTION_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setServerCongestionWatch(bool,string,string,int,int);

Sets a watch on RTserver connection congestion. A MON_SERVER_CONGETSTION_STATUS message is returned.

public static void setServerCongestionWatch(TipcSrv,bool,string,string,int,int);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setServerCongestionWatch Method (Boolean, String, String, Int32, Int32)

Sets a watch on RTserver connection congestion. A MON_SERVER_CONGESTION_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setServerCongestionWatch(
bool status,
string server,
string connectedProcess,
int highWater,
int lowWater
);

Parameters

status
true to set the watch, false to clear it.
server
the unique subject of the server to receive the watch, or ALL
connectedProcess
the name of the RTserver conn to be monitored or ALL
highWater
the number of bytes constituting the high water threshold of the buffer
lowWater
the number of bytes constituting the high water threshold of the buffer

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setServerCongestionWatch Overload List


TipcMon.setServerCongestionWatch Method (TipcSrv, Boolean, String, String, Int32, Int32)

Sets a watch on RTserver connection congestion. A MON_SERVER_CONGETSTION_STATUS message is returned.

public static void setServerCongestionWatch(
TipcSrv srv,
bool status,
string server,
string connectedProcess,
int highWater,
int lowWater
);

Parameters

srv
the RTserver to be monitored.
status
true to set the watch, false to clear it.
server
the unique subject of the server to receive the watch, or ALL
connectedProcess
the name of the RTserver conn to be monitored or ALL
highWater
the number of bytes constituting the high water threshold of the buffer
lowWater
the number of bytes constituting the high water threshold of the buffer

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setServerCongestionWatch Overload List


setServerConnWatch Method

SmartSockets .NET Class Library

TipcMon.setServerConnWatch Method

Sets a watch on the connections maintained by RTserver. A MON_SERVER_CONN_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on the connections maintained by RTserver. A MON_SERVER_CONN_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setServerConnWatch(bool);

Sets a watch on the connections maintained by RTserver. A MON_SERVER_CONN_STATUS message is returned.

public static void setServerConnWatch(TipcSrv,bool);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setServerConnWatch Method (Boolean)

Sets a watch on the connections maintained by RTserver. A MON_SERVER_CONN_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setServerConnWatch(
bool status
);

Parameters

status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setServerConnWatch Overload List


TipcMon.setServerConnWatch Method (TipcSrv, Boolean)

Sets a watch on the connections maintained by RTserver. A MON_SERVER_CONN_STATUS message is returned.

public static void setServerConnWatch(
TipcSrv srv,
bool status
);

Parameters

srv
the RTserver connection issuing the poll.
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setServerConnWatch Overload List


setServerMaxClientLicensesWatch Method

SmartSockets .NET Class Library

TipcMon.setServerMaxClientLicensesWatch Method

Sets a watch on an RTserver rejecting a client connection due to the maximum number of client licenses allowed being exceeded. A MON_SERVER_MAX_CLIENT_LICENSES_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on an RTserver rejecting a client connection due to the maximum number of client licenses allowed being exceeded. A MON_SERVER_MAX_CLIENT_LICENSES_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setServerMaxClientLicensesWatch(bool,string);

Sets a watch on an RTserver rejecting a client connection due to the maximum number of client licenses allowed being exceeded. A MON_SERVER_MAX_CLIENT_LICENSES_STATUS message is returned.

public static void setServerMaxClientLicensesWatch(TipcSrv,bool,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setServerMaxClientLicensesWatch Method (Boolean, String)

Sets a watch on an RTserver rejecting a client connection due to the maximum number of client licenses allowed being exceeded. A MON_SERVER_MAX_CLIENT_LICENSES_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setServerMaxClientLicensesWatch(
bool status,
string server
);

Parameters

status
true to set the watch, false to clear it.
server
the unique subject of the server to receive the watch, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setServerMaxClientLicensesWatch Overload List


TipcMon.setServerMaxClientLicensesWatch Method (TipcSrv, Boolean, String)

Sets a watch on an RTserver rejecting a client connection due to the maximum number of client licenses allowed being exceeded. A MON_SERVER_MAX_CLIENT_LICENSES_STATUS message is returned.

public static void setServerMaxClientLicensesWatch(
TipcSrv srv,
bool status,
string server
);

Parameters

srv
the RTserver connection issuing the poll.
status
true to set the watch, false to clear it.
server
the unique subject of the server to receive the watch, or ALL

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setServerMaxClientLicensesWatch Overload List


setServerNamesWatch Method

SmartSockets .NET Class Library

TipcMon.setServerNamesWatch Method

Sets a watch on the RTservers in the current project. A MON_SERVER_NAMES_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on the RTservers in the current project. A MON_SERVER_NAMES_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setServerNamesWatch(bool);

Sets a watch on the RTservers in the current project. A MON_SERVER_NAMES_STATUS message is returned.

public static void setServerNamesWatch(TipcSrv,bool);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setServerNamesWatch Method (Boolean)

Sets a watch on the RTservers in the current project. A MON_SERVER_NAMES_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setServerNamesWatch(
bool status
);

Parameters

status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setServerNamesWatch Overload List


TipcMon.setServerNamesWatch Method (TipcSrv, Boolean)

Sets a watch on the RTservers in the current project. A MON_SERVER_NAMES_STATUS message is returned.

public static void setServerNamesWatch(
TipcSrv srv,
bool status
);

Parameters

srv
the RTserver connection issuing the poll.
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setServerNamesWatch Overload List


setSubjectNamesWatch Method

SmartSockets .NET Class Library

TipcMon.setSubjectNamesWatch Method

Sets a watch on the subjects in the current project. A MON_SUBJECT_NAMES_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on the subjects in the current project. A MON_SUBJECT_NAMES_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setSubjectNamesWatch(bool);

Sets a watch on the subjects in the current project. A MON_SUBJECT_NAMES_STATUS message is returned.

public static void setSubjectNamesWatch(TipcSrv,bool);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setSubjectNamesWatch Method (Boolean)

Sets a watch on the subjects in the current project. A MON_SUBJECT_NAMES_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setSubjectNamesWatch(
bool status
);

Parameters

status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setSubjectNamesWatch Overload List


TipcMon.setSubjectNamesWatch Method (TipcSrv, Boolean)

Sets a watch on the subjects in the current project. A MON_SUBJECT_NAMES_STATUS message is returned.

public static void setSubjectNamesWatch(
TipcSrv srv,
bool status
);

Parameters

srv
the RTserver connection issuing the poll.
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setSubjectNamesWatch Overload List


setSubjectSubscribeWatch Method

SmartSockets .NET Class Library

TipcMon.setSubjectSubscribeWatch Method

Sets a watch on the subject subscription statistics in the current project. A MON_SUBJECT_SUBSCRIBE_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sets a watch on the subject subscription statistics in the current project. A MON_SUBJECT_SUBSCRIBE_STATUS message is returned. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setSubjectSubscribeWatch(string,bool);

Sets a watch on the subject subscription statistics in the current project. A MON_SUBJECT_SUBSCRIBE_STATUS message is returned.

public static void setSubjectSubscribeWatch(TipcSrv,string,bool);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.setSubjectSubscribeWatch Method (String, Boolean)

Sets a watch on the subject subscription statistics in the current project. A MON_SUBJECT_SUBSCRIBE_STATUS message is returned.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void setSubjectSubscribeWatch(
string subject,
bool status
);

Parameters

subject
subject to watch.
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the subject is invalid
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setSubjectSubscribeWatch Overload List


TipcMon.setSubjectSubscribeWatch Method (TipcSrv, String, Boolean)

Sets a watch on the subject subscription statistics in the current project. A MON_SUBJECT_SUBSCRIBE_STATUS message is returned.

public static void setSubjectSubscribeWatch(
TipcSrv srv,
string subject,
bool status
);

Parameters

srv
the RTserver connection issuing the poll.
subject
subject to watch.
status
true to set the watch, false to clear it.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the subject is invalid
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.setSubjectSubscribeWatch Overload List


subjectNamesPoll Method

SmartSockets .NET Class Library

TipcMon.subjectNamesPoll Method

Sends a MON_SUBJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the subjects in the current project in a MON_SUBJECT_NAMES_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_SUBJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the subjects in the current project in a MON_SUBJECT_NAMES_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void subjectNamesPoll();

Sends a MON_SUBJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the subjects in the current project in a MON_SUBJECT_NAMES_POLL_RESULT message.

public static void subjectNamesPoll(TipcSrv);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.subjectNamesPoll Method ()

Sends a MON_SUBJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the subjects in the current project in a MON_SUBJECT_NAMES_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void subjectNamesPoll();

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.subjectNamesPoll Overload List


TipcMon.subjectNamesPoll Method (TipcSrv)

Sends a MON_SUBJECT_NAMES_POLL_CALL message to RTserver. This poll returns a list of the subjects in the current project in a MON_SUBJECT_NAMES_POLL_RESULT message.

public static void subjectNamesPoll(
TipcSrv srv
);

Parameters

srv
the RTserver connection issuing the poll.

Exceptions

Exception Type | Condition
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.subjectNamesPoll Overload List


subjectSubscribePoll Method

SmartSockets .NET Class Library

TipcMon.subjectSubscribePoll Method

Sends a MON_SUBJECT_SUBSCRIBE_POLL_CALL message to RTserver. This poll returns data on a particular subject in the current project in a MON_SUBJECT_SUBSCRIBE_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

Overload List

Sends a MON_SUBJECT_SUBSCRIBE_POLL_CALL message to RTserver. This poll returns data on a particular subject in the current project in a MON_SUBJECT_SUBSCRIBE_POLL_RESULT message. Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void subjectSubscribePoll(string);

Sends a MON_SUBJECT_SUBSCRIBE_POLL_CALL message to RTserver. This poll returns data on a particular subject in the current project in a MON_SUBJECT_SUBSCRIBE_POLL_RESULT message.

public static void subjectSubscribePoll(TipcSrv,string);

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace


TipcMon.subjectSubscribePoll Method (String)

Sends a MON_SUBJECT_SUBSCRIBE_POLL_CALL message to RTserver. This poll returns data on a particular subject in the current project in a MON_SUBJECT_SUBSCRIBE_POLL_RESULT message.

Note: This method should only be invoked when using a single, global RTserver connection via the Srv method.

public static void subjectSubscribePoll(
string subject
);

Parameters

subject
the subject to retreive the data for, or ALL

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the subject is invalid
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.subjectSubscribePoll Overload List


TipcMon.subjectSubscribePoll Method (TipcSrv, String)

Sends a MON_SUBJECT_SUBSCRIBE_POLL_CALL message to RTserver. This poll returns data on a particular subject in the current project in a MON_SUBJECT_SUBSCRIBE_POLL_RESULT message.

public static void subjectSubscribePoll(
TipcSrv srv,
string subject
);

Parameters

srv
the RTserver connection issuing the poll.
subject
the subject to retreive the data for, or ALL

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the subject is invalid
TipcException | If an error occurs sending the message.

See Also

TipcMon Class | TIBCO.SMARTSOCKETS Namespace | TipcMon.subjectSubscribePoll Overload List


TipcMonExt Class

This class provides a set of static methods that provide the monitoring extensions for an RTclient.

Note: There are two versions of each method in this class. When multiple RTserver connections are created by the createSrv method, then the version that requires a TipcSrv object as its first argument should be used. If the RTserver connection was created using the Srv property, then use the version that does not take a TipcSrv object as its first argument.

For a list of all members of this type, see TipcMonExt Members.

System.Object
TIBCO.SMARTSOCKETS.TipcMonExt

public class TipcMonExt

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMonExt Members | TIBCO.SMARTSOCKETS Namespace


TipcMonExt Members

TipcMonExt overview

Public Static Methods

delete | Overloaded. Deletes a named field from the monitor extension message. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setBinary | Overloaded. Adds a binary field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setBool | Overloaded. Adds a boolean field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setBoolArray | Overloaded. Adds a boolean array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setInt2 | Overloaded. Adds an int2 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setInt2Array | Overloaded. Adds a int2 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setInt4 | Overloaded. Adds an int4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setInt4Array | Overloaded. Adds a int4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setInt8 | Overloaded. Adds an int8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setInt8Array | Overloaded. Adds a int8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setReal4 | Overloaded. Adds a real4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setReal4Array | Overloaded. Adds a real4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setReal8 | Overloaded. Adds a real8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setReal8Array | Overloaded. Adds a real8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setStr | Overloaded. Adds a string field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setStrArray | Overloaded. Adds a string array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setUtf8 | Overloaded. Adds a utf8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setUtf8Array | Overloaded. Adds a utf8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt Methods

The methods of the TipcMonExt class are listed below. For a complete list of TipcMonExt class members, see the TipcMonExt Members topic.

Public Static Methods

delete | Overloaded. Deletes a named field from the monitor extension message. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setBinary | Overloaded. Adds a binary field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setBool | Overloaded. Adds a boolean field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setBoolArray | Overloaded. Adds a boolean array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setInt2 | Overloaded. Adds an int2 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setInt2Array | Overloaded. Adds a int2 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setInt4 | Overloaded. Adds an int4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setInt4Array | Overloaded. Adds a int4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setInt8 | Overloaded. Adds an int8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setInt8Array | Overloaded. Adds a int8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setReal4 | Overloaded. Adds a real4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setReal4Array | Overloaded. Adds a real4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setReal8 | Overloaded. Adds a real8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setReal8Array | Overloaded. Adds a real8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setStr | Overloaded. Adds a string field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setStrArray | Overloaded. Adds a string array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setUtf8 | Overloaded. Adds a utf8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.
setUtf8Array | Overloaded. Adds a utf8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


delete Method

SmartSockets .NET Class Library

TipcMonExt.delete Method

Deletes a named field from the monitor extension message.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Deletes a named field from the monitor extension message. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void delete(string);

Deletes a named field from the monitor extension message.

public static void delete(TipcSrv,string);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.delete Method (String)

Deletes a named field from the monitor extension message.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void delete(
string data_name
);

Parameters

data_name
the name associated with the extension data being deleted.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.delete Overload List


TipcMonExt.delete Method (TipcSrv, String)

Deletes a named field from the monitor extension message.

public static void delete(
TipcSrv srv,
string data_name
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being deleted.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.delete Overload List


setBinary Method

SmartSockets .NET Class Library

TipcMonExt.setBinary Method

Adds a binary field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a binary field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setBinary(string,sbyte[]);

Adds an bianry field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setBinary(TipcSrv,string,sbyte[]);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setBinary Method (String, SByte[])

Adds a binary field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setBinary(
string data_name,
sbyte[] data
);

Parameters

data_name
the name associated with the extension data being added.
data
the binary data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setBinary Overload List


TipcMonExt.setBinary Method (TipcSrv, String, SByte[])

Adds an bianry field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setBinary(
TipcSrv srv,
string data_name,
sbyte[] data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the binary data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setBinary Overload List


setBool Method

SmartSockets .NET Class Library

TipcMonExt.setBool Method

Adds a boolean field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a boolean field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setBool(string,bool);

Adds a boolean field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setBool(TipcSrv,string,bool);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setBool Method (String, Boolean)

Adds a boolean field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setBool(
string data_name,
bool data
);

Parameters

data_name
the name associated with the extension data being added.
data
the boolean data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setBool Overload List


TipcMonExt.setBool Method (TipcSrv, String, Boolean)

Adds a boolean field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setBool(
TipcSrv srv,
string data_name,
bool data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the boolean data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setBool Overload List


setBoolArray Method

SmartSockets .NET Class Library

TipcMonExt.setBoolArray Method

Adds a boolean array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a boolean array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setBoolArray(string,bool[]);

Adds a boolean array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setBoolArray(TipcSrv,string,bool[]);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setBoolArray Method (String, Boolean[])

Adds a boolean array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setBoolArray(
string data_name,
bool[] data
);

Parameters

data_name
the name associated with the extension data being added.
data
the boolean array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setBoolArray Overload List


TipcMonExt.setBoolArray Method (TipcSrv, String, Boolean[])

Adds a boolean array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setBoolArray(
TipcSrv srv,
string data_name,
bool[] data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the boolean array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setBoolArray Overload List


setInt2 Method

SmartSockets .NET Class Library

TipcMonExt.setInt2 Method

Adds an int2 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds an int2 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setInt2(string,short);

Adds an int2 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setInt2(TipcSrv,string,short);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setInt2 Method (String, Int16)

Adds an int2 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setInt2(
string data_name,
short data
);

Parameters

data_name
the name associated with the extension data being added.
data
the int4 data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setInt2 Overload List


TipcMonExt.setInt2 Method (TipcSrv, String, Int16)

Adds an int2 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setInt2(
TipcSrv srv,
string data_name,
short data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the int4 data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setInt2 Overload List


setInt2Array Method

SmartSockets .NET Class Library

TipcMonExt.setInt2Array Method

Adds a int2 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a int2 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setInt2Array(string,short[]);

Adds a int2 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setInt2Array(TipcSrv,string,short[]);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setInt2Array Method (String, Int16[])

Adds a int2 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setInt2Array(
string data_name,
short[] data
);

Parameters

data_name
the name associated with the extension data being added.
data
the boolean array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setInt2Array Overload List


TipcMonExt.setInt2Array Method (TipcSrv, String, Int16[])

Adds a int2 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setInt2Array(
TipcSrv srv,
string data_name,
short[] data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the boolean array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setInt2Array Overload List


setInt4 Method

SmartSockets .NET Class Library

TipcMonExt.setInt4 Method

Adds an int4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds an int4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setInt4(string,int);

Adds an int4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setInt4(TipcSrv,string,int);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setInt4 Method (String, Int32)

Adds an int4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setInt4(
string data_name,
int data
);

Parameters

data_name
the name associated with the extension data being added.
data
the int4 data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setInt4 Overload List


TipcMonExt.setInt4 Method (TipcSrv, String, Int32)

Adds an int4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setInt4(
TipcSrv srv,
string data_name,
int data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the int4 data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setInt4 Overload List


setInt4Array Method

SmartSockets .NET Class Library

TipcMonExt.setInt4Array Method

Adds a int4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a int4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setInt4Array(string,int[]);

Adds a int4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setInt4Array(TipcSrv,string,int[]);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setInt4Array Method (String, Int32[])

Adds a int4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setInt4Array(
string data_name,
int[] data
);

Parameters

data_name
the name associated with the extension data being added.
data
the boolean array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setInt4Array Overload List


TipcMonExt.setInt4Array Method (TipcSrv, String, Int32[])

Adds a int4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setInt4Array(
TipcSrv srv,
string data_name,
int[] data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the boolean array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setInt4Array Overload List


setInt8 Method

SmartSockets .NET Class Library

TipcMonExt.setInt8 Method

Adds an int8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds an int8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setInt8(string,long);

Adds an int8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setInt8(TipcSrv,string,long);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setInt8 Method (String, Int64)

Adds an int8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setInt8(
string data_name,
long data
);

Parameters

data_name
the name associated with the extension data being added.
data
the int8 data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setInt8 Overload List


TipcMonExt.setInt8 Method (TipcSrv, String, Int64)

Adds an int8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setInt8(
TipcSrv srv,
string data_name,
long data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the int8 data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setInt8 Overload List


setInt8Array Method

SmartSockets .NET Class Library

TipcMonExt.setInt8Array Method

Adds a int8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a int8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setInt8Array(string,long[]);

Adds a int8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setInt8Array(TipcSrv,string,long[]);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setInt8Array Method (String, Int64[])

Adds a int8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setInt8Array(
string data_name,
long[] data
);

Parameters

data_name
the name associated with the extension data being added.
data
the int8 array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setInt8Array Overload List


TipcMonExt.setInt8Array Method (TipcSrv, String, Int64[])

Adds a int8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setInt8Array(
TipcSrv srv,
string data_name,
long[] data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the int8 array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setInt8Array Overload List


setReal4 Method

SmartSockets .NET Class Library

TipcMonExt.setReal4 Method

Adds a real4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a real4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setReal4(string,float);

Adds an real4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setReal4(TipcSrv,string,float);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setReal4 Method (String, Single)

Adds a real4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setReal4(
string data_name,
float data
);

Parameters

data_name
the name associated with the extension data being added.
data
the real4 data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setReal4 Overload List


TipcMonExt.setReal4 Method (TipcSrv, String, Single)

Adds an real4 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setReal4(
TipcSrv srv,
string data_name,
float data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the real4 data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setReal4 Overload List


setReal4Array Method

SmartSockets .NET Class Library

TipcMonExt.setReal4Array Method

Adds a real4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a real4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setReal4Array(string,float[]);

Adds a real4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setReal4Array(TipcSrv,string,float[]);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setReal4Array Method (String, Single[])

Adds a real4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setReal4Array(
string data_name,
float[] data
);

Parameters

data_name
the name associated with the extension data being added.
data
the real4 array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setReal4Array Overload List


TipcMonExt.setReal4Array Method (TipcSrv, String, Single[])

Adds a real4 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setReal4Array(
TipcSrv srv,
string data_name,
float[] data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the real4 array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setReal4Array Overload List


setReal8 Method

SmartSockets .NET Class Library

TipcMonExt.setReal8 Method

Adds a real8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a real8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setReal8(string,double);

Adds an real8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setReal8(TipcSrv,string,double);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setReal8 Method (String, Double)

Adds a real8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setReal8(
string data_name,
double data
);

Parameters

data_name
the name associated with the extension data being added.
data
the real8 data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setReal8 Overload List


TipcMonExt.setReal8 Method (TipcSrv, String, Double)

Adds an real8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setReal8(
TipcSrv srv,
string data_name,
double data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the real8 data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setReal8 Overload List


setReal8Array Method

SmartSockets .NET Class Library

TipcMonExt.setReal8Array Method

Adds a real8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a real8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setReal8Array(string,double[]);

Adds a real8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setReal8Array(TipcSrv,string,double[]);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setReal8Array Method (String, Double[])

Adds a real8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setReal8Array(
string data_name,
double[] data
);

Parameters

data_name
the name associated with the extension data being added.
data
the real8 array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setReal8Array Overload List


TipcMonExt.setReal8Array Method (TipcSrv, String, Double[])

Adds a real8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setReal8Array(
TipcSrv srv,
string data_name,
double[] data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the real8 array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setReal8Array Overload List


setStr Method

SmartSockets .NET Class Library

TipcMonExt.setStr Method

Adds a string field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a string field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setStr(string,string);

Adds a string field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setStr(TipcSrv,string,string);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setStr Method (String, String)

Adds a string field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setStr(
string data_name,
string data
);

Parameters

data_name
the name associated with the extension data being added.
data
the boolean data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setStr Overload List


TipcMonExt.setStr Method (TipcSrv, String, String)

Adds a string field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setStr(
TipcSrv srv,
string data_name,
string data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the boolean data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setStr Overload List


setStrArray Method

SmartSockets .NET Class Library

TipcMonExt.setStrArray Method

Adds a string array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a string array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setStrArray(string,string[]);

Adds a string array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setStrArray(TipcSrv,string,string[]);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setStrArray Method (String, String[])

Adds a string array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setStrArray(
string data_name,
string[] data
);

Parameters

data_name
the name associated with the extension data being added.
data
the boolean array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setStrArray Overload List


TipcMonExt.setStrArray Method (TipcSrv, String, String[])

Adds a string array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setStrArray(
TipcSrv srv,
string data_name,
string[] data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the boolean array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setStrArray Overload List


setUtf8 Method

SmartSockets .NET Class Library

TipcMonExt.setUtf8 Method

Adds a utf8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a utf8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setUtf8(string,string);

Adds an utf8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setUtf8(TipcSrv,string,string);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setUtf8 Method (String, String)

Adds a utf8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setUtf8(
string data_name,
string data
);

Parameters

data_name
the name associated with the extension data being added.
data
the utf8 data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setUtf8 Overload List


TipcMonExt.setUtf8 Method (TipcSrv, String, String)

Adds an utf8 field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setUtf8(
TipcSrv srv,
string data_name,
string data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the utf8 data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setUtf8 Overload List


setUtf8Array Method

SmartSockets .NET Class Library

TipcMonExt.setUtf8Array Method

Adds a utf8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

Overload List

Adds a utf8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field. Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setUtf8Array(string,string[]);

Adds a utf8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setUtf8Array(TipcSrv,string,string[]);

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace


TipcMonExt.setUtf8Array Method (String, String[])

Adds a utf8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

Note: This method should only be invoked when using a single, global RTserver connection via the TipSvc.getSrv method.

public static void setUtf8Array(
string data_name,
string[] data
);

Parameters

data_name
the name associated with the extension data being added.
data
the utf8 array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setUtf8Array Overload List


TipcMonExt.setUtf8Array Method (TipcSrv, String, String[])

Adds a utf8 array field to the monitor extension message, associating that field with a name. If the named field already exists the method will update the value of the named field.

public static void setUtf8Array(
TipcSrv srv,
string data_name,
string[] data
);

Parameters

srv
the RTserver connection issuing the set.
data_name
the name associated with the extension data being added.
data
the utf8 array data to be added to the monitor extension message.

Exceptions

Exception Type | Condition
TipcException | If an error occurs updating the message.

See Also

TipcMonExt Class | TIBCO.SMARTSOCKETS Namespace | TipcMonExt.setUtf8Array Overload List


TipcMsg Class

Provides access to message objects.

Messages can only be created from the TipcSvc factory class with createMsg.

A message consists of a type TipcMt, properties, and zero or more fields. The field types are used to convert the field data from the format used by the sending platform to the format used by the receiving platform (byte order, etc.). These types are:

BINARY - an array of uninterpreted bytes (byte[])
CHAR   - a character (char)
STR    - an array of signed bytes representing a string (String)
INT2   - a signed 2 byte integer (short)
INT4   - a signed 4 byte integer (int)
INT8   - a signed 8 byte integer (long)
REAL4  - a 4 byte real number (float)
REAL8  - an 8 byte real number (double)
REAL16 - a 16 byte real number (unsupported by .NET)
MSG    - an embedded SmartSockets message (TipcMsg)
BOOL   - a boolean value (boolean)
BYTE   - a single byte (byte)
UTF8   - an array of bytes representing a UTF-8 encoded string (String)
XML    - a XML object (TutXml)
OBJECT - a .NET object (Object)

For a list of all members of this type, see TipcMsg Members.

System.Object
TIBCO.SMARTSOCKETS.TipcMsg

public class TipcMsg : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMsg Members | TIBCO.SMARTSOCKETS Namespace


TipcMsg Members

TipcMsg overview

Public Instance Properties

ArrivalTimestamp | Gets/Sets the arrival timestamp property of the message. Returns the timestamp of the message in seconds since 00:00:00 UTC, January 1, 1970, or 0.0 if not set
Compression | Gets/Sets the compression flag. True to enable compression.
CorrelationId | Gets/Sets the correlation id property of the message. Returns the message id of the message or null if not set.
Current | Gets/Sets the current field number of the message. The "current field" is a cursor indexing the fields in a message.
CurrentFieldCharFormat | Gets the character format for the current field. The char format, which will be one of CHAR_US_ASCII or CHAR_US_EBCDIC
CurrentFieldIntFormat | Gets the integer format for the current field. The int format, which will be one of INT_LITTLE_ENDIAN or INT_BIG_ENDIAN
CurrentFieldKnown | Returns true if the current field contains an actual value; false if the field is marked as having an 'unknown value'.
CurrentFieldRealFormat | Gets the real format for the current field. The real format, which will be one of REAL_DEC_G, REAL_DEC_D, REAL_IEEE, or REAL_370
DeliveryMode | Gets/Sets the GMD delivery mode of the message. The delivery mode is one of: DELIVERY_BEST_EFFORT, DELIVERY_ORDERED, DELIVERY_SOME, or DELIVERY_ALL.
DeliveryTimeout | Gets/Sets the delivery timeout property of the message. The delivery timeout determines how long the client will wait for a GMD acknowledgement before deciding that a failure has occurred.
Dest | Gets/Sets the destination property of the message. The destination property is the subject this message is being published to. It has no meaning in peer-to-peer connections.
Enumerator | Returns a TipcMsgEnumerator for this message object.
Expiration | Gets/Sets the expiration property of the message. Returns the message time-to-live value in seconds
LbMode | Gets/Sets the load balancing mode of the message. The load balancing mode is one of: LB_NONE, LB_ROUND_ROBIN, LB_WEIGHTED, or LB_SORTED.
MessageId | Gets the message id property of the message. A message id will uniquely identify each message sent by a publisher. Returns the message id of the message or null if not set
MonitorId | Monitor ID.
NameCurrent | Gets/Sets the name of the current field. Appending a new field does not advance the current field index, so you must manually set the current field after appending a field to a message.
NumFields | Gets/Sets the number of fields in the message. When the number of fields is set and the number is smaller than the actual number of fields, the extra fields will be removed.
PacketSize | Gets the packet size (in bytes) of the message.
Priority | Gets/Sets the priority of the message.
ReadOnly | Gets the read-only property of the message. A message is "read-only" if it is embedded as a message-within-a-message. You may not append new fields to a read-only message, and you may not set this property.
ReplyTo | Gets/Sets the reply to subject property of the message. Returns the reply to subject or null if not set
Sender | Gets/Sets the sender property of the message. The sender property identifies the sending client. By default, this is set to the unique subject of the client. For RTserver connections, this property is forced to the sender's unique subject, regardless of the setting of this property.
SenderTimestamp | Gets/Sets the sender timestamp property of the message. Returns the timestamp of the message in seconds since 00:00:00 UTC, January 1, 1970, or 0.0 if not set
SeqNum | Gets/Sets the sequence number property of the message.
StreamID | Gets/Sets the source ordered delivery stream ID property of the message.
Type | Gets/Sets the message type of the message. Returns the message type of the message Note: that any default properties of the new message type do NOT affect this message's properties when this method is used to set the message type.
UserProp | Gets/Sets the user property of the message. The user property is any arbitrary value (int) the user assigns.

Public Instance Methods

ack | Acknowledges the receipt of a message received by Guaranteed Message Delivery.
addNamedBinary | Appends a binary field to a message, with a name.
addNamedBool | Append a boolean field to a message, with a name.
addNamedBoolArray | Append a boolean array field to a message, with a name.
addNamedByte | Appends a byte field to a message, with a name.
addNamedChar | Overloaded. Appends a character field to a message, with a name.
addNamedGuid | Appends a Globally Unique Identifier to a message, with a name.
addNamedGuidArray | Append an array of Globally Unique Identifiers to a message, with a name.
addNamedInt2 | Appends a 2 byte integer field to a message, with a name.
addNamedInt2Array | Appends a 2 byte integer array field to a message, with a name.
addNamedInt4 | Appends a 4 byte integer field to a message, with a name.
addNamedInt4Array | Appends 4 byte integer array field to a message, with a name.
addNamedInt8 | Appends a 8 byte integer field to a message, with a name.
addNamedInt8Array | Appends a 8 byte integer array field to a message, with a name.
addNamedMsg | Appends a message field to a message, with a name.
addNamedMsgArray | Appends a message array field to a message, with a name.
addNamedMsgId | Append a TIBCO message ID to a message, with a name.
addNamedMsgIdArray | Append an array of TIBCO message IDs to a message.
addNamedObject | Appends an arbitrary .NET Object to the message, with a name. The object will be encoded in a binary field, using the standard serialization mechanism. Therefore, the object passed to this method must implement the Serializable interface. Note that any objects to be serialized must not only themselves be implemented Serializable, but all of the classes they extend must be Serializable. This object will only be useful to receiving clients in .NET. C clients will receive a binary field which may be forwarded to other .NET clients.
addNamedReal4 | Appends a 4 byte real field to a message, with a name.
addNamedReal4Array | Appends a 4 byte real array field to a message, with a name.
addNamedReal8 | Appends a 8 byte real field to a message, with a name.
addNamedReal8Array | Appends a 8 byte real array field to a message, with a name.
addNamedStr | Appends a string field to a message, with a name.
addNamedStrArray | Appends a string array field to a message, with a name.
addNamedTimestamp | Append a timestamp field to a message, with a name.
addNamedTimestampArray | Append a timestamp array field to a message, with a name.
addNamedUnknown | Appends a new named field of the specified type to the message, but marks the field as 'value unknown'. The constants required for the parameter, field_type, are specified in this module (TipcMsg) and can be recognized by their FT_* names.
addNamedUtf8 | Append a UTF-8 string field to a message, with a name.
addNamedUtf8Array | Append a UTF-8 string array field to a message, with a name.
addNamedXml | Appends an XML field to a message, with a name.
appendBinary | Overloaded. Appends a binary field to a message. No conversion will occur for binary fields. It is up to the programmer to provide any required conversion.
appendBool | Append a boolean field to a message.
appendBoolArray | Overloaded. Append a boolean array field to a message.
appendByte | Appends a byte field to a message.
appendChar | Overloaded. Appends a character field to a message.
appendGuid | Append a Globally Unique Identifier to a message.
appendGuidArray | Append an array of Globally Unique Identifiers to a message.
appendInt2 | Appends a 2 byte integer field to a message.
appendInt2Array | Overloaded. Appends a 2 byte integer array field to a message.
appendInt4 | Appends a 4 byte integer field to a message.
appendInt4Array | Overloaded. Appends a 4 byte integer array field to a message.
appendInt8 | Appends a 8 byte integer field to a message.
appendInt8Array | Overloaded. Appends a 8 byte integer array field to a message.
appendMsg | Appends a message field to a message.
appendMsgArray | Overloaded. Appends a message array field to a message.
appendMsgId | Append a TIBCO message ID to a message.
appendMsgIdArray | Append an array of TIBCO message IDs to a message.
appendObject | Appends an arbitrary Object to the message. The object will be encoded in a binary field, using the standard serialization mechanism. Therefore, the object passed to this method must implement the Serializable interface. Note that any objects to be serialized must not only themselves be implemented as Serializable, but all of the classes they extend must be Serializable. This object will only be useful to receiving clients in .NET, C/C++/Java clients will receive a binary field which may be forwarded to other .NET clients.
appendReal4 | Appends a 4 byte real field to a message.
appendReal4Array | Overloaded. Appends a 4 byte real array field to a message.
appendReal8 | Appends a 8 byte real field to a message.
appendReal8Array | Overloaded. Appends a 8 byte real array field to a message.
appendStr | Appends a string field to a message. For C/C++ clients, this field will represent ASCII characters only. To send Unicode strings to C/C++ clients use appendUtf8.
appendStrArray | Overloaded. Appends a string array field to a message. For C/C++ clients, this field will represent ASCII characters only. To send Unicode strings to C/C++ clients use appendUtf8Array.
appendTimestamp | Append a timestamp field to a message.
appendTimestampArray | Append an array of timestamps to a message.
appendUnknown | Appends a new field of the specified type to the message, but marks the field as an 'unknown value'. The constants required for the parameter, field_type, are specified in this class and can be recognized by their FT_* names.
appendUtf8 | Append a UTF-8 string field to a message. The String will be converted to UTF-8 prior to being appended to the message.
appendUtf8Array | Overloaded. Append an array of UTF-8 strings to a message. The String's will be converted to UTF-8 prior to being appended to the message.
appendXml | Appends an XML field to a message.
Clone | Clones the message.
deleteCurrent | Deletes current field in a message.
deleteField | Deletes the specified field in a message.
deleteNamedField | Deletes a named field in a message.
deleteProp | Implementation of public interface method.
destroy | Destroys the message. If the message was received using GMD, this will also acknowledge the message.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
existsNamed | Returns true if there is a field by the given field name, false if not.
generateMessageId | Generates the message id property for the message. A message id will uniquely identify each message sent by a publisher.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getNamedBinary | Returns the binary field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedBool | Returns a boolean field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedBoolArray | Returns a boolean array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedByte | Returns the byte field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedChar | Returns the character field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedCharByte | Returns the character field corresponding to the given field name as a byte. If there is no field by that name, an exception will be thrown.
getNamedFieldKnown | Examines the named field and reports back if it is an actual value, or a field marked as having an 'unknown value'. Does not advance to the next field.
getNamedGuid | Returns Guid field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedGuidArray | Returns Guid Array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedInt2 | Returns a 2 byte integer field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedInt2Array | Returns a 2 byte integer array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedInt4 | Returns a 4 byte integer field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedInt4Array | Returns a 4 byte integer array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedInt8 | Returns a 8 byte integer field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedInt8Array | Returns a 8 byte integer array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedMsg | Returns message field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedMsgArray | Returns message array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedMsgId | Returns MsgId field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedMsgIdArray | Returns MsgId Array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedObject | Returns Object field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedReal4 | Returns a 4 byte real field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedReal4Array | Returns a 4 byte real array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedReal8 | Returns a 8 byte real field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedReal8Array | Returns a 8 byte real array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedStr | Returns string field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedStrArray | Returns string array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedTimestamp | Returns a timestamp field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedTimestampArray | Returns a timestamp array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedUnknown | Returns true if the field corresponding to the given field name is marked as having 'unknown value'. If the field has a 'known value' a TipcMsgBadFieldException will be thrown. If there is no field by that name, an exception will be thrown.
getNamedUtf8 | Returns a UTF-8 string field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedUtf8Array | Returns a UTF-8 string array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedXml | Returns an XML field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNamed | Returns the type of the field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
log | Logs the message to the stream.
nextBinary | Overloaded. Gets a binary field from the message.
nextBool | Gets a boolean field from the message.
nextBoolArray | Overloaded. Gets a boolean array from the message.
nextByte | Gets a byte field from the message.
nextChar | Gets a character field from the message.
nextCharByte | Gets a character field as a byte from the message.
nextGuid | Gets a Globally Unique Identifer from the message.
nextGuidArray | Overloaded. Gets an array of Globally Unique Identifers from the message.
nextInt2 | Gets a 2 byte integer field from the message.
nextInt2Array | Overloaded. Gets a 2 byte integer array from the message.
nextInt4 | Gets a 4 byte integer field from the message.
nextInt4Array | Overloaded. Gets a 4 byte integer array from the message.
nextInt8 | Gets a 8 byte integer field from the message.
nextInt8Array | Overloaded. Gets a 8 byte integer array from the message.
nextMsg | Gets a message field from the message.
nextMsgArray | Overloaded. Gets a message array from the message.
nextMsgId | Gets a TIBCO message ID from the message.
nextMsgIdArray | Overloaded. Gets an array of TIBCO message IDs from the message.
nextObject | Decodes the next field (which must be a binary field) as an arbitrary .NET Object. Objects encoded into a binary field with the appendObject method are decoded with this method. Decoding objects carries the same restrictions as the standard .NET serialization mechanism. Serialized objects must implement the Serializable interface.
nextReal4 | Gets a 4 byte real field from the message.
nextReal4Array | Overloaded. Gets a 4 byte real array from the message.
nextReal8 | Gets a 8 byte real field from the message.
nextReal8Array | Overloaded. Gets a 8 byte real array from the message.
nextStr | Gets a string field from the message.
nextStrArray | Overloaded. Gets a string array from the message.
nextTimestamp | Gets a timestamp field from the message.
nextTimestampArray | Gets a timestamp array from the message.
nextType | Gets the type (FT_*) of the next field.
nextUnknown | If the next field in the message is marked as an 'unknown value', this method will skip over the field and return true. If the field has a 'known value', the current field will not be advanced, and a TipcMsgBadFieldException will be thrown.
nextUtf8 | Gets a UTF-8 string field from the message.
nextUtf8Array | Overloaded. Gets a UTF-8 string array field from the message.
nextXml | Implementation of public interface method.
print | Overloaded. Prints the message. Prints the message in human readable form, showing the value of all user-settable fields as well as all data currently in the message.
setPropBinary | Set a message property as a partial binary field. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.
setPropInt | Set a message property as an integer. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.
setPropShort | Set a message property as a short. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.
setPropStr | Set a message property as a string. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.
setPropStrArray | Set a message property as a partial string array. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.
toByteArray | Serializes the contents of the current message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.
updateNamedBinary | Updates a named binary field in a message.
updateNamedBool | Updates a named bool field in a message.
updateNamedBoolArray | Updates a named bool array field in a message.
updateNamedByte | Updates a named byte field in a message.
updateNamedChar | Overloaded. Updates a named character field in a message.
updateNamedGuid | updates a Globally Unique Identifier to a message, with a name.
updateNamedGuidArray | Update an array of Globally Unique Identifiers to a message, with a name.
updateNamedInt2 | Updates a named 2 byte integer field in a message.
updateNamedInt2Array | Updates a named 2 byte integer array field in a message.
updateNamedInt4 | Updates a named 4 byte integer field in a message.
updateNamedInt4Array | Updates a named 4 byte integer array field in a message.
updateNamedInt8 | Updates a named 8 byte integer field in a message.
updateNamedInt8Array | Updates a named 8 byte integer array field in a message.
updateNamedMsg | Updates a named message field in a message.
updateNamedMsgArray | Updates a named message array field in a message.
updateNamedMsgId | Updates a named TIBCO message ID field in a message.
updateNamedMsgIdArray | Update a named TIBCO message ID array field in a message.
updateNamedObject | Updates a named arbitrary .NET Object in the message. The object will be encoded in a binary field, using the standard serialization mechanism. Therefore, the object passed to this method must implement the Serializable interface. Note that any objects to be serialized must not only themselves implemented Serializable, but all of the classes they extend must be Serializable. This object will only be useful to receiving clients in .NET C clients will receive a binary field which may be forwarded to other .NET clients.
updateNamedReal4 | Updates a named 4 byte real field in a message.
updateNamedReal4Array | Updates a named 4 byte real array field in a message.
updateNamedReal8 | Updates a named 8 byte real field in a message.
updateNamedReal8Array | Updates a named 8 byte real array field in a message.
updateNamedStr | Updates a named string field in a message.
updateNamedStrArray | Updates a named string array field in a message.
updateNamedTimestamp | Updates a named timestamp field in a message.
updateNamedTimestampArray | Updates a named timestamp array field in a message.
updateNamedUtf8 | Updates a named Utf8 field in a message.
updateNamedUtf8Array | Updates a named Utf8Array field in a message.
updateNamedXml | Updates a named XML field in a message.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg Properties

The properties of the TipcMsg class are listed below. For a complete list of TipcMsg class members, see the TipcMsg Members topic.

Public Instance Properties

ArrivalTimestamp | Gets/Sets the arrival timestamp property of the message. Returns the timestamp of the message in seconds since 00:00:00 UTC, January 1, 1970, or 0.0 if not set
Compression | Gets/Sets the compression flag. True to enable compression.
CorrelationId | Gets/Sets the correlation id property of the message. Returns the message id of the message or null if not set.
Current | Gets/Sets the current field number of the message. The "current field" is a cursor indexing the fields in a message.
CurrentFieldCharFormat | Gets the character format for the current field. The char format, which will be one of CHAR_US_ASCII or CHAR_US_EBCDIC
CurrentFieldIntFormat | Gets the integer format for the current field. The int format, which will be one of INT_LITTLE_ENDIAN or INT_BIG_ENDIAN
CurrentFieldKnown | Returns true if the current field contains an actual value; false if the field is marked as having an 'unknown value'.
CurrentFieldRealFormat | Gets the real format for the current field. The real format, which will be one of REAL_DEC_G, REAL_DEC_D, REAL_IEEE, or REAL_370
DeliveryMode | Gets/Sets the GMD delivery mode of the message. The delivery mode is one of: DELIVERY_BEST_EFFORT, DELIVERY_ORDERED, DELIVERY_SOME, or DELIVERY_ALL.
DeliveryTimeout | Gets/Sets the delivery timeout property of the message. The delivery timeout determines how long the client will wait for a GMD acknowledgement before deciding that a failure has occurred.
Dest | Gets/Sets the destination property of the message. The destination property is the subject this message is being published to. It has no meaning in peer-to-peer connections.
Enumerator | Returns a TipcMsgEnumerator for this message object.
Expiration | Gets/Sets the expiration property of the message. Returns the message time-to-live value in seconds
LbMode | Gets/Sets the load balancing mode of the message. The load balancing mode is one of: LB_NONE, LB_ROUND_ROBIN, LB_WEIGHTED, or LB_SORTED.
MessageId | Gets the message id property of the message. A message id will uniquely identify each message sent by a publisher. Returns the message id of the message or null if not set
MonitorId | Monitor ID.
NameCurrent | Gets/Sets the name of the current field. Appending a new field does not advance the current field index, so you must manually set the current field after appending a field to a message.
NumFields | Gets/Sets the number of fields in the message. When the number of fields is set and the number is smaller than the actual number of fields, the extra fields will be removed.
PacketSize | Gets the packet size (in bytes) of the message.
Priority | Gets/Sets the priority of the message.
ReadOnly | Gets the read-only property of the message. A message is "read-only" if it is embedded as a message-within-a-message. You may not append new fields to a read-only message, and you may not set this property.
ReplyTo | Gets/Sets the reply to subject property of the message. Returns the reply to subject or null if not set
Sender | Gets/Sets the sender property of the message. The sender property identifies the sending client. By default, this is set to the unique subject of the client. For RTserver connections, this property is forced to the sender's unique subject, regardless of the setting of this property.
SenderTimestamp | Gets/Sets the sender timestamp property of the message. Returns the timestamp of the message in seconds since 00:00:00 UTC, January 1, 1970, or 0.0 if not set
SeqNum | Gets/Sets the sequence number property of the message.
StreamID | Gets/Sets the source ordered delivery stream ID property of the message.
Type | Gets/Sets the message type of the message. Returns the message type of the message Note: that any default properties of the new message type do NOT affect this message's properties when this method is used to set the message type.
UserProp | Gets/Sets the user property of the message. The user property is any arbitrary value (int) the user assigns.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


ArrivalTimestamp Property

SmartSockets .NET Class Library

TipcMsg.ArrivalTimestamp Property

Gets/Sets the arrival timestamp property of the message.

Returns the timestamp of the message in seconds since 00:00:00 UTC, January 1, 1970, or 0.0 if not set

public virtual double ArrivalTimestamp {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the timestamp is invalid

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


Compression Property

SmartSockets .NET Class Library

TipcMsg.Compression Property

Gets/Sets the compression flag. True to enable compression.

public virtual bool Compression {get; set;}

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


CorrelationId Property

SmartSockets .NET Class Library

TipcMsg.CorrelationId Property

Gets/Sets the correlation id property of the message.

Returns the message id of the message or null if not set.

public virtual string CorrelationId {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the correlationId is null

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


Current Property

SmartSockets .NET Class Library

TipcMsg.Current Property

Gets/Sets the current field number of the message.

The "current field" is a cursor indexing the fields in a message.

public virtual int Current {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If field_num is negative or greater than the last index in the message.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


CurrentFieldCharFormat Property

SmartSockets .NET Class Library

TipcMsg.CurrentFieldCharFormat Property

Gets the character format for the current field.

The char format, which will be one of CHAR_US_ASCII or CHAR_US_EBCDIC

public virtual int CurrentFieldCharFormat {get;}

Exceptions

Exception Type | Condition
TipcMsgEomException | If there is no current field
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


CurrentFieldIntFormat Property

SmartSockets .NET Class Library

TipcMsg.CurrentFieldIntFormat Property

Gets the integer format for the current field.

The int format, which will be one of INT_LITTLE_ENDIAN or INT_BIG_ENDIAN

public virtual int CurrentFieldIntFormat {get;}

Exceptions

Exception Type | Condition
TipcMsgEomException | If there is no current field
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


CurrentFieldKnown Property

SmartSockets .NET Class Library

TipcMsg.CurrentFieldKnown Property

Returns true if the current field contains an actual value; false if the field is marked as having an 'unknown value'.

public virtual bool CurrentFieldKnown {get;}

Exceptions

Exception Type | Condition
TipcMsgEomException | If there is no field
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


CurrentFieldRealFormat Property

SmartSockets .NET Class Library

TipcMsg.CurrentFieldRealFormat Property

Gets the real format for the current field.

The real format, which will be one of REAL_DEC_G, REAL_DEC_D, REAL_IEEE, or REAL_370

public virtual int CurrentFieldRealFormat {get;}

Exceptions

Exception Type | Condition
TipcMsgEomException | If there is no current field
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


DeliveryMode Property

SmartSockets .NET Class Library

TipcMsg.DeliveryMode Property

Gets/Sets the GMD delivery mode of the message.

The delivery mode is one of: DELIVERY_BEST_EFFORT, DELIVERY_ORDERED, DELIVERY_SOME, or DELIVERY_ALL.

public virtual int DeliveryMode {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If delivery_mode is not one of the pre-defined values.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


DeliveryTimeout Property

SmartSockets .NET Class Library

TipcMsg.DeliveryTimeout Property

Gets/Sets the delivery timeout property of the message.

The delivery timeout determines how long the client will wait for a GMD acknowledgement before deciding that a failure has occurred.

public virtual double DeliveryTimeout {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If delivery_timeout is negative.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


Dest Property

SmartSockets .NET Class Library

TipcMsg.Dest Property

Gets/Sets the destination property of the message.

The destination property is the subject this message is being published to. It has no meaning in peer-to-peer connections.

public virtual string Dest {get; set;}

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


Enumerator Property

SmartSockets .NET Class Library

TipcMsg.Enumerator Property

Returns a TipcMsgEnumerator for this message object.

public virtual TipcMsgEnumerator Enumerator {get;}

Exceptions

Exception Type | Condition
TipcMsgException | If there an exception while getting the enumerator

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


Expiration Property

SmartSockets .NET Class Library

TipcMsg.Expiration Property

Gets/Sets the expiration property of the message.

Returns the message time-to-live value in seconds

public virtual double Expiration {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the value is negative
TipcException | For all other errors.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


LbMode Property

SmartSockets .NET Class Library

TipcMsg.LbMode Property

Gets/Sets the load balancing mode of the message.

The load balancing mode is one of: LB_NONE, LB_ROUND_ROBIN, LB_WEIGHTED, or LB_SORTED.

public virtual int LbMode {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If lb_mode is not one of the pre-defined types.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


MessageId Property

SmartSockets .NET Class Library

TipcMsg.MessageId Property

Gets the message id property of the message.

A message id will uniquely identify each message sent by a publisher. Returns the message id of the message or null if not set

public virtual string MessageId {get;}

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


MonitorId Property

SmartSockets .NET Class Library

TipcMsg.MonitorId Property

Monitor ID.

public virtual sbyte[] MonitorId {get;}

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


NameCurrent Property

SmartSockets .NET Class Library

TipcMsg.NameCurrent Property

Gets/Sets the name of the current field.

Appending a new field does not advance the current field index, so you must manually set the current field after appending a field to a message.

public virtual string NameCurrent {get; set;}

Exceptions

Exception Type | Condition
TipcMsgEomException | If there is no field at the current field index (the index is past the end of the message).
TipcException | For any errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


NumFields Property

SmartSockets .NET Class Library

TipcMsg.NumFields Property

Gets/Sets the number of fields in the message.

When the number of fields is set and the number is smaller than the actual number of fields, the extra fields will be removed.

public virtual int NumFields {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If num_fields is larger than the actual number of fields.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


PacketSize Property

SmartSockets .NET Class Library

TipcMsg.PacketSize Property

Gets the packet size (in bytes) of the message.

public virtual int PacketSize {get;}

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


Priority Property

SmartSockets .NET Class Library

TipcMsg.Priority Property

Gets/Sets the priority of the message.

public virtual short Priority {get; set;}

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


ReadOnly Property

SmartSockets .NET Class Library

TipcMsg.ReadOnly Property

Gets the read-only property of the message.

A message is "read-only" if it is embedded as a message-within-a-message. You may not append new fields to a read-only message, and you may not set this property.

public virtual bool ReadOnly {get;}

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


ReplyTo Property

SmartSockets .NET Class Library

TipcMsg.ReplyTo Property

Gets/Sets the reply to subject property of the message.

Returns the reply to subject or null if not set

public virtual string ReplyTo {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If subject is null

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


Sender Property

SmartSockets .NET Class Library

TipcMsg.Sender Property

Gets/Sets the sender property of the message.

The sender property identifies the sending client. By default, this is set to the unique subject of the client. For RTserver connections, this property is forced to the sender's unique subject, regardless of the setting of this property.

public virtual string Sender {get; set;}

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


SenderTimestamp Property

SmartSockets .NET Class Library

TipcMsg.SenderTimestamp Property

Gets/Sets the sender timestamp property of the message.

Returns the timestamp of the message in seconds since 00:00:00 UTC, January 1, 1970, or 0.0 if not set

public virtual double SenderTimestamp {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the timestamp is negative

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


SeqNum Property

SmartSockets .NET Class Library

TipcMsg.SeqNum Property

Gets/Sets the sequence number property of the message.

public virtual int SeqNum {get; set;}

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


StreamID Property

SmartSockets .NET Class Library

TipcMsg.StreamID Property

Gets/Sets the source ordered delivery stream ID property of the message.

public virtual string StreamID {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the stream ID is invalid

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


Type Property

SmartSockets .NET Class Library

TipcMsg.Type Property

Gets/Sets the message type of the message.

Returns the message type of the message

Note: that any default properties of the new message type do NOT affect this message's properties when this method is used to set the message type.

public virtual TipcMt Type {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If mt is not a valid message type.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


UserProp Property

SmartSockets .NET Class Library

TipcMsg.UserProp Property

Gets/Sets the user property of the message.

The user property is any arbitrary value (int) the user assigns.

public virtual int UserProp {get; set;}

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg Methods

The methods of the TipcMsg class are listed below. For a complete list of TipcMsg class members, see the TipcMsg Members topic.

Public Instance Methods

ack | Acknowledges the receipt of a message received by Guaranteed Message Delivery.
addNamedBinary | Appends a binary field to a message, with a name.
addNamedBool | Append a boolean field to a message, with a name.
addNamedBoolArray | Append a boolean array field to a message, with a name.
addNamedByte | Appends a byte field to a message, with a name.
addNamedChar | Overloaded. Appends a character field to a message, with a name.
addNamedGuid | Appends a Globally Unique Identifier to a message, with a name.
addNamedGuidArray | Append an array of Globally Unique Identifiers to a message, with a name.
addNamedInt2 | Appends a 2 byte integer field to a message, with a name.
addNamedInt2Array | Appends a 2 byte integer array field to a message, with a name.
addNamedInt4 | Appends a 4 byte integer field to a message, with a name.
addNamedInt4Array | Appends 4 byte integer array field to a message, with a name.
addNamedInt8 | Appends a 8 byte integer field to a message, with a name.
addNamedInt8Array | Appends a 8 byte integer array field to a message, with a name.
addNamedMsg | Appends a message field to a message, with a name.
addNamedMsgArray | Appends a message array field to a message, with a name.
addNamedMsgId | Append a TIBCO message ID to a message, with a name.
addNamedMsgIdArray | Append an array of TIBCO message IDs to a message.
addNamedObject | Appends an arbitrary .NET Object to the message, with a name. The object will be encoded in a binary field, using the standard serialization mechanism. Therefore, the object passed to this method must implement the Serializable interface. Note that any objects to be serialized must not only themselves be implemented Serializable, but all of the classes they extend must be Serializable. This object will only be useful to receiving clients in .NET. C clients will receive a binary field which may be forwarded to other .NET clients.
addNamedReal4 | Appends a 4 byte real field to a message, with a name.
addNamedReal4Array | Appends a 4 byte real array field to a message, with a name.
addNamedReal8 | Appends a 8 byte real field to a message, with a name.
addNamedReal8Array | Appends a 8 byte real array field to a message, with a name.
addNamedStr | Appends a string field to a message, with a name.
addNamedStrArray | Appends a string array field to a message, with a name.
addNamedTimestamp | Append a timestamp field to a message, with a name.
addNamedTimestampArray | Append a timestamp array field to a message, with a name.
addNamedUnknown | Appends a new named field of the specified type to the message, but marks the field as 'value unknown'. The constants required for the parameter, field_type, are specified in this module (TipcMsg) and can be recognized by their FT_* names.
addNamedUtf8 | Append a UTF-8 string field to a message, with a name.
addNamedUtf8Array | Append a UTF-8 string array field to a message, with a name.
addNamedXml | Appends an XML field to a message, with a name.
appendBinary | Overloaded. Appends a binary field to a message. No conversion will occur for binary fields. It is up to the programmer to provide any required conversion.
appendBool | Append a boolean field to a message.
appendBoolArray | Overloaded. Append a boolean array field to a message.
appendByte | Appends a byte field to a message.
appendChar | Overloaded. Appends a character field to a message.
appendGuid | Append a Globally Unique Identifier to a message.
appendGuidArray | Append an array of Globally Unique Identifiers to a message.
appendInt2 | Appends a 2 byte integer field to a message.
appendInt2Array | Overloaded. Appends a 2 byte integer array field to a message.
appendInt4 | Appends a 4 byte integer field to a message.
appendInt4Array | Overloaded. Appends a 4 byte integer array field to a message.
appendInt8 | Appends a 8 byte integer field to a message.
appendInt8Array | Overloaded. Appends a 8 byte integer array field to a message.
appendMsg | Appends a message field to a message.
appendMsgArray | Overloaded. Appends a message array field to a message.
appendMsgId | Append a TIBCO message ID to a message.
appendMsgIdArray | Append an array of TIBCO message IDs to a message.
appendObject | Appends an arbitrary Object to the message. The object will be encoded in a binary field, using the standard serialization mechanism. Therefore, the object passed to this method must implement the Serializable interface. Note that any objects to be serialized must not only themselves be implemented as Serializable, but all of the classes they extend must be Serializable. This object will only be useful to receiving clients in .NET, C/C++/Java clients will receive a binary field which may be forwarded to other .NET clients.
appendReal4 | Appends a 4 byte real field to a message.
appendReal4Array | Overloaded. Appends a 4 byte real array field to a message.
appendReal8 | Appends a 8 byte real field to a message.
appendReal8Array | Overloaded. Appends a 8 byte real array field to a message.
appendStr | Appends a string field to a message. For C/C++ clients, this field will represent ASCII characters only. To send Unicode strings to C/C++ clients use appendUtf8.
appendStrArray | Overloaded. Appends a string array field to a message. For C/C++ clients, this field will represent ASCII characters only. To send Unicode strings to C/C++ clients use appendUtf8Array.
appendTimestamp | Append a timestamp field to a message.
appendTimestampArray | Append an array of timestamps to a message.
appendUnknown | Appends a new field of the specified type to the message, but marks the field as an 'unknown value'. The constants required for the parameter, field_type, are specified in this class and can be recognized by their FT_* names.
appendUtf8 | Append a UTF-8 string field to a message. The String will be converted to UTF-8 prior to being appended to the message.
appendUtf8Array | Overloaded. Append an array of UTF-8 strings to a message. The String's will be converted to UTF-8 prior to being appended to the message.
appendXml | Appends an XML field to a message.
Clone | Clones the message.
deleteCurrent | Deletes current field in a message.
deleteField | Deletes the specified field in a message.
deleteNamedField | Deletes a named field in a message.
deleteProp | Implementation of public interface method.
destroy | Destroys the message. If the message was received using GMD, this will also acknowledge the message.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
existsNamed | Returns true if there is a field by the given field name, false if not.
generateMessageId | Generates the message id property for the message. A message id will uniquely identify each message sent by a publisher.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getNamedBinary | Returns the binary field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedBool | Returns a boolean field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedBoolArray | Returns a boolean array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedByte | Returns the byte field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedChar | Returns the character field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedCharByte | Returns the character field corresponding to the given field name as a byte. If there is no field by that name, an exception will be thrown.
getNamedFieldKnown | Examines the named field and reports back if it is an actual value, or a field marked as having an 'unknown value'. Does not advance to the next field.
getNamedGuid | Returns Guid field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedGuidArray | Returns Guid Array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedInt2 | Returns a 2 byte integer field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedInt2Array | Returns a 2 byte integer array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedInt4 | Returns a 4 byte integer field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedInt4Array | Returns a 4 byte integer array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedInt8 | Returns a 8 byte integer field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedInt8Array | Returns a 8 byte integer array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedMsg | Returns message field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedMsgArray | Returns message array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedMsgId | Returns MsgId field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedMsgIdArray | Returns MsgId Array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedObject | Returns Object field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedReal4 | Returns a 4 byte real field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedReal4Array | Returns a 4 byte real array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedReal8 | Returns a 8 byte real field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedReal8Array | Returns a 8 byte real array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedStr | Returns string field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedStrArray | Returns string array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedTimestamp | Returns a timestamp field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedTimestampArray | Returns a timestamp array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedUnknown | Returns true if the field corresponding to the given field name is marked as having 'unknown value'. If the field has a 'known value' a TipcMsgBadFieldException will be thrown. If there is no field by that name, an exception will be thrown.
getNamedUtf8 | Returns a UTF-8 string field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedUtf8Array | Returns a UTF-8 string array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
getNamedXml | Returns an XML field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
GetType (inherited from Object) | Gets the Type of the current instance.
getTypeNamed | Returns the type of the field corresponding to the given field name. If there is no field by that name, an exception will be thrown.
log | Logs the message to the stream.
nextBinary | Overloaded. Gets a binary field from the message.
nextBool | Gets a boolean field from the message.
nextBoolArray | Overloaded. Gets a boolean array from the message.
nextByte | Gets a byte field from the message.
nextChar | Gets a character field from the message.
nextCharByte | Gets a character field as a byte from the message.
nextGuid | Gets a Globally Unique Identifer from the message.
nextGuidArray | Overloaded. Gets an array of Globally Unique Identifers from the message.
nextInt2 | Gets a 2 byte integer field from the message.
nextInt2Array | Overloaded. Gets a 2 byte integer array from the message.
nextInt4 | Gets a 4 byte integer field from the message.
nextInt4Array | Overloaded. Gets a 4 byte integer array from the message.
nextInt8 | Gets a 8 byte integer field from the message.
nextInt8Array | Overloaded. Gets a 8 byte integer array from the message.
nextMsg | Gets a message field from the message.
nextMsgArray | Overloaded. Gets a message array from the message.
nextMsgId | Gets a TIBCO message ID from the message.
nextMsgIdArray | Overloaded. Gets an array of TIBCO message IDs from the message.
nextObject | Decodes the next field (which must be a binary field) as an arbitrary .NET Object. Objects encoded into a binary field with the appendObject method are decoded with this method. Decoding objects carries the same restrictions as the standard .NET serialization mechanism. Serialized objects must implement the Serializable interface.
nextReal4 | Gets a 4 byte real field from the message.
nextReal4Array | Overloaded. Gets a 4 byte real array from the message.
nextReal8 | Gets a 8 byte real field from the message.
nextReal8Array | Overloaded. Gets a 8 byte real array from the message.
nextStr | Gets a string field from the message.
nextStrArray | Overloaded. Gets a string array from the message.
nextTimestamp | Gets a timestamp field from the message.
nextTimestampArray | Gets a timestamp array from the message.
nextType | Gets the type (FT_*) of the next field.
nextUnknown | If the next field in the message is marked as an 'unknown value', this method will skip over the field and return true. If the field has a 'known value', the current field will not be advanced, and a TipcMsgBadFieldException will be thrown.
nextUtf8 | Gets a UTF-8 string field from the message.
nextUtf8Array | Overloaded. Gets a UTF-8 string array field from the message.
nextXml | Implementation of public interface method.
print | Overloaded. Prints the message. Prints the message in human readable form, showing the value of all user-settable fields as well as all data currently in the message.
setPropBinary | Set a message property as a partial binary field. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.
setPropInt | Set a message property as an integer. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.
setPropShort | Set a message property as a short. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.
setPropStr | Set a message property as a string. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.
setPropStrArray | Set a message property as a partial string array. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.
toByteArray | Serializes the contents of the current message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.
updateNamedBinary | Updates a named binary field in a message.
updateNamedBool | Updates a named bool field in a message.
updateNamedBoolArray | Updates a named bool array field in a message.
updateNamedByte | Updates a named byte field in a message.
updateNamedChar | Overloaded. Updates a named character field in a message.
updateNamedGuid | updates a Globally Unique Identifier to a message, with a name.
updateNamedGuidArray | Update an array of Globally Unique Identifiers to a message, with a name.
updateNamedInt2 | Updates a named 2 byte integer field in a message.
updateNamedInt2Array | Updates a named 2 byte integer array field in a message.
updateNamedInt4 | Updates a named 4 byte integer field in a message.
updateNamedInt4Array | Updates a named 4 byte integer array field in a message.
updateNamedInt8 | Updates a named 8 byte integer field in a message.
updateNamedInt8Array | Updates a named 8 byte integer array field in a message.
updateNamedMsg | Updates a named message field in a message.
updateNamedMsgArray | Updates a named message array field in a message.
updateNamedMsgId | Updates a named TIBCO message ID field in a message.
updateNamedMsgIdArray | Update a named TIBCO message ID array field in a message.
updateNamedObject | Updates a named arbitrary .NET Object in the message. The object will be encoded in a binary field, using the standard serialization mechanism. Therefore, the object passed to this method must implement the Serializable interface. Note that any objects to be serialized must not only themselves implemented Serializable, but all of the classes they extend must be Serializable. This object will only be useful to receiving clients in .NET C clients will receive a binary field which may be forwarded to other .NET clients.
updateNamedReal4 | Updates a named 4 byte real field in a message.
updateNamedReal4Array | Updates a named 4 byte real array field in a message.
updateNamedReal8 | Updates a named 8 byte real field in a message.
updateNamedReal8Array | Updates a named 8 byte real array field in a message.
updateNamedStr | Updates a named string field in a message.
updateNamedStrArray | Updates a named string array field in a message.
updateNamedTimestamp | Updates a named timestamp field in a message.
updateNamedTimestampArray | Updates a named timestamp array field in a message.
updateNamedUtf8 | Updates a named Utf8 field in a message.
updateNamedUtf8Array | Updates a named Utf8Array field in a message.
updateNamedXml | Updates a named XML field in a message.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.ack Method

Acknowledges the receipt of a message received by Guaranteed Message Delivery.

public virtual void ack();

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.addNamedBinary Method

Appends a binary field to a message, with a name.

public virtual void addNamedBinary(
string name,
sbyte[] Value,
int off,
int len
);

Parameters

name
the name to use
Value
the binary data for the field
off
offset into 'Value'
len
number of bytes in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedBool Method

Append a boolean field to a message, with a name.

public virtual void addNamedBool(
string name,
bool Value
);

Parameters

name
the name to use
Value
data for a new message field.

Exceptions

Exception Type | Condition
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedBoolArray Method

Append a boolean array field to a message, with a name.

public virtual void addNamedBoolArray(
string name,
bool[] Value,
int off,
int len
);

Parameters

name
the name to use
Value
data for a new message field.
off
the offset into the array.
len
the number of elements to append.

Exceptions

Exception Type | Condition
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedByte Method

Appends a byte field to a message, with a name.

public virtual void addNamedByte(
string name,
sbyte Value
);

Parameters

name
the name to use
Value
the byte value to append

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


addNamedChar Method

SmartSockets .NET Class Library

TipcMsg.addNamedChar Method

Appends a character field to a message, with a name.

Overload List

Appends a character field to a message, with a name.

public virtual void addNamedChar(string,char);

Appends a character (byte) field to a message, with a name.

public virtual void addNamedChar(string,sbyte);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedChar Method (String, Char)

Appends a character field to a message, with a name.

public virtual void addNamedChar(
string name,
char Value
);

Parameters

name
the name to use
Value
the character value to append

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.addNamedChar Overload List |


TipcMsg.addNamedChar Method (String, SByte)

Appends a character (byte) field to a message, with a name.

public virtual void addNamedChar(
string name,
sbyte Value
);

Parameters

name
the name to use
Value
the byte value to append

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.addNamedChar Overload List |


TipcMsg.addNamedGuid Method

Appends a Globally Unique Identifier to a message, with a name.

public virtual void addNamedGuid(
string name,
sbyte[] Value,
int offset
);

Parameters

name
the name to use
Value
a byte array holding the GUID
offset
the offset into the array

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedGuidArray Method

Append an array of Globally Unique Identifiers to a message, with a name.

public virtual void addNamedGuidArray(
string name,
sbyte[][] Value,
int offset,
int length
);

Parameters

name
the name to use
Value
a byte array holding the GUID array
offset
the offset into the array
length
the number of elements to add

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedInt2 Method

Appends a 2 byte integer field to a message, with a name.

public virtual void addNamedInt2(
string name,
short Value
);

Parameters

name
the name to use
Value
the short value to append

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedInt2Array Method

Appends a 2 byte integer array field to a message, with a name.

public virtual void addNamedInt2Array(
string name,
short[] Value,
int off,
int len
);

Parameters

name
the name to use
Value
the data for the field
off
offset into 'Value'
len
number of shorts in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedInt4 Method

Appends a 4 byte integer field to a message, with a name.

public virtual void addNamedInt4(
string name,
int Value
);

Parameters

name
the name to use
Value
the int value to append

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedInt4Array Method

Appends 4 byte integer array field to a message, with a name.

public virtual void addNamedInt4Array(
string name,
int[] Value,
int off,
int len
);

Parameters

name
the name to use
Value
the data for the field
off
offset into 'Value'
len
number of ints in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedInt8 Method

Appends a 8 byte integer field to a message, with a name.

public virtual void addNamedInt8(
string name,
long Value
);

Parameters

name
the name to use
Value
the long value to append

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedInt8Array Method

Appends a 8 byte integer array field to a message, with a name.

public virtual void addNamedInt8Array(
string name,
long[] Value,
int off,
int len
);

Parameters

name
the name to use
Value
the data for the field
off
offset into 'Value'
len
number of longs in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedMsg Method

Appends a message field to a message, with a name.

public virtual void addNamedMsg(
string name,
TipcMsg Value
);

Parameters

name
the name to use
Value
the TipcMsg value to append

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedMsgArray Method

Appends a message array field to a message, with a name.

public virtual void addNamedMsgArray(
string name,
TipcMsg[] Value,
int off,
int len
);

Parameters

name
the name to use
Value
the data for the field
off
offset into 'Value'
len
number of TipcMsgs in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedMsgId Method

Append a TIBCO message ID to a message, with a name.

public virtual void addNamedMsgId(
string name,
sbyte[] Value,
int offset
);

Parameters

name
the name to use
Value
a byte array holding the message ID.
offset
the offset into the array

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedMsgIdArray Method

Append an array of TIBCO message IDs to a message.

public virtual void addNamedMsgIdArray(
string name,
sbyte[][] Value,
int offset,
int length
);

Parameters

name
the name to use
Value
a byte array holding the message ID.
offset
the offset into the array
length
the number of elements to add

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedObject Method

Appends an arbitrary .NET Object to the message, with a name. The object will be encoded in a binary field, using the standard serialization mechanism. Therefore, the object passed to this method must implement the Serializable interface. Note that any objects to be serialized must not only themselves be implemented Serializable, but all of the classes they extend must be Serializable.

This object will only be useful to receiving clients in .NET. C clients will receive a binary field which may be forwarded to other .NET clients.

public virtual void addNamedObject(
string name,
object obj
);

Parameters

name
the name to use
obj
the object to be appended

Exceptions

Exception Type | Condition
TipcIOException | If the object serialization fails
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedReal4 Method

Appends a 4 byte real field to a message, with a name.

public virtual void addNamedReal4(
string name,
float Value
);

Parameters

name
the name to use
Value
the float value to append

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedReal4Array Method

Appends a 4 byte real array field to a message, with a name.

public virtual void addNamedReal4Array(
string name,
float[] Value,
int off,
int len
);

Parameters

name
the name to use
Value
the data for the field
off
offset into 'Value'
len
number of floats in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedReal8 Method

Appends a 8 byte real field to a message, with a name.

public virtual void addNamedReal8(
string name,
double Value
);

Parameters

name
the name to use
Value
the double value to append

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedReal8Array Method

Appends a 8 byte real array field to a message, with a name.

public virtual void addNamedReal8Array(
string name,
double[] Value,
int off,
int len
);

Parameters

name
the name to use
Value
the data for the field
off
offset into 'Value'
len
number of doubles in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedStr Method

Appends a string field to a message, with a name.

public virtual void addNamedStr(
string name,
string Value
);

Parameters

name
the name to use
Value
the String value to append

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedStrArray Method

Appends a string array field to a message, with a name.

public virtual void addNamedStrArray(
string name,
string[] Value,
int off,
int len
);

Parameters

name
the name to use
Value
the data for the field
off
offset into 'Value'
len
number of Strings in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedTimestamp Method

Append a timestamp field to a message, with a name.

public virtual void addNamedTimestamp(
string name,
double Value
);

Parameters

name
the name to use
Value
data for a new message field.

Exceptions

Exception Type | Condition
TipcAlreadyExistsException | If the named field already
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedTimestampArray Method

Append a timestamp array field to a message, with a name.

public virtual void addNamedTimestampArray(
string name,
double[] Value
);

Parameters

name
the name to use
Value
data for a new message field.

Exceptions

Exception Type | Condition
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedUnknown Method

Appends a new named field of the specified type to the message, but marks the field as 'value unknown'. The constants required for the parameter, field_type, are specified in this module (TipcMsg) and can be recognized by their FT_* names.

public virtual void addNamedUnknown(
string name,
int type
);

Parameters

name
the name to use
type
the type of field to append and mark as an 'unknown value'

Exceptions

Exception Type | Condition
TipcAssertionException | If bad field type parameter is passed in
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedUtf8 Method

Append a UTF-8 string field to a message, with a name.

public virtual void addNamedUtf8(
string name,
string Value
);

Parameters

name
the name to use
Value
data for a new message field.

Exceptions

Exception Type | Condition
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedUtf8Array Method

Append a UTF-8 string array field to a message, with a name.

public virtual void addNamedUtf8Array(
string name,
string[] Value,
int off,
int len
);

Parameters

name
the name to use
Value
data for a new message field.
off
offset into 'Value'
len
number of Strings in 'Value' to copy

Exceptions

Exception Type | Condition
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.addNamedXml Method

Appends an XML field to a message, with a name.

public virtual void addNamedXml(
string name,
TutXml Value
);

Parameters

name
the name to use
Value
the TutXml object to append

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcAlreadyExistsException | If the named field already exists
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


appendBinary Method

SmartSockets .NET Class Library

TipcMsg.appendBinary Method

Appends a binary field to a message. No conversion will occur for binary fields. It is up to the programmer to provide any required conversion.

Overload List

Appends a binary field to a message. No conversion will occur for binary fields. It is up to the programmer to provide any required conversion.

public virtual void appendBinary(sbyte[]);

Appends a binary field to a message. No conversion will occur for binary fields. It is up to the programmer to provide any required conversion.

public virtual void appendBinary(sbyte[],int,int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendBinary Method (SByte[])

Appends a binary field to a message. No conversion will occur for binary fields. It is up to the programmer to provide any required conversion.

public virtual void appendBinary(
sbyte[] binary_data
);

Parameters

binary_data
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendBinary Overload List


TipcMsg.appendBinary Method (SByte[], Int32, Int32)

Appends a binary field to a message. No conversion will occur for binary fields. It is up to the programmer to provide any required conversion.

public virtual void appendBinary(
sbyte[] binary_data,
int offset,
int length
);

Parameters

binary_data
data for new message field
offset
start location in binary_data
length
number of bytes to append

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendBinary Overload List


TipcMsg.appendBool Method

Append a boolean field to a message.

public virtual void appendBool(
bool b
);

Parameters

b
data for a new message field.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


appendBoolArray Method

SmartSockets .NET Class Library

TipcMsg.appendBoolArray Method

Append a boolean array field to a message.

Overload List

Append a boolean array field to a message.

public virtual void appendBoolArray(bool[]);

Append a boolean array field to a message.

public virtual void appendBoolArray(bool[],int,int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendBoolArray Method (Boolean[])

Append a boolean array field to a message.

public virtual void appendBoolArray(
bool[] data
);

Parameters

data
data for a new message field.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendBoolArray Overload List


TipcMsg.appendBoolArray Method (Boolean[], Int32, Int32)

Append a boolean array field to a message.

public virtual void appendBoolArray(
bool[] data,
int offset,
int length
);

Parameters

data
data for a new message field.
offset
the offset into the array.
length
the number of elements to append.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendBoolArray Overload List


TipcMsg.appendByte Method

Appends a byte field to a message.

public virtual void appendByte(
sbyte b
);

Parameters

b
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


appendChar Method

SmartSockets .NET Class Library

TipcMsg.appendChar Method

Appends a character field to a message.

Overload List

Appends a character field to a message.

public virtual void appendChar(char);

Appends a character field to a message.

public virtual void appendChar(sbyte);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendChar Method (Char)

Appends a character field to a message.

public virtual void appendChar(
char c
);

Parameters

c
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendChar Overload List


TipcMsg.appendChar Method (SByte)

Appends a character field to a message.

public virtual void appendChar(
sbyte c
);

Parameters

c
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendChar Overload List


TipcMsg.appendGuid Method

Append a Globally Unique Identifier to a message.

public virtual void appendGuid(
sbyte[] guid,
int offset
);

Parameters

guid
a byte array holding the GUID
offset
the offset into the array

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendGuidArray Method

Append an array of Globally Unique Identifiers to a message.

public virtual void appendGuidArray(
sbyte[][] guidArray,
int offset,
int length
);

Parameters

guidArray
a byte array holding the GUID array
offset
the offset into the array
length
the number of elements to append

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendInt2 Method

Appends a 2 byte integer field to a message.

public virtual void appendInt2(
short s
);

Parameters

s
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


appendInt2Array Method

SmartSockets .NET Class Library

TipcMsg.appendInt2Array Method

Appends a 2 byte integer array field to a message.

Overload List

Appends a 2 byte integer array field to a message.

public virtual void appendInt2Array(short[]);

Appends a 2 byte integer array field to a message.

public virtual void appendInt2Array(short[],int,int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendInt2Array Method (Int16[])

Appends a 2 byte integer array field to a message.

public virtual void appendInt2Array(
short[] data
);

Parameters

data
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendInt2Array Overload List


TipcMsg.appendInt2Array Method (Int16[], Int32, Int32)

Appends a 2 byte integer array field to a message.

public virtual void appendInt2Array(
short[] data,
int offset,
int length
);

Parameters

data
data for new message field
offset
start location in int2_array_data
length
number of elements to append

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendInt2Array Overload List


TipcMsg.appendInt4 Method

Appends a 4 byte integer field to a message.

public virtual void appendInt4(
int i
);

Parameters

i
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


appendInt4Array Method

SmartSockets .NET Class Library

TipcMsg.appendInt4Array Method

Appends a 4 byte integer array field to a message.

Overload List

Appends a 4 byte integer array field to a message.

public virtual void appendInt4Array(int[]);

Appends a 4 byte integer array field to a message.

public virtual void appendInt4Array(int[],int,int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendInt4Array Method (Int32[])

Appends a 4 byte integer array field to a message.

public virtual void appendInt4Array(
int[] data
);

Parameters

data
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendInt4Array Overload List


TipcMsg.appendInt4Array Method (Int32[], Int32, Int32)

Appends a 4 byte integer array field to a message.

public virtual void appendInt4Array(
int[] data,
int offset,
int length
);

Parameters

data
data for new message field
offset
start location in int4_array_data
length
number of elements to append

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendInt4Array Overload List


TipcMsg.appendInt8 Method

Appends a 8 byte integer field to a message.

public virtual void appendInt8(
long l
);

Parameters

l
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


appendInt8Array Method

SmartSockets .NET Class Library

TipcMsg.appendInt8Array Method

Appends a 8 byte integer array field to a message.

Overload List

Appends a 8 byte integer array field to a message.

public virtual void appendInt8Array(long[]);

Appends a 8 byte integer array field to a message.

public virtual void appendInt8Array(long[],int,int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendInt8Array Method (Int64[])

Appends a 8 byte integer array field to a message.

public virtual void appendInt8Array(
long[] data
);

Parameters

data
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendInt8Array Overload List


TipcMsg.appendInt8Array Method (Int64[], Int32, Int32)

Appends a 8 byte integer array field to a message.

public virtual void appendInt8Array(
long[] data,
int offset,
int length
);

Parameters

data
data for new message field
offset
start location in int8_array_data
length
number of elements to append

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendInt8Array Overload List


TipcMsg.appendMsg Method

Appends a message field to a message.

public virtual void appendMsg(
TipcMsg msg_data
);

Parameters

msg_data
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


appendMsgArray Method

SmartSockets .NET Class Library

TipcMsg.appendMsgArray Method

Appends a message array field to a message.

Overload List

Appends a message array field to a message.

public virtual void appendMsgArray(TipcMsg[]);

Appends a message array field to a message.

public virtual void appendMsgArray(TipcMsg[],int,int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendMsgArray Method (TipcMsg[])

Appends a message array field to a message.

public virtual void appendMsgArray(
TipcMsg[] data
);

Parameters

data
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendMsgArray Overload List


TipcMsg.appendMsgArray Method (TipcMsg[], Int32, Int32)

Appends a message array field to a message.

public virtual void appendMsgArray(
TipcMsg[] data,
int offset,
int length
);

Parameters

data
data for new message field
offset
start location in data
length
number of elements to append

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendMsgArray Overload List


TipcMsg.appendMsgId Method

Append a TIBCO message ID to a message.

public virtual void appendMsgId(
sbyte[] msgId,
int offset
);

Parameters

msgId
a byte array holding the message ID.
offset
the offset into the array

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendMsgIdArray Method

Append an array of TIBCO message IDs to a message.

public virtual void appendMsgIdArray(
sbyte[][] msgIdArray,
int offset,
int length
);

Parameters

msgIdArray
a byte array holding the message ID.
offset
the offset into the array
length
number of elements to append

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendObject Method

Appends an arbitrary Object to the message. The object will be encoded in a binary field, using the standard serialization mechanism. Therefore, the object passed to this method must implement the Serializable interface. Note that any objects to be serialized must not only themselves be implemented as Serializable, but all of the classes they extend must be Serializable.

This object will only be useful to receiving clients in .NET, C/C++/Java clients will receive a binary field which may be forwarded to other .NET clients.

public virtual void appendObject(
object obj
);

Parameters

obj
the object to be appended

Exceptions

Exception Type | Condition
TipcIOException | If the object serialization fails

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.appendReal4 Method

Appends a 4 byte real field to a message.

public virtual void appendReal4(
float f
);

Parameters

f
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


appendReal4Array Method

SmartSockets .NET Class Library

TipcMsg.appendReal4Array Method

Appends a 4 byte real array field to a message.

Overload List

Appends a 4 byte real array field to a message.

public virtual void appendReal4Array(float[]);

Appends a 4 byte real array field to a message.

public virtual void appendReal4Array(float[],int,int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendReal4Array Method (Single[])

Appends a 4 byte real array field to a message.

public virtual void appendReal4Array(
float[] data
);

Parameters

data
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendReal4Array Overload List


TipcMsg.appendReal4Array Method (Single[], Int32, Int32)

Appends a 4 byte real array field to a message.

public virtual void appendReal4Array(
float[] data,
int offset,
int length
);

Parameters

data
data for new message field
offset
start location in data
length
number of elements to append

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendReal4Array Overload List


TipcMsg.appendReal8 Method

Appends a 8 byte real field to a message.

public virtual void appendReal8(
double d
);

Parameters

d
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


appendReal8Array Method

SmartSockets .NET Class Library

TipcMsg.appendReal8Array Method

Appends a 8 byte real array field to a message.

Overload List

Appends a 8 byte real array field to a message.

public virtual void appendReal8Array(double[]);

Appends a 8 byte real array field to a message.

public virtual void appendReal8Array(double[],int,int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendReal8Array Method (Double[])

Appends a 8 byte real array field to a message.

public virtual void appendReal8Array(
double[] data
);

Parameters

data
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendReal8Array Overload List


TipcMsg.appendReal8Array Method (Double[], Int32, Int32)

Appends a 8 byte real array field to a message.

public virtual void appendReal8Array(
double[] data,
int offset,
int length
);

Parameters

data
data for new message field
offset
start location in data
length
number of elements to append

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendReal8Array Overload List


TipcMsg.appendStr Method

Appends a string field to a message.

For C/C++ clients, this field will represent ASCII characters only. To send Unicode strings to C/C++ clients use appendUtf8.

public virtual void appendStr(
string s
);

Parameters

s
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


appendStrArray Method

SmartSockets .NET Class Library

TipcMsg.appendStrArray Method

Appends a string array field to a message.

For C/C++ clients, this field will represent ASCII characters only. To send Unicode strings to C/C++ clients use appendUtf8Array.

Overload List

Appends a string array field to a message. For C/C++ clients, this field will represent ASCII characters only. To send Unicode strings to C/C++ clients use appendUtf8Array.

public virtual void appendStrArray(string[]);

Appends a string array field to a message. For C/C++ clients, this field will represent ASCII characters only. To send Unicode strings to C/C++ clients use appendUtf8Array.

public virtual void appendStrArray(string[],int,int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.appendStrArray Method (String[])

Appends a string array field to a message.

For C/C++ clients, this field will represent ASCII characters only. To send Unicode strings to C/C++ clients use appendUtf8Array.

public virtual void appendStrArray(
string[] data
);

Parameters

data
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendStrArray Overload List |


TipcMsg.appendStrArray Method (String[], Int32, Int32)

Appends a string array field to a message.

For C/C++ clients, this field will represent ASCII characters only. To send Unicode strings to C/C++ clients use appendUtf8Array.

public virtual void appendStrArray(
string[] data,
int offset,
int length
);

Parameters

data
data for new message field
offset
start location in str_array_data
length
number of elements to append

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendStrArray Overload List |


TipcMsg.appendTimestamp Method

Append a timestamp field to a message.

public virtual void appendTimestamp(
double timestamp_data
);

Parameters

timestamp_data
data for a new message field.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendTimestampArray Method

Append an array of timestamps to a message.

public virtual void appendTimestampArray(
double[] timestamp_array_data
);

Parameters

timestamp_array_data
data for a new message field.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendUnknown Method

Appends a new field of the specified type to the message, but marks the field as an 'unknown value'. The constants required for the parameter, field_type, are specified in this class and can be recognized by their FT_* names.

public virtual void appendUnknown(
int ft
);

Parameters

ft
the type of field to append and mark as of 'unknown value'

Exceptions

Exception Type | Condition
TipcAssertionException | If bad field_type parameter passed in
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.appendUtf8 Method

Append a UTF-8 string field to a message. The String will be converted to UTF-8 prior to being appended to the message.

public virtual void appendUtf8(
string s
);

Parameters

s
data for a new message field.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


appendUtf8Array Method

SmartSockets .NET Class Library

TipcMsg.appendUtf8Array Method

Append an array of UTF-8 strings to a message. The String's will be converted to UTF-8 prior to being appended to the message.

Overload List

Append an array of UTF-8 strings to a message. The String's will be converted to UTF-8 prior to being appended to the message.

public virtual void appendUtf8Array(string[]);

Append an array of UTF-8 strings to a message. The String's will be converted to UTF-8 prior to being appended to the message.

public virtual void appendUtf8Array(string[],int,int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.appendUtf8Array Method (String[])

Append an array of UTF-8 strings to a message. The String's will be converted to UTF-8 prior to being appended to the message.

public virtual void appendUtf8Array(
string[] data
);

Parameters

data
data for a new message field.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendUtf8Array Overload List


TipcMsg.appendUtf8Array Method (String[], Int32, Int32)

Append an array of UTF-8 strings to a message. The String's will be converted to UTF-8 prior to being appended to the message.

public virtual void appendUtf8Array(
string[] data,
int offset,
int length
);

Parameters

data
data for a new message field.
offset
start location in str_array_data
length
number of elements to append

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.appendUtf8Array Overload List


TipcMsg.appendXml Method

Appends an XML field to a message.

public virtual void appendXml(
TutXml xml
);

Parameters

xml
data for new message field

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.Clone Method

Clones the message.

public virtual object Clone();

Return Value

A clone of the message.

Implements

ICloneable.Clone

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.deleteCurrent Method

Deletes current field in a message.

public virtual void deleteCurrent();

Exceptions

Exception Type | Condition
TipcMsgException | If the message is read only
TipcMsgEomException | If there is no field in the message
TipcMsgEomException | If the current field is at the end of the message
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.deleteField Method

Deletes the specified field in a message.

public virtual void deleteField(
int index
);

Parameters

index
The index of the field to be deleted.

Exceptions

Exception Type | Condition
TipcMsgException | If the message is read only.
TipcMsgEomException | If there is not field in the message or the current field is at the end of the message.
TipcException | For all other errors.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | deleteCurrent | deleteNamedField


TipcMsg.deleteNamedField Method

Deletes a named field in a message.

public virtual void deleteNamedField(
string name
);

Parameters

name
the name of the field to be deleted

Exceptions

Exception Type | Condition
TipcMsgException | If the message is read only
TipcMsgException | If there is no field by that name
TipcMsgEomException | If there is no field in the message
TipcMsgEomException | If the current field is at the end of the message
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.deleteProp Method

Implementation of public interface method.

public virtual bool deleteProp(
int propKey
);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.destroy Method

Destroys the message. If the message was received using GMD, this will also acknowledge the message.

public virtual void destroy();

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.existsNamed Method

Returns true if there is a field by the given field name, false if not.

public virtual bool existsNamed(
string name
);

Parameters

name
the field name

Exceptions

Exception Type | Condition
TipcMsgException | if the message is corrupt
TipcException | for all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.generateMessageId Method

Generates the message id property for the message.

A message id will uniquely identify each message sent by a publisher.

public virtual void generateMessageId();

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedBinary Method

Returns the binary field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual sbyte[] getNamedBinary(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedBool Method

Returns a boolean field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual bool getNamedBool(
string name
);

Parameters

name
the name to use

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedBoolArray Method

Returns a boolean array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual bool[] getNamedBoolArray(
string name
);

Parameters

name
the name to use

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedByte Method

Returns the byte field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual sbyte getNamedByte(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedChar Method

Returns the character field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual char getNamedChar(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedCharByte Method

Returns the character field corresponding to the given field name as a byte. If there is no field by that name, an exception will be thrown.

public virtual sbyte getNamedCharByte(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedFieldKnown Method

Examines the named field and reports back if it is an actual value, or a field marked as having an 'unknown value'. Does not advance to the next field.

public virtual bool getNamedFieldKnown(
string name
);

Return Value

true if the named field contains an actual value; false if the field is marked as having an 'unknown value'.

Exceptions

Exception Type | Condition
TipcMsgException | if there is no field by that name
TipcException | for all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedGuid Method

Returns Guid field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual sbyte[] getNamedGuid(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedGuidArray Method

Returns Guid Array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual sbyte[][] getNamedGuidArray(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedInt2 Method

Returns a 2 byte integer field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual short getNamedInt2(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedInt2Array Method

Returns a 2 byte integer array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual short[] getNamedInt2Array(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedInt4 Method

Returns a 4 byte integer field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual int getNamedInt4(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedInt4Array Method

Returns a 4 byte integer array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual int[] getNamedInt4Array(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedInt8 Method

Returns a 8 byte integer field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual long getNamedInt8(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedInt8Array Method

Returns a 8 byte integer array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual long[] getNamedInt8Array(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedMsg Method

Returns message field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual TipcMsg getNamedMsg(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedMsgArray Method

Returns message array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual TipcMsg[] getNamedMsgArray(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedMsgId Method

Returns MsgId field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual sbyte[] getNamedMsgId(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedMsgIdArray Method

Returns MsgId Array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual sbyte[][] getNamedMsgIdArray(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedObject Method

Returns Object field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual object getNamedObject(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.getNamedReal4 Method

Returns a 4 byte real field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual float getNamedReal4(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedReal4Array Method

Returns a 4 byte real array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual float[] getNamedReal4Array(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedReal8 Method

Returns a 8 byte real field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual double getNamedReal8(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedReal8Array Method

Returns a 8 byte real array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual double[] getNamedReal8Array(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedStr Method

Returns string field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual string getNamedStr(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedStrArray Method

Returns string array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual string[] getNamedStrArray(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedTimestamp Method

Returns a timestamp field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual double getNamedTimestamp(
string name
);

Parameters

name
the name to use

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedTimestampArray Method

Returns a timestamp array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual double[] getNamedTimestampArray(
string name
);

Parameters

name
the name to use

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedUnknown Method

Returns true if the field corresponding to the given field name is marked as having 'unknown value'. If the field has a 'known value' a TipcMsgBadFieldException will be thrown. If there is no field by that name, an exception will be thrown.

public virtual bool getNamedUnknown(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedUtf8 Method

Returns a UTF-8 string field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual string getNamedUtf8(
string name
);

Parameters

name
the name to use

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedUtf8Array Method

Returns a UTF-8 string array field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual string[] getNamedUtf8Array(
string name
);

Parameters

name
the name to use

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getNamedXml Method

Returns an XML field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual TutXml getNamedXml(
string name
);

Parameters

name
the field name

Return Value

the field data

Exceptions

Exception Type | Condition
TipcMsgException | If there is no field by that name
TipcMsgUnknownFieldException | If the field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.getTypeNamed Method

Returns the type of the field corresponding to the given field name. If there is no field by that name, an exception will be thrown.

public virtual int getTypeNamed(
string name
);

Parameters

name
the field name

Return Value

the type (see list of field types above)

Exceptions

Exception Type | Condition
TipcMsgEomException | If there is no field by that name or if the index has have moved past last field
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.log Method

Logs the message to the stream.

public virtual void log(
StreamWriter Out
);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


nextBinary Method

SmartSockets .NET Class Library

TipcMsg.nextBinary Method

Gets a binary field from the message.

Overload List

Gets a binary field from the message.

public virtual sbyte[] nextBinary();

Gets a binary field from the message.

public virtual int nextBinary(sbyte[],int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextBinary Method ()

Gets a binary field from the message.

public virtual sbyte[] nextBinary();

Return Value

the binary data

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextBinary Overload List


TipcMsg.nextBinary Method (SByte[], Int32)

Gets a binary field from the message.

public virtual int nextBinary(
sbyte[] ret,
int off
);

Parameters

ret
storage for the binary data
off
first byte in ret to use

Return Value

the number of bytes retrieved

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextBinary Overload List


TipcMsg.nextBool Method

Gets a boolean field from the message.

public virtual bool nextBool();

Return Value

the boolean data

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


nextBoolArray Method

SmartSockets .NET Class Library

TipcMsg.nextBoolArray Method

Gets a boolean array from the message.

Overload List

Gets a boolean array from the message.

public virtual bool[] nextBoolArray();

Gets a boolean array from the message.

public virtual int nextBoolArray(bool[],int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextBoolArray Method ()

Gets a boolean array from the message.

public virtual bool[] nextBoolArray();

Return Value

the boolean array from the message

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextBoolArray Overload List


TipcMsg.nextBoolArray Method (Boolean[], Int32)

Gets a boolean array from the message.

public virtual int nextBoolArray(
bool[] ret,
int offset
);

Parameters

ret
storage for the int4 array
offset
first element of ret to use

Return Value

the number of elements retrieved

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextBoolArray Overload List


TipcMsg.nextByte Method

Gets a byte field from the message.

public virtual sbyte nextByte();

Return Value

the byte data

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextChar Method

Gets a character field from the message.

public virtual char nextChar();

Return Value

the char data

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextCharByte Method

Gets a character field as a byte from the message.

public virtual sbyte nextCharByte();

Return Value

the character data as a byte

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextGuid Method

Gets a Globally Unique Identifer from the message.

public virtual sbyte[] nextGuid();

Return Value

a byte array containing the GUID.

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


nextGuidArray Method

SmartSockets .NET Class Library

TipcMsg.nextGuidArray Method

Gets an array of Globally Unique Identifers from the message.

Overload List

Gets an array of Globally Unique Identifers from the message.

public virtual sbyte[][] nextGuidArray();

Gets an array of Globally Unique Identifers from the message.

public virtual int nextGuidArray(sbyte[][],int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextGuidArray Method ()

Gets an array of Globally Unique Identifers from the message.

public virtual sbyte[][] nextGuidArray();

Return Value

the Guid array

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextGuidArray Overload List


TipcMsg.nextGuidArray Method (SByte[][], Int32)

Gets an array of Globally Unique Identifers from the message.

public virtual int nextGuidArray(
sbyte[][] buf,
int off
);

Parameters

buf
an array of arrays large enough to hold the data
off
offset into the outermost array of arrays

Return Value

the number of elements in the array

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextGuidArray Overload List


TipcMsg.nextInt2 Method

Gets a 2 byte integer field from the message.

public virtual short nextInt2();

Return Value

the int2 data

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


nextInt2Array Method

SmartSockets .NET Class Library

TipcMsg.nextInt2Array Method

Gets a 2 byte integer array from the message.

Overload List

Gets a 2 byte integer array from the message.

public virtual short[] nextInt2Array();

Gets a 2 byte integer array from the message.

public virtual int nextInt2Array(short[],int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextInt2Array Method ()

Gets a 2 byte integer array from the message.

public virtual short[] nextInt2Array();

Return Value

the int2 array from the message

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextInt2Array Overload List


TipcMsg.nextInt2Array Method (Int16[], Int32)

Gets a 2 byte integer array from the message.

public virtual int nextInt2Array(
short[] ret,
int off
);

Parameters

ret
storage for the int2 array
off
first element of ret to use.

Return Value

the number of elements retrieved

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextInt2Array Overload List


TipcMsg.nextInt4 Method

Gets a 4 byte integer field from the message.

public virtual int nextInt4();

Return Value

the int4 data

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


nextInt4Array Method

SmartSockets .NET Class Library

TipcMsg.nextInt4Array Method

Gets a 4 byte integer array from the message.

Overload List

Gets a 4 byte integer array from the message.

public virtual int[] nextInt4Array();

Gets a 4 byte integer array from the message.

public virtual int nextInt4Array(int[],int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextInt4Array Method ()

Gets a 4 byte integer array from the message.

public virtual int[] nextInt4Array();

Return Value

the int4 array from the message

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextInt4Array Overload List


TipcMsg.nextInt4Array Method (Int32[], Int32)

Gets a 4 byte integer array from the message.

public virtual int nextInt4Array(
int[] ret,
int offset
);

Parameters

ret
storage for the int4 array
offset
first element of ret to use.

Return Value

the number of elements retrieved

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextInt4Array Overload List


TipcMsg.nextInt8 Method

Gets a 8 byte integer field from the message.

public virtual long nextInt8();

Return Value

the int8 data

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested_type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


nextInt8Array Method

SmartSockets .NET Class Library

TipcMsg.nextInt8Array Method

Gets a 8 byte integer array from the message.

Overload List

Gets a 8 byte integer array from the message.

public virtual long[] nextInt8Array();

Gets a 8 byte integer array from the message.

public virtual int nextInt8Array(long[],int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextInt8Array Method ()

Gets a 8 byte integer array from the message.

public virtual long[] nextInt8Array();

Return Value

the int8 array from the message

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextInt8Array Overload List


TipcMsg.nextInt8Array Method (Int64[], Int32)

Gets a 8 byte integer array from the message.

public virtual int nextInt8Array(
long[] ret,
int off
);

Parameters

ret
storage for the int8 array
off
first element of ret to use.

Return Value

the number of elements retrieved

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextInt8Array Overload List


TipcMsg.nextMsg Method

Gets a message field from the message.

public virtual TipcMsg nextMsg();

Return Value

the msg data

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


nextMsgArray Method

SmartSockets .NET Class Library

TipcMsg.nextMsgArray Method

Gets a message array from the message.

Overload List

Gets a message array from the message.

public virtual TipcMsg[] nextMsgArray();

Gets a message array from the message.

public virtual int nextMsgArray(TipcMsg[],int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextMsgArray Method ()

Gets a message array from the message.

public virtual TipcMsg[] nextMsgArray();

Return Value

the msg array from the message

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextMsgArray Overload List


TipcMsg.nextMsgArray Method (TipcMsg[], Int32)

Gets a message array from the message.

public virtual int nextMsgArray(
TipcMsg[] ret,
int off
);

Parameters

ret
storage for the msg array
off
first element of ret to use.

Return Value

the number of elements retrieved

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextMsgArray Overload List


TipcMsg.nextMsgId Method

Gets a TIBCO message ID from the message.

public virtual sbyte[] nextMsgId();

Return Value

a byte array containing the message ID

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


nextMsgIdArray Method

SmartSockets .NET Class Library

TipcMsg.nextMsgIdArray Method

Gets an array of TIBCO message IDs from the message.

Overload List

Gets an array of TIBCO message IDs from the message.

public virtual sbyte[][] nextMsgIdArray();

Gets an array of TIBCO message IDs from the message.

public virtual int nextMsgIdArray(sbyte[][],int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextMsgIdArray Method ()

Gets an array of TIBCO message IDs from the message.

public virtual sbyte[][] nextMsgIdArray();

Return Value

the number of elements in the array

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextMsgIdArray Overload List


TipcMsg.nextMsgIdArray Method (SByte[][], Int32)

Gets an array of TIBCO message IDs from the message.

public virtual int nextMsgIdArray(
sbyte[][] buf,
int off
);

Parameters

buf
an array of arrays large enough to hold the data
off
offset into the outermost array of arrays

Return Value

the number of elements in the array

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextMsgIdArray Overload List


TipcMsg.nextObject Method

Decodes the next field (which must be a binary field) as an arbitrary .NET Object. Objects encoded into a binary field with the appendObject method are decoded with this method. Decoding objects carries the same restrictions as the standard .NET serialization mechanism. Serialized objects must implement the Serializable interface.

public virtual object nextObject();

Return Value

the object

Exceptions

Exception Type | Condition
TipcIOException | If the object cannot be read

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace |


TipcMsg.nextReal4 Method

Gets a 4 byte real field from the message.

public virtual float nextReal4();

Return Value

the real4 data

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


nextReal4Array Method

SmartSockets .NET Class Library

TipcMsg.nextReal4Array Method

Gets a 4 byte real array from the message.

Overload List

Gets a 4 byte real array from the message.

public virtual float[] nextReal4Array();

Gets a 4 byte real array from the message.

public virtual int nextReal4Array(float[],int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextReal4Array Method ()

Gets a 4 byte real array from the message.

public virtual float[] nextReal4Array();

Return Value

the real4 array from the message

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextReal4Array Overload List


TipcMsg.nextReal4Array Method (Single[], Int32)

Gets a 4 byte real array from the message.

public virtual int nextReal4Array(
float[] ret,
int off
);

Parameters

ret
storage for the real4 array
off
first element of ret to use.

Return Value

the number of elements retrieved

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextReal4Array Overload List


TipcMsg.nextReal8 Method

Gets a 8 byte real field from the message.

public virtual double nextReal8();

Return Value

the real8 data

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


nextReal8Array Method

SmartSockets .NET Class Library

TipcMsg.nextReal8Array Method

Gets a 8 byte real array from the message.

Overload List

Gets a 8 byte real array from the message.

public virtual double[] nextReal8Array();

Gets a 8 byte real array from the message.

public virtual int nextReal8Array(double[],int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextReal8Array Method ()

Gets a 8 byte real array from the message.

public virtual double[] nextReal8Array();

Return Value

the real8 array from the message

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextReal8Array Overload List


TipcMsg.nextReal8Array Method (Double[], Int32)

Gets a 8 byte real array from the message.

public virtual int nextReal8Array(
double[] ret,
int off
);

Parameters

ret
storage for the real8 array
off
first element of ret to use.

Return Value

the number of elements retrieved

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextReal8Array Overload List


TipcMsg.nextStr Method

Gets a string field from the message.

public virtual string nextStr();

Return Value

the str data

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


nextStrArray Method

SmartSockets .NET Class Library

TipcMsg.nextStrArray Method

Gets a string array from the message.

Overload List

Gets a string array from the message.

public virtual string[] nextStrArray();

Gets a string array from the message.

public virtual int nextStrArray(string[],int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextStrArray Method ()

Gets a string array from the message.

public virtual string[] nextStrArray();

Return Value

the str array from the message

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextStrArray Overload List


TipcMsg.nextStrArray Method (String[], Int32)

Gets a string array from the message.

public virtual int nextStrArray(
string[] ret,
int off
);

Parameters

ret
storage for the str array
off
first element of ret to use.

Return Value

the number of elements retrieved

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextStrArray Overload List


TipcMsg.nextTimestamp Method

Gets a timestamp field from the message.

public virtual double nextTimestamp();

Return Value

the timestamp as a double.

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextTimestampArray Method

Gets a timestamp array from the message.

public virtual double[] nextTimestampArray();

Return Value

the timestamp array from the message

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextType Method

Gets the type (FT_*) of the next field.

public virtual int nextType();

Return Value

the next field type, which will be one of the FT_* constants

Exceptions

Exception Type | Condition
TipcMsgEomException | If there is no next field.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextUnknown Method

If the next field in the message is marked as an 'unknown value', this method will skip over the field and return true. If the field has a 'known value', the current field will not be advanced, and a TipcMsgBadFieldException will be thrown.

public virtual bool nextUnknown();

Return Value

true if the field has 'unknown value'

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.nextUtf8 Method

Gets a UTF-8 string field from the message.

public virtual string nextUtf8();

Return Value

the string data

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


nextUtf8Array Method

SmartSockets .NET Class Library

TipcMsg.nextUtf8Array Method

Gets a UTF-8 string array field from the message.

Overload List

Gets a UTF-8 string array field from the message.

public virtual string[] nextUtf8Array();

Gets a UTF-8 string array field from the message.

public virtual int nextUtf8Array(string[],int);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.nextUtf8Array Method ()

Gets a UTF-8 string array field from the message.

public virtual string[] nextUtf8Array();

Return Value

the string array data

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextUtf8Array Overload List


TipcMsg.nextUtf8Array Method (String[], Int32)

Gets a UTF-8 string array field from the message.

public virtual int nextUtf8Array(
string[] ret,
int off
);

Parameters

ret
storage for the string array
off
first element of ret to use

Return Value

the number of elements retrieved

Exceptions

Exception Type | Condition
TipcMsgBadFieldException | If the next field is not of the requested type
TipcMsgEomException | If there is no next field.
TipcMsgUnknownFieldException | If the next field is marked unknown
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.nextUtf8Array Overload List


TipcMsg.nextXml Method

Implementation of public interface method.

public virtual TutXml nextXml();

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


print Method

SmartSockets .NET Class Library

TipcMsg.print Method

Prints the message to the SmartSockets "standard" output stream.

Prints the message in human readable form, showing the value of all user-settable fields as well as all data currently in the message.

Overload List

Prints the message to the SmartSockets "standard" output stream. Prints the message in human readable form, showing the value of all user-settable fields as well as all data currently in the message.

public virtual void print();

Prints the message. Prints the message in human readable form, showing the value of all user-settable fields as well as all data currently in the message.

public virtual void print(StreamWriter);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.print Method ()

Prints the message to the SmartSockets "standard" output stream.

Prints the message in human readable form, showing the value of all user-settable fields as well as all data currently in the message.

public virtual void print();

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.print Overload List


TipcMsg.print Method (StreamWriter)

Prints the message.

Prints the message in human readable form, showing the value of all user-settable fields as well as all data currently in the message.

public virtual void print(
StreamWriter Out
);

Parameters

Out
The stream to print to.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.print Overload List


TipcMsg.setPropBinary Method

Set a message property as a partial binary field. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.

public virtual void setPropBinary(
int propKey,
sbyte[] Value,
int offset,
int length
);

Parameters

propKey
Key for this property.
Value
Value of the property.
offset
Offset into Value.
length
Length of data from Value.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If propKey is invalid or value is null.
TipcException | For all other errors.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.setPropInt Method

Set a message property as an integer. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.

public virtual void setPropInt(
int propKey,
int Value
);

Parameters

propKey
Key for this property.
Value
Value of the property.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If propKey is invalid or value is null.
TipcException | For all other errors.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.setPropShort Method

Set a message property as a short. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.

public virtual void setPropShort(
int propKey,
short Value
);

Parameters

propKey
Key for this property.
Value
Value of the property.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If propKey is invalid or value is null.
TipcException | For all other errors.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.setPropStr Method

Set a message property as a string. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.

public virtual void setPropStr(
int propKey,
string Value
);

Parameters

propKey
Key for this property.
Value
Value of the property.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If propKey is invalid or value is null.
TipcException | For all other errors.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.setPropStrArray Method

Set a message property as a partial string array. Use of this method is strongly discouraged. It is intended for TIBCO internal use, and is subject to arbitrary changes.

public virtual void setPropStrArray(
int propKey,
string[] Value,
int offset,
int length
);

Parameters

propKey
Key for this property.
Value
Value of the property.
offset
Offset into Value.
length
Length of data from Value.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If propKey is invalid or value is null.
TipcException | For all other errors.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.toByteArray Method

Serializes the contents of the current message into a byte array.

public virtual sbyte[] toByteArray();

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data.

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg.updateNamedBinary Method

Updates a named binary field in a message.

public virtual void updateNamedBinary(
string name,
sbyte[] Value,
int offset,
int length
);

Parameters

name
the name of the field
Value
the new binary data for the field
offset
offset into 'Value'
length
number of bytes in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedBool Method

Updates a named bool field in a message.

public virtual void updateNamedBool(
string name,
bool Value
);

Parameters

name
the name of the field
Value
the new binary data for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedBoolArray Method

Updates a named bool array field in a message.

public virtual void updateNamedBoolArray(
string name,
bool[] Value,
int offset,
int length
);

Parameters

name
the name of the field
Value
the new binary data for the field
offset
offset into 'Value'
length
number of bytes in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedByte Method

Updates a named byte field in a message.

public virtual void updateNamedByte(
string name,
sbyte Value
);

Parameters

name
the name of the field
Value
the new byte value for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


updateNamedChar Method

SmartSockets .NET Class Library

TipcMsg.updateNamedChar Method

Updates a named character field in a message.

Overload List

Updates a named character field in a message.

public virtual void updateNamedChar(string,char);

Updates a named character (byte) field in a message.

public virtual void updateNamedChar(string,sbyte);

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedChar Method (String, Char)

Updates a named character field in a message.

public virtual void updateNamedChar(
string name,
char Value
);

Parameters

name
the name of the field
Value
the new byte value for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.updateNamedChar Overload List | |


TipcMsg.updateNamedChar Method (String, SByte)

Updates a named character (byte) field in a message.

public virtual void updateNamedChar(
string name,
sbyte Value
);

Parameters

name
the name of the field
Value
the new byte value for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg.updateNamedChar Overload List | |


TipcMsg.updateNamedGuid Method

updates a Globally Unique Identifier to a message, with a name.

public virtual void updateNamedGuid(
string name,
sbyte[] Value,
int offset
);

Parameters

name
the name to use
Value
a byte array holding the GUID
offset
the offset into the array

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedGuidArray Method

Update an array of Globally Unique Identifiers to a message, with a name.

public virtual void updateNamedGuidArray(
string name,
sbyte[][] Value,
int offset,
int length
);

Parameters

name
the name to use
Value
a byte array holding the GUID array
offset
the offset into the array
length
number of bytes in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedInt2 Method

Updates a named 2 byte integer field in a message.

public virtual void updateNamedInt2(
string name,
short Value
);

Parameters

name
the name of the field
Value
the new short value for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedInt2Array Method

Updates a named 2 byte integer array field in a message.

public virtual void updateNamedInt2Array(
string name,
short[] Value,
int offset,
int length
);

Parameters

name
the name of the field
Value
the new int2 array data for the field
offset
offset into 'Value'
length
number of shorts in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedInt4 Method

Updates a named 4 byte integer field in a message.

public virtual void updateNamedInt4(
string name,
int Value
);

Parameters

name
the name to of the field
Value
the new int4 data for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedInt4Array Method

Updates a named 4 byte integer array field in a message.

public virtual void updateNamedInt4Array(
string name,
int[] Value,
int offset,
int length
);

Parameters

name
the name of the field
Value
the new int4 array data for the field
offset
offset into 'Value'
length
number of ints in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedInt8 Method

Updates a named 8 byte integer field in a message.

public virtual void updateNamedInt8(
string name,
long Value
);

Parameters

name
the name of the field
Value
the new long data for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedInt8Array Method

Updates a named 8 byte integer array field in a message.

public virtual void updateNamedInt8Array(
string name,
long[] Value,
int offset,
int length
);

Parameters

name
the name of the field
Value
the new int8 array data for the field
offset
offset into 'Value'
length
number of longs in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedMsg Method

Updates a named message field in a message.

public virtual void updateNamedMsg(
string name,
TipcMsg Value
);

Parameters

name
the name of the field
Value
the new TipcMsg data for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedMsgArray Method

Updates a named message array field in a message.

public virtual void updateNamedMsgArray(
string name,
TipcMsg[] Value,
int offset,
int length
);

Parameters

name
the name of the field
Value
the new msg array data for the field
offset
offset into 'Value'
length
number of TipcMsgs in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedMsgId Method

Updates a named TIBCO message ID field in a message.

public virtual void updateNamedMsgId(
string name,
sbyte[] Value,
int offset
);

Parameters

name
the name to use
Value
a byte array holding the message ID.
offset
the offset into the array

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedMsgIdArray Method

Update a named TIBCO message ID array field in a message.

public virtual void updateNamedMsgIdArray(
string name,
sbyte[][] Value,
int offset,
int length
);

Parameters

name
the name to use
Value
a byte array holding the message ID.
offset
the offset into the array
length
number of message ids in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedObject Method

Updates a named arbitrary .NET Object in the message. The object will be encoded in a binary field, using the standard serialization mechanism. Therefore, the object passed to this method must implement the Serializable interface. Note that any objects to be serialized must not only themselves implemented Serializable, but all of the classes they extend must be Serializable.

This object will only be useful to receiving clients in .NET C clients will receive a binary field which may be forwarded to other .NET clients.

public virtual void updateNamedObject(
string name,
object obj
);

Parameters

name
the name to use
obj
the object to be appended

Exceptions

Exception Type | Condition
TipcIOException | If the object serialization fails
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedReal4 Method

Updates a named 4 byte real field in a message.

public virtual void updateNamedReal4(
string name,
float Value
);

Parameters

name
the name of the field
Value
the new float value for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedReal4Array Method

Updates a named 4 byte real array field in a message.

public virtual void updateNamedReal4Array(
string name,
float[] Value,
int offset,
int length
);

Parameters

name
the name of the field
Value
the new real4 array data for the field
offset
offset into 'Value'
length
number of floats in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedReal8 Method

Updates a named 8 byte real field in a message.

public virtual void updateNamedReal8(
string name,
double Value
);

Parameters

name
the name of the field
Value
the new double Value for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedReal8Array Method

Updates a named 8 byte real array field in a message.

public virtual void updateNamedReal8Array(
string name,
double[] Value,
int offset,
int length
);

Parameters

name
the name of the field
Value
the new real8 array data for the field
offset
offset into 'Value'
length
number of doubles in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedStr Method

Updates a named string field in a message.

public virtual void updateNamedStr(
string name,
string Value
);

Parameters

name
the name of the field
Value
the new String value for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedStrArray Method

Updates a named string array field in a message.

public virtual void updateNamedStrArray(
string name,
string[] Value,
int offset,
int length
);

Parameters

name
the name for the field
Value
the new str array data for the field
offset
offset into 'Value'
length
number of Strings in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedTimestamp Method

Updates a named timestamp field in a message.

public virtual void updateNamedTimestamp(
string name,
double Value
);

Parameters

name
the name of the field
Value
the new timestamp value for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedTimestampArray Method

Updates a named timestamp array field in a message.

public virtual void updateNamedTimestampArray(
string name,
double[] Value
);

Parameters

name
the name of the field
Value
the new timestamp array for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedUtf8 Method

Updates a named Utf8 field in a message.

public virtual void updateNamedUtf8(
string name,
string Value
);

Parameters

name
the name of the field
Value
the new String value for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedUtf8Array Method

Updates a named Utf8Array field in a message.

public virtual void updateNamedUtf8Array(
string name,
string[] Value,
int offset,
int length
);

Parameters

name
the name of the field
Value
the new String value for the field
offset
offset into 'Value'
length
number of Strings in 'Value' to copy

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | If there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg.updateNamedXml Method

Updates a named XML field in a message.

public virtual void updateNamedXml(
string name,
TutXml Value
);

Parameters

name
the name of the field
Value
the new TutXml object for the field

Exceptions

Exception Type | Condition
TipcException | If there is an error copying the data
TipcMsgException | if there is no field by that name
TipcException | For all other errors

See Also

TipcMsg Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMsg_Fields Structure

Provides access to message objects.

Messages can only be created from the TipcSvc factory class with createMsg.

A message consists of a type TipcMt, properties, and zero or more fields. The field types are used to convert the field data from the format used by the sending platform to the format used by the receiving platform (byte order, etc.). These types are:

BINARY - an array of uninterpreted bytes (byte[])
CHAR   - a character (char)
STR    - an array of signed bytes representing a string (String)
INT2   - a signed 2 byte integer (short)
INT4   - a signed 4 byte integer (int)
INT8   - a signed 8 byte integer (long)
REAL4  - a 4 byte real number (float)
REAL8  - an 8 byte real number (double)
REAL16 - a 16 byte real number (unsupported by .NET)
MSG    - an embedded SmartSockets message (TipcMsg)
BOOL   - a boolean value (boolean)
BYTE   - a single byte (byte)
UTF8   - an array of bytes representing a UTF-8 encoded string (String)
XML    - a XML object (TutXml)
OBJECT - a .NET object (Object)

For a list of all members of this type, see TipcMsg_Fields Members.

System.Object
System.ValueType
TIBCO.SMARTSOCKETS.TipcMsg_Fields

public struct TipcMsg_Fields

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMsg_Fields Members | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields Members

TipcMsg_Fields overview

Public Static Fields

FT_BINARY | Field Type - an array of uninterpreted bytes
FT_BOOL | Field Type - a 4 byte signed integer
FT_BOOL_ARRAY | Field Type - an array of 4 byte signed integers
FT_BYTE | Field Type - a byte
FT_CHAR | Field Type - a character
FT_GUID | Field Type - a Global Unique Identifier
FT_GUID_ARRAY | Field Type - an array of Global Unique Identifiers
FT_INT2 | Field Type - a 2 byte signed integer
FT_INT2_ARRAY | Field Type - an array of 2 byte signed integers
FT_INT4 | Field Type - a 4 byte signed integer
FT_INT4_ARRAY | Field Type - an array of 4 bytes signed integers
FT_INT8 | Field Type - an 8 byte signed integer
FT_INT8_ARRAY | Field Type - an array of 8 byte signed integers
FT_INVALID | Field Type - marker for an invalid field
FT_MSG | Field Type - an embedded TipcMsg
FT_MSG_ARRAY | Field Type - an array of embedded TipcMsg's
FT_MSGID | Field Type - a globally unique message identifiers
FT_MSGID_ARRAY | Field Type - an array of globally unique message identifiers
FT_REAL16 | Field Type - a 16 byte real (unsupported by .NET)
FT_REAL16_ARRAY | Field Type - an array of 16 byte reals (unsupported by .NET)
FT_REAL4 | Field Type - a 4 byte real
FT_REAL4_ARRAY | Field Type - an array of 4 byte reals
FT_REAL8 | Field Type - an 8 byte real
FT_REAL8_ARRAY | Field Type - an array of 8 byte reals
FT_STR | Field Type - a string
FT_STR_ARRAY | Field Type - an array of strings
FT_TIMESTAMP | Field Type - timestamp
FT_TIMESTAMP_ARRAY | Field Type - an array of timestamps
FT_UTF8 | Field Type - a UTF-8 encoded string
FT_UTF8_ARRAY | Field Type - an array of UTF-8 encoded strings
FT_XML | Field Type - a TutXml
PROP_APP_STR | Property - project (application)
PROP_ARRIVAL_TIMESTAMP_NUM | Property - arrival timestamp
PROP_CORRELATION_ID_STR | Property - message correlation identifier
PROP_DEST_CLIENT_NAME_ARRAY | Property - destination client name array
PROP_DEST_CLIENT_NUM_ARRAY | Property - destination client number array
PROP_DEST_CLIENT_STR_ARRAY | Property - destination client array
PROP_DEST_SERVER_NAME_ARRAY | Property - destination server name array
PROP_DEST_SERVER_NUM_ARRAY | Property - destination server number array
PROP_DEST_SERVER_STR_ARRAY | Property - destination server array
PROP_DEST_STR | Property - destination
PROP_EXPIRATION_NUM | Property - message expiration
PROP_FIELD_INDEX_ARRAY | Property - field index array
PROP_FIELD_NAME_ARRAY | Property - field name array
PROP_GROUP_DEST_ID_NUM_ARRAY | Property - group destination identifer array
PROP_GROUP_SENDER_ID_NUM | Property - group sender identifier
PROP_LB_MODE_NUM | Property - load balancing mode
PROP_LOCAL_DELIVERY | Property - local delivery
PROP_MESSAGE_ID_STR | Property - message identifier
PROP_REPLY_TO_DEST_STR | Property - reply to destination
PROP_RTSERVER_NAME_ARRAY | Property - RTserver name array
PROP_RTSERVER_NUM_ARRAY | Property - RTserver number array
PROP_SCOPE_NAME_ARRAY | Property - scope name array
PROP_SCOPE_NUM_ARRAY | Property - scope number array
PROP_SCOPE_STR_ARRAY | Property - scope array
PROP_SENDER_SERVER_STR | Property - sender server
PROP_SENDER_STR | Property - sender
PROP_SENDER_TIMESTAMP_NUM | Property - sender timestamp
PROP_SOD_SID_GUID | Property - arrival timestamp
PROP_SQ_1 | Property - SmartQueue 1
PROP_SQ_2 | Property - SmartQueue 2
PROP_SQ_3 | Property - SmartQueue 3
PROP_SQ_4 | Property - SmartQueue 4
PROP_SQ_START | Property - SmartQueue start
PROP_TMP_DELIVERY_TIMEOUT | Property - delivery timeout
PROP_UNUSED | Property - unused

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields Fields

The fields of the TipcMsg_Fields structure are listed below. For a complete list of TipcMsg_Fields structure members, see the TipcMsg_Fields Members topic.

Public Static Fields

FT_BINARY | Field Type - an array of uninterpreted bytes
FT_BOOL | Field Type - a 4 byte signed integer
FT_BOOL_ARRAY | Field Type - an array of 4 byte signed integers
FT_BYTE | Field Type - a byte
FT_CHAR | Field Type - a character
FT_GUID | Field Type - a Global Unique Identifier
FT_GUID_ARRAY | Field Type - an array of Global Unique Identifiers
FT_INT2 | Field Type - a 2 byte signed integer
FT_INT2_ARRAY | Field Type - an array of 2 byte signed integers
FT_INT4 | Field Type - a 4 byte signed integer
FT_INT4_ARRAY | Field Type - an array of 4 bytes signed integers
FT_INT8 | Field Type - an 8 byte signed integer
FT_INT8_ARRAY | Field Type - an array of 8 byte signed integers
FT_INVALID | Field Type - marker for an invalid field
FT_MSG | Field Type - an embedded TipcMsg
FT_MSG_ARRAY | Field Type - an array of embedded TipcMsg's
FT_MSGID | Field Type - a globally unique message identifiers
FT_MSGID_ARRAY | Field Type - an array of globally unique message identifiers
FT_REAL16 | Field Type - a 16 byte real (unsupported by .NET)
FT_REAL16_ARRAY | Field Type - an array of 16 byte reals (unsupported by .NET)
FT_REAL4 | Field Type - a 4 byte real
FT_REAL4_ARRAY | Field Type - an array of 4 byte reals
FT_REAL8 | Field Type - an 8 byte real
FT_REAL8_ARRAY | Field Type - an array of 8 byte reals
FT_STR | Field Type - a string
FT_STR_ARRAY | Field Type - an array of strings
FT_TIMESTAMP | Field Type - timestamp
FT_TIMESTAMP_ARRAY | Field Type - an array of timestamps
FT_UTF8 | Field Type - a UTF-8 encoded string
FT_UTF8_ARRAY | Field Type - an array of UTF-8 encoded strings
FT_XML | Field Type - a TutXml
PROP_APP_STR | Property - project (application)
PROP_ARRIVAL_TIMESTAMP_NUM | Property - arrival timestamp
PROP_CORRELATION_ID_STR | Property - message correlation identifier
PROP_DEST_CLIENT_NAME_ARRAY | Property - destination client name array
PROP_DEST_CLIENT_NUM_ARRAY | Property - destination client number array
PROP_DEST_CLIENT_STR_ARRAY | Property - destination client array
PROP_DEST_SERVER_NAME_ARRAY | Property - destination server name array
PROP_DEST_SERVER_NUM_ARRAY | Property - destination server number array
PROP_DEST_SERVER_STR_ARRAY | Property - destination server array
PROP_DEST_STR | Property - destination
PROP_EXPIRATION_NUM | Property - message expiration
PROP_FIELD_INDEX_ARRAY | Property - field index array
PROP_FIELD_NAME_ARRAY | Property - field name array
PROP_GROUP_DEST_ID_NUM_ARRAY | Property - group destination identifer array
PROP_GROUP_SENDER_ID_NUM | Property - group sender identifier
PROP_LB_MODE_NUM | Property - load balancing mode
PROP_LOCAL_DELIVERY | Property - local delivery
PROP_MESSAGE_ID_STR | Property - message identifier
PROP_REPLY_TO_DEST_STR | Property - reply to destination
PROP_RTSERVER_NAME_ARRAY | Property - RTserver name array
PROP_RTSERVER_NUM_ARRAY | Property - RTserver number array
PROP_SCOPE_NAME_ARRAY | Property - scope name array
PROP_SCOPE_NUM_ARRAY | Property - scope number array
PROP_SCOPE_STR_ARRAY | Property - scope array
PROP_SENDER_SERVER_STR | Property - sender server
PROP_SENDER_STR | Property - sender
PROP_SENDER_TIMESTAMP_NUM | Property - sender timestamp
PROP_SOD_SID_GUID | Property - arrival timestamp
PROP_SQ_1 | Property - SmartQueue 1
PROP_SQ_2 | Property - SmartQueue 2
PROP_SQ_3 | Property - SmartQueue 3
PROP_SQ_4 | Property - SmartQueue 4
PROP_SQ_START | Property - SmartQueue start
PROP_TMP_DELIVERY_TIMEOUT | Property - delivery timeout
PROP_UNUSED | Property - unused

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_BINARY Field

Field Type - an array of uninterpreted bytes

public const int FT_BINARY = 2;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_BOOL Field

Field Type - a 4 byte signed integer

public const int FT_BOOL = 75;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_BOOL_ARRAY Field

Field Type - an array of 4 byte signed integers

public const int FT_BOOL_ARRAY = 76;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_BYTE Field

Field Type - a byte

public const int FT_BYTE = 77;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_CHAR Field

Field Type - a character

public const int FT_CHAR = 1;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_GUID Field

Field Type - a Global Unique Identifier

public const int FT_GUID = 64;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_GUID_ARRAY Field

Field Type - an array of Global Unique Identifiers

public const int FT_GUID_ARRAY = 65;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_INT2 Field

Field Type - a 2 byte signed integer

public const int FT_INT2 = 5;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_INT2_ARRAY Field

Field Type - an array of 2 byte signed integers

public const int FT_INT2_ARRAY = 6;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_INT4 Field

Field Type - a 4 byte signed integer

public const int FT_INT4 = 7;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_INT4_ARRAY Field

Field Type - an array of 4 bytes signed integers

public const int FT_INT4_ARRAY = 8;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_INT8 Field

Field Type - an 8 byte signed integer

public const int FT_INT8 = 9;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_INT8_ARRAY Field

Field Type - an array of 8 byte signed integers

public const int FT_INT8_ARRAY = 10;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_INVALID Field

Field Type - marker for an invalid field

public const int FT_INVALID = 0;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_MSG Field

Field Type - an embedded TipcMsg

public const int FT_MSG = 17;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_MSG_ARRAY Field

Field Type - an array of embedded TipcMsg's

public const int FT_MSG_ARRAY = 18;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_MSGID Field

Field Type - a globally unique message identifiers

public const int FT_MSGID = 66;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_MSGID_ARRAY Field

Field Type - an array of globally unique message identifiers

public const int FT_MSGID_ARRAY = 67;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_REAL16 Field

Field Type - a 16 byte real (unsupported by .NET)

public const int FT_REAL16 = 15;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_REAL16_ARRAY Field

Field Type - an array of 16 byte reals (unsupported by .NET)

public const int FT_REAL16_ARRAY = 16;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_REAL4 Field

Field Type - a 4 byte real

public const int FT_REAL4 = 11;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_REAL4_ARRAY Field

Field Type - an array of 4 byte reals

public const int FT_REAL4_ARRAY = 12;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_REAL8 Field

Field Type - an 8 byte real

public const int FT_REAL8 = 13;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_REAL8_ARRAY Field

Field Type - an array of 8 byte reals

public const int FT_REAL8_ARRAY = 14;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_STR Field

Field Type - a string

public const int FT_STR = 3;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_STR_ARRAY Field

Field Type - an array of strings

public const int FT_STR_ARRAY = 4;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_TIMESTAMP Field

Field Type - timestamp

public const int FT_TIMESTAMP = 71;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_TIMESTAMP_ARRAY Field

Field Type - an array of timestamps

public const int FT_TIMESTAMP_ARRAY = 72;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_UTF8 Field

Field Type - a UTF-8 encoded string

public const int FT_UTF8 = 73;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_UTF8_ARRAY Field

Field Type - an array of UTF-8 encoded strings

public const int FT_UTF8_ARRAY = 74;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.FT_XML Field

Field Type - a TutXml

public const int FT_XML = 70;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_APP_STR Field

Property - project (application)

public const int PROP_APP_STR = -114;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_ARRIVAL_TIMESTAMP_NUM Field

Property - arrival timestamp

public const int PROP_ARRIVAL_TIMESTAMP_NUM = -100;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_CORRELATION_ID_STR Field

Property - message correlation identifier

public const int PROP_CORRELATION_ID_STR = -104;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_DEST_CLIENT_NAME_ARRAY Field

Property - destination client name array

public const int PROP_DEST_CLIENT_NAME_ARRAY = -120;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_DEST_CLIENT_NUM_ARRAY Field

Property - destination client number array

public const int PROP_DEST_CLIENT_NUM_ARRAY = -121;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_DEST_CLIENT_STR_ARRAY Field

Property - destination client array

public const int PROP_DEST_CLIENT_STR_ARRAY = -111;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_DEST_SERVER_NAME_ARRAY Field

Property - destination server name array

public const int PROP_DEST_SERVER_NAME_ARRAY = -124;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_DEST_SERVER_NUM_ARRAY Field

Property - destination server number array

public const int PROP_DEST_SERVER_NUM_ARRAY = -125;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_DEST_SERVER_STR_ARRAY Field

Property - destination server array

public const int PROP_DEST_SERVER_STR_ARRAY = -113;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_DEST_STR Field

Property - destination

public const int PROP_DEST_STR = -115;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_EXPIRATION_NUM Field

Property - message expiration

public const int PROP_EXPIRATION_NUM = -102;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_FIELD_INDEX_ARRAY Field

Property - field index array

public const int PROP_FIELD_INDEX_ARRAY = -108;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_FIELD_NAME_ARRAY Field

Property - field name array

public const int PROP_FIELD_NAME_ARRAY = -109;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_GROUP_DEST_ID_NUM_ARRAY Field

Property - group destination identifer array

public const int PROP_GROUP_DEST_ID_NUM_ARRAY = -106;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_GROUP_SENDER_ID_NUM Field

Property - group sender identifier

public const int PROP_GROUP_SENDER_ID_NUM = -107;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_LB_MODE_NUM Field

Property - load balancing mode

public const int PROP_LB_MODE_NUM = -119;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_LOCAL_DELIVERY Field

Property - local delivery

public const int PROP_LOCAL_DELIVERY = -110;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_MESSAGE_ID_STR Field

Property - message identifier

public const int PROP_MESSAGE_ID_STR = -105;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_REPLY_TO_DEST_STR Field

Property - reply to destination

public const int PROP_REPLY_TO_DEST_STR = -103;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_RTSERVER_NAME_ARRAY Field

Property - RTserver name array

public const int PROP_RTSERVER_NAME_ARRAY = -126;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_RTSERVER_NUM_ARRAY Field

Property - RTserver number array

public const int PROP_RTSERVER_NUM_ARRAY = -127;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_SCOPE_NAME_ARRAY Field

Property - scope name array

public const int PROP_SCOPE_NAME_ARRAY = -122;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_SCOPE_NUM_ARRAY Field

Property - scope number array

public const int PROP_SCOPE_NUM_ARRAY = -123;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_SCOPE_STR_ARRAY Field

Property - scope array

public const int PROP_SCOPE_STR_ARRAY = -112;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_SENDER_SERVER_STR Field

Property - sender server

public const int PROP_SENDER_SERVER_STR = -116;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_SENDER_STR Field

Property - sender

public const int PROP_SENDER_STR = -117;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_SENDER_TIMESTAMP_NUM Field

Property - sender timestamp

public const int PROP_SENDER_TIMESTAMP_NUM = -101;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_SOD_SID_GUID Field

Property - arrival timestamp

public const int PROP_SOD_SID_GUID = -99;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_SQ_1 Field

Property - SmartQueue 1

public const int PROP_SQ_1 = -4;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_SQ_2 Field

Property - SmartQueue 2

public const int PROP_SQ_2 = -3;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_SQ_3 Field

Property - SmartQueue 3

public const int PROP_SQ_3 = -2;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_SQ_4 Field

Property - SmartQueue 4

public const int PROP_SQ_4 = -1;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_SQ_START Field

Property - SmartQueue start

public const int PROP_SQ_START = -4;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_TMP_DELIVERY_TIMEOUT Field

Property - delivery timeout

public const int PROP_TMP_DELIVERY_TIMEOUT = -118;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsg_Fields.PROP_UNUSED Field

Property - unused

public const int PROP_UNUSED = -128;

See Also

TipcMsg_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgBadFieldException Class

Thrown when attempting to access a TipcMsg field using the incorrect type.

For a list of all members of this type, see TipcMsgBadFieldException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcMsgException
TIBCO.SMARTSOCKETS.TipcMsgBadFieldException

public class TipcMsgBadFieldException : TipcMsgException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMsgBadFieldException Members | TIBCO.SMARTSOCKETS Namespace


TipcMsgBadFieldException Members

TipcMsgBadFieldException overview

Public Instance Constructors

TipcMsgBadFieldException Overloaded. Initializes a new instance of the TipcMsgBadFieldException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMsgBadFieldException Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgBadFieldException Constructor

Constructs a TipcMsgBadFieldException with null as its error message string.

Overload List

Constructs a TipcMsgBadFieldException with null as its error message string.

public TipcMsgBadFieldException();

Constructs a TipcMsgBadFieldException with an error message.

public TipcMsgBadFieldException(string);

See Also

TipcMsgBadFieldException Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgBadFieldException Constructor ()

Constructs a TipcMsgBadFieldException with null as its error message string.

public TipcMsgBadFieldException();

See Also

TipcMsgBadFieldException Class | TIBCO.SMARTSOCKETS Namespace | TipcMsgBadFieldException Constructor Overload List


TipcMsgBadFieldException Constructor (String)

Constructs a TipcMsgBadFieldException with an error message.

public TipcMsgBadFieldException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcMsgBadFieldException Class | TIBCO.SMARTSOCKETS Namespace | TipcMsgBadFieldException Constructor Overload List


TipcMsgEnumerator Class

A helper class that implements the Enumeration interface and returns TipcMsgEnumeratorElement when the nextElement method is invoked.

For a list of all members of this type, see TipcMsgEnumerator Members.

System.Object
TIBCO.SMARTSOCKETS.TipcMsgEnumerator

public class TipcMsgEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMsgEnumerator Members | TIBCO.SMARTSOCKETS Namespace


TipcMsgEnumerator Members

TipcMsgEnumerator overview

Public Instance Properties

Current Returns current element.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
hasMoreElements | Returns true if there are more fields in message.
MoveNext | Move to next element.
nextElement | Returns next element in message.
Reset | Reset
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMsgEnumerator Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgEnumerator Properties

The properties of the TipcMsgEnumerator class are listed below. For a complete list of TipcMsgEnumerator class members, see the TipcMsgEnumerator Members topic.

Public Instance Properties

Current Returns current element.

See Also

TipcMsgEnumerator Class | TIBCO.SMARTSOCKETS Namespace


Current Property

SmartSockets .NET Class Library

TipcMsgEnumerator.Current Property

Returns current element.

public virtual object Current {get;}

Implements

IEnumerator.Current

See Also

TipcMsgEnumerator Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgEnumerator Methods

The methods of the TipcMsgEnumerator class are listed below. For a complete list of TipcMsgEnumerator class members, see the TipcMsgEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
hasMoreElements | Returns true if there are more fields in message.
MoveNext | Move to next element.
nextElement | Returns next element in message.
Reset | Reset
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMsgEnumerator Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgEnumerator.hasMoreElements Method

Returns true if there are more fields in message.

public virtual bool hasMoreElements();

See Also

TipcMsgEnumerator Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgEnumerator.MoveNext Method

Move to next element.

public virtual bool MoveNext();

Implements

IEnumerator.MoveNext

See Also

TipcMsgEnumerator Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgEnumerator.nextElement Method

Returns next element in message.

public virtual object nextElement();

See Also

TipcMsgEnumerator Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgEnumerator.Reset Method

Reset

public virtual void Reset();

Implements

IEnumerator.Reset

See Also

TipcMsgEnumerator Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgEnumeratorElement Class

This is the Object that is returned when nextElement is invoked. This object can then be used to retrieve the appropriate field based on type.

TipcMsg msg = null;
char c = 'a';
short short_value = 10;
TipcMsgEnumerator msgEnumerator = null;
try {
  msg = TipcSvc.createMsg(TipcMt_Fields.INFO);
  msg.appendChar(c);
  msg.appendUnknown(TipcMsg_Fields.FT_INT4);
  msg.appendInt2(short_value);
  msg.addNamedStr("test str name", "test str value");

  msgEnumerator = msg.Enumerator;

  TipcMsgEnumeratorElement enum_element = null;
  while(msgEnumerator.hasMoreElements()) {
    enum_element = (TipcMsgEnumeratorElement)msgEnumerator.nextElement();

    System.out.println("index = " + enum_element.Index);
    System.out.println("isNamed = " + enum_element.Named);
    if (enum_element.Named) {
      System.out.println("Named field's name = " + enum_element.Name);
    }
    if (enum_element.Type == TipcMsg_Fields.FT_CHAR) {
      System.out.println("CHAR VALUE = " + enum_element.Char);
    }
    if (enum_element.Type == TipcMsg_Fields.FT_INT2) {
      System.out.println("INT2 VALUE = " + enum_element.Int2);
    }
    if (enum_element.Type == TipcMsg_Fields.FT_STR) {
      System.out.println("STR VALUE = " + enum_element.Str);
    }
  }
}  catch (TipcException e) { System.out.println(e.Message); }

For a list of all members of this type, see TipcMsgEnumeratorElement Members.

System.Object
TIBCO.SMARTSOCKETS.TipcMsgEnumeratorElement

public class TipcMsgEnumeratorElement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMsgEnumeratorElement Members | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


TipcMsgEnumeratorElement Members

TipcMsgEnumeratorElement overview

Public Instance Properties

Binary | If the Enumerator element is of type FT_BINARY then the binary value is returned or else an exception is thrown
Bool | If the Enumerator element is of type FT_BOOL then the bool value is returned or else an exception is thrown
BoolArray | If the Enumerator element is of type FT_BOOL_ARRAY then the bool_array value is returned or else an exception is thrown
Byte | If the Enumerator element is of type FT_BYTE then the byte value is returned or else an exception is thrown
Char | If the Enumerator element is of type FT_CHAR then the char value is returned or else an exception is thrown
Guid | If the Enumerator element is of type FT_GUID then the guid value is returned or else an exception is thrown
GuidArray | If the Enumerator element is of type FT_GUID_ARRAY then the guid_array value is returned or else an exception is thrown
Index | Returns the index of the EnumeratorElement, which is actually the index of the element within the message
Int2 | If the Enumerator element is of type FT_INT2 then the int2 value is returned or else an exception is thrown
Int2Array | If the Enumerator element is of type FT_INT2_ARRAY then the int2_array value is returned or else an exception is thrown
Int4 | If the Enumerator element is of type FT_INT4 then the int4 value is returned or else an exception is thrown
Int4Array | If the Enumerator element is of type FT_INT4_ARRAY then the int4 array value is returned or else an exception is thrown
Int8 | If the Enumerator element is of type FT_INT8 then the int8 value is returned or else an exception is thrown
Int8Array | If the Enumerator element is of type FT_INT8_ARRAY then the int8_array value is returned or else an exception is thrown
Msg | If the Enumerator element is of type FT_MSG then the msg value is returned or else an exception is thrown
MsgArray | If the Enumerator element is of type FT_MSG_ARRAY then the msg_array value is returned or else an exception is thrown
MsgId | If the Enumerator element is of type FT_MSGID then the msgid value is returned or else an exception is thrown
MsgIdArray | If the Enumerator element is of type FT_MSGID_ARRAY then the msgid array value is returned or else an exception is thrown
Name | Returns the name of the EnumeratorElement, if the element is a named field If the field is not a named field then this method returns null.
Named | Returns true if the EnumeratorElement is a named field type, false otherwise.
Real4 | If the Enumerator element is of type FT_REAL4 then the real4 value is returned or else an exception is thrown
Real4Array | If the Enumerator element is of type FT_REAL4_ARRAY then the real4_array value is returned or else an exception is thrown
Real8 | If the Enumerator element is of type FT_REAL8 then the real8 value is returned or else an exception is thrown
Real8Array | If the Enumerator element is of type FT_REAL8_ARRAY then the real8_array value is returned or else an exception is thrown
Str | If the Enumerator element is of type FT_STR then the str value is returned or else an exception is thrown
StrArray | If the Enumerator element is of type FT_STR_ARRAY then the str_array value is returned or else an exception is thrown
Timestamp | If the Enumerator element is of type FT_TIMESTAMP then the timestamp value is returned or else an exception is thrown
TimestampArray | If the Enumerator element is of type FT_TIMESTAMP_ARRAY then the timestamp array value is returned or else an exception is thrown
Type | Returns the type of the EnumeratorElement, which is actually the field type of the current field within the message
Unknown | Returns true if the EnumeratorElement is of type unknown, false otherwise.
Utf8 | If the Enumerator element is of type FT_UTF8 then the utf8 value is returned or else an exception is thrown
Utf8Array | If the Enumerator element is of type FT_UTF8_ARRAY then the utf8_array value is returned or else an exception is thrown
Xml | If the Enumerator element is of type FT_XML then the xml value is returned or else an exception is thrown

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


TipcMsgEnumeratorElement Properties

The properties of the TipcMsgEnumeratorElement class are listed below. For a complete list of TipcMsgEnumeratorElement class members, see the TipcMsgEnumeratorElement Members topic.

Public Instance Properties

Binary | If the Enumerator element is of type FT_BINARY then the binary value is returned or else an exception is thrown
Bool | If the Enumerator element is of type FT_BOOL then the bool value is returned or else an exception is thrown
BoolArray | If the Enumerator element is of type FT_BOOL_ARRAY then the bool_array value is returned or else an exception is thrown
Byte | If the Enumerator element is of type FT_BYTE then the byte value is returned or else an exception is thrown
Char | If the Enumerator element is of type FT_CHAR then the char value is returned or else an exception is thrown
Guid | If the Enumerator element is of type FT_GUID then the guid value is returned or else an exception is thrown
GuidArray | If the Enumerator element is of type FT_GUID_ARRAY then the guid_array value is returned or else an exception is thrown
Index | Returns the index of the EnumeratorElement, which is actually the index of the element within the message
Int2 | If the Enumerator element is of type FT_INT2 then the int2 value is returned or else an exception is thrown
Int2Array | If the Enumerator element is of type FT_INT2_ARRAY then the int2_array value is returned or else an exception is thrown
Int4 | If the Enumerator element is of type FT_INT4 then the int4 value is returned or else an exception is thrown
Int4Array | If the Enumerator element is of type FT_INT4_ARRAY then the int4 array value is returned or else an exception is thrown
Int8 | If the Enumerator element is of type FT_INT8 then the int8 value is returned or else an exception is thrown
Int8Array | If the Enumerator element is of type FT_INT8_ARRAY then the int8_array value is returned or else an exception is thrown
Msg | If the Enumerator element is of type FT_MSG then the msg value is returned or else an exception is thrown
MsgArray | If the Enumerator element is of type FT_MSG_ARRAY then the msg_array value is returned or else an exception is thrown
MsgId | If the Enumerator element is of type FT_MSGID then the msgid value is returned or else an exception is thrown
MsgIdArray | If the Enumerator element is of type FT_MSGID_ARRAY then the msgid array value is returned or else an exception is thrown
Name | Returns the name of the EnumeratorElement, if the element is a named field If the field is not a named field then this method returns null.
Named | Returns true if the EnumeratorElement is a named field type, false otherwise.
Real4 | If the Enumerator element is of type FT_REAL4 then the real4 value is returned or else an exception is thrown
Real4Array | If the Enumerator element is of type FT_REAL4_ARRAY then the real4_array value is returned or else an exception is thrown
Real8 | If the Enumerator element is of type FT_REAL8 then the real8 value is returned or else an exception is thrown
Real8Array | If the Enumerator element is of type FT_REAL8_ARRAY then the real8_array value is returned or else an exception is thrown
Str | If the Enumerator element is of type FT_STR then the str value is returned or else an exception is thrown
StrArray | If the Enumerator element is of type FT_STR_ARRAY then the str_array value is returned or else an exception is thrown
Timestamp | If the Enumerator element is of type FT_TIMESTAMP then the timestamp value is returned or else an exception is thrown
TimestampArray | If the Enumerator element is of type FT_TIMESTAMP_ARRAY then the timestamp array value is returned or else an exception is thrown
Type | Returns the type of the EnumeratorElement, which is actually the field type of the current field within the message
Unknown | Returns true if the EnumeratorElement is of type unknown, false otherwise.
Utf8 | If the Enumerator element is of type FT_UTF8 then the utf8 value is returned or else an exception is thrown
Utf8Array | If the Enumerator element is of type FT_UTF8_ARRAY then the utf8_array value is returned or else an exception is thrown
Xml | If the Enumerator element is of type FT_XML then the xml value is returned or else an exception is thrown

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Binary Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Binary Property

If the Enumerator element is of type FT_BINARY then the binary value is returned or else an exception is thrown

public virtual sbyte[] Binary {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type binary and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Bool Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Bool Property

If the Enumerator element is of type FT_BOOL then the bool value is returned or else an exception is thrown

public virtual bool Bool {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type bool and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


BoolArray Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.BoolArray Property

If the Enumerator element is of type FT_BOOL_ARRAY then the bool_array value is returned or else an exception is thrown

public virtual bool[] BoolArray {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type bool_array and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Byte Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Byte Property

If the Enumerator element is of type FT_BYTE then the byte value is returned or else an exception is thrown

public virtual sbyte Byte {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type byte and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Char Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Char Property

If the Enumerator element is of type FT_CHAR then the char value is returned or else an exception is thrown

public virtual char Char {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type char and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Guid Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Guid Property

If the Enumerator element is of type FT_GUID then the guid value is returned or else an exception is thrown

public virtual sbyte[] Guid {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type guid and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


GuidArray Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.GuidArray Property

If the Enumerator element is of type FT_GUID_ARRAY then the guid_array value is returned or else an exception is thrown

public virtual sbyte[][] GuidArray {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type guid_array and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Index Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Index Property

Returns the index of the EnumeratorElement, which is actually the index of the element within the message

public virtual int Index {get;}

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace


Int2 Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Int2 Property

If the Enumerator element is of type FT_INT2 then the int2 value is returned or else an exception is thrown

public virtual short Int2 {get;}

Exceptions

Exception Type | Condition
TipcException | if the EnumeratorElement is not of type int2 and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Int2Array Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Int2Array Property

If the Enumerator element is of type FT_INT2_ARRAY then the int2_array value is returned or else an exception is thrown

public virtual short[] Int2Array {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratoeElement is not of type int2_array and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Int4 Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Int4 Property

If the Enumerator element is of type FT_INT4 then the int4 value is returned or else an exception is thrown

public virtual int Int4 {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratoeElement is not of type int4 and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Int4Array Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Int4Array Property

If the Enumerator element is of type FT_INT4_ARRAY then the int4 array value is returned or else an exception is thrown

public virtual int[] Int4Array {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratoeElement is not of type int4_array and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Int8 Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Int8 Property

If the Enumerator element is of type FT_INT8 then the int8 value is returned or else an exception is thrown

public virtual long Int8 {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratoeElement is not of type int8 and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Int8Array Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Int8Array Property

If the Enumerator element is of type FT_INT8_ARRAY then the int8_array value is returned or else an exception is thrown

public virtual long[] Int8Array {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type int8_array and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Msg Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Msg Property

If the Enumerator element is of type FT_MSG then the msg value is returned or else an exception is thrown

public virtual TipcMsg Msg {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type msg and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


MsgArray Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.MsgArray Property

If the Enumerator element is of type FT_MSG_ARRAY then the msg_array value is returned or else an exception is thrown

public virtual TipcMsg[] MsgArray {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type msg_array and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


MsgId Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.MsgId Property

If the Enumerator element is of type FT_MSGID then the msgid value is returned or else an exception is thrown

public virtual sbyte[] MsgId {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type msgid and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


MsgIdArray Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.MsgIdArray Property

If the Enumerator element is of type FT_MSGID_ARRAY then the msgid array value is returned or else an exception is thrown

public virtual sbyte[][] MsgIdArray {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type FT_MSGID_ARRAY and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Name Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Name Property

Returns the name of the EnumeratorElement, if the element is a named field If the field is not a named field then this method returns null.

public virtual string Name {get;}

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace


Named Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Named Property

Returns true if the EnumeratorElement is a named field type, false otherwise.

public virtual bool Named {get;}

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace


Real4 Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Real4 Property

If the Enumerator element is of type FT_REAL4 then the real4 value is returned or else an exception is thrown

public virtual float Real4 {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type real4 and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Real4Array Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Real4Array Property

If the Enumerator element is of type FT_REAL4_ARRAY then the real4_array value is returned or else an exception is thrown

public virtual float[] Real4Array {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type real4_array and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Real8 Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Real8 Property

If the Enumerator element is of type FT_REAL8 then the real8 value is returned or else an exception is thrown

public virtual double Real8 {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type real8 and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Real8Array Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Real8Array Property

If the Enumerator element is of type FT_REAL8_ARRAY then the real8_array value is returned or else an exception is thrown

public virtual double[] Real8Array {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type real8_array and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Str Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Str Property

If the Enumerator element is of type FT_STR then the str value is returned or else an exception is thrown

public virtual string Str {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type str and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


StrArray Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.StrArray Property

If the Enumerator element is of type FT_STR_ARRAY then the str_array value is returned or else an exception is thrown

public virtual string[] StrArray {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type str_array and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Timestamp Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Timestamp Property

If the Enumerator element is of type FT_TIMESTAMP then the timestamp value is returned or else an exception is thrown

public virtual double Timestamp {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type timestamp and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


TimestampArray Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.TimestampArray Property

If the Enumerator element is of type FT_TIMESTAMP_ARRAY then the timestamp array value is returned or else an exception is thrown

public virtual double[] TimestampArray {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type timestamp array and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Type Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Type Property

Returns the type of the EnumeratorElement, which is actually the field type of the current field within the message

public virtual int Type {get;}

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace


Unknown Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Unknown Property

Returns true if the EnumeratorElement is of type unknown, false otherwise.

public virtual bool Unknown {get;}

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace


Utf8 Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Utf8 Property

If the Enumerator element is of type FT_UTF8 then the utf8 value is returned or else an exception is thrown

public virtual string Utf8 {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type utf8 and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Utf8Array Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Utf8Array Property

If the Enumerator element is of type FT_UTF8_ARRAY then the utf8_array value is returned or else an exception is thrown

public virtual string[] Utf8Array {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type utf8_array value and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


Xml Property

SmartSockets .NET Class Library

TipcMsgEnumeratorElement.Xml Property

If the Enumerator element is of type FT_XML then the xml value is returned or else an exception is thrown

public virtual TutXml Xml {get;}

Exceptions

Exception Type | Condition
TipcException | If the EnumeratorElement is not of type xml and an attempt is being made to retrieve a field of this type.

See Also

TipcMsgEnumeratorElement Class | TIBCO.SMARTSOCKETS Namespace | TipcMsg_Fields


TipcMsgEomException Class

Thrown when attempting to read past the end of a TipcMsg.

For a list of all members of this type, see TipcMsgEomException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcMsgException
TIBCO.SMARTSOCKETS.TipcMsgEomException

public class TipcMsgEomException : TipcMsgException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMsgEomException Members | TIBCO.SMARTSOCKETS Namespace


TipcMsgEomException Members

TipcMsgEomException overview

Public Instance Constructors

TipcMsgEomException Overloaded. Initializes a new instance of the TipcMsgEomException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMsgEomException Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgEomException Constructor

Constructs a TipcMsgEomException with null as its error message string.

Overload List

Constructs a TipcMsgEomException with null as its error message string.

public TipcMsgEomException();

Constructs a TipcMsgEomException with an error message.

public TipcMsgEomException(string);

See Also

TipcMsgEomException Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgEomException Constructor ()

Constructs a TipcMsgEomException with null as its error message string.

public TipcMsgEomException();

See Also

TipcMsgEomException Class | TIBCO.SMARTSOCKETS Namespace | TipcMsgEomException Constructor Overload List


TipcMsgEomException Constructor (String)

Constructs a TipcMsgEomException with an error message.

public TipcMsgEomException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcMsgEomException Class | TIBCO.SMARTSOCKETS Namespace | TipcMsgEomException Constructor Overload List


TipcMsgEventArgs Class

This class contains event data for the TipcMsgEvent.

For a list of all members of this type, see TipcMsgEventArgs Members.

System.Object
System.EventArgs
TIBCO.SMARTSOCKETS.TipcMsgEventArgs

public class TipcMsgEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMsgEventArgs Members | TIBCO.SMARTSOCKETS Namespace


TipcMsgEventArgs Members

TipcMsgEventArgs overview

Public Instance Properties

Msg Retrieves the TipcMsg from the event arg object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMsgEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgEventArgs Properties

The properties of the TipcMsgEventArgs class are listed below. For a complete list of TipcMsgEventArgs class members, see the TipcMsgEventArgs Members topic.

Public Instance Properties

Msg Retrieves the TipcMsg from the event arg object.

See Also

TipcMsgEventArgs Class | TIBCO.SMARTSOCKETS Namespace


Msg Property

SmartSockets .NET Class Library

TipcMsgEventArgs.Msg Property

Retrieves the TipcMsg from the event arg object.

public TipcMsg Msg {get;}

See Also

TipcMsgEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgException Class

Thrown when an error occurs parsing a TipcMsg.

For a list of all members of this type, see TipcMsgException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcMsgException
TIBCO.SMARTSOCKETS.TipcMsgBadFieldException
TIBCO.SMARTSOCKETS.TipcMsgEomException
TIBCO.SMARTSOCKETS.TipcMsgUnknownFieldException

public class TipcMsgException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMsgException Members | TIBCO.SMARTSOCKETS Namespace


TipcMsgException Members

TipcMsgException overview

Public Instance Constructors

TipcMsgException Overloaded. Initializes a new instance of the TipcMsgException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMsgException Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgException Constructor

Constructs a TipcMsgException with null as its error message string.

Overload List

Constructs a TipcMsgException with null as its error message string.

public TipcMsgException();

Constructs a TipcMsgException with an error message.

public TipcMsgException(string);

See Also

TipcMsgException Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgException Constructor ()

Constructs a TipcMsgException with null as its error message string.

public TipcMsgException();

See Also

TipcMsgException Class | TIBCO.SMARTSOCKETS Namespace | TipcMsgException Constructor Overload List


TipcMsgException Constructor (String)

Constructs a TipcMsgException with an error message.

public TipcMsgException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcMsgException Class | TIBCO.SMARTSOCKETS Namespace | TipcMsgException Constructor Overload List


TipcMsgHandler Delegate

Represents the method that will handle the TipcMsgEvent event.

public delegate void TipcMsgHandler(
object sender,
TipcMsgEventArgs e
);

Parameters

sender
The source of the event.
e
The TipcMsgEventArgs that contains the event data.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TIBCO.SMARTSOCKETS Namespace


TipcMsgUnknownFieldException Class

Thrown during an attempt to read a TipcMsg field that is marked as "unknown".

For a list of all members of this type, see TipcMsgUnknownFieldException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcMsgException
TIBCO.SMARTSOCKETS.TipcMsgUnknownFieldException

public class TipcMsgUnknownFieldException : TipcMsgException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMsgUnknownFieldException Members | TIBCO.SMARTSOCKETS Namespace


TipcMsgUnknownFieldException Members

TipcMsgUnknownFieldException overview

Public Instance Constructors

TipcMsgUnknownFieldException Overloaded. Initializes a new instance of the TipcMsgUnknownFieldException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMsgUnknownFieldException Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgUnknownFieldException Constructor

Constructs a TipcMsgUnknownFieldException with null as its error message string.

Overload List

Constructs a TipcMsgUnknownFieldException with null as its error message string.

public TipcMsgUnknownFieldException();

Constructs a TipcMsgUnknownFieldException with an error message.

public TipcMsgUnknownFieldException(string);

See Also

TipcMsgUnknownFieldException Class | TIBCO.SMARTSOCKETS Namespace


TipcMsgUnknownFieldException Constructor ()

Constructs a TipcMsgUnknownFieldException with null as its error message string.

public TipcMsgUnknownFieldException();

See Also

TipcMsgUnknownFieldException Class | TIBCO.SMARTSOCKETS Namespace | TipcMsgUnknownFieldException Constructor Overload List


TipcMsgUnknownFieldException Constructor (String)

Constructs a TipcMsgUnknownFieldException with an error message.

public TipcMsgUnknownFieldException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcMsgUnknownFieldException Class | TIBCO.SMARTSOCKETS Namespace | TipcMsgUnknownFieldException Constructor Overload List


TipcMt Class

Provides access to the message type class.

This interface is used by TipcMt objects returned from the TipcSvc factory class to createMt user-defined message types and to lookupMt both user-defined messages types and standard SmartSockets message types.

The identifiers for the standard SmartSockets message types are contained in the TipcMt_Fields structure.

Note: All user-defined message type numbers must be greater than zero. All SmartSockets-defined message type numbers are less than zero. Zero is not a valid message type number.

For a list of all members of this type, see TipcMt Members.

System.Object
TIBCO.SMARTSOCKETS.TipcMt

public class TipcMt

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMt Members | TIBCO.SMARTSOCKETS Namespace


TipcMt Members

TipcMt overview

Public Instance Properties

Compression | Gets/Sets the compression property of a message type. Compression is enabled when true and disabled when false.
DeliveryMode | Gets/Sets the delivery mode of a message type. The delivery mode of a message type is used as the default delivery mode for messages of this type. When a message is created, its delivery mode is initialized to the message type delivery mode. The default message type delivery mode is DELIVERY_BEST_EFFORT. In this mode, no special actions are taken to ensure delivery of sent messages. The message is delivered unless network failures or process failures occur. If the message is not delivered, there is no way for the sender to know that the delivery failed. In the case of a network or process failure, a more useful delivery mode is DELIVERY_ORDERED. Messages can still be lost in the event of a failure, but all delivered messages are received in the order in which they were published. Another delivery mode is DELIVERY_SOME. In this mode, the sending process saves a copy of the message until the message is successfully delivered, and the sender can also resend the message if necessary. Delivery is considered successful if the sent message is acknowledged by at least one receiving process. The most robust delivery mode is DELIVERY_ALL. In this mode, the sending process saves a copy of the message until the message is successfully delivered, and the sender can also resend the message if necessary. Delivery is not considered successful until all receiving processes acknowledge the sent message. The delivery mode of an outgoing message can always be set on a per-message basis, but using the message type delivery modes makes it easier to change the default delivery mode mode for all outgoing messages of a specific type. The standard Smartsockets message type by default all have a delivery mode of DELIVERY_BEST_EFFORT, but these can be changed if desired. User-defined message types can also use whatever delivery mode is appropriate.
DeliveryTimeout | Gets/Sets the delivery timeout of a message type. The delivery timeout of a message controls how long to wait for guaranteed message delivery to complete when a message is sent through a connection. The delivery timeout of a message type is used as the default delivery timeout for messages of this type. When a message is created, its delivery timeout is initialized to the message type delivery timeout. The delivery timeout of an outgoing message can always be set on a per-message basis, but using the message type delivery timtout makes it easier to change the default delivery timeout for all outgoing message of a specific type. The standard SmartSockets message types by default all have a delivery timeout of unknown, but these can be changed. User-defined message types can also use whatever delivery timeout is appropriate
Grammar | Gets the grammar of a message type. Message types grammars are lists of field types and are used to write message to message files in a compact format.
LbMode | Gets/Set the load balancing mode of a message type. The load balancing mode of a message controls how (or if) the message is load balanced among RTclients subscribed to a load balanced subject. The load balancing mode of a message type is used as the default load balancing mode for message of this type. When a message is created, its load balancing mode is initialized to the message type load balancing mode. Valid load balancing modes: LB_NONE, LB_ROUND_ROBIN, LB_SORTED, and LB_WEIGHTED The load balancing mode of an outgoing message can always be set on a per-message basis, but using message type load balancing mode makes it easier to change the default load balancing mode for all ougoing messages of a specific type. The standard SmartSockets message types by default all have a load balancing mode of LB_NONE
LocalDelivery | Gets/Sets the local delivery property of a message type.
Name | Gets the name of a message type.
Num | Returns the number of a message type.
Priority | Gets/Sets the priority of a message type. The priority of a message type, if set, is used as the default priority of for messages of this type. The message type priority can either be set to a specific value or it can be unknown. When a message is created, its priority is initialized to the message type priority (if set) or to the value of the option Default_Msg_Priority (if the message type priority is unknown). The priority of an outgoing message can always be set on a per-message basis, but using message type priorities makes it easier to raise or lower the default priority for all outgoing messages of a specific type. The standard SmartSockets message types by default all have a priority of unknown, but these can be changed. User-defined message types can also use whatever priority is appropriate. When a message type is first created, its priority is initialized to unknown.
UserProp | Gets/Sets the user-defined property of a message type.

Public Instance Methods

destroy | Destroy a message type.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
setPriorityUnknown | Set priority of a message to unknown.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace


TipcMt Properties

The properties of the TipcMt class are listed below. For a complete list of TipcMt class members, see the TipcMt Members topic.

Public Instance Properties

Compression | Gets/Sets the compression property of a message type. Compression is enabled when true and disabled when false.
DeliveryMode | Gets/Sets the delivery mode of a message type. The delivery mode of a message type is used as the default delivery mode for messages of this type. When a message is created, its delivery mode is initialized to the message type delivery mode. The default message type delivery mode is DELIVERY_BEST_EFFORT. In this mode, no special actions are taken to ensure delivery of sent messages. The message is delivered unless network failures or process failures occur. If the message is not delivered, there is no way for the sender to know that the delivery failed. In the case of a network or process failure, a more useful delivery mode is DELIVERY_ORDERED. Messages can still be lost in the event of a failure, but all delivered messages are received in the order in which they were published. Another delivery mode is DELIVERY_SOME. In this mode, the sending process saves a copy of the message until the message is successfully delivered, and the sender can also resend the message if necessary. Delivery is considered successful if the sent message is acknowledged by at least one receiving process. The most robust delivery mode is DELIVERY_ALL. In this mode, the sending process saves a copy of the message until the message is successfully delivered, and the sender can also resend the message if necessary. Delivery is not considered successful until all receiving processes acknowledge the sent message. The delivery mode of an outgoing message can always be set on a per-message basis, but using the message type delivery modes makes it easier to change the default delivery mode mode for all outgoing messages of a specific type. The standard Smartsockets message type by default all have a delivery mode of DELIVERY_BEST_EFFORT, but these can be changed if desired. User-defined message types can also use whatever delivery mode is appropriate.
DeliveryTimeout | Gets/Sets the delivery timeout of a message type. The delivery timeout of a message controls how long to wait for guaranteed message delivery to complete when a message is sent through a connection. The delivery timeout of a message type is used as the default delivery timeout for messages of this type. When a message is created, its delivery timeout is initialized to the message type delivery timeout. The delivery timeout of an outgoing message can always be set on a per-message basis, but using the message type delivery timtout makes it easier to change the default delivery timeout for all outgoing message of a specific type. The standard SmartSockets message types by default all have a delivery timeout of unknown, but these can be changed. User-defined message types can also use whatever delivery timeout is appropriate
Grammar | Gets the grammar of a message type. Message types grammars are lists of field types and are used to write message to message files in a compact format.
LbMode | Gets/Set the load balancing mode of a message type. The load balancing mode of a message controls how (or if) the message is load balanced among RTclients subscribed to a load balanced subject. The load balancing mode of a message type is used as the default load balancing mode for message of this type. When a message is created, its load balancing mode is initialized to the message type load balancing mode. Valid load balancing modes: LB_NONE, LB_ROUND_ROBIN, LB_SORTED, and LB_WEIGHTED The load balancing mode of an outgoing message can always be set on a per-message basis, but using message type load balancing mode makes it easier to change the default load balancing mode for all ougoing messages of a specific type. The standard SmartSockets message types by default all have a load balancing mode of LB_NONE
LocalDelivery | Gets/Sets the local delivery property of a message type.
Name | Gets the name of a message type.
Num | Returns the number of a message type.
Priority | Gets/Sets the priority of a message type. The priority of a message type, if set, is used as the default priority of for messages of this type. The message type priority can either be set to a specific value or it can be unknown. When a message is created, its priority is initialized to the message type priority (if set) or to the value of the option Default_Msg_Priority (if the message type priority is unknown). The priority of an outgoing message can always be set on a per-message basis, but using message type priorities makes it easier to raise or lower the default priority for all outgoing messages of a specific type. The standard SmartSockets message types by default all have a priority of unknown, but these can be changed. User-defined message types can also use whatever priority is appropriate. When a message type is first created, its priority is initialized to unknown.
UserProp | Gets/Sets the user-defined property of a message type.

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace


Compression Property

SmartSockets .NET Class Library

TipcMt.Compression Property

Gets/Sets the compression property of a message type.

Compression is enabled when true and disabled when false.

public virtual bool Compression {get; set;}

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace


DeliveryMode Property

SmartSockets .NET Class Library

TipcMt.DeliveryMode Property

Gets/Sets the delivery mode of a message type.

The delivery mode of a message type is used as the default delivery mode for messages of this type. When a message is created, its delivery mode is initialized to the message type delivery mode.

The default message type delivery mode is DELIVERY_BEST_EFFORT. In this mode, no special actions are taken to ensure delivery of sent messages. The message is delivered unless network failures or process failures occur. If the message is not delivered, there is no way for the sender to know that the delivery failed.

In the case of a network or process failure, a more useful delivery mode is DELIVERY_ORDERED. Messages can still be lost in the event of a failure, but all delivered messages are received in the order in which they were published.

Another delivery mode is DELIVERY_SOME. In this mode, the sending process saves a copy of the message until the message is successfully delivered, and the sender can also resend the message if necessary. Delivery is considered successful if the sent message is acknowledged by at least one receiving process.

The most robust delivery mode is DELIVERY_ALL. In this mode, the sending process saves a copy of the message until the message is successfully delivered, and the sender can also resend the message if necessary. Delivery is not considered successful until all receiving processes acknowledge the sent message.

The delivery mode of an outgoing message can always be set on a per-message basis, but using the message type delivery modes makes it easier to change the default delivery mode mode for all outgoing messages of a specific type. The standard Smartsockets message type by default all have a delivery mode of DELIVERY_BEST_EFFORT, but these can be changed if desired. User-defined message types can also use whatever delivery mode is appropriate.

public virtual int DeliveryMode {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | Invalid Delivery Mode specified.

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace | |


DeliveryTimeout Property

SmartSockets .NET Class Library

TipcMt.DeliveryTimeout Property

Gets/Sets the delivery timeout of a message type.

The delivery timeout of a message controls how long to wait for guaranteed message delivery to complete when a message is sent through a connection. The delivery timeout of a message type is used as the default delivery timeout for messages of this type. When a message is created, its delivery timeout is initialized to the message type delivery timeout.

The delivery timeout of an outgoing message can always be set on a per-message basis, but using the message type delivery timtout makes it easier to change the default delivery timeout for all outgoing message of a specific type. The standard SmartSockets message types by default all have a delivery timeout of unknown, but these can be changed. User-defined message types can also use whatever delivery timeout is appropriate

public virtual double DeliveryTimeout {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If delivery timeout is negative.

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace | DeliveryMode | DeliveryTimeout


Grammar Property

SmartSockets .NET Class Library

TipcMt.Grammar Property

Gets the grammar of a message type.

Message types grammars are lists of field types and are used to write message to message files in a compact format.

public virtual string Grammar {get;}

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace


LbMode Property

SmartSockets .NET Class Library

TipcMt.LbMode Property

Gets/Set the load balancing mode of a message type.

The load balancing mode of a message controls how (or if) the message is load balanced among RTclients subscribed to a load balanced subject. The load balancing mode of a message type is used as the default load balancing mode for message of this type. When a message is created, its load balancing mode is initialized to the message type load balancing mode.

Valid load balancing modes: LB_NONE, LB_ROUND_ROBIN, LB_SORTED, and LB_WEIGHTED

The load balancing mode of an outgoing message can always be set on a per-message basis, but using message type load balancing mode makes it easier to change the default load balancing mode for all ougoing messages of a specific type. The standard SmartSockets message types by default all have a load balancing mode of LB_NONE
public virtual int LbMode {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If load balancing mode is not valid.

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace | LbMode


LocalDelivery Property

SmartSockets .NET Class Library

TipcMt.LocalDelivery Property

Gets/Sets the local delivery property of a message type.

public virtual bool LocalDelivery {get; set;}

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace


Name Property

SmartSockets .NET Class Library

TipcMt.Name Property

Gets the name of a message type.

public virtual string Name {get;}

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace


Num Property

SmartSockets .NET Class Library

TipcMt.Num Property

Returns the number of a message type.

public virtual int Num {get;}

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace


Priority Property

SmartSockets .NET Class Library

TipcMt.Priority Property

Gets/Sets the priority of a message type.

The priority of a message type, if set, is used as the default priority of for messages of this type. The message type priority can either be set to a specific value or it can be unknown. When a message is created, its priority is initialized to the message type priority (if set) or to the value of the option Default_Msg_Priority (if the message type priority is unknown).

The priority of an outgoing message can always be set on a per-message basis, but using message type priorities makes it easier to raise or lower the default priority for all outgoing messages of a specific type. The standard SmartSockets message types by default all have a priority of unknown, but these can be changed. User-defined message types can also use whatever priority is appropriate.

When a message type is first created, its priority is initialized to unknown.

public virtual short Priority {get; set;}

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace |


UserProp Property

SmartSockets .NET Class Library

TipcMt.UserProp Property

Gets/Sets the user-defined property of a message type.

public virtual int UserProp {get; set;}

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace


TipcMt Methods

The methods of the TipcMt class are listed below. For a complete list of TipcMt class members, see the TipcMt Members topic.

Public Instance Methods

destroy | Destroy a message type.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
setPriorityUnknown | Set priority of a message to unknown.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace


TipcMt.destroy Method

Destroy a message type.

public virtual void destroy();

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace


TipcMt.setPriorityUnknown Method

Set priority of a message to unknown.

public virtual void setPriorityUnknown();

See Also

TipcMt Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields Structure

Provides access to the identifiers for the standard SmartSockets message types.

For a list of all members of this type, see TipcMt_Fields Members.

System.Object
System.ValueType
TIBCO.SMARTSOCKETS.TipcMt_Fields

public struct TipcMt_Fields

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcMt_Fields Members | TIBCO.SMARTSOCKETS Namespace | |


TipcMt_Fields Members

TipcMt_Fields overview

Public Static Fields

ALERT | Standard Msg Type constant
ANY | Standard Msg Type constant
BATCH_SUBJECT_SET_SUBSCRIBE | Standard Msg Type constant
BATCH_SUBJECT_SET_SUBSCRIBE_RESULT | Standard Msg Type constant
BOOLEAN_DATA | Standard Msg Type constant
CANCEL_ALERT | Standard Msg Type constant
CANCEL_WARNING | Standard Msg Type constant
CLIENT_AUTH_CHALLENGE_CALL | Standard Msg Type constant
CLIENT_AUTH_CHALLENGE_RESULT | Standard Msg Type constant
CLIENT_CLOSE_CALL | Standard Msg Type constant
CLIENT_CLOSE_RESULT | Standard Msg Type constant
CLIENT_CONNECT_CALL | Standard Msg Type constant
CLIENT_CONNECT_RESULT | Standard Msg Type constant
CLIENT_OPEN_CALL | Standard Msg Type constant
CLIENT_OPEN_RESULT | Standard Msg Type constant
CONN_INIT | Standard Msg Type constant
CONNECT_CALL | Standard Msg Type constant
CONNECT_CALL_74 | Standard Msg Type constant
CONNECT_RESULT | Standard Msg Type constant
CONNECT_RESULT_74 | Standard Msg Type constant
CONTROL | Standard Msg Type constant
DBI_ADAPTER_REPLY | Standard Msg Type constant
DBI_ADAPTER_REQUEST | Standard Msg Type constant
DISCONNECT | Standard Msg Type constant
ENCRYPT | Standard Msg Type constant
END_OF_FRAME | Standard Msg Type constant
ENUM_DATA | Standard Msg Type constant
GMD_ACK | Standard Msg Type constant
GMD_DELETE | Standard Msg Type constant
GMD_FAILURE | Standard Msg Type constant
GMD_INIT_CALL | Standard Msg Type constant
GMD_INIT_RESULT | Standard Msg Type constant
GMD_NACK | Standard Msg Type constant
GMD_STATUS_CALL | Standard Msg Type constant
GMD_STATUS_RESULT | Standard Msg Type constant
HISTORY_BOOLEAN_DATA | Standard Msg Type constant
HISTORY_ENUM_DATA | Standard Msg Type constant
HISTORY_NUMERIC_DATA | Standard Msg Type constant
HISTORY_STRING_DATA | Standard Msg Type constant
INFO | Standard Msg Type constant
KEEP_ALIVE_CALL | Standard Msg Type constant
KEEP_ALIVE_RESULT | Standard Msg Type constant
MON_CLIENT_BUFFER_POLL_CALL | Standard Msg Type constant
MON_CLIENT_BUFFER_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_BUFFER_SET_WATCH | Standard Msg Type constant
MON_CLIENT_BUFFER_STATUS | Standard Msg Type constant
MON_CLIENT_CB_POLL_CALL | Standard Msg Type constant
MON_CLIENT_CB_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_CONGESTION_SET_WATCH | Standard Msg Type constant
MON_CLIENT_CONGESTION_STATUS | Standard Msg Type constant
MON_CLIENT_CPU_POLL_CALL | Standard Msg Type constant
MON_CLIENT_CPU_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_EXT_POLL_CALL | Standard Msg Type constant
MON_CLIENT_EXT_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_GENERAL_POLL_CALL | Standard Msg Type constant
MON_CLIENT_GENERAL_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_INFO_POLL_CALL | Standard Msg Type constant
MON_CLIENT_INFO_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_MSG_RECV_SET_WATCH | Standard Msg Type constant
MON_CLIENT_MSG_RECV_STATUS | Standard Msg Type constant
MON_CLIENT_MSG_SEND_SET_WATCH | Standard Msg Type constant
MON_CLIENT_MSG_SEND_STATUS | Standard Msg Type constant
MON_CLIENT_MSG_TRAFFIC_POLL_CALL | Standard Msg Type constant
MON_CLIENT_MSG_TRAFFIC_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_MSG_TYPE_EX_POLL_CALL | Standard Msg Type constant
MON_CLIENT_MSG_TYPE_EX_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_MSG_TYPE_POLL_CALL | Standard Msg Type constant
MON_CLIENT_MSG_TYPE_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_NAMES_NUM_POLL_CALL | Standard Msg Type constant
MON_CLIENT_NAMES_NUM_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_NAMES_POLL_CALL | Standard Msg Type constant
MON_CLIENT_NAMES_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_NAMES_SET_WATCH | Standard Msg Type constant
MON_CLIENT_NAMES_STATUS | Standard Msg Type constant
MON_CLIENT_OPTION_POLL_CALL | Standard Msg Type constant
MON_CLIENT_OPTION_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_SUBJECT_EX_POLL_CALL | Standard Msg Type constant
MON_CLIENT_SUBJECT_EX_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_SUBJECT_POLL_CALL | Standard Msg Type constant
MON_CLIENT_SUBJECT_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_SUBSCRIBE_NUM_POLL_CALL | Standard Msg Type constant
MON_CLIENT_SUBSCRIBE_NUM_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_SUBSCRIBE_POLL_CALL | Standard Msg Type constant
MON_CLIENT_SUBSCRIBE_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_SUBSCRIBE_SET_WATCH | Standard Msg Type constant
MON_CLIENT_SUBSCRIBE_STATUS | Standard Msg Type constant
MON_CLIENT_TIME_POLL_CALL | Standard Msg Type constant
MON_CLIENT_TIME_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_TIME_SET_WATCH | Standard Msg Type constant
MON_CLIENT_TIME_STATUS | Standard Msg Type constant
MON_CLIENT_VERSION_POLL_CALL | Standard Msg Type constant
MON_CLIENT_VERSION_POLL_RESULT | Standard Msg Type constant
MON_EXT_POLL_CALL | Standard Msg Type constant
MON_EXT_POLL_RESULT | Standard Msg Type constant
MON_PROJECT_NAMES_POLL_CALL | Standard Msg Type constant
MON_PROJECT_NAMES_POLL_RESULT | Standard Msg Type constant
MON_PROJECT_NAMES_SET_WATCH | Standard Msg Type constant
MON_PROJECT_NAMES_STATUS | Standard Msg Type constant
MON_SERVER_BUFFER_POLL_CALL | Standard Msg Type constant
MON_SERVER_BUFFER_POLL_RESULT | Standard Msg Type constant
MON_SERVER_CONGESTION_SET_WATCH | Standard Msg Type constant
MON_SERVER_CONGESTION_STATUS | Standard Msg Type constant
MON_SERVER_CONN_POLL_CALL | Standard Msg Type constant
MON_SERVER_CONN_POLL_RESULT | Standard Msg Type constant
MON_SERVER_CONN_SET_WATCH | Standard Msg Type constant
MON_SERVER_CONN_STATUS | Standard Msg Type constant
MON_SERVER_CPU_POLL_CALL | Standard Msg Type constant
MON_SERVER_CPU_POLL_RESULT | Standard Msg Type constant
MON_SERVER_GENERAL_POLL_CALL | Standard Msg Type constant
MON_SERVER_GENERAL_POLL_RESULT | Standard Msg Type constant
MON_SERVER_MAX_CLIENT_LICENSES_SET_WATCH | Standard Msg Type constant
MON_SERVER_MAX_CLIENT_LICENSES_STATUS | Standard Msg Type constant
MON_SERVER_MSG_TRAFFIC_EX_POLL_CALL | Standard Msg Type constant
MON_SERVER_MSG_TRAFFIC_EX_POLL_RESULT | Standard Msg Type constant
MON_SERVER_MSG_TRAFFIC_POLL_CALL | Standard Msg Type constant
MON_SERVER_MSG_TRAFFIC_POLL_RESULT | Standard Msg Type constant
MON_SERVER_NAMES_POLL_CALL | Standard Msg Type constant
MON_SERVER_NAMES_POLL_RESULT | Standard Msg Type constant
MON_SERVER_NAMES_SET_WATCH | Standard Msg Type constant
MON_SERVER_NAMES_STATUS | Standard Msg Type constant
MON_SERVER_OPTION_POLL_CALL | Standard Msg Type constant
MON_SERVER_OPTION_POLL_RESULT | Standard Msg Type constant
MON_SERVER_ROUTE_POLL_CALL | Standard Msg Type constant
MON_SERVER_ROUTE_POLL_RESULT | Standard Msg Type constant
MON_SERVER_START_TIME_POLL_CALL | Standard Msg Type constant
MON_SERVER_START_TIME_POLL_RESULT | Standard Msg Type constant
MON_SERVER_TIME_POLL_CALL | Standard Msg Type constant
MON_SERVER_TIME_POLL_RESULT | Standard Msg Type constant
MON_SERVER_VERSION_POLL_CALL | Standard Msg Type constant
MON_SERVER_VERSION_POLL_RESULT | Standard Msg Type constant
MON_SUBJECT_NAMES_POLL_CALL | Standard Msg Type constant
MON_SUBJECT_NAMES_POLL_RESULT | Standard Msg Type constant
MON_SUBJECT_NAMES_SET_WATCH | Standard Msg Type constant
MON_SUBJECT_NAMES_STATUS | Standard Msg Type constant
MON_SUBJECT_SUBSCRIBE_POLL_CALL | Standard Msg Type constant
MON_SUBJECT_SUBSCRIBE_POLL_RESULT | Standard Msg Type constant
MON_SUBJECT_SUBSCRIBE_SET_WATCH | Standard Msg Type constant
MON_SUBJECT_SUBSCRIBE_STATUS | Standard Msg Type constant
NUMERIC_DATA | Standard Msg Type constant
OBJ_BG | Standard Msg Type constant
OBJ_FG | Standard Msg Type constant
OBJECT_DATA | Standard Msg Type constant
POPDOWN | Standard Msg Type constant
POPUP | Standard Msg Type constant
RULE_CREATE | Standard Msg Type constant
RULE_DESTROY | Standard Msg Type constant
SERVER_STOP_CALL | Standard Msg Type constant
SERVER_STOP_RESULT | Standard Msg Type constant
STRING_DATA | Standard Msg Type constant
SUBJECT_RETRIEVE | Standard Msg Type constant
SUBJECT_SET_SUBSCRIBE | Standard Msg Type constant
T_MT_DBI_START | TIBCO database interface (LiveDB) defined message types.
TIME | Standard Msg Type constant
VAR_BG | Standard Msg Type constant
VAR_FG | Standard Msg Type constant
VAR_VALUE_CALL | Standard Msg Type constant
VAR_VALUE_RESULT | Standard Msg Type constant
VIEW_DATA | Standard Msg Type constant
WARNING | Standard Msg Type constant

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMt_Fields Fields

The fields of the TipcMt_Fields structure are listed below. For a complete list of TipcMt_Fields structure members, see the TipcMt_Fields Members topic.

Public Static Fields

ALERT | Standard Msg Type constant
ANY | Standard Msg Type constant
BATCH_SUBJECT_SET_SUBSCRIBE | Standard Msg Type constant
BATCH_SUBJECT_SET_SUBSCRIBE_RESULT | Standard Msg Type constant
BOOLEAN_DATA | Standard Msg Type constant
CANCEL_ALERT | Standard Msg Type constant
CANCEL_WARNING | Standard Msg Type constant
CLIENT_AUTH_CHALLENGE_CALL | Standard Msg Type constant
CLIENT_AUTH_CHALLENGE_RESULT | Standard Msg Type constant
CLIENT_CLOSE_CALL | Standard Msg Type constant
CLIENT_CLOSE_RESULT | Standard Msg Type constant
CLIENT_CONNECT_CALL | Standard Msg Type constant
CLIENT_CONNECT_RESULT | Standard Msg Type constant
CLIENT_OPEN_CALL | Standard Msg Type constant
CLIENT_OPEN_RESULT | Standard Msg Type constant
CONN_INIT | Standard Msg Type constant
CONNECT_CALL | Standard Msg Type constant
CONNECT_CALL_74 | Standard Msg Type constant
CONNECT_RESULT | Standard Msg Type constant
CONNECT_RESULT_74 | Standard Msg Type constant
CONTROL | Standard Msg Type constant
DBI_ADAPTER_REPLY | Standard Msg Type constant
DBI_ADAPTER_REQUEST | Standard Msg Type constant
DISCONNECT | Standard Msg Type constant
ENCRYPT | Standard Msg Type constant
END_OF_FRAME | Standard Msg Type constant
ENUM_DATA | Standard Msg Type constant
GMD_ACK | Standard Msg Type constant
GMD_DELETE | Standard Msg Type constant
GMD_FAILURE | Standard Msg Type constant
GMD_INIT_CALL | Standard Msg Type constant
GMD_INIT_RESULT | Standard Msg Type constant
GMD_NACK | Standard Msg Type constant
GMD_STATUS_CALL | Standard Msg Type constant
GMD_STATUS_RESULT | Standard Msg Type constant
HISTORY_BOOLEAN_DATA | Standard Msg Type constant
HISTORY_ENUM_DATA | Standard Msg Type constant
HISTORY_NUMERIC_DATA | Standard Msg Type constant
HISTORY_STRING_DATA | Standard Msg Type constant
INFO | Standard Msg Type constant
KEEP_ALIVE_CALL | Standard Msg Type constant
KEEP_ALIVE_RESULT | Standard Msg Type constant
MON_CLIENT_BUFFER_POLL_CALL | Standard Msg Type constant
MON_CLIENT_BUFFER_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_BUFFER_SET_WATCH | Standard Msg Type constant
MON_CLIENT_BUFFER_STATUS | Standard Msg Type constant
MON_CLIENT_CB_POLL_CALL | Standard Msg Type constant
MON_CLIENT_CB_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_CONGESTION_SET_WATCH | Standard Msg Type constant
MON_CLIENT_CONGESTION_STATUS | Standard Msg Type constant
MON_CLIENT_CPU_POLL_CALL | Standard Msg Type constant
MON_CLIENT_CPU_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_EXT_POLL_CALL | Standard Msg Type constant
MON_CLIENT_EXT_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_GENERAL_POLL_CALL | Standard Msg Type constant
MON_CLIENT_GENERAL_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_INFO_POLL_CALL | Standard Msg Type constant
MON_CLIENT_INFO_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_MSG_RECV_SET_WATCH | Standard Msg Type constant
MON_CLIENT_MSG_RECV_STATUS | Standard Msg Type constant
MON_CLIENT_MSG_SEND_SET_WATCH | Standard Msg Type constant
MON_CLIENT_MSG_SEND_STATUS | Standard Msg Type constant
MON_CLIENT_MSG_TRAFFIC_POLL_CALL | Standard Msg Type constant
MON_CLIENT_MSG_TRAFFIC_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_MSG_TYPE_EX_POLL_CALL | Standard Msg Type constant
MON_CLIENT_MSG_TYPE_EX_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_MSG_TYPE_POLL_CALL | Standard Msg Type constant
MON_CLIENT_MSG_TYPE_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_NAMES_NUM_POLL_CALL | Standard Msg Type constant
MON_CLIENT_NAMES_NUM_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_NAMES_POLL_CALL | Standard Msg Type constant
MON_CLIENT_NAMES_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_NAMES_SET_WATCH | Standard Msg Type constant
MON_CLIENT_NAMES_STATUS | Standard Msg Type constant
MON_CLIENT_OPTION_POLL_CALL | Standard Msg Type constant
MON_CLIENT_OPTION_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_SUBJECT_EX_POLL_CALL | Standard Msg Type constant
MON_CLIENT_SUBJECT_EX_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_SUBJECT_POLL_CALL | Standard Msg Type constant
MON_CLIENT_SUBJECT_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_SUBSCRIBE_NUM_POLL_CALL | Standard Msg Type constant
MON_CLIENT_SUBSCRIBE_NUM_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_SUBSCRIBE_POLL_CALL | Standard Msg Type constant
MON_CLIENT_SUBSCRIBE_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_SUBSCRIBE_SET_WATCH | Standard Msg Type constant
MON_CLIENT_SUBSCRIBE_STATUS | Standard Msg Type constant
MON_CLIENT_TIME_POLL_CALL | Standard Msg Type constant
MON_CLIENT_TIME_POLL_RESULT | Standard Msg Type constant
MON_CLIENT_TIME_SET_WATCH | Standard Msg Type constant
MON_CLIENT_TIME_STATUS | Standard Msg Type constant
MON_CLIENT_VERSION_POLL_CALL | Standard Msg Type constant
MON_CLIENT_VERSION_POLL_RESULT | Standard Msg Type constant
MON_EXT_POLL_CALL | Standard Msg Type constant
MON_EXT_POLL_RESULT | Standard Msg Type constant
MON_PROJECT_NAMES_POLL_CALL | Standard Msg Type constant
MON_PROJECT_NAMES_POLL_RESULT | Standard Msg Type constant
MON_PROJECT_NAMES_SET_WATCH | Standard Msg Type constant
MON_PROJECT_NAMES_STATUS | Standard Msg Type constant
MON_SERVER_BUFFER_POLL_CALL | Standard Msg Type constant
MON_SERVER_BUFFER_POLL_RESULT | Standard Msg Type constant
MON_SERVER_CONGESTION_SET_WATCH | Standard Msg Type constant
MON_SERVER_CONGESTION_STATUS | Standard Msg Type constant
MON_SERVER_CONN_POLL_CALL | Standard Msg Type constant
MON_SERVER_CONN_POLL_RESULT | Standard Msg Type constant
MON_SERVER_CONN_SET_WATCH | Standard Msg Type constant
MON_SERVER_CONN_STATUS | Standard Msg Type constant
MON_SERVER_CPU_POLL_CALL | Standard Msg Type constant
MON_SERVER_CPU_POLL_RESULT | Standard Msg Type constant
MON_SERVER_GENERAL_POLL_CALL | Standard Msg Type constant
MON_SERVER_GENERAL_POLL_RESULT | Standard Msg Type constant
MON_SERVER_MAX_CLIENT_LICENSES_SET_WATCH | Standard Msg Type constant
MON_SERVER_MAX_CLIENT_LICENSES_STATUS | Standard Msg Type constant
MON_SERVER_MSG_TRAFFIC_EX_POLL_CALL | Standard Msg Type constant
MON_SERVER_MSG_TRAFFIC_EX_POLL_RESULT | Standard Msg Type constant
MON_SERVER_MSG_TRAFFIC_POLL_CALL | Standard Msg Type constant
MON_SERVER_MSG_TRAFFIC_POLL_RESULT | Standard Msg Type constant
MON_SERVER_NAMES_POLL_CALL | Standard Msg Type constant
MON_SERVER_NAMES_POLL_RESULT | Standard Msg Type constant
MON_SERVER_NAMES_SET_WATCH | Standard Msg Type constant
MON_SERVER_NAMES_STATUS | Standard Msg Type constant
MON_SERVER_OPTION_POLL_CALL | Standard Msg Type constant
MON_SERVER_OPTION_POLL_RESULT | Standard Msg Type constant
MON_SERVER_ROUTE_POLL_CALL | Standard Msg Type constant
MON_SERVER_ROUTE_POLL_RESULT | Standard Msg Type constant
MON_SERVER_START_TIME_POLL_CALL | Standard Msg Type constant
MON_SERVER_START_TIME_POLL_RESULT | Standard Msg Type constant
MON_SERVER_TIME_POLL_CALL | Standard Msg Type constant
MON_SERVER_TIME_POLL_RESULT | Standard Msg Type constant
MON_SERVER_VERSION_POLL_CALL | Standard Msg Type constant
MON_SERVER_VERSION_POLL_RESULT | Standard Msg Type constant
MON_SUBJECT_NAMES_POLL_CALL | Standard Msg Type constant
MON_SUBJECT_NAMES_POLL_RESULT | Standard Msg Type constant
MON_SUBJECT_NAMES_SET_WATCH | Standard Msg Type constant
MON_SUBJECT_NAMES_STATUS | Standard Msg Type constant
MON_SUBJECT_SUBSCRIBE_POLL_CALL | Standard Msg Type constant
MON_SUBJECT_SUBSCRIBE_POLL_RESULT | Standard Msg Type constant
MON_SUBJECT_SUBSCRIBE_SET_WATCH | Standard Msg Type constant
MON_SUBJECT_SUBSCRIBE_STATUS | Standard Msg Type constant
NUMERIC_DATA | Standard Msg Type constant
OBJ_BG | Standard Msg Type constant
OBJ_FG | Standard Msg Type constant
OBJECT_DATA | Standard Msg Type constant
POPDOWN | Standard Msg Type constant
POPUP | Standard Msg Type constant
RULE_CREATE | Standard Msg Type constant
RULE_DESTROY | Standard Msg Type constant
SERVER_STOP_CALL | Standard Msg Type constant
SERVER_STOP_RESULT | Standard Msg Type constant
STRING_DATA | Standard Msg Type constant
SUBJECT_RETRIEVE | Standard Msg Type constant
SUBJECT_SET_SUBSCRIBE | Standard Msg Type constant
T_MT_DBI_START | TIBCO database interface (LiveDB) defined message types.
TIME | Standard Msg Type constant
VAR_BG | Standard Msg Type constant
VAR_FG | Standard Msg Type constant
VAR_VALUE_CALL | Standard Msg Type constant
VAR_VALUE_RESULT | Standard Msg Type constant
VIEW_DATA | Standard Msg Type constant
WARNING | Standard Msg Type constant

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace | |


TipcMt_Fields.ALERT Field

Standard Msg Type constant

public const int ALERT = -41;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.ANY Field

Standard Msg Type constant

public const int ANY = -79;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.BATCH_SUBJECT_SET_SUBSCRIBE Field

Standard Msg Type constant

public const int BATCH_SUBJECT_SET_SUBSCRIBE = -11601;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.BATCH_SUBJECT_SET_SUBSCRIBE_RESULT Field

Standard Msg Type constant

public const int BATCH_SUBJECT_SET_SUBSCRIBE_RESULT = -11600;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.BOOLEAN_DATA Field

Standard Msg Type constant

public const int BOOLEAN_DATA = -20;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CANCEL_ALERT Field

Standard Msg Type constant

public const int CANCEL_ALERT = -42;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CANCEL_WARNING Field

Standard Msg Type constant

public const int CANCEL_WARNING = -44;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CLIENT_AUTH_CHALLENGE_CALL Field

Standard Msg Type constant

public const int CLIENT_AUTH_CHALLENGE_CALL = -87;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CLIENT_AUTH_CHALLENGE_RESULT Field

Standard Msg Type constant

public const int CLIENT_AUTH_CHALLENGE_RESULT = -86;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CLIENT_CLOSE_CALL Field

Standard Msg Type constant

public const int CLIENT_CLOSE_CALL = -89;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CLIENT_CLOSE_RESULT Field

Standard Msg Type constant

public const int CLIENT_CLOSE_RESULT = -88;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CLIENT_CONNECT_CALL Field

Standard Msg Type constant

public const int CLIENT_CONNECT_CALL = -83;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CLIENT_CONNECT_RESULT Field

Standard Msg Type constant

public const int CLIENT_CONNECT_RESULT = -82;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CLIENT_OPEN_CALL Field

Standard Msg Type constant

public const int CLIENT_OPEN_CALL = -85;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CLIENT_OPEN_RESULT Field

Standard Msg Type constant

public const int CLIENT_OPEN_RESULT = -84;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CONN_INIT Field

Standard Msg Type constant

public const int CONN_INIT = -10;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CONNECT_CALL Field

Standard Msg Type constant

public const int CONNECT_CALL = -75;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CONNECT_CALL_74 Field

Standard Msg Type constant

public const int CONNECT_CALL_74 = -81;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CONNECT_RESULT Field

Standard Msg Type constant

public const int CONNECT_RESULT = -74;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CONNECT_RESULT_74 Field

Standard Msg Type constant

public const int CONNECT_RESULT_74 = -80;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.CONTROL Field

Standard Msg Type constant

public const int CONTROL = -30;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.DBI_ADAPTER_REPLY Field

Standard Msg Type constant

public const int DBI_ADAPTER_REPLY = -11101;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.DBI_ADAPTER_REQUEST Field

Standard Msg Type constant

public const int DBI_ADAPTER_REQUEST = -11100;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.DISCONNECT Field

Standard Msg Type constant

public const int DISCONNECT = -5;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.ENCRYPT Field

Standard Msg Type constant

public const int ENCRYPT = -900;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.END_OF_FRAME Field

Standard Msg Type constant

public const int END_OF_FRAME = -28;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.ENUM_DATA Field

Standard Msg Type constant

public const int ENUM_DATA = -21;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.GMD_ACK Field

Standard Msg Type constant

public const int GMD_ACK = -11;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.GMD_DELETE Field

Standard Msg Type constant

public const int GMD_DELETE = -14;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.GMD_FAILURE Field

Standard Msg Type constant

public const int GMD_FAILURE = -13;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.GMD_INIT_CALL Field

Standard Msg Type constant

public const int GMD_INIT_CALL = -78;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.GMD_INIT_RESULT Field

Standard Msg Type constant

public const int GMD_INIT_RESULT = -77;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.GMD_NACK Field

Standard Msg Type constant

public const int GMD_NACK = -12;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.GMD_STATUS_CALL Field

Standard Msg Type constant

public const int GMD_STATUS_CALL = -16;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.GMD_STATUS_RESULT Field

Standard Msg Type constant

public const int GMD_STATUS_RESULT = -15;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.HISTORY_BOOLEAN_DATA Field

Standard Msg Type constant

public const int HISTORY_BOOLEAN_DATA = -24;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.HISTORY_ENUM_DATA Field

Standard Msg Type constant

public const int HISTORY_ENUM_DATA = -25;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.HISTORY_NUMERIC_DATA Field

Standard Msg Type constant

public const int HISTORY_NUMERIC_DATA = -26;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.HISTORY_STRING_DATA Field

Standard Msg Type constant

public const int HISTORY_STRING_DATA = -27;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.INFO Field

Standard Msg Type constant

public const int INFO = -40;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.KEEP_ALIVE_CALL Field

Standard Msg Type constant

public const int KEEP_ALIVE_CALL = -19;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.KEEP_ALIVE_RESULT Field

Standard Msg Type constant

public const int KEEP_ALIVE_RESULT = -18;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_BUFFER_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_BUFFER_POLL_CALL = -447;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_BUFFER_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_BUFFER_POLL_RESULT = -446;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_BUFFER_SET_WATCH Field

Standard Msg Type constant

public const int MON_CLIENT_BUFFER_SET_WATCH = -414;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_BUFFER_STATUS Field

Standard Msg Type constant

public const int MON_CLIENT_BUFFER_STATUS = -415;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_CB_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_CB_POLL_CALL = -453;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_CB_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_CB_POLL_RESULT = -452;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_CONGESTION_SET_WATCH Field

Standard Msg Type constant

public const int MON_CLIENT_CONGESTION_SET_WATCH = -486;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_CONGESTION_STATUS Field

Standard Msg Type constant

public const int MON_CLIENT_CONGESTION_STATUS = -487;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_CPU_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_CPU_POLL_CALL = -477;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_CPU_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_CPU_POLL_RESULT = -476;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_EXT_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_EXT_POLL_CALL = -489;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_EXT_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_EXT_POLL_RESULT = -488;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_GENERAL_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_GENERAL_POLL_CALL = -443;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_GENERAL_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_GENERAL_POLL_RESULT = -442;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_INFO_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_INFO_POLL_CALL = -481;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_INFO_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_INFO_POLL_RESULT = -480;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_MSG_RECV_SET_WATCH Field

Standard Msg Type constant

public const int MON_CLIENT_MSG_RECV_SET_WATCH = -416;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_MSG_RECV_STATUS Field

Standard Msg Type constant

public const int MON_CLIENT_MSG_RECV_STATUS = -417;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_MSG_SEND_SET_WATCH Field

Standard Msg Type constant

public const int MON_CLIENT_MSG_SEND_SET_WATCH = -418;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_MSG_SEND_STATUS Field

Standard Msg Type constant

public const int MON_CLIENT_MSG_SEND_STATUS = -419;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_MSG_TRAFFIC_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_MSG_TRAFFIC_POLL_CALL = -455;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_MSG_TRAFFIC_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_MSG_TRAFFIC_POLL_RESULT = -454;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_MSG_TYPE_EX_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_MSG_TYPE_EX_POLL_CALL = -1501;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_MSG_TYPE_EX_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_MSG_TYPE_EX_POLL_RESULT = -1500;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_MSG_TYPE_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_MSG_TYPE_POLL_CALL = -451;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_MSG_TYPE_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_MSG_TYPE_POLL_RESULT = -450;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_NAMES_NUM_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_NAMES_NUM_POLL_CALL = -473;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_NAMES_NUM_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_NAMES_NUM_POLL_RESULT = -472;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_NAMES_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_NAMES_POLL_CALL = -433;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_NAMES_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_NAMES_POLL_RESULT = -432;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_NAMES_SET_WATCH Field

Standard Msg Type constant

public const int MON_CLIENT_NAMES_SET_WATCH = -402;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_NAMES_STATUS Field

Standard Msg Type constant

public const int MON_CLIENT_NAMES_STATUS = -403;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_OPTION_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_OPTION_POLL_CALL = -449;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_OPTION_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_OPTION_POLL_RESULT = -448;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_SUBJECT_EX_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_SUBJECT_EX_POLL_CALL = -1503;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_SUBJECT_EX_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_SUBJECT_EX_POLL_RESULT = -1502;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_SUBJECT_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_SUBJECT_POLL_CALL = -457;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_SUBJECT_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_SUBJECT_POLL_RESULT = -456;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_SUBSCRIBE_NUM_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_SUBSCRIBE_NUM_POLL_CALL = -475;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_SUBSCRIBE_NUM_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_SUBSCRIBE_NUM_POLL_RESULT = -474;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_SUBSCRIBE_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_SUBSCRIBE_POLL_CALL = -441;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_SUBSCRIBE_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_SUBSCRIBE_POLL_RESULT = -440;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_SUBSCRIBE_SET_WATCH Field

Standard Msg Type constant

public const int MON_CLIENT_SUBSCRIBE_SET_WATCH = -410;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_SUBSCRIBE_STATUS Field

Standard Msg Type constant

public const int MON_CLIENT_SUBSCRIBE_STATUS = -411;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_TIME_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_TIME_POLL_CALL = -445;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_TIME_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_TIME_POLL_RESULT = -444;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_TIME_SET_WATCH Field

Standard Msg Type constant

public const int MON_CLIENT_TIME_SET_WATCH = -412;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_TIME_STATUS Field

Standard Msg Type constant

public const int MON_CLIENT_TIME_STATUS = -413;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_VERSION_POLL_CALL Field

Standard Msg Type constant

public const int MON_CLIENT_VERSION_POLL_CALL = -491;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_CLIENT_VERSION_POLL_RESULT Field

Standard Msg Type constant

public const int MON_CLIENT_VERSION_POLL_RESULT = -490;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_EXT_POLL_CALL Field

Standard Msg Type constant

public const int MON_EXT_POLL_CALL = -489;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_EXT_POLL_RESULT Field

Standard Msg Type constant

public const int MON_EXT_POLL_RESULT = -488;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_PROJECT_NAMES_POLL_CALL Field

Standard Msg Type constant

public const int MON_PROJECT_NAMES_POLL_CALL = -431;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_PROJECT_NAMES_POLL_RESULT Field

Standard Msg Type constant

public const int MON_PROJECT_NAMES_POLL_RESULT = -430;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_PROJECT_NAMES_SET_WATCH Field

Standard Msg Type constant

public const int MON_PROJECT_NAMES_SET_WATCH = -400;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_PROJECT_NAMES_STATUS Field

Standard Msg Type constant

public const int MON_PROJECT_NAMES_STATUS = -401;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_BUFFER_POLL_CALL Field

Standard Msg Type constant

public const int MON_SERVER_BUFFER_POLL_CALL = -463;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_BUFFER_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SERVER_BUFFER_POLL_RESULT = -462;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_CONGESTION_SET_WATCH Field

Standard Msg Type constant

public const int MON_SERVER_CONGESTION_SET_WATCH = -482;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_CONGESTION_STATUS Field

Standard Msg Type constant

public const int MON_SERVER_CONGESTION_STATUS = -483;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_CONN_POLL_CALL Field

Standard Msg Type constant

public const int MON_SERVER_CONN_POLL_CALL = -467;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_CONN_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SERVER_CONN_POLL_RESULT = -466;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_CONN_SET_WATCH Field

Standard Msg Type constant

public const int MON_SERVER_CONN_SET_WATCH = -420;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_CONN_STATUS Field

Standard Msg Type constant

public const int MON_SERVER_CONN_STATUS = -421;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_CPU_POLL_CALL Field

Standard Msg Type constant

public const int MON_SERVER_CPU_POLL_CALL = -479;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_CPU_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SERVER_CPU_POLL_RESULT = -478;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_GENERAL_POLL_CALL Field

Standard Msg Type constant

public const int MON_SERVER_GENERAL_POLL_CALL = -459;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_GENERAL_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SERVER_GENERAL_POLL_RESULT = -458;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_MAX_CLIENT_LICENSES_SET_WATCH Field

Standard Msg Type constant

public const int MON_SERVER_MAX_CLIENT_LICENSES_SET_WATCH = -484;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_MAX_CLIENT_LICENSES_STATUS Field

Standard Msg Type constant

public const int MON_SERVER_MAX_CLIENT_LICENSES_STATUS = -485;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_MSG_TRAFFIC_EX_POLL_CALL Field

Standard Msg Type constant

public const int MON_SERVER_MSG_TRAFFIC_EX_POLL_CALL = -1505;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_MSG_TRAFFIC_EX_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SERVER_MSG_TRAFFIC_EX_POLL_RESULT = -1504;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_MSG_TRAFFIC_POLL_CALL Field

Standard Msg Type constant

public const int MON_SERVER_MSG_TRAFFIC_POLL_CALL = -471;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_MSG_TRAFFIC_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SERVER_MSG_TRAFFIC_POLL_RESULT = -470;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_NAMES_POLL_CALL Field

Standard Msg Type constant

public const int MON_SERVER_NAMES_POLL_CALL = -435;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_NAMES_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SERVER_NAMES_POLL_RESULT = -434;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_NAMES_SET_WATCH Field

Standard Msg Type constant

public const int MON_SERVER_NAMES_SET_WATCH = -404;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_NAMES_STATUS Field

Standard Msg Type constant

public const int MON_SERVER_NAMES_STATUS = -405;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_OPTION_POLL_CALL Field

Standard Msg Type constant

public const int MON_SERVER_OPTION_POLL_CALL = -465;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_OPTION_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SERVER_OPTION_POLL_RESULT = -464;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_ROUTE_POLL_CALL Field

Standard Msg Type constant

public const int MON_SERVER_ROUTE_POLL_CALL = -469;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_ROUTE_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SERVER_ROUTE_POLL_RESULT = -468;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_START_TIME_POLL_CALL Field

Standard Msg Type constant

public const int MON_SERVER_START_TIME_POLL_CALL = -495;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_START_TIME_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SERVER_START_TIME_POLL_RESULT = -494;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_TIME_POLL_CALL Field

Standard Msg Type constant

public const int MON_SERVER_TIME_POLL_CALL = -461;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_TIME_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SERVER_TIME_POLL_RESULT = -460;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_VERSION_POLL_CALL Field

Standard Msg Type constant

public const int MON_SERVER_VERSION_POLL_CALL = -493;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SERVER_VERSION_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SERVER_VERSION_POLL_RESULT = -492;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SUBJECT_NAMES_POLL_CALL Field

Standard Msg Type constant

public const int MON_SUBJECT_NAMES_POLL_CALL = -437;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SUBJECT_NAMES_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SUBJECT_NAMES_POLL_RESULT = -436;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SUBJECT_NAMES_SET_WATCH Field

Standard Msg Type constant

public const int MON_SUBJECT_NAMES_SET_WATCH = -406;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SUBJECT_NAMES_STATUS Field

Standard Msg Type constant

public const int MON_SUBJECT_NAMES_STATUS = -407;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SUBJECT_SUBSCRIBE_POLL_CALL Field

Standard Msg Type constant

public const int MON_SUBJECT_SUBSCRIBE_POLL_CALL = -439;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SUBJECT_SUBSCRIBE_POLL_RESULT Field

Standard Msg Type constant

public const int MON_SUBJECT_SUBSCRIBE_POLL_RESULT = -438;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SUBJECT_SUBSCRIBE_SET_WATCH Field

Standard Msg Type constant

public const int MON_SUBJECT_SUBSCRIBE_SET_WATCH = -408;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.MON_SUBJECT_SUBSCRIBE_STATUS Field

Standard Msg Type constant

public const int MON_SUBJECT_SUBSCRIBE_STATUS = -409;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.NUMERIC_DATA Field

Standard Msg Type constant

public const int NUMERIC_DATA = -22;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.OBJ_BG Field

Standard Msg Type constant

public const int OBJ_BG = -46;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.OBJ_FG Field

Standard Msg Type constant

public const int OBJ_FG = -45;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.OBJECT_DATA Field

Standard Msg Type constant

public const int OBJECT_DATA = -54;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.POPDOWN Field

Standard Msg Type constant

public const int POPDOWN = -50;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.POPUP Field

Standard Msg Type constant

public const int POPUP = -49;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.RULE_CREATE Field

Standard Msg Type constant

public const int RULE_CREATE = -60;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.RULE_DESTROY Field

Standard Msg Type constant

public const int RULE_DESTROY = -61;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.SERVER_STOP_CALL Field

Standard Msg Type constant

public const int SERVER_STOP_CALL = -4;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.SERVER_STOP_RESULT Field

Standard Msg Type constant

public const int SERVER_STOP_RESULT = -3;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.STRING_DATA Field

Standard Msg Type constant

public const int STRING_DATA = -23;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.SUBJECT_RETRIEVE Field

Standard Msg Type constant

public const int SUBJECT_RETRIEVE = -73;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.SUBJECT_SET_SUBSCRIBE Field

Standard Msg Type constant

public const int SUBJECT_SET_SUBSCRIBE = -76;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.T_MT_DBI_START Field

TIBCO database interface (LiveDB) defined message types.

public const int T_MT_DBI_START = -11100;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.TIME Field

Standard Msg Type constant

public const int TIME = -29;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.VAR_BG Field

Standard Msg Type constant

public const int VAR_BG = -48;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.VAR_FG Field

Standard Msg Type constant

public const int VAR_FG = -47;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.VAR_VALUE_CALL Field

Standard Msg Type constant

public const int VAR_VALUE_CALL = -32;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.VAR_VALUE_RESULT Field

Standard Msg Type constant

public const int VAR_VALUE_RESULT = -31;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.VIEW_DATA Field

Standard Msg Type constant

public const int VIEW_DATA = -51;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcMt_Fields.WARNING Field

Standard Msg Type constant

public const int WARNING = -43;

See Also

TipcMt_Fields Class | TIBCO.SMARTSOCKETS Namespace


TipcNotFoundException Class

Thrown when the requested object is not found by a method.

For a list of all members of this type, see TipcNotFoundException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcNotFoundException

public class TipcNotFoundException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcNotFoundException Members | TIBCO.SMARTSOCKETS Namespace


TipcNotFoundException Members

TipcNotFoundException overview

Public Instance Constructors

TipcNotFoundException Overloaded. Initializes a new instance of the TipcNotFoundException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcNotFoundException Class | TIBCO.SMARTSOCKETS Namespace


TipcNotFoundException Constructor

Constructs a TipcNotFoundException with null as its error message string.

Overload List

Constructs a TipcNotFoundException with null as its error message string.

public TipcNotFoundException();

Constructs a TipcNotFoundException with an error message.

public TipcNotFoundException(string);

See Also

TipcNotFoundException Class | TIBCO.SMARTSOCKETS Namespace


TipcNotFoundException Constructor ()

Constructs a TipcNotFoundException with null as its error message string.

public TipcNotFoundException();

See Also

TipcNotFoundException Class | TIBCO.SMARTSOCKETS Namespace | TipcNotFoundException Constructor Overload List


TipcNotFoundException Constructor (String)

Constructs a TipcNotFoundException with an error message.

public TipcNotFoundException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcNotFoundException Class | TIBCO.SMARTSOCKETS Namespace | TipcNotFoundException Constructor Overload List


TipcNotSubscribedException Class

Thrown when unsubscribing from a subject not currently subscribed to by the client.

For a list of all members of this type, see TipcNotSubscribedException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcNotSubscribedException

public class TipcNotSubscribedException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcNotSubscribedException Members | TIBCO.SMARTSOCKETS Namespace |


TipcNotSubscribedException Members

TipcNotSubscribedException overview

Public Instance Constructors

TipcNotSubscribedException Overloaded. Initializes a new instance of the TipcNotSubscribedException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcNotSubscribedException Class | TIBCO.SMARTSOCKETS Namespace |


TipcNotSubscribedException Constructor

Constructs a TipcNotSubscribedException with null as its error message string.

Overload List

Constructs a TipcNotSubscribedException with null as its error message string.

public TipcNotSubscribedException();

Constructs a TipcNotSubscribedException with an error message.

public TipcNotSubscribedException(string);

See Also

TipcNotSubscribedException Class | TIBCO.SMARTSOCKETS Namespace


TipcNotSubscribedException Constructor ()

Constructs a TipcNotSubscribedException with null as its error message string.

public TipcNotSubscribedException();

See Also

TipcNotSubscribedException Class | TIBCO.SMARTSOCKETS Namespace | TipcNotSubscribedException Constructor Overload List


TipcNotSubscribedException Constructor (String)

Constructs a TipcNotSubscribedException with an error message.

public TipcNotSubscribedException(
string s
);

Parameters

s
the detailed error string.

See Also

TipcNotSubscribedException Class | TIBCO.SMARTSOCKETS Namespace | TipcNotSubscribedException Constructor Overload List


TipcOption Class

Represents one option setting. This class may not be created directly, but is instead returned by Tut.createOption, Tut.getOption, and Tut.removeOption.

The options database consists of a table of these objects. When a Property database is loaded, these objects are automatically created.

The value of all options is a String. However, these may be extracted as a boolean, an int, a double, or a Vector of Strings if the value contains a comma-separated list. Also, String values can be verified against a list of legal values (Enum), or mapped to a list of integers (EnumMap).

To set the value of a standard SmartSockets option, you may either get the TipcOption instance for that option, or you can use a convenience method:

TipcOption opt = Tut.getOption("ss.project");
opt.setValue("foo");
- or -
Tut.setOption("ss.project", "foo");

Options must be created before they can be set, retrieved, or removed. All of the standard SmartSockets options are created when the process starts up. If you wish to add your own options, you must use Tut.createOption to create the option and add it to the options table:

TipcOption opt = Tut.createOption("foo", "bar");
...
TipcOption opt = Tut.getOption("foo");
String s = opt.getValueStr();
- or -
String s = Tut.getOptionStr("foo");

If you wish to create an Enum or EnumMap option, you must then add a list of legal values to the option with addEnumLegalValue and addEnumMapLegalValue. Enums and EnumMaps cannot be intermixed; a given option must support one or the other, not both:

TipcOption opt = Tut.createOption("enum_foo", "baz");
opt.addEnumMapLegalValue("baz", 0);
opt.addEnumMapLegalValue("bat", 1);
opt.addEnumMapLegalValue("bark", 2);
...
TipcOption opt = Tut.getOption("enum_foo");
int i = opt.getValueEnumMap();

For a list of all members of this type, see TipcOption Members.

System.Object
TIBCO.SMARTSOCKETS.TipcOption

public class TipcOption

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcOption Members | TIBCO.SMARTSOCKETS Namespace


TipcOption Members

TipcOption overview

Public Instance Properties

Protected | Options can be marked as "protected", so they cannot be monitored.
ReadOnly | Options can be marked as "read only", so they cannot be set.
Value | Sets the value of an option. No error checking is done on the value.
ValueBool | Gets the value of the option as a boolean. The rules for the value of the option are the same as JDK library method Boolean.booleanValue.
ValueDouble | Gets the value of the option as a double.
ValueEnum | Gets the value of the option and verifies it against a list of legal values. For example, if you have a list of names: "foo", "bar", "baz"; and the value is "baz", then "baz" would be returned. If the value was "whiffle", then an exception would be thrown, since this value does not appear in the list of legal values. The list of legal values is set with addEnumLegalValue.
ValueEnumMap | Gets the value of the option and maps it to an enumerated list. For example, if you have a list of names: "first", "second" and "third"; and you want to use those internally as 1, 2, 3; then you would use this to get the value. You must first set the map ("first" = 1, "second" = 2, etc.) with addEnumMapValidValue.
ValueInt | Gets the value of the option as an int.
ValueList | Parses the value containing a comma-separated list into a Vector of Strings.
ValueStr | Gets the value of the option as a String.

Public Instance Methods

addEnumLegalValue | Adds an enum name to the list of valid names.
addEnumMapLegalValue | Adds an enum map name and value to the list of valid names.
clearEnumLegalValues | Clears the list of enumerated legal values.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getName | Gets the name of the option. This is the same as the name that is used to get the option.
GetType (inherited from Object) | Gets the Type of the current instance.
isRequired | Some options are required for SmartSockets to operate properly. This property is set internally by the library and may not be modified.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


TipcOption Properties

The properties of the TipcOption class are listed below. For a complete list of TipcOption class members, see the TipcOption Members topic.

Public Instance Properties

Protected | Options can be marked as "protected", so they cannot be monitored.
ReadOnly | Options can be marked as "read only", so they cannot be set.
Value | Sets the value of an option. No error checking is done on the value.
ValueBool | Gets the value of the option as a boolean. The rules for the value of the option are the same as JDK library method Boolean.booleanValue.
ValueDouble | Gets the value of the option as a double.
ValueEnum | Gets the value of the option and verifies it against a list of legal values. For example, if you have a list of names: "foo", "bar", "baz"; and the value is "baz", then "baz" would be returned. If the value was "whiffle", then an exception would be thrown, since this value does not appear in the list of legal values. The list of legal values is set with addEnumLegalValue.
ValueEnumMap | Gets the value of the option and maps it to an enumerated list. For example, if you have a list of names: "first", "second" and "third"; and you want to use those internally as 1, 2, 3; then you would use this to get the value. You must first set the map ("first" = 1, "second" = 2, etc.) with addEnumMapValidValue.
ValueInt | Gets the value of the option as an int.
ValueList | Parses the value containing a comma-separated list into a Vector of Strings.
ValueStr | Gets the value of the option as a String.

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


Protected Property

SmartSockets .NET Class Library

TipcOption.Protected Property

Options can be marked as "protected", so they cannot be monitored.

public virtual bool Protected {get; set;}

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


ReadOnly Property

SmartSockets .NET Class Library

TipcOption.ReadOnly Property

Options can be marked as "read only", so they cannot be set.

public virtual bool ReadOnly {get; set;}

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


Value Property

SmartSockets .NET Class Library

TipcOption.Value Property

Sets the value of an option. No error checking is done on the value.

public virtual string Value {get; set;}

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


ValueBool Property

SmartSockets .NET Class Library

TipcOption.ValueBool Property

Gets the value of the option as a boolean. The rules for the value of the option are the same as JDK library method Boolean.booleanValue.

public virtual bool ValueBool {get;}

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


ValueDouble Property

SmartSockets .NET Class Library

TipcOption.ValueDouble Property

Gets the value of the option as a double.

public virtual double ValueDouble {get;}

Exceptions

Exception Type | Condition
TipcNotFoundException | If the value cannot be converted into a valid double.

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


ValueEnum Property

SmartSockets .NET Class Library

TipcOption.ValueEnum Property

Gets the value of the option and verifies it against a list of legal values.

For example, if you have a list of names: "foo", "bar", "baz"; and the value is "baz", then "baz" would be returned. If the value was "whiffle", then an exception would be thrown, since this value does not appear in the list of legal values. The list of legal values is set with addEnumLegalValue.

public virtual string ValueEnum {get;}

Exceptions

Exception Type | Condition
TipcNotFoundException | If the value cannot be converted into a valid enum.

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


ValueEnumMap Property

SmartSockets .NET Class Library

TipcOption.ValueEnumMap Property

Gets the value of the option and maps it to an enumerated list. For example, if you have a list of names: "first", "second" and "third"; and you want to use those internally as 1, 2, 3; then you would use this to get the value. You must first set the map ("first" = 1, "second" = 2, etc.) with addEnumMapValidValue.

public virtual int ValueEnumMap {get;}

Exceptions

Exception Type | Condition
TipcNotFoundException | If the value cannot be converted into a valid enum.

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


ValueInt Property

SmartSockets .NET Class Library

TipcOption.ValueInt Property

Gets the value of the option as an int.

public virtual int ValueInt {get;}

Exceptions

Exception Type | Condition
TipcNotFoundException | If the value cannot be converted into a valid int.

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


ValueList Property

SmartSockets .NET Class Library

TipcOption.ValueList Property

Parses the value containing a comma-separated list into a Vector of Strings.

public virtual System.Collections.ArrayList ValueList {get;}

Exceptions

Exception Type | Condition
TipcNotFoundException | If the value cannot be converted into a valid list.

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


ValueStr Property

SmartSockets .NET Class Library

TipcOption.ValueStr Property

Gets the value of the option as a String.

public virtual string ValueStr {get;}

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


TipcOption Methods

The methods of the TipcOption class are listed below. For a complete list of TipcOption class members, see the TipcOption Members topic.

Public Instance Methods

addEnumLegalValue | Adds an enum name to the list of valid names.
addEnumMapLegalValue | Adds an enum map name and value to the list of valid names.
clearEnumLegalValues | Clears the list of enumerated legal values.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getName | Gets the name of the option. This is the same as the name that is used to get the option.
GetType (inherited from Object) | Gets the Type of the current instance.
isRequired | Some options are required for SmartSockets to operate properly. This property is set internally by the library and may not be modified.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


TipcOption.addEnumLegalValue Method

Adds an enum name to the list of valid names.

public virtual void addEnumLegalValue(
string ename
);

Parameters

ename
the name of the enumerated value

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


TipcOption.addEnumMapLegalValue Method

Adds an enum map name and value to the list of valid names.

public virtual void addEnumMapLegalValue(
string name,
int value
);

Parameters

name
the name of the enumerated value
value
the value the name maps to

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


TipcOption.clearEnumLegalValues Method

Clears the list of enumerated legal values.

public virtual void clearEnumLegalValues();

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


TipcOption.getName Method

Gets the name of the option. This is the same as the name that is used to get the option.

public virtual string getName();

Return Value

the name of the option.

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


TipcOption.isRequired Method

Some options are required for SmartSockets to operate properly. This property is set internally by the library and may not be modified.

public virtual bool isRequired();

Return Value

true if this option is required, false otherwise.

See Also

TipcOption Class | TIBCO.SMARTSOCKETS Namespace


TipcProcessCb Interface

The user interface for connection process callbacks.

Connection process callbacks are executed while processing a message. This callback type is the most frequently used. A process callback can be called for a specific type of message, on a specific subject (destination), or created globally and called for all messages. For example, a process callback can be created for the INFO message type. When any message of that type is processed by calling process or mainLoop, the process callback is called. If the process callback is created globally, it is called for all INFO messages as well as any other type of message.

For a list of all members of this type, see TipcProcessCb Members.

public interface TipcProcessCb

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcProcessCb Members | TIBCO.SMARTSOCKETS Namespace |


TipcProcessCb Members

TipcProcessCb overview

Public Instance Methods

process Method invoked when processing a message with process or mainLoop.

See Also

TipcProcessCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcProcessCb Methods

The methods of the TipcProcessCb interface are listed below. For a complete list of TipcProcessCb interface members, see the TipcProcessCb Members topic.

Public Instance Methods

process Method invoked when processing a message with process or mainLoop.

See Also

TipcProcessCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcProcessCb.process Method

Method invoked when processing a message with process or mainLoop.

void process(
TipcMsg msg,
object arg
);

Parameters

msg
The message.
arg
The user-defined argument.

See Also

TipcProcessCb Interface | TIBCO.SMARTSOCKETS Namespace


TipcProperties Class

Table of TipcOption objects, which can contain another table as its defaults; this second collection is searched if the TipcOption is not found in the original table.

For a list of all members of this type, see TipcProperties Members.

System.Object
System.Collections.Hashtable
TIBCO.SMARTSOCKETS.TipcProperties

public class TipcProperties : Hashtable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcProperties Members | TIBCO.SMARTSOCKETS Namespace


TipcProperties Members

TipcProperties overview

Public Instance Properties

Count (inherited from Hashtable) | Gets the number of key-and-value pairs contained in the Hashtable.
IsFixedSize (inherited from Hashtable) | Gets a value indicating whether the Hashtable has a fixed size.
IsReadOnly (inherited from Hashtable) | Gets a value indicating whether the Hashtable is read-only.
IsSynchronized (inherited from Hashtable) | Gets a value indicating whether access to the Hashtable is synchronized (thread-safe).
Item (inherited from Hashtable) | Gets or sets the value associated with the specified key.
Keys (inherited from Hashtable) | Gets an ICollection containing the keys in the Hashtable.
SyncRoot (inherited from Hashtable) | Gets an object that can be used to synchronize access to the Hashtable.
Values (inherited from Hashtable) | Gets an ICollection containing the values in the Hashtable.

Public Instance Methods

Add (inherited from Hashtable) | Adds an element with the specified key and value into the Hashtable.
addAll | Adds the properties, replacing any existing property with the same name.
Clear (inherited from Hashtable) | Removes all elements from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsKey (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines whether the Hashtable contains a specific value.
CopyTo (inherited from Hashtable) | Copies the Hashtable elements to a one-dimensional Array instance at the specified index.
createOption | Overloaded. Create a new option.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from Hashtable) | Returns an IDictionaryEnumerator that can iterate through the Hashtable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Hashtable) | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
getOption | Searches for the TipcOption with the specified name.
getOptionBool | Searches for the TipcOption with the specified name.
getOptionDouble | Searches for the TipcOption with the specified name.
getOptionInt | Searches for the TipcOption with the specified name.
getOptionStr | Searches for the TipcOption with the specified name.
GetType (inherited from Object) | Gets the Type of the current instance.
list | Prints this collection to the specified output stream. This method is useful for debugging.
loadOptions | Overloaded. Reads properties from an input stream.
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
optionNames | Returns an enumeration of all the option names in this collection, including the names in the default collection.
put | Sets the option value. Only allows TipcOption objects to be added.
Remove (inherited from Hashtable) | Removes the element with the specified key from the Hashtable.
removeOption | Overloaded. Removes an option.
setOption | Sets the option value.
storeOptions | Writes this collection to the specified output stream suitable for loading using the loadOptions
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

comparer (inherited from Hashtable) | Gets or sets the comparer to use for the Hashtable.
hcp (inherited from Hashtable) | Gets or sets the object that can dispense hash codes.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHash (inherited from Hashtable) | Returns the hash code for the specified key.
KeyEquals (inherited from Hashtable) | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


TipcProperties Methods

The methods of the TipcProperties class are listed below. For a complete list of TipcProperties class members, see the TipcProperties Members topic.

Public Instance Methods

Add (inherited from Hashtable) | Adds an element with the specified key and value into the Hashtable.
addAll | Adds the properties, replacing any existing property with the same name.
Clear (inherited from Hashtable) | Removes all elements from the Hashtable.
Clone (inherited from Hashtable) | Creates a shallow copy of the Hashtable.
Contains (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsKey (inherited from Hashtable) | Determines whether the Hashtable contains a specific key.
ContainsValue (inherited from Hashtable) | Determines whether the Hashtable contains a specific value.
CopyTo (inherited from Hashtable) | Copies the Hashtable elements to a one-dimensional Array instance at the specified index.
createOption | Overloaded. Create a new option.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from Hashtable) | Returns an IDictionaryEnumerator that can iterate through the Hashtable.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Hashtable) | Implements the ISerializable interface and returns the data needed to serialize the Hashtable.
getOption | Searches for the TipcOption with the specified name.
getOptionBool | Searches for the TipcOption with the specified name.
getOptionDouble | Searches for the TipcOption with the specified name.
getOptionInt | Searches for the TipcOption with the specified name.
getOptionStr | Searches for the TipcOption with the specified name.
GetType (inherited from Object) | Gets the Type of the current instance.
list | Prints this collection to the specified output stream. This method is useful for debugging.
loadOptions | Overloaded. Reads properties from an input stream.
OnDeserialization (inherited from Hashtable) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
optionNames | Returns an enumeration of all the option names in this collection, including the names in the default collection.
put | Sets the option value. Only allows TipcOption objects to be added.
Remove (inherited from Hashtable) | Removes the element with the specified key from the Hashtable.
removeOption | Overloaded. Removes an option.
setOption | Sets the option value.
storeOptions | Writes this collection to the specified output stream suitable for loading using the loadOptions
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHash (inherited from Hashtable) | Returns the hash code for the specified key.
KeyEquals (inherited from Hashtable) | Compares a specific Object with a specific key in the Hashtable.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


TipcProperties.addAll Method

Adds the properties, replacing any existing property with the same name.

public virtual void addAll(
NameValueCollection props
);

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


createOption Method

SmartSockets .NET Class Library

TipcProperties.createOption Method

Create a new option.

Overload List

Create a new option.

public virtual TipcOption createOption(string,string);

Create a new option.

public virtual TipcOption createOption(string,string,bool,bool,bool);

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


TipcProperties.createOption Method (String, String)

Create a new option.

public virtual TipcOption createOption(
string name,
string Value
);

Parameters

name
the option to create.
Value
the initial value of the option.

Return Value

the newly created option.

Exceptions

Exception Type | Condition
TipcAlreadyExistsException | If the option already exists.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace | TipcProperties.createOption Overload List


TipcProperties.createOption Method (String, String, Boolean, Boolean, Boolean)

Create a new option.

public virtual TipcOption createOption(
string name,
string Value,
bool require,
bool readOnly,
bool protect
);

Parameters

name
the option to create.
Value
the initial value of the option.
require
if the option is required to have a value.
readOnly
if the option is read only.
protect
if the option is to be protected (non-monitorable).

Return Value

the newly created option.

Exceptions

Exception Type | Condition
TipcAlreadyExistsException | If the option already exists.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace | TipcProperties.createOption Overload List


TipcProperties.getOption Method

Searches for the TipcOption with the specified name.

public virtual TipcOption getOption(
string name
);

Parameters

name
the name of the option to get.

Return Value

the option.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the option does not exist.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


TipcProperties.getOptionBool Method

Searches for the TipcOption with the specified name.

public virtual bool getOptionBool(
string name
);

Parameters

name
the name of the option to get.

Return Value

the boolean value of the option.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the option does not exist.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


TipcProperties.getOptionDouble Method

Searches for the TipcOption with the specified name.

public virtual double getOptionDouble(
string name
);

Parameters

name
the name of the option to get.

Return Value

the double value of the option.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the option does not exist.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


TipcProperties.getOptionInt Method

Searches for the TipcOption with the specified name.

public virtual int getOptionInt(
string name
);

Parameters

name
the name of the option to get.

Return Value

the int value of the option.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the option does not exist.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


TipcProperties.getOptionStr Method

Searches for the TipcOption with the specified name.

public virtual string getOptionStr(
string name
);

Parameters

name
the name of the option to get.

Return Value

the String value of the option.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the option does not exist.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


TipcProperties.list Method

Prints this collection to the specified output stream. This method is useful for debugging.

public virtual void list(
StreamWriter Out
);

Parameters

Out
an output stream.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


loadOptions Method

SmartSockets .NET Class Library

TipcProperties.loadOptions Method

Reads options from the application configuration file

Overload List

Reads options from the application configuration file

public virtual void loadOptions();

Reads properties from an input stream.

public virtual void loadOptions(Stream);

Reads properties from an input stream.

public virtual void loadOptions(string);

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


TipcProperties.loadOptions Method ()

Reads options from the application configuration file

public virtual void loadOptions();

Exceptions

Exception Type | Condition
TipcIOException | If an error occurs when reading.
TipcException | For all other errors

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace | TipcProperties.loadOptions Overload List


TipcProperties.loadOptions Method (Stream)

Reads properties from an input stream.

public virtual void loadOptions(
Stream In
);

Parameters

In
the input stream.

Exceptions

Exception Type | Condition
TipcIOException | If an error occurs when reading.
TipcException | For all other errors

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace | TipcProperties.loadOptions Overload List


TipcProperties.loadOptions Method (String)

Reads properties from an input stream.

public virtual void loadOptions(
string location
);

Parameters

location
The input stream.

Exceptions

Exception Type | Condition
TipcIOException | If an error occurs when reading.
TipcException | For all other errors

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace | TipcProperties.loadOptions Overload List


TipcProperties.optionNames Method

Returns an enumeration of all the option names in this collection, including the names in the default collection.

public virtual IEnumerator optionNames();

Return Value

an enumeration of all the option names in this collection, including the names in the default collection.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


TipcProperties.put Method

Sets the option value. Only allows TipcOption objects to be added.

public object put(
object key,
object Value
);

Parameters

key
the name of the option.
Value
the option.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


removeOption Method

SmartSockets .NET Class Library

TipcProperties.removeOption Method

Removes an option.

Overload List

Removes an option.

public virtual TipcOption removeOption(string);

Removes an option.

public virtual TipcOption removeOption(TipcOption);

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


TipcProperties.removeOption Method (String)

Removes an option.

public virtual TipcOption removeOption(
string name
);

Parameters

name
the option to remove.

Return Value

the removed option.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the option does not exist.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace | TipcProperties.removeOption Overload List


TipcProperties.removeOption Method (TipcOption)

Removes an option.

public virtual TipcOption removeOption(
TipcOption option
);

Parameters

option
the option to remove.

Return Value

the removed option.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the option does not exist.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace | TipcProperties.removeOption Overload List


TipcProperties.setOption Method

Sets the option value.

public virtual TipcOption setOption(
string name,
string Value
);

Parameters

name
the option to set.
Value
the value of the option.

Return Value

the option that was set.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the option does not exist.
TipcReadOnlyException | If the option is read only.

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


TipcProperties.storeOptions Method

Writes this collection to the specified output stream suitable for loading using the loadOptions

public virtual void storeOptions(
Stream Out,
string header
);

Parameters

Out
an output stream.
header
Header string

Exceptions

Exception Type | Condition
TipcIOException | When errors occur writing to the file
TipcException | For all other errors

See Also

TipcProperties Class | TIBCO.SMARTSOCKETS Namespace


TipcProtocolMismatchException Class

Thrown trying to send a message to an incompatible peer or server.

For a list of all members of this type, see TipcProtocolMismatchException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcProtocolMismatchException

public class TipcProtocolMismatchException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcProtocolMismatchException Members | TIBCO.SMARTSOCKETS Namespace


TipcProtocolMismatchException Members

TipcProtocolMismatchException overview

Public Instance Constructors

TipcProtocolMismatchException Overloaded. Initializes a new instance of the TipcProtocolMismatchException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcProtocolMismatchException Class | TIBCO.SMARTSOCKETS Namespace


TipcProtocolMismatchException Constructor

Constructs a TipcProtocolMismatchException with null as its error message string.

Overload List

Constructs a TipcProtocolMismatchException with null as its error message string.

public TipcProtocolMismatchException();

Constructs a TipcProtocolMismatchException with an error message.

public TipcProtocolMismatchException(string);

See Also

TipcProtocolMismatchException Class | TIBCO.SMARTSOCKETS Namespace


TipcProtocolMismatchException Constructor ()

Constructs a TipcProtocolMismatchException with null as its error message string.

public TipcProtocolMismatchException();

See Also

TipcProtocolMismatchException Class | TIBCO.SMARTSOCKETS Namespace | TipcProtocolMismatchException Constructor Overload List


TipcProtocolMismatchException Constructor (String)

Constructs a TipcProtocolMismatchException with an error message.

public TipcProtocolMismatchException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcProtocolMismatchException Class | TIBCO.SMARTSOCKETS Namespace | TipcProtocolMismatchException Constructor Overload List


TipcProxyException Class

Thrown when a proxy server returns an error.

For a list of all members of this type, see TipcProxyException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcProxyException

public class TipcProxyException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcProxyException Members | TIBCO.SMARTSOCKETS Namespace


TipcProxyException Members

TipcProxyException overview

Public Instance Constructors

TipcProxyException Overloaded. Initializes a new instance of the TipcProxyException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcProxyException Class | TIBCO.SMARTSOCKETS Namespace


TipcProxyException Constructor

Constructs a TipcProxyException with default values.

Overload List

Constructs a TipcProxyException with default values.

public TipcProxyException();

Constructs a TipcProxyException with an error number and error message.

public TipcProxyException(int,string);

See Also

TipcProxyException Class | TIBCO.SMARTSOCKETS Namespace


TipcProxyException Constructor ()

Constructs a TipcProxyException with default values.

public TipcProxyException();

See Also

TipcProxyException Class | TIBCO.SMARTSOCKETS Namespace | TipcProxyException Constructor Overload List


TipcProxyException Constructor (Int32, String)

Constructs a TipcProxyException with an error number and error message.

public TipcProxyException(
int num,
string s
);

Parameters

num
the error number.
s
the detailed error message.

See Also

TipcProxyException Class | TIBCO.SMARTSOCKETS Namespace | TipcProxyException Constructor Overload List |


TipcQueueCb Interface

The user interface for connection queue callbacks.

Connection queue callbacks are executed when a message is inserted into or deleted from a connection's message queue. Queue callbacks are useful for watching the messages that have been read in from a connection's socket and inserted into the message queue, but not yet processed.

For a list of all members of this type, see TipcQueueCb Members.

public interface TipcQueueCb

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcQueueCb Members | TIBCO.SMARTSOCKETS Namespace |


TipcQueueCb Members

TipcQueueCb overview

Public Instance Methods

queue_cb Method invoked when a message is inserted or removed from the connection's message queue.

See Also

TipcQueueCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcQueueCb Methods

The methods of the TipcQueueCb interface are listed below. For a complete list of TipcQueueCb interface members, see the TipcQueueCb Members topic.

Public Instance Methods

queue_cb Method invoked when a message is inserted or removed from the connection's message queue.

See Also

TipcQueueCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcQueueCb.queue_cb Method

Method invoked when a message is inserted or removed from the connection's message queue.

void queue_cb(
TipcMsg msg,
bool insert_flag,
int position,
object arg
);

Parameters

msg
The message that was inserted or removed.
insert_flag
true if the message was inserted, false otherwise.
position
Queue position to insert/remove message.
arg
The user-defined argument.

See Also

TipcQueueCb Interface | TIBCO.SMARTSOCKETS Namespace


TipcQueueEventArgs Class

This class contains event data for the TipcQueueEvent.

For a list of all members of this type, see TipcQueueEventArgs Members.

System.Object
System.EventArgs
TIBCO.SMARTSOCKETS.TipcQueueEventArgs

public class TipcQueueEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcQueueEventArgs Members | TIBCO.SMARTSOCKETS Namespace


TipcQueueEventArgs Members

TipcQueueEventArgs overview

Public Instance Properties

insertFlag | Returns the boolean flag. True for insert.
Msg | Returns the message
position | Returns the position in queue where message is either inserted or deleted.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcQueueEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcQueueEventArgs Properties

The properties of the TipcQueueEventArgs class are listed below. For a complete list of TipcQueueEventArgs class members, see the TipcQueueEventArgs Members topic.

Public Instance Properties

insertFlag | Returns the boolean flag. True for insert.
Msg | Returns the message
position | Returns the position in queue where message is either inserted or deleted.

See Also

TipcQueueEventArgs Class | TIBCO.SMARTSOCKETS Namespace


insertFlag Property

SmartSockets .NET Class Library

TipcQueueEventArgs.insertFlag Property

Returns the boolean flag. True for insert.

public bool insertFlag {get;}

See Also

TipcQueueEventArgs Class | TIBCO.SMARTSOCKETS Namespace


Msg Property

SmartSockets .NET Class Library

TipcQueueEventArgs.Msg Property

Returns the message

public TipcMsg Msg {get;}

See Also

TipcQueueEventArgs Class | TIBCO.SMARTSOCKETS Namespace


position Property

SmartSockets .NET Class Library

TipcQueueEventArgs.position Property

Returns the position in queue where message is either inserted or deleted.

public int position {get;}

See Also

TipcQueueEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcQueueHandler Delegate

Represents the method that will handle the TipcQueueEvent event.

public delegate void TipcQueueHandler(
object sender,
TipcQueueEventArgs e
);

Parameters

sender
The source of the event.
e
The TipcQueueEventArgs that contains the event data.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TIBCO.SMARTSOCKETS Namespace


TipcReadCb Interface

The user interface for connection read callbacks.

Connection read callbacks are executed when an incoming message is read from a connection's socket into the read buffer and first unpacked into a message. Read callbacks are most commonly used for writing incoming messages to message files.

For a list of all members of this type, see TipcReadCb Members.

public interface TipcReadCb

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcReadCb Members | TIBCO.SMARTSOCKETS Namespace |


TipcReadCb Members

TipcReadCb overview

Public Instance Methods

read Method invoked when a message is read from the socket.

See Also

TipcReadCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcReadCb Methods

The methods of the TipcReadCb interface are listed below. For a complete list of TipcReadCb interface members, see the TipcReadCb Members topic.

Public Instance Methods

read Method invoked when a message is read from the socket.

See Also

TipcReadCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcReadCb.read Method

Method invoked when a message is read from the socket.

void read(
TipcMsg msg,
object arg
);

Parameters

msg
The message.
arg
The user-defined argument.

See Also

TipcReadCb Interface | TIBCO.SMARTSOCKETS Namespace


TipcReadEventArgs Class

This class contains event data for the TipcReadEvent.

For a list of all members of this type, see TipcReadEventArgs Members.

System.Object
System.EventArgs
TIBCO.SMARTSOCKETS.TipcReadEventArgs

public class TipcReadEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcReadEventArgs Members | TIBCO.SMARTSOCKETS Namespace


TipcReadEventArgs Members

TipcReadEventArgs overview

Public Instance Properties

Msg Returns the message.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcReadEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcReadEventArgs Properties

The properties of the TipcReadEventArgs class are listed below. For a complete list of TipcReadEventArgs class members, see the TipcReadEventArgs Members topic.

Public Instance Properties

Msg Returns the message.

See Also

TipcReadEventArgs Class | TIBCO.SMARTSOCKETS Namespace


Msg Property

SmartSockets .NET Class Library

TipcReadEventArgs.Msg Property

Returns the message.

public TipcMsg Msg {get;}

See Also

TipcReadEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcReadHandler Delegate

Represents the method that will handle the TipcReadEvent event.

public delegate void TipcReadHandler(
object sender,
TipcReadEventArgs e
);

Parameters

sender
The source of the event.
e
The TipcReadEventArgs that contains the event data.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TIBCO.SMARTSOCKETS Namespace


TipcReadOnlyException Class

Thrown when the requested object is readonly by a method.

For a list of all members of this type, see TipcReadOnlyException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcReadOnlyException

public class TipcReadOnlyException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcReadOnlyException Members | TIBCO.SMARTSOCKETS Namespace


TipcReadOnlyException Members

TipcReadOnlyException overview

Public Instance Constructors

TipcReadOnlyException Overloaded. Initializes a new instance of the TipcReadOnlyException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcReadOnlyException Class | TIBCO.SMARTSOCKETS Namespace


TipcReadOnlyException Constructor

Constructs a TipcReadOnlyException with null as its error message string.

Overload List

Constructs a TipcReadOnlyException with null as its error message string.

public TipcReadOnlyException();

Constructs a TipcReadOnlyException with an error message.

public TipcReadOnlyException(string);

See Also

TipcReadOnlyException Class | TIBCO.SMARTSOCKETS Namespace


TipcReadOnlyException Constructor ()

Constructs a TipcReadOnlyException with null as its error message string.

public TipcReadOnlyException();

See Also

TipcReadOnlyException Class | TIBCO.SMARTSOCKETS Namespace | TipcReadOnlyException Constructor Overload List


TipcReadOnlyException Constructor (String)

Constructs a TipcReadOnlyException with an error message.

public TipcReadOnlyException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcReadOnlyException Class | TIBCO.SMARTSOCKETS Namespace | TipcReadOnlyException Constructor Overload List


TipcRuntimeException Class

Superclass of all SmartSockets runtime exceptions.

For a list of all members of this type, see TipcRuntimeException Members.

System.Object
System.Exception
System.SystemException
TIBCO.SMARTSOCKETS.TipcRuntimeException
TIBCO.SMARTSOCKETS.TipcAssertionException

public class TipcRuntimeException : SystemException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcRuntimeException Members | TIBCO.SMARTSOCKETS Namespace


TipcRuntimeException Members

TipcRuntimeException overview

Public Instance Constructors

TipcRuntimeException Overloaded. Initializes a new instance of the TipcRuntimeException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcRuntimeException Class | TIBCO.SMARTSOCKETS Namespace


TipcRuntimeException Constructor

Constructs a TipcRuntimeException with null as its error message string.

Overload List

Constructs a TipcRuntimeException with null as its error message string.

public TipcRuntimeException();

Constructs a TipcRuntimeException with an error message.

public TipcRuntimeException(string);

See Also

TipcRuntimeException Class | TIBCO.SMARTSOCKETS Namespace


TipcRuntimeException Constructor ()

Constructs a TipcRuntimeException with null as its error message string.

public TipcRuntimeException();

See Also

TipcRuntimeException Class | TIBCO.SMARTSOCKETS Namespace | TipcRuntimeException Constructor Overload List


TipcRuntimeException Constructor (String)

Constructs a TipcRuntimeException with an error message.

public TipcRuntimeException(
string s
);

Parameters

s
the detail message

See Also

TipcRuntimeException Class | TIBCO.SMARTSOCKETS Namespace | TipcRuntimeException Constructor Overload List


TipcSearcher Interface

The user interface for the search function required by search. This method will be called as the connection's message queue is traversed. This method should return true if the message matches the required criteria, false if it does not.

For a list of all members of this type, see TipcSearcher Members.

public interface TipcSearcher

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcSearcher Members | TIBCO.SMARTSOCKETS Namespace |


TipcSearcher Members

TipcSearcher overview

Public Instance Methods

search The method invoked by search.

See Also

TipcSearcher Interface | TIBCO.SMARTSOCKETS Namespace |


TipcSearcher Methods

The methods of the TipcSearcher interface are listed below. For a complete list of TipcSearcher interface members, see the TipcSearcher Members topic.

Public Instance Methods

search The method invoked by search.

See Also

TipcSearcher Interface | TIBCO.SMARTSOCKETS Namespace |


TipcSearcher.search Method

The method invoked by search.

bool search(
TipcMsg msg,
object arg
);

Parameters

msg
The next message in the queue.
arg
The user-defined argument.

See Also

TipcSearcher Interface | TIBCO.SMARTSOCKETS Namespace


TipcSrv Class

Provides an interface to RTserver connections.

The single, global RTserver connection instance of this class is returned through Srv.

This is a subclass of TipcConnClient, and much of the interesting functionality is provided by that class.

An RTserver must be running before any attempt is made to connect to it. This class will automatically try to connect to any RTservers that appear in the"ss.server_names" option, trying each RTserver in turn until it successfully connects to one.

For a list of all members of this type, see TipcSrv Members.

System.Object
TIBCO.SMARTSOCKETS.TipcConnClient
TIBCO.SMARTSOCKETS.TipcSrv

public class TipcSrv : TipcConnClient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcSrv Members | TIBCO.SMARTSOCKETS Namespace


TipcSrv Members

TipcSrv overview

Public Instance Properties

Arch (inherited from TipcConnClient) | Returns the architecture this client is running on.
AutoFlushSize (inherited from TipcConnClient) | Gets/Sets the number of bytes buffered before the outbound queue is automatically flushed, or 0 if this behavior is disabled, in which case manual calls to flush are required to empty the outbound queue.
BlockMode (inherited from TipcConnClient) | Gets/Sets the blocking mode. This is true (i.e., block) by default.
ConnStatus | Returns true if this process is connected to RTserver, false otherwise.
ConnStatusEx | Returns the status of the connection, CONN_WARM, CONN_NONE, or CONN_FULL,
DefaultControlCb (inherited from TipcConnClient) | Gets the default callback for CONTROL messages.
DefaultErrorCb | Gets the default RTclient error callback. This is useful if you wish to replace the default error callback. The returned TipcCb object can be passed to the removeErrorCb method. The default RTclient error callback first calls destroy to destroy the current connection to the RTserver, then calls create to create a new connection to the RTserver.
DefaultGmdFailureCb (inherited from TipcConnClient) | Gets the default callback for GMD_FAILURE messages.
GmdNumPending (inherited from TipcConnClient) | Gets the number of GMD messages that have been sent but not ack'd or deleted.
LocalPid (inherited from TipcConnClient) | Gets/Sets the local pid for this connection.
Node (inherited from TipcConnClient) | Gets the node (host) name for the remote machine.
NumQueued (inherited from TipcConnClient) | Get the number of messages queued for reading.
Pid (inherited from TipcConnClient) | Get the pid (process id) for the remote machine.
Properties (inherited from TipcConnClient) | Get this connection's properties.
QueueSize (inherited from TipcConnClient) | Gets the size of the read queue, in bytes.
ReadBufferSize (inherited from TipcConnClient) | Gets the total number of bytes in the connection's read buffer.
Running | Checks if this process is connected to RTserver, and connects if its isn't.
ServerLCN | Gets the fully expanded logical connection name for the server we are connected to.
ServerName | Gets the name of the server we are connected to.
SubscribedList | Gets the list of subjects currently subscribed to.
TrafficBytesRecv (inherited from TipcConnClient) | Gets the total number of bytes received on this connection Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficBytesRecv8.
TrafficBytesRecv8 (inherited from TipcConnClient) | Gets the total number of bytes received on this connection
TrafficBytesSent (inherited from TipcConnClient) | Gets the total number of bytes written to the write buffer on a connection. This number usually is the same as the total number of bytes actually sent on the connection, but sometimes the retrieved number is larger than the number of bytes sent when the write buffer is not frequently flushed. Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficBytesSent8.
TrafficBytesSent8 (inherited from TipcConnClient) | Gets the total number of bytes written to the write buffer on a connection. This number usually is the same as the total number of bytes actually sent on the connection, but sometimes the retrieved number is larger than the number of bytes sent when the write buffer is not frequently flushed.
TrafficMsgsRecv (inherited from TipcConnClient) | Gets the total number of messages received on this connection Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficMsgsRecv8.
TrafficMsgsRecv8 (inherited from TipcConnClient) | Gets the total number of messages received on this connection
TrafficMsgsSent (inherited from TipcConnClient) | Gets the total number of messages written to the write buffer on a connection. This number usually is the same as the total number of messages actually sent on the connection, but sometimes the retrieved number is larger than the number of messages sent when the write buffer is not frequently flushed. Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficMsgsSent8.
TrafficMsgsSent8 (inherited from TipcConnClient) | Gets the total number of messages written to the write buffer on a connection. This number usually is the same as the total number of messages actually sent on the connection, but sometimes the retrieved number is larger than the number of messages sent when the write buffer is not frequently flushed.
UniqueSubject | Returns the unique subject of the connection
User (inherited from TipcConnClient) | Get user id of client process.
WriteBufferSize (inherited from TipcConnClient) | Gets the total number of bytes in the connection's write buffer.

Public Instance Methods

addCreateCb | Overloaded. Adds a callback for the RTserver connection creation with given priority.
addDefaultCb (inherited from TipcConnClient) | Overloaded. Adds a default callback class with given priority. This callback is called if there are no other callbacks defined for a given message type.
addDestroyCb | Overloaded. Adds a callback for the RTserver destruction with given priority.
addErrorCb (inherited from TipcConnClient) | Overloaded. Adds an error callback class with given priority. The error callback is called when certian types of errors occur.
addProcessCb | Overloaded. public implementation
addProcessCb (inherited from TipcConnClient) | Overloaded. Adds a process callback class with given priority. The process callback is called when process is called with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.
addQueueCb (inherited from TipcConnClient) | Overloaded. Adds a queue callback class for message type with given priority. The queue callback is called when a message is inserted or removed from the connection's queue. The queue callback is called when a message is inserted or removed and message has a callback registered with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.
addReadCb (inherited from TipcConnClient) | Overloaded. Adds a read callback class for message type with given priority. The read callback is called when a message is read. It is called before the message is returned by the next method. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.
addWriteBufferChangeCb (inherited from TipcConnClient) | Overloaded. Adds a write buffer change callback class with given priority. The write buffer callbacks are called when the write buffer is either flushed or written to THROUGH the message interface ONLY.
addWriteCb (inherited from TipcConnClient) | Overloaded. Adds a write callback class for message type with given priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.
check | Check for traffic on the connection. If mode is IO_CHECK_READ, this method will return true if there is data available to be read. If , true will be returned if data can be written to the connection without blocking. If the ss.server_read_timeout option is 0.0, this method will block for up the specified timeout. Otherwise, this method will return immediately.
create | Overloaded. Creates the RTserver connection using a specified connection type. Connects to and handshakes with the RTserver process. Does not attempt to auto-start an RTserver if one cannot be contacted. Instead, it will loop through the list of servers specified with ss.server_names option until a connection is made. This process is synchronous. and all other threads that attempt to use the connection will block until this succeeds, or fails completely.
destroy | Overloaded. Destroys (closes) the RTServer connection using a specified connection type.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
flush | Flushes queue data to the connection. This ensures that all buffered data is written immediately. This outbound queue will be flushed automatically when it reaches a set size, set by the ss.server_auto_flush_size option.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getOption (inherited from TipcConnClient) | Convenience method to get an option by name. Typically one would use the getOption method. This method is available for when an option needs to be different for each connection.
getOptionBool (inherited from TipcConnClient) | Convenience method to get an option's boolean value. Typically one would use the getOptionBool method. This method is available for when an option needs to be different for each connection.
getOptionDouble (inherited from TipcConnClient) | Convenience method to get an option's double value. Typically one would use the getOptionDouble method. This method is available for when an option needs to be different for each connection.
getOptionInt (inherited from TipcConnClient) | Convenience method to get an option's int value. Typically one would use the getOptionInt method. This method is available for when an option needs to be different for each connection.
getOptionStr (inherited from TipcConnClient) | Convenience method to get an option's String value. Typically one would use the getOptionStr method. This method is available for when an option needs to be different for each connection.
getSubjectLb | find out if a subject is using load balancing.
getSubjectSubscribe | find out if a subject is subscribed to.
getTimeout (inherited from TipcConnClient) | Get a timeout value. There are several timeout properties associated with a connection: TIMEOUT_READ, TIMEOUT_WRITE, TIMEOUT_KEEP_ALIVE, and TIMEOUT_DELIVERY, all of which are used to check for network failures. This method allows the values of these timeout properties to be inspected. All timeout values are in seconds. The TIMEOUT_READ property specifies the length of time that no data is read on the connection before a keep alive message is exchanged with remote end. If this is set to 0.0, the connection will block forever waiting for data to arrive and no keep alives will be generated. The TIMEOUT_KEEP_ALIVE property is the length of time the client will wait for a reply to a keep alive request. If this timeout expires, the error callback will be called with a timeout error code. The TIMEOUT_DELIVERY property is the length of time the client will wait for an ack to arrive for amessage sent with GMD. If this expires, a GMD_FAILURE message will be generated and processed by the client. The TIMEOUT_WRITE property is not implemented in this release.
GetType (inherited from Object) | Gets the Type of the current instance.
gmdFileDelete (inherited from TipcConnClient) | Removes GMD files from disk.
gmdMsgAck (inherited from TipcConnClient) | Acknowledges a message sent with GMD.
gmdMsgDelete (inherited from TipcConnClient) | Delete a message from the local spool.
gmdMsgResend (inherited from TipcConnClient) | Resends a message previously sent with GMD. This should only be used within a GMD_FAILURE callback.
gmdMsgServerDelete | Deletes a GMD message from RTserver's spool. Use gmdMsgDelete to delete a message from the local spool. This method fails silently if the msg doesn't exist.
gmdMsgStatus | Gets the status of the gmd message.
gmdResend (inherited from TipcConnClient) | Resends all spooled messages. For Rtserver connections, method will be called automatically when a connection is re-made, so there is no need to call it yourself. Caution: this method should only be used when a connection is first created. This method resends messages with GMD, but does not explicitly flush the messags. You may need to invoke flush.
insert (inherited from TipcConnClient) | Insert a message into the inbound queue. For inserting messages to be processed as though they were received from the socket, or re-inserting messages that have been removed, but cannot be processed immediately.
keepAlive (inherited from TipcConnClient) | Send a keep alive message to the other end and wait synchronously for a response. The amount of time to wait is set by the KEEP_ALIVE timeout. If the keep alive timeout expires before the other end of the connection responds, this method will fail.
loadOptionsStream (inherited from TipcConnClient) | Loads an option file from an InputStream. Loaded options override existing options with the same key. Typically one would use the loadOptionsStream method. This method is available for when an option needs to be different for each connection.
logAddMt | Overloaded. Adds a message type for message logging. Messages will logged to the file specified by the options: ss.log_out_data, ss.log_in_data, ss_log_out_status. ss.log_in_status, ss.log_out_internal, and ss.log_in_internal And based upon the logging type.
logRemoveMt | Overloaded. Removes a message type from message logging.
lookupCreateCb | Looks up a callback for the RTserver connection creation
lookupDefaultCb (inherited from TipcConnClient) | Looks up callback for default message processing.
lookupDestroyCb | Looks up a callback for the RTserver destruction.
lookupErrorCb (inherited from TipcConnClient) | Looks up callback for error processing.
lookupProcessCb | Overloaded. public implementation
lookupProcessCb (inherited from TipcConnClient) | Overloaded. Looks up callback for process message processing.
lookupQueueCb (inherited from TipcConnClient) | Overloaded. Looks up callback for queued message processing.
lookupReadCb (inherited from TipcConnClient) | Overloaded. Looks up callback for message reading.
lookupWriteBufferChangeCb (inherited from TipcConnClient) | Looks up callback for write buffer change processing.
lookupWriteCb (inherited from TipcConnClient) | Overloaded. Looks up callback for message writing.
mainLoop (inherited from TipcConnClient) | Loop for the specified timeout, reading and processing messages from the connection. This is a convenience method, which employs a loop doing next, process, and ack. To specify an infinite loop, pass TIMEOUT_FOREVER.
makeSubjectAbsolute (inherited from TipcConnClient) | If the subject isn't absolute (doesn't start with "/"), tack on the default subject prefix, if is exists. If the prefix isn't set to anything, it simply returns the original name untouched.
next | Get messages from the inbound queue. If no messages are waiting in the inbound queue then this method will wait for the specified timeout for a message to arrive.
process | Process a message by calling the process callback for that message's type. A callback may be setup to process messages as they arrive. This method calls those callbacks.
processCacheRequest | set Caching Interface
read (inherited from TipcConnClient) | Read traffic. This is functionally equivalent to calling check with IO_CHECK_READ mode. The background reader thread will fill the inbound message queue with any messages that arrive during the timeout period.
removeCreateCb | Removes a callback for the RTserver connection creation.
removeDefaultCb (inherited from TipcConnClient) | Remove a default callback class.
removeDestroyCb | Removes a callback for the RTserver destruction.
removeErrorCb (inherited from TipcConnClient) | Remove a error callback class.
removeProcessCb | Removes a callback for the RTserver connection.
removeQueueCb (inherited from TipcConnClient) | Remove a queue callback class.
removeReadCb (inherited from TipcConnClient) | Remove a read callback class.
removeTrafficCb (inherited from TipcConnClient) | Remove a traffic callback class.
removeWriteBufferChangeCb (inherited from TipcConnClient) | Remove a write buffer change callback class.
removeWriteCb (inherited from TipcConnClient) | Remove a write callback class.
search (inherited from TipcConnClient) | Find a message in the inbound queue, using a user-provided matching method. This method scans the inbound queue, calling a user-provided method that is handed each message in turn to see if it matches the desired criteria. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.
searchType (inherited from TipcConnClient) | Overloaded. Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.
searchType | Overloaded. Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.
searchTypeNoFlush (inherited from TipcConnClient) | Searches for a message of a particular type without flushing the outbound queue first.
send | Send a message. This method actually queues the data for later transmission. It is not actually sent until flush is called, either by the user directly, or by the auto-flush mechanism, based on the buffer size. The auto-flush mechanism is regulated by the ss.server_auto_flush_size option.
sendRpc | Send a RPC message.
setOption (inherited from TipcConnClient) | Convenience method to set an option by name. Typically one would use the setOption method. This method is available for when an option needs to be different for each connection.
setSubjectSubscribe | set the subscribe status on a subject.
setSubjectSubscribeEx | Extended Subscribe/Unsubscribe
setSubjectSubscribeLb | set the subscribe and load balancing status on a subject.
setTimeout (inherited from TipcConnClient) | Set a timeout value. See the getTimeout method for an explanation of connection timeout properties.
setUsernamePassword | Sets the username and password for the RTclient when connecting to an RTserver with the Basic Security Driver installed. The password is immediately encrypted and is never sent in plain text to the RTserver.
subjectGmdInit | initializes GMD. This has not yet been implemented.
subjectLbInit | initializes load balancing.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

TipcErrorEvent (inherited from TipcConnClient) Occurs when an error occurs on a connection. Connection Error events are raised when an unrecoverable error occurs. These errors include socket problems and network failures such as:
  • A read timeout has occured and the keep-alive then failed.
  • A write timeout has occured.
  • A read operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.
  • A write operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.
TipcMsgEvent (inherited from TipcConnClient) | Occurs when a message is processed. Connection process events are raised while processing a message. This callback type is the most frequently used. A process delegate method is called for every of message received. When any message of any type is processed by calling process or mainLoop, the process callback is called.
TipcQueueEvent (inherited from TipcConnClient) | Occurs with message queue events. Connection queue events are raised when a message is inserted into or deleted from a connection's message queue. Queue events are useful for watching the messages that have been read in from a connection's socket and inserted into the message queue, but not yet processed.
TipcReadEvent (inherited from TipcConnClient) | Occurs when a message is read from a connection. Connection read events are raised when an incoming message is read from a connection's socket into the read buffer and first unpacked into a message. Read events are most commonly used for writing incoming messages to message files.
TipcSrvCreateEvent | Occurs when a connection to RTserver is created. Server create callbacks are called when an RTclient creates either a full or warm connection to the RTserver. If an RTclient creates and destoys its connection to the RTserver many times, it should use server create handlers to create the other handlers needed in the connection to RTserver.
TipcSrvDestroyEvent | Occurs when a connection to RTserver is destroyed. Server destroy callbacks are called when an RTclient destroys its connection to the RTserver, leaving either a warm connection or no connection. Server destroy callbacks are the opposite of server create callbacks. Server destroy handlers are useful for RTclients that need to know when the connection to the RTserver no longer has a valid socket, such as RTclients that are also GUI programs.
TipcWriteBufferChangeEvent (inherited from TipcConnClient) | Occurs when the write buffer is accessed. Write buffer change events are raised when data is either flushed from the write buffer or written into write buffer THROUGH the message interface (i.e. with send(msg)) ONLY.
TipcWriteEvent (inherited from TipcConnClient) | Occurs when a message is written to a connection. Connection write events are raised when an outgoing message is sent to a connection (that is, copied to a connection's write buffer). Write events are most commonly used for writing outgoing messages to message files.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

handleOptionPoll protected implemenation of TipcConnClient.handleOptionPoll

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv Properties

The properties of the TipcSrv class are listed below. For a complete list of TipcSrv class members, see the TipcSrv Members topic.

Public Instance Properties

Arch (inherited from TipcConnClient) | Returns the architecture this client is running on.
AutoFlushSize (inherited from TipcConnClient) | Gets/Sets the number of bytes buffered before the outbound queue is automatically flushed, or 0 if this behavior is disabled, in which case manual calls to flush are required to empty the outbound queue.
BlockMode (inherited from TipcConnClient) | Gets/Sets the blocking mode. This is true (i.e., block) by default.
ConnStatus | Returns true if this process is connected to RTserver, false otherwise.
ConnStatusEx | Returns the status of the connection, CONN_WARM, CONN_NONE, or CONN_FULL,
DefaultControlCb (inherited from TipcConnClient) | Gets the default callback for CONTROL messages.
DefaultErrorCb | Gets the default RTclient error callback. This is useful if you wish to replace the default error callback. The returned TipcCb object can be passed to the removeErrorCb method. The default RTclient error callback first calls destroy to destroy the current connection to the RTserver, then calls create to create a new connection to the RTserver.
DefaultGmdFailureCb (inherited from TipcConnClient) | Gets the default callback for GMD_FAILURE messages.
GmdNumPending (inherited from TipcConnClient) | Gets the number of GMD messages that have been sent but not ack'd or deleted.
LocalPid (inherited from TipcConnClient) | Gets/Sets the local pid for this connection.
Node (inherited from TipcConnClient) | Gets the node (host) name for the remote machine.
NumQueued (inherited from TipcConnClient) | Get the number of messages queued for reading.
Pid (inherited from TipcConnClient) | Get the pid (process id) for the remote machine.
Properties (inherited from TipcConnClient) | Get this connection's properties.
QueueSize (inherited from TipcConnClient) | Gets the size of the read queue, in bytes.
ReadBufferSize (inherited from TipcConnClient) | Gets the total number of bytes in the connection's read buffer.
Running | Checks if this process is connected to RTserver, and connects if its isn't.
ServerLCN | Gets the fully expanded logical connection name for the server we are connected to.
ServerName | Gets the name of the server we are connected to.
SubscribedList | Gets the list of subjects currently subscribed to.
TrafficBytesRecv (inherited from TipcConnClient) | Gets the total number of bytes received on this connection Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficBytesRecv8.
TrafficBytesRecv8 (inherited from TipcConnClient) | Gets the total number of bytes received on this connection
TrafficBytesSent (inherited from TipcConnClient) | Gets the total number of bytes written to the write buffer on a connection. This number usually is the same as the total number of bytes actually sent on the connection, but sometimes the retrieved number is larger than the number of bytes sent when the write buffer is not frequently flushed. Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficBytesSent8.
TrafficBytesSent8 (inherited from TipcConnClient) | Gets the total number of bytes written to the write buffer on a connection. This number usually is the same as the total number of bytes actually sent on the connection, but sometimes the retrieved number is larger than the number of bytes sent when the write buffer is not frequently flushed.
TrafficMsgsRecv (inherited from TipcConnClient) | Gets the total number of messages received on this connection Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficMsgsRecv8.
TrafficMsgsRecv8 (inherited from TipcConnClient) | Gets the total number of messages received on this connection
TrafficMsgsSent (inherited from TipcConnClient) | Gets the total number of messages written to the write buffer on a connection. This number usually is the same as the total number of messages actually sent on the connection, but sometimes the retrieved number is larger than the number of messages sent when the write buffer is not frequently flushed. Note: The result is truncated to 31 bits, and may contain an incorrect sign bit on some older clients. New clients should use TrafficMsgsSent8.
TrafficMsgsSent8 (inherited from TipcConnClient) | Gets the total number of messages written to the write buffer on a connection. This number usually is the same as the total number of messages actually sent on the connection, but sometimes the retrieved number is larger than the number of messages sent when the write buffer is not frequently flushed.
UniqueSubject | Returns the unique subject of the connection
User (inherited from TipcConnClient) | Get user id of client process.
WriteBufferSize (inherited from TipcConnClient) | Gets the total number of bytes in the connection's write buffer.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


ConnStatus Property

SmartSockets .NET Class Library

TipcSrv.ConnStatus Property

Returns true if this process is connected to RTserver, false otherwise.

public virtual bool ConnStatus {get;}

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


ConnStatusEx Property

SmartSockets .NET Class Library

TipcSrv.ConnStatusEx Property

Returns the status of the connection, CONN_WARM, CONN_NONE, or CONN_FULL,

public virtual int ConnStatusEx {get;}

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


DefaultErrorCb Property

SmartSockets .NET Class Library

TipcSrv.DefaultErrorCb Property

Gets the default RTclient error callback. This is useful if you wish to replace the default error callback. The returned TipcCb object can be passed to the removeErrorCb method.

The default RTclient error callback first calls destroy to destroy the current connection to the RTserver, then calls create to create a new connection to the RTserver.

public virtual TipcCb DefaultErrorCb {get;}

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


Running Property

SmartSockets .NET Class Library

TipcSrv.Running Property

Checks if this process is connected to RTserver, and connects if its isn't.

public virtual bool Running {get;}

Exceptions

Exception Type | Condition
TipcTimeoutException | if the client timed out waiting for RTserver to reply to a connection request.
TipcAccessDeniedException | If the server replied, but deined access. This is usually because the client's unique subject isn't unique within the client's project.
TipcIOException | For unrecoverable network failures.
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


ServerLCN Property

SmartSockets .NET Class Library

TipcSrv.ServerLCN Property

Gets the fully expanded logical connection name for the server we are connected to.

public virtual string ServerLCN {get;}

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


ServerName Property

SmartSockets .NET Class Library

TipcSrv.ServerName Property

Gets the name of the server we are connected to.

public virtual string ServerName {get;}

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


SubscribedList Property

SmartSockets .NET Class Library

TipcSrv.SubscribedList Property

Gets the list of subjects currently subscribed to.

public virtual string[] SubscribedList {get;}

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


UniqueSubject Property

SmartSockets .NET Class Library

TipcSrv.UniqueSubject Property

Returns the unique subject of the connection

public override string UniqueSubject {get;}

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv Methods

The methods of the TipcSrv class are listed below. For a complete list of TipcSrv class members, see the TipcSrv Members topic.

Public Instance Methods

addCreateCb | Overloaded. Adds a callback for the RTserver connection creation with given priority.
addDefaultCb (inherited from TipcConnClient) | Overloaded. Adds a default callback class with given priority. This callback is called if there are no other callbacks defined for a given message type.
addDestroyCb | Overloaded. Adds a callback for the RTserver destruction with given priority.
addErrorCb (inherited from TipcConnClient) | Overloaded. Adds an error callback class with given priority. The error callback is called when certian types of errors occur.
addProcessCb | Overloaded. public implementation
addProcessCb (inherited from TipcConnClient) | Overloaded. Adds a process callback class with given priority. The process callback is called when process is called with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.
addQueueCb (inherited from TipcConnClient) | Overloaded. Adds a queue callback class for message type with given priority. The queue callback is called when a message is inserted or removed from the connection's queue. The queue callback is called when a message is inserted or removed and message has a callback registered with a message matching the provided message type. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the cast. you can use the mt number version instead, and pass a 0 as the mt number.
addReadCb (inherited from TipcConnClient) | Overloaded. Adds a read callback class for message type with given priority. The read callback is called when a message is read. It is called before the message is returned by the next method. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.
addWriteBufferChangeCb (inherited from TipcConnClient) | Overloaded. Adds a write buffer change callback class with given priority. The write buffer callbacks are called when the write buffer is either flushed or written to THROUGH the message interface ONLY.
addWriteCb (inherited from TipcConnClient) | Overloaded. Adds a write callback class for message type with given priority. The write callback is called when a message is written. It is called when the message is actually sent, not when the send method is called. The message type parameter may be null, which means that all message types will be passed to this method. However, if you use the null form, you must cast the null to TipcMt, or the compiler will be unable to resolve which version of this method you wish: this one, or the version that takes a mt number parameter. To avoid the case, you can use the mt number version instead, and pass a 0 as the mt number.
check | Check for traffic on the connection. If mode is IO_CHECK_READ, this method will return true if there is data available to be read. If , true will be returned if data can be written to the connection without blocking. If the ss.server_read_timeout option is 0.0, this method will block for up the specified timeout. Otherwise, this method will return immediately.
create | Overloaded. Creates the RTserver connection using a specified connection type. Connects to and handshakes with the RTserver process. Does not attempt to auto-start an RTserver if one cannot be contacted. Instead, it will loop through the list of servers specified with ss.server_names option until a connection is made. This process is synchronous. and all other threads that attempt to use the connection will block until this succeeds, or fails completely.
destroy | Overloaded. Destroys (closes) the RTServer connection using a specified connection type.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
flush | Flushes queue data to the connection. This ensures that all buffered data is written immediately. This outbound queue will be flushed automatically when it reaches a set size, set by the ss.server_auto_flush_size option.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getOption (inherited from TipcConnClient) | Convenience method to get an option by name. Typically one would use the getOption method. This method is available for when an option needs to be different for each connection.
getOptionBool (inherited from TipcConnClient) | Convenience method to get an option's boolean value. Typically one would use the getOptionBool method. This method is available for when an option needs to be different for each connection.
getOptionDouble (inherited from TipcConnClient) | Convenience method to get an option's double value. Typically one would use the getOptionDouble method. This method is available for when an option needs to be different for each connection.
getOptionInt (inherited from TipcConnClient) | Convenience method to get an option's int value. Typically one would use the getOptionInt method. This method is available for when an option needs to be different for each connection.
getOptionStr (inherited from TipcConnClient) | Convenience method to get an option's String value. Typically one would use the getOptionStr method. This method is available for when an option needs to be different for each connection.
getSubjectLb | find out if a subject is using load balancing.
getSubjectSubscribe | find out if a subject is subscribed to.
getTimeout (inherited from TipcConnClient) | Get a timeout value. There are several timeout properties associated with a connection: TIMEOUT_READ, TIMEOUT_WRITE, TIMEOUT_KEEP_ALIVE, and TIMEOUT_DELIVERY, all of which are used to check for network failures. This method allows the values of these timeout properties to be inspected. All timeout values are in seconds. The TIMEOUT_READ property specifies the length of time that no data is read on the connection before a keep alive message is exchanged with remote end. If this is set to 0.0, the connection will block forever waiting for data to arrive and no keep alives will be generated. The TIMEOUT_KEEP_ALIVE property is the length of time the client will wait for a reply to a keep alive request. If this timeout expires, the error callback will be called with a timeout error code. The TIMEOUT_DELIVERY property is the length of time the client will wait for an ack to arrive for amessage sent with GMD. If this expires, a GMD_FAILURE message will be generated and processed by the client. The TIMEOUT_WRITE property is not implemented in this release.
GetType (inherited from Object) | Gets the Type of the current instance.
gmdFileDelete (inherited from TipcConnClient) | Removes GMD files from disk.
gmdMsgAck (inherited from TipcConnClient) | Acknowledges a message sent with GMD.
gmdMsgDelete (inherited from TipcConnClient) | Delete a message from the local spool.
gmdMsgResend (inherited from TipcConnClient) | Resends a message previously sent with GMD. This should only be used within a GMD_FAILURE callback.
gmdMsgServerDelete | Deletes a GMD message from RTserver's spool. Use gmdMsgDelete to delete a message from the local spool. This method fails silently if the msg doesn't exist.
gmdMsgStatus | Gets the status of the gmd message.
gmdResend (inherited from TipcConnClient) | Resends all spooled messages. For Rtserver connections, method will be called automatically when a connection is re-made, so there is no need to call it yourself. Caution: this method should only be used when a connection is first created. This method resends messages with GMD, but does not explicitly flush the messags. You may need to invoke flush.
insert (inherited from TipcConnClient) | Insert a message into the inbound queue. For inserting messages to be processed as though they were received from the socket, or re-inserting messages that have been removed, but cannot be processed immediately.
keepAlive (inherited from TipcConnClient) | Send a keep alive message to the other end and wait synchronously for a response. The amount of time to wait is set by the KEEP_ALIVE timeout. If the keep alive timeout expires before the other end of the connection responds, this method will fail.
loadOptionsStream (inherited from TipcConnClient) | Loads an option file from an InputStream. Loaded options override existing options with the same key. Typically one would use the loadOptionsStream method. This method is available for when an option needs to be different for each connection.
logAddMt | Overloaded. Adds a message type for message logging. Messages will logged to the file specified by the options: ss.log_out_data, ss.log_in_data, ss_log_out_status. ss.log_in_status, ss.log_out_internal, and ss.log_in_internal And based upon the logging type.
logRemoveMt | Overloaded. Removes a message type from message logging.
lookupCreateCb | Looks up a callback for the RTserver connection creation
lookupDefaultCb (inherited from TipcConnClient) | Looks up callback for default message processing.
lookupDestroyCb | Looks up a callback for the RTserver destruction.
lookupErrorCb (inherited from TipcConnClient) | Looks up callback for error processing.
lookupProcessCb | Overloaded. public implementation
lookupProcessCb (inherited from TipcConnClient) | Overloaded. Looks up callback for process message processing.
lookupQueueCb (inherited from TipcConnClient) | Overloaded. Looks up callback for queued message processing.
lookupReadCb (inherited from TipcConnClient) | Overloaded. Looks up callback for message reading.
lookupWriteBufferChangeCb (inherited from TipcConnClient) | Looks up callback for write buffer change processing.
lookupWriteCb (inherited from TipcConnClient) | Overloaded. Looks up callback for message writing.
mainLoop (inherited from TipcConnClient) | Loop for the specified timeout, reading and processing messages from the connection. This is a convenience method, which employs a loop doing next, process, and ack. To specify an infinite loop, pass TIMEOUT_FOREVER.
makeSubjectAbsolute (inherited from TipcConnClient) | If the subject isn't absolute (doesn't start with "/"), tack on the default subject prefix, if is exists. If the prefix isn't set to anything, it simply returns the original name untouched.
next | Get messages from the inbound queue. If no messages are waiting in the inbound queue then this method will wait for the specified timeout for a message to arrive.
process | Process a message by calling the process callback for that message's type. A callback may be setup to process messages as they arrive. This method calls those callbacks.
processCacheRequest | set Caching Interface
read (inherited from TipcConnClient) | Read traffic. This is functionally equivalent to calling check with IO_CHECK_READ mode. The background reader thread will fill the inbound message queue with any messages that arrive during the timeout period.
removeCreateCb | Removes a callback for the RTserver connection creation.
removeDefaultCb (inherited from TipcConnClient) | Remove a default callback class.
removeDestroyCb | Removes a callback for the RTserver destruction.
removeErrorCb (inherited from TipcConnClient) | Remove a error callback class.
removeProcessCb | Removes a callback for the RTserver connection.
removeQueueCb (inherited from TipcConnClient) | Remove a queue callback class.
removeReadCb (inherited from TipcConnClient) | Remove a read callback class.
removeTrafficCb (inherited from TipcConnClient) | Remove a traffic callback class.
removeWriteBufferChangeCb (inherited from TipcConnClient) | Remove a write buffer change callback class.
removeWriteCb (inherited from TipcConnClient) | Remove a write callback class.
search (inherited from TipcConnClient) | Find a message in the inbound queue, using a user-provided matching method. This method scans the inbound queue, calling a user-provided method that is handed each message in turn to see if it matches the desired criteria. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.
searchType (inherited from TipcConnClient) | Overloaded. Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.
searchType | Overloaded. Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.
searchTypeNoFlush (inherited from TipcConnClient) | Searches for a message of a particular type without flushing the outbound queue first.
send | Send a message. This method actually queues the data for later transmission. It is not actually sent until flush is called, either by the user directly, or by the auto-flush mechanism, based on the buffer size. The auto-flush mechanism is regulated by the ss.server_auto_flush_size option.
sendRpc | Send a RPC message.
setOption (inherited from TipcConnClient) | Convenience method to set an option by name. Typically one would use the setOption method. This method is available for when an option needs to be different for each connection.
setSubjectSubscribe | set the subscribe status on a subject.
setSubjectSubscribeEx | Extended Subscribe/Unsubscribe
setSubjectSubscribeLb | set the subscribe and load balancing status on a subject.
setTimeout (inherited from TipcConnClient) | Set a timeout value. See the getTimeout method for an explanation of connection timeout properties.
setUsernamePassword | Sets the username and password for the RTclient when connecting to an RTserver with the Basic Security Driver installed. The password is immediately encrypted and is never sent in plain text to the RTserver.
subjectGmdInit | initializes GMD. This has not yet been implemented.
subjectLbInit | initializes load balancing.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

handleOptionPoll protected implemenation of TipcConnClient.handleOptionPoll

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


addCreateCb Method

SmartSockets .NET Class Library

TipcSrv.addCreateCb Method

Adds a callback for the RTserver connection creation with given priority.

Overload List

Adds a callback for the RTserver connection creation with given priority.

public virtual TipcCb addCreateCb(TipcCreateCb,short,object);

Adds a callback for the RTserver connection creation with default priority.

public virtual TipcCb addCreateCb(TipcCreateCb,object);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.addCreateCb Method (TipcCreateCb, Int16, Object)

Adds a callback for the RTserver connection creation with given priority.

public virtual TipcCb addCreateCb(
TipcCreateCb l,
short priority,
object arg
);

Parameters

l
The callback to add.
priority
The priority of the callback.
arg
user-defined argument to pass to callback.

Return Value

The newly created callback.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.addCreateCb Overload List


TipcSrv.addCreateCb Method (TipcCreateCb, Object)

Adds a callback for the RTserver connection creation with default priority.

public virtual TipcCb addCreateCb(
TipcCreateCb l,
object arg
);

Parameters

l
The callback to add.
arg
user-defined argument to pass to callback.

Return Value

The newly created callback.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.addCreateCb Overload List


addDestroyCb Method

SmartSockets .NET Class Library

TipcSrv.addDestroyCb Method

Adds a callback for the RTserver destruction with given priority.

Overload List

Adds a callback for the RTserver destruction with given priority.

public virtual TipcCb addDestroyCb(TipcDestroyCb,short,object);

Adds a callback for the RTserver destruction with default priority.

public virtual TipcCb addDestroyCb(TipcDestroyCb,object);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.addDestroyCb Method (TipcDestroyCb, Int16, Object)

Adds a callback for the RTserver destruction with given priority.

public virtual TipcCb addDestroyCb(
TipcDestroyCb l,
short priority,
object arg
);

Parameters

l
The callback to add.
priority
The priority of the callback.
arg
user-defined argument to pass to callback.

Return Value

The newly created callback.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.addDestroyCb Overload List


TipcSrv.addDestroyCb Method (TipcDestroyCb, Object)

Adds a callback for the RTserver destruction with default priority.

public virtual TipcCb addDestroyCb(
TipcDestroyCb l,
object arg
);

Parameters

l
The callback to add.
arg
user-defined argument to pass to callback.

Return Value

The newly created callback.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.addDestroyCb Overload List


addProcessCb Method

SmartSockets .NET Class Library

TipcSrv.addProcessCb Method

public implementation

Overload List

Inherited from TipcConnClient.

public virtual TipcCb addProcessCb(TipcProcessCb,int,short,object);

Inherited from TipcConnClient.

public virtual TipcCb addProcessCb(TipcProcessCb,int,object);

public implementation

public virtual TipcCb addProcessCb(TipcProcessCb,string,short,object);

public implementation

public virtual TipcCb addProcessCb(TipcProcessCb,string,object);

Inherited from TipcConnClient.

public virtual TipcCb addProcessCb(TipcProcessCb,TipcMt,short,object);

Inherited from TipcConnClient.

public virtual TipcCb addProcessCb(TipcProcessCb,TipcMt,object);

public implementation

public virtual TipcCb addProcessCb(TipcProcessCb,TipcMt,string,short,object);

public implementation

public virtual TipcCb addProcessCb(TipcProcessCb,TipcMt,string,object);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.addProcessCb Method (TipcProcessCb, String, Int16, Object)

public implementation

public virtual TipcCb addProcessCb(
TipcProcessCb l,
string subject,
short priority,
object arg
);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.addProcessCb Overload List


TipcSrv.addProcessCb Method (TipcProcessCb, String, Object)

public implementation

public virtual TipcCb addProcessCb(
TipcProcessCb l,
string subject,
object arg
);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.addProcessCb Overload List


TipcSrv.addProcessCb Method (TipcProcessCb, TipcMt, String, Int16, Object)

public implementation

public virtual TipcCb addProcessCb(
TipcProcessCb l,
TipcMt mt,
string subject,
short priority,
object arg
);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.addProcessCb Overload List


TipcSrv.addProcessCb Method (TipcProcessCb, TipcMt, String, Object)

public implementation

public virtual TipcCb addProcessCb(
TipcProcessCb l,
TipcMt mt,
string subject,
object arg
);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.addProcessCb Overload List


TipcSrv.check Method

Check for traffic on the connection. If mode is IO_CHECK_READ, this method will return true if there is data available to be read. If , true will be returned if data can be written to the connection without blocking.

If the ss.server_read_timeout option is 0.0, this method will block for up the specified timeout. Otherwise, this method will return immediately.

public override bool check(
int mode,
double timeout
);

Parameters

mode
Either IO_CHECK_READ or IO_CHECK_WRITE
timeout
The length of time (in seconds). If timeout is 0.0, the connection will be polled, and no waiting will be done. If time is TIMEOUT_FOREVER, the connection will block until traffic is available.

Return Value

true if traffic has occured, false if timed out.

Exceptions

Exception Type | Condition
TipcInterruptedException | Interrupt is called.
TipcException | For all errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


create Method

SmartSockets .NET Class Library

TipcSrv.create Method

Creates the RTserver connection using the default connection type CONN_FULL.

Connects to and handshakes with the RTserver process. Does not attempt to auto-start an RTserver if one cannot be contacted. Instead, it will loop through the list of servers specified with ss.server_names option until a connection is made. This process is synchronous. and all other threads that attempt to use the connection will block until this succeeds, or fails completely.

Overload List

Creates the RTserver connection using the default connection type CONN_FULL. Connects to and handshakes with the RTserver process. Does not attempt to auto-start an RTserver if one cannot be contacted. Instead, it will loop through the list of servers specified with ss.server_names option until a connection is made. This process is synchronous. and all other threads that attempt to use the connection will block until this succeeds, or fails completely.

public virtual bool create();

Creates the RTserver connection using a specified connection type. Connects to and handshakes with the RTserver process. Does not attempt to auto-start an RTserver if one cannot be contacted. Instead, it will loop through the list of servers specified with ss.server_names option until a connection is made. This process is synchronous. and all other threads that attempt to use the connection will block until this succeeds, or fails completely.

public virtual bool create(int);

Creates the RTserver connection using the default connection type CONN_FULL and with the specified credentials. Connects to and handshakes with the RTserver process. Does not attempt to auto-start an RTserver if one cannot be contacted. Instead, it will loop through the list of servers specified with ss.server_names option until a connection is made. This process is synchronous. and all other threads that attempt to use the connection will block until this succeeds, or fails completely.

public virtual bool create(int,sbyte[]);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.create Method ()

Creates the RTserver connection using the default connection type CONN_FULL.

Connects to and handshakes with the RTserver process. Does not attempt to auto-start an RTserver if one cannot be contacted. Instead, it will loop through the list of servers specified with ss.server_names option until a connection is made. This process is synchronous. and all other threads that attempt to use the connection will block until this succeeds, or fails completely.

public virtual bool create();

Return Value

true if a successful connection was made. If the server process cannot be connected at all, then false will be returned.

Exceptions

Exception Type | Condition
TipcTimeoutException | If the client timed out waiting for RTserver to reply to a connection request.
TipcAccessDeniedException | If the server replied, but denied access.
TipcIOException | For unrecoverable network failures.
TipcBadArgumentException | When an invalid LCN is specified.
TipcNotFoundException | When the protocol driver cannot be found.
TipcAssertionException | If the LCN hostname is unknown.
TipcProxyException | For erros when connecting to a proxy server.
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.create Overload List


TipcSrv.create Method (Int32)

Creates the RTserver connection using a specified connection type.

Connects to and handshakes with the RTserver process. Does not attempt to auto-start an RTserver if one cannot be contacted. Instead, it will loop through the list of servers specified with ss.server_names option until a connection is made. This process is synchronous. and all other threads that attempt to use the connection will block until this succeeds, or fails completely.

public virtual bool create(
int connType
);

Parameters

connType
One of the valid connection types CONN_WARM or CONN_FULL.

Return Value

true if a successful connection was made. If the server process cannot be connected at all, then false will be returned.

Exceptions

Exception Type | Condition
TipcTimeoutException | If the client timed out waiting for RTserver to reply to a connection request.
TipcAccessDeniedException | If the server replied, but denied access. This is usually because the client's unique subject isn't unique within the client's project.
TipcIOException | For unrecoverable network failures.
TipcInterruptedException | Interrupt is called.
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.create Overload List


TipcSrv.create Method (Int32, SByte[])

Creates the RTserver connection using the default connection type CONN_FULL and with the specified credentials.

Connects to and handshakes with the RTserver process. Does not attempt to auto-start an RTserver if one cannot be contacted. Instead, it will loop through the list of servers specified with ss.server_names option until a connection is made. This process is synchronous. and all other threads that attempt to use the connection will block until this succeeds, or fails completely.

public virtual bool create(
int auth_policy_id,
sbyte[] auth_data
);

Parameters

auth_policy_id
User-specified authorization policy identifier to be sent to the Security Manager.
auth_data
User-specified authorization data to be sent to the Security Manager.

Return Value

true if a successful connection was made. If the server process cannot be connected at all, then false will be returned.

Exceptions

Exception Type | Condition
TipcTimeoutException | If the client timed out waiting for RTserver to reply to a connection request.
TipcAccessDeniedException | If the server replied, but denied access.
TipcIOException | For unrecoverable network failures.
TipcBadArgumentException | When an invalid LCN is specified.
TipcNotFoundException | When the protocol driver cannot be found.
TipcAssertionException | If the LCN hostname is unknown.
TipcProxyException | For erros when connecting to a proxy server.
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.create Overload List


destroy Method

SmartSockets .NET Class Library

TipcSrv.destroy Method

Destroys (closes) the RTServer connection.

Overload List

Destroys (closes) the RTServer connection.

public override void destroy();

Destroys (closes) the RTServer connection using a specified connection type.

public virtual void destroy(int);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.destroy Method ()

Destroys (closes) the RTServer connection.

public override void destroy();

Exceptions

Exception Type | Condition
TipcException | For all errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.destroy Overload List


TipcSrv.destroy Method (Int32)

Destroys (closes) the RTServer connection using a specified connection type.

public virtual void destroy(
int connType
);

Parameters

connType
One of the valid connection types: CONN_WARM or CONN_FULL

Exceptions

Exception Type | Condition
TipcException | For all errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.destroy Overload List


TipcSrv.flush Method

Flushes queue data to the connection. This ensures that all buffered data is written immediately. This outbound queue will be flushed automatically when it reaches a set size, set by the ss.server_auto_flush_size option.

public override void flush();

Exceptions

Exception Type | Condition
TipcSrvNotConnectedException | If the connection status is currently warm.
TipcInterruptedException | Interrupt is called.
TipcException | If no server connection and auto-connect is false.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.getSubjectLb Method

find out if a subject is using load balancing.

public virtual bool getSubjectLb(
string subject
);

Parameters

subject
the subject to check

Return Value

true if the subject is using load balancing, false if not.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the subject is not in the subscription list.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.getSubjectSubscribe Method

find out if a subject is subscribed to.

public virtual bool getSubjectSubscribe(
string subject
);

Parameters

subject
the subject to check.

Return Value

true if the client is subscribed to the subject, false if not.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.gmdMsgServerDelete Method

Deletes a GMD message from RTserver's spool. Use gmdMsgDelete to delete a message from the local spool. This method fails silently if the msg doesn't exist.

public virtual void gmdMsgServerDelete(
TipcMsg msg
);

Parameters

msg
The message to delete.

Exceptions

Exception Type | Condition
TipcException | If no server connection and auto-connect is fale.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.gmdMsgStatus Method

Gets the status of the gmd message.

public virtual void gmdMsgStatus(
TipcMsg msg
);

Parameters

msg
The message to find the status for.

Exceptions

Exception Type | Condition
TipcException | If no server connection and auto-connect is false.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.handleOptionPoll Method

protected implemenation of TipcConnClient.handleOptionPoll

protected internal virtual void handleOptionPoll(
TipcMsg msg,
string opName
);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


logAddMt Method

SmartSockets .NET Class Library

TipcSrv.logAddMt Method

Adds a message type for message logging. Messages will logged to the file specified by the options: ss.log_out_data, ss.log_in_data, ss_log_out_status. ss.log_in_status, ss.log_out_internal, and ss.log_in_internal And based upon the logging type.

Overload List

Adds a message type for message logging. Messages will logged to the file specified by the options: ss.log_out_data, ss.log_in_data, ss_log_out_status. ss.log_in_status, ss.log_out_internal, and ss.log_in_internal And based upon the logging type.

public virtual void logAddMt(int,int);

Adds a message type for message logging. Messages will logged to the file specified by the options: ss.log_out_data, ss.log_in_data, ss_log_out_status. ss.log_in_status, ss.log_out_internal, and ss.log_in_internal And based upon the logging type.

public virtual void logAddMt(int,TipcMt);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.logAddMt Method (Int32, Int32)

Adds a message type for message logging. Messages will logged to the file specified by the options: ss.log_out_data, ss.log_in_data, ss_log_out_status. ss.log_in_status, ss.log_out_internal, and ss.log_in_internal And based upon the logging type.

public virtual void logAddMt(
int logType,
int mtNum
);

Parameters

logType
One of LOG_DATA, LOG_STATUS, or LOG_INTERNAL
mtNum
The message type number.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the message type does not exist.
TipcBadArgumentException | If the message logging type is invalid.
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.logAddMt Overload List


TipcSrv.logAddMt Method (Int32, TipcMt)

Adds a message type for message logging. Messages will logged to the file specified by the options: ss.log_out_data, ss.log_in_data, ss_log_out_status. ss.log_in_status, ss.log_out_internal, and ss.log_in_internal And based upon the logging type.

public virtual void logAddMt(
int logType,
TipcMt mt
);

Parameters

logType
One of LOG_DATA, LOG_STATUS, or LOG_INTERNAL
mt
The message type.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the message logging type is invalid.
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.logAddMt Overload List


logRemoveMt Method

SmartSockets .NET Class Library

TipcSrv.logRemoveMt Method

Removes a message type from message logging.

Overload List

Removes a message type from message logging.

public virtual void logRemoveMt(int,int);

Removes a message type from message logging.

public virtual void logRemoveMt(int,TipcMt);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.logRemoveMt Method (Int32, Int32)

Removes a message type from message logging.

public virtual void logRemoveMt(
int logType,
int mtNum
);

Parameters

logType
One of LOG_DATA, LOG_STATUS, or LOG_INTERNAL
mtNum
The message type number.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the message type does not exist or if message type is not being logged for the indicated logging type.
TipcBadArgumentException | If the message logging type is invalid.
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.logRemoveMt Overload List


TipcSrv.logRemoveMt Method (Int32, TipcMt)

Removes a message type from message logging.

public virtual void logRemoveMt(
int logType,
TipcMt mt
);

Parameters

logType
One of LOG_DATA, LOG_STATUS, or LOG_INTERNAL
mt
The message type.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the message type is not being logged for the indicated logging type.
TipcBadArgumentException | If the message logging type is invalid.
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.logRemoveMt Overload List


TipcSrv.lookupCreateCb Method

Looks up a callback for the RTserver connection creation

public virtual TipcCb lookupCreateCb(
TipcCreateCb l,
object arg
);

Parameters

l
The callback class.
arg
user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.lookupDestroyCb Method

Looks up a callback for the RTserver destruction.

public virtual TipcCb lookupDestroyCb(
TipcDestroyCb l,
object arg
);

Parameters

l
The callback class.
arg
user-defined argument passed to the callback.

Return Value

The callback, or null if it doesn't exist.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


lookupProcessCb Method

SmartSockets .NET Class Library

TipcSrv.lookupProcessCb Method

public implementation

Overload List

Inherited from TipcConnClient.

public virtual TipcCb lookupProcessCb(TipcProcessCb,int,object);

public implementation

public virtual TipcCb lookupProcessCb(TipcProcessCb,string,object);

Inherited from TipcConnClient.

public virtual TipcCb lookupProcessCb(TipcProcessCb,TipcMt,object);

public implementation

public virtual TipcCb lookupProcessCb(TipcProcessCb,TipcMt,string,object);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.lookupProcessCb Method (TipcProcessCb, String, Object)

public implementation

public virtual TipcCb lookupProcessCb(
TipcProcessCb l,
string subject,
object arg
);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.lookupProcessCb Overload List


TipcSrv.lookupProcessCb Method (TipcProcessCb, TipcMt, String, Object)

public implementation

public virtual TipcCb lookupProcessCb(
TipcProcessCb l,
TipcMt mt,
string subject,
object arg
);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.lookupProcessCb Overload List


TipcSrv.next Method

Get messages from the inbound queue. If no messages are waiting in the inbound queue then this method will wait for the specified timeout for a message to arrive.

public override TipcMsg next(
double timeout
);

Parameters

timeout
length in time (in seconds) to wait for message to arrive.

Return Value

The message read, or null if timeout expires.

Exceptions

Exception Type | Condition
TipcInterruptedException | Interrupt is called.
TipcException | For all errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.process Method

Process a message by calling the process callback for that message's type. A callback may be setup to process messages as they arrive. This method calls those callbacks.

public override void process(
TipcMsg msg
);

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the message is invalid.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.processCacheRequest Method

set Caching Interface

public virtual void processCacheRequest(
string subject,
int flags,
bool status,
TipcCache obj
);

Parameters

subject
- the subject to set the status on
flags
- Flags Used by the Extension
status
- the status to set, true to subscribe, false to unsubscribe
obj
- Extra info used by the Extension

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.removeCreateCb Method

Removes a callback for the RTserver connection creation.

public virtual void removeCreateCb(
TipcCb cb
);

Parameters

cb
The callback to remove.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the callback table is corrupt.
TipcAssertionException | If the callback is corrupt.
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.removeDestroyCb Method

Removes a callback for the RTserver destruction.

public virtual void removeDestroyCb(
TipcCb cb
);

Parameters

cb
The callback to remove.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the callback table is corrupt.
TipcAssertionException | If the callback is corrupt.
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.removeProcessCb Method

Removes a callback for the RTserver connection.

public override void removeProcessCb(
TipcCb cb
);

Parameters

cb
The callback to remove.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the callback table is corrupt.
TipcAssertionException | If the callback is corrupt.
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


searchType Method

SmartSockets .NET Class Library

TipcSrv.searchType Method

Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.

Overload List

Inherited from TipcConnClient.

public virtual TipcMsg searchType(double,int);

Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.

public override TipcMsg searchType(double,TipcMt);

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.searchType Method (Double, TipcMt)

Find a message in the inbound queue matching a specific message type. This method scans the inbound queue, checking for messages matching the desired type. If no appropriate messages are found in the inbound queue, this method will wait until the desired message arrives from the connection. The message, if found, will be removed from the inbound queue.

public override TipcMsg searchType(
double timeout,
TipcMt mt
);

Parameters

timeout
Length of time (in seconds) to wait for a message to arrive.
mt
The message type to look for.

Return Value

the matching message, or null if no message is found before the timeout expires.

Exceptions

Exception Type | Condition
TipcIOException | For low-level errors.
TipcInterruptedException | Interrupt is called.
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace | TipcSrv.searchType Overload List


TipcSrv.send Method

Send a message.

This method actually queues the data for later transmission. It is not actually sent until flush is called, either by the user directly, or by the auto-flush mechanism, based on the buffer size. The auto-flush mechanism is regulated by the ss.server_auto_flush_size option.

public override void send(
TipcMsg msg
);

Parameters

msg
the message to send

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the message destination is not a valid subject.
TipcException | If no server connection and auto-connect is false.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.sendRpc Method

Send a RPC message.

public override TipcMsg sendRpc(
TipcMsg msg,
double timeout
);

Parameters

msg
the message to send
timeout
the length of time (in seconds) to wait for synchronous response.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the message destination is not a valid subject.
TipcException | If no server connection and auto-connect is false.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.setSubjectSubscribe Method

set the subscribe status on a subject.

public virtual void setSubjectSubscribe(
string subject,
bool status
);

Parameters

subject
the subject to set the status on
status
the status to set, true to subscribe, false to unsubscribe.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the subject is invalid.
TipcAlreadySubscribedException | If already subscribed to subject.
TipcNotSubscribedException | If not subscribed to subject
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.setSubjectSubscribeEx Method

Extended Subscribe/Unsubscribe

public virtual void setSubjectSubscribeEx(
string subject,
bool status,
int type,
int flags,
object obj
);

Parameters

subject
- the subject to set the status on
status
- the status to set, true to subscribe, false to unsubscribe
type
- Type of subscribe: SUBEX_TYPE_NONE or SUBEX_TYPE_CACHE
flags
- Flags used by subscribe types. For SUBEX_TYPE_NONE, this parameter is ignored. For SUBEX_TYPE_CACHE valid values are: SUBEX_CACHE_FLAG_LATEST_MSG or SUBEX_CACHE_FLAG_INITIAL_LOAD
obj
- Extra info used by each type. For SUBEX_TYPE_NONE, this parameter is ignored. For SUBEX_TYPE_CACHE, this parameter must contain a valid TipcCache object.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the subject is invalid.
TipcAlreadySubscribedException | If already subscribed to subject.
TipcNotSubscribedException | If not subscribed to subject
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.setSubjectSubscribeLb Method

set the subscribe and load balancing status on a subject.

public virtual void setSubjectSubscribeLb(
string subject,
bool status,
bool lb_status
);

Parameters

subject
the subject to set the status on
status
the status to set, true to subscribe, false to unsubscribe.
lb_status
the status to set, true to enable load balancing, false to disable load balancing.

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the subject is invalid.
TipcAlreadySubscribedException | If already subscribed to subject.
TipcNotSubscribedException | If not subscribed to subject
TipcException | For all other errors.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.setUsernamePassword Method

Sets the username and password for the RTclient when connecting to an RTserver with the Basic Security Driver installed. The password is immediately encrypted and is never sent in plain text to the RTserver.

public virtual void setUsernamePassword(
string username,
string password
);

Parameters

username
The username to use for authentication and authorization.
password
The password to use for authentication.

Exceptions

Exception Type | Condition
TipcSrvAlreadyConnectedException | If the RTclient is already connected to the RTserver.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.subjectGmdInit Method

initializes GMD.

This has not yet been implemented.

public virtual bool subjectGmdInit();

Return Value

status of the operation (always false)

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.subjectLbInit Method

initializes load balancing.

public virtual bool subjectLbInit();

Return Value

true if successful, false otherwise

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv Events

The events of the TipcSrv class are listed below. For a complete list of TipcSrv class members, see the TipcSrv Members topic.

Public Instance Events

TipcErrorEvent (inherited from TipcConnClient) Occurs when an error occurs on a connection. Connection Error events are raised when an unrecoverable error occurs. These errors include socket problems and network failures such as:
  • A read timeout has occured and the keep-alive then failed.
  • A write timeout has occured.
  • A read operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.
  • A write operation on the connection's socket failed. The most common cause of this error is that the process at the other end of the connection has destroyed its connection, which closed the socket.
TipcMsgEvent (inherited from TipcConnClient) | Occurs when a message is processed. Connection process events are raised while processing a message. This callback type is the most frequently used. A process delegate method is called for every of message received. When any message of any type is processed by calling process or mainLoop, the process callback is called.
TipcQueueEvent (inherited from TipcConnClient) | Occurs with message queue events. Connection queue events are raised when a message is inserted into or deleted from a connection's message queue. Queue events are useful for watching the messages that have been read in from a connection's socket and inserted into the message queue, but not yet processed.
TipcReadEvent (inherited from TipcConnClient) | Occurs when a message is read from a connection. Connection read events are raised when an incoming message is read from a connection's socket into the read buffer and first unpacked into a message. Read events are most commonly used for writing incoming messages to message files.
TipcSrvCreateEvent | Occurs when a connection to RTserver is created. Server create callbacks are called when an RTclient creates either a full or warm connection to the RTserver. If an RTclient creates and destoys its connection to the RTserver many times, it should use server create handlers to create the other handlers needed in the connection to RTserver.
TipcSrvDestroyEvent | Occurs when a connection to RTserver is destroyed. Server destroy callbacks are called when an RTclient destroys its connection to the RTserver, leaving either a warm connection or no connection. Server destroy callbacks are the opposite of server create callbacks. Server destroy handlers are useful for RTclients that need to know when the connection to the RTserver no longer has a valid socket, such as RTclients that are also GUI programs.
TipcWriteBufferChangeEvent (inherited from TipcConnClient) | Occurs when the write buffer is accessed. Write buffer change events are raised when data is either flushed from the write buffer or written into write buffer THROUGH the message interface (i.e. with send(msg)) ONLY.
TipcWriteEvent (inherited from TipcConnClient) | Occurs when a message is written to a connection. Connection write events are raised when an outgoing message is sent to a connection (that is, copied to a connection's write buffer). Write events are most commonly used for writing outgoing messages to message files.

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.TipcSrvCreateEvent Event

Occurs when a connection to RTserver is created.

Server create callbacks are called when an RTclient creates either a full or warm connection to the RTserver. If an RTclient creates and destoys its connection to the RTserver many times, it should use server create handlers to create the other handlers needed in the connection to RTserver.

public event TipcSrvCreateHandler TipcSrvCreateEvent;

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrv.TipcSrvDestroyEvent Event

Occurs when a connection to RTserver is destroyed.

Server destroy callbacks are called when an RTclient destroys its connection to the RTserver, leaving either a warm connection or no connection. Server destroy callbacks are the opposite of server create callbacks.

Server destroy handlers are useful for RTclients that need to know when the connection to the RTserver no longer has a valid socket, such as RTclients that are also GUI programs.

public event TipcSrvDestroyHandler TipcSrvDestroyEvent;

See Also

TipcSrv Class | TIBCO.SMARTSOCKETS Namespace


TipcSrvAlreadyConnectedException Class

Thrown when a method requires no connection to the RTserver and a connection already exists.

For a list of all members of this type, see TipcSrvAlreadyConnectedException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcSrvAlreadyConnectedException

public class TipcSrvAlreadyConnectedException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcSrvAlreadyConnectedException Members | TIBCO.SMARTSOCKETS Namespace


TipcSrvAlreadyConnectedException Members

TipcSrvAlreadyConnectedException overview

Public Instance Constructors

TipcSrvAlreadyConnectedException Overloaded. Initializes a new instance of the TipcSrvAlreadyConnectedException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcSrvAlreadyConnectedException Class | TIBCO.SMARTSOCKETS Namespace


TipcSrvAlreadyConnectedException Constructor

Constructs a TipcSrvAlreadyConnectedException with null as its error message string.

Overload List

Constructs a TipcSrvAlreadyConnectedException with null as its error message string.

public TipcSrvAlreadyConnectedException();

Constructs a TipcSrvAlreadyConnectedException with an error message.

public TipcSrvAlreadyConnectedException(string);

See Also

TipcSrvAlreadyConnectedException Class | TIBCO.SMARTSOCKETS Namespace


TipcSrvAlreadyConnectedException Constructor ()

Constructs a TipcSrvAlreadyConnectedException with null as its error message string.

public TipcSrvAlreadyConnectedException();

See Also

TipcSrvAlreadyConnectedException Class | TIBCO.SMARTSOCKETS Namespace | TipcSrvAlreadyConnectedException Constructor Overload List


TipcSrvAlreadyConnectedException Constructor (String)

Constructs a TipcSrvAlreadyConnectedException with an error message.

public TipcSrvAlreadyConnectedException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcSrvAlreadyConnectedException Class | TIBCO.SMARTSOCKETS Namespace | TipcSrvAlreadyConnectedException Constructor Overload List


TipcSrvCreateEventArgs Class

This class contains event data for the TipcSrvCreateEvent.

For a list of all members of this type, see TipcSrvCreateEventArgs Members.

System.Object
System.EventArgs
TIBCO.SMARTSOCKETS.TipcSrvCreateEventArgs

public class TipcSrvCreateEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcSrvCreateEventArgs Members | TIBCO.SMARTSOCKETS Namespace


TipcSrvCreateEventArgs Members

TipcSrvCreateEventArgs overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcSrvCreateEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcSrvCreateHandler Delegate

Represents the method that will handle the TipcSrvCreateEvent event.

public delegate void TipcSrvCreateHandler(
object sender,
TipcSrvCreateEventArgs e
);

Parameters

sender
The source of the event. This will be the TipcSrv object.
e
The event argument, TipcSrvCreateEventArgs

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TIBCO.SMARTSOCKETS Namespace


TipcSrvDestroyEventArgs Class

This class contains event data for the TipcSrvDestroyEvent.

For a list of all members of this type, see TipcSrvDestroyEventArgs Members.

System.Object
System.EventArgs
TIBCO.SMARTSOCKETS.TipcSrvDestroyEventArgs

public class TipcSrvDestroyEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcSrvDestroyEventArgs Members | TIBCO.SMARTSOCKETS Namespace


TipcSrvDestroyEventArgs Members

TipcSrvDestroyEventArgs overview

Public Instance Constructors

TipcSrvDestroyEventArgs Constructor TipcSrvDestroyEventArgs

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcSrvDestroyEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcSrvDestroyEventArgs Constructor

TipcSrvDestroyEventArgs

public TipcSrvDestroyEventArgs();

See Also

TipcSrvDestroyEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcSrvDestroyHandler Delegate

Represents the method that will handle the TipcSrvDestroyEvent event.

public delegate void TipcSrvDestroyHandler(
object sender,
TipcSrvDestroyEventArgs e
);

Parameters

sender
The source of the event. This will be the TipcSrv object.
e
The event argument, TipcSrvDestroyEventArgs

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TIBCO.SMARTSOCKETS Namespace


TipcSrvNotConnectedException Class

Thrown when a method requires a connection to the RTserver and the connection does not exist.

For a list of all members of this type, see TipcSrvNotConnectedException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcSrvNotConnectedException

public class TipcSrvNotConnectedException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcSrvNotConnectedException Members | TIBCO.SMARTSOCKETS Namespace


TipcSrvNotConnectedException Members

TipcSrvNotConnectedException overview

Public Instance Constructors

TipcSrvNotConnectedException Overloaded. Initializes a new instance of the TipcSrvNotConnectedException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcSrvNotConnectedException Class | TIBCO.SMARTSOCKETS Namespace


TipcSrvNotConnectedException Constructor

Constructs a TipcSrvNotConnectedException with null as its error message string.

Overload List

Constructs a TipcSrvNotConnectedException with null as its error message string.

public TipcSrvNotConnectedException();

Constructs a TipcSrvNotConnectedException with an error message.

public TipcSrvNotConnectedException(string);

See Also

TipcSrvNotConnectedException Class | TIBCO.SMARTSOCKETS Namespace


TipcSrvNotConnectedException Constructor ()

Constructs a TipcSrvNotConnectedException with null as its error message string.

public TipcSrvNotConnectedException();

See Also

TipcSrvNotConnectedException Class | TIBCO.SMARTSOCKETS Namespace | TipcSrvNotConnectedException Constructor Overload List


TipcSrvNotConnectedException Constructor (String)

Constructs a TipcSrvNotConnectedException with an error message.

public TipcSrvNotConnectedException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcSrvNotConnectedException Class | TIBCO.SMARTSOCKETS Namespace | TipcSrvNotConnectedException Constructor Overload List


TipcSvc Class

A static factory class for the TipcMt, TipcMsg, TipcConnClient, TipcConnServer, and TipcSrv interfaces. Objects of the required concrete classes that implement these interfaces are created with this class.

For example, to create a connection to the RTserver and to create and send a SmartSockets message on the connection, you would do the following:

// get the connection to the RTserver from the factory
TipcSrv srv = TipcSvc.Srv;

// create an INFO message from the factory
TipcMsg msg = TipcSvc.createMsg(TipcMt_Fields.INFO);

// publish the INFO message to the "/foo" subject on the connection
msg.setDest("/foo");
srv.send(msg);

For a list of all members of this type, see TipcSvc Members.

System.Object
TIBCO.SMARTSOCKETS.TipcSvc

public class TipcSvc

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcSvc Members | TIBCO.SMARTSOCKETS Namespace


TipcSvc Members

TipcSvc overview

Public Static Properties

Srv Gets the global TipcSrv RTserver connection object. Note: this method will not create a connection to RTserver. Use the create method to do this. The methods to send and receive messages will also automatically connect to RTserver. Example:
// get the instance of the connection to the RTserver
TipcSrv srv = TipcSvc.Srv;

// create a SmartSockets message to publish
TipcMsg msg = TipcSvc.createMsg(TipcMt.ALERT);
msg.setDest("/foo");
msg.appendStr("warning!");

// TipcSrv.send will automatically connect to the RTserver if not already
srv.send(msg);
srv.flush();
RTserver must be running before a connection is made. The .NET library does not attempt to start an instance of RTserver.

Public Static Methods

createConnClient Creates a new peer-to-peer client connection. This method creates the client end of a peer-to-peer connection. The server end must be up and running prior to this call, so the client has something to connect to. The protocol, hostname, and port number for the connection are specified as a "logical connection name" (LCN), using the form: protocol:hostname:port. "_node" may be substituted for the local hostname. Example:
// connect to a peer listening via TCP on host foo at port 8002
TipcConnClient conn = TipcSvc.createConnClient("tcp:foo:8002");

// create a SmartSockets message and send it to the server
TipcMsg msg = TipcSvc.createMsg(TipcMt_Fields.INFO);
msg.appendStr("hello");
conn.send(msg);
conn.flush();
createConnServer Create a new peer-to-peer server connection. This method creates the server end of a peer-to-peer connection. The protocol, hostname, and port number are specified using the same "logical connection name" (LCN) as the client connection. This connection is only used to accept connections from clients. All actual communication is done with the client connection returned by accept. Example:
// create the server-side of a connection listening via TCP on port 8002
TipcConnServer srvConn = TipcSvc.createConnServer("tcp:_node:8002");

// accept a client connection
TipcConnClient conn = srvConn.accept();

// get the next message sent by the client
TipcMsg msg = conn.next(10.0);
createMsg Overloaded. Creates a new SmartSockets message of the specified message type. Example:
// look up the message type number 500
TipcMt mt = TipcSvc.lookupMt(500);

// create a message of this type
TipcMsg msg = TipcSvc.createMsg(mt);
createMt Defines a new message type. Once a message type is defined, it may be looked up with the name and number lookup functions. For example, to define a new message type named "foo", which has the number '500', and is intended to take two integer fields and a string field, you'd do this:
TipcMt mt = TipcSvc.createMt("foo", 500, "int4 int4 str");
You may use the TipcMt object directly, or look up the instance by name or number, like any other predefined message type:
// look up a message type by name
TipcMt mt = TipcSvc.lookupMt("foo");

// look up a message type by number
TipcMt mt = TipcSvc.lookupMt(500);
createSrv Creates a new TipcSrv RTserver connection object. All RTserver connections share a common set of options set by the option assessor methods in the Tut class. Option values for a particular connection object may be overridden by using the option assessor methods available to the TipcSrv object, inherited from the TipcConnClient interface. The one exception is the ss.unique_subject option. A new default unique subject will be generated for each TipcSrv object created by the this method. Note: this method will not create a connection to RTserver. Use the create method to do this. The methods to send and receive messages will also automatically connect to RTserver. Example:
// create a new connection object
TipcSrv srv = TipcSvc.createSrv();

// set the unique subject of the connection
srv.setOption("ss.unique_subject", "/publish_client");

// create the connection to the RTserver
srv.create();
RTserver must be running before a connection is made. The .NET library does not attempt to start an instance of RTserver.
lookupMt Overloaded. Returns the message type indexed by name. This message type must be one of the standard SmartSockets message types, or a type previously defined with createMt. Example:
// look up the message type named "foo"
TipcMt mt = TipcSvc.lookupMt("foo");
makeSubjectAbsolute | If the subject is not absolute (doesn't start with "/"), tack on the default subject prefix, if it exists. If the prefix isn't set to anything, it simply returns the original name untouched. This method should only be invoked when using the global RTserver connection via the Srv property. Otherwise, use makeSubjectAbsolute.
matchSubjects | Matches two subject strings, one or both of which may be wildcarded. Note: Subjects are not case sensitive.
validSubject | Checks that the subject is valid. Invalid subjects are null or empty subjects, those with only whitespace between subject delimiters.

Protected Static Fields

srv Connection to RTserver

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace


TipcSvc Fields

The fields of the TipcSvc class are listed below. For a complete list of TipcSvc class members, see the TipcSvc Members topic.

Protected Static Fields

srv Connection to RTserver

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace


Srv Property

SmartSockets .NET Class Library

TipcSvc.Srv Property

Gets the global TipcSrv RTserver connection object.

Note: this method will not create a connection to RTserver. Use the create method to do this. The methods to send and receive messages will also automatically connect to RTserver.

Example:

// get the instance of the connection to the RTserver
TipcSrv srv = TipcSvc.Srv;

// create a SmartSockets message to publish
TipcMsg msg = TipcSvc.createMsg(TipcMt.ALERT);
msg.setDest("/foo");
msg.appendStr("warning!");

// TipcSrv.send will automatically connect to the RTserver if not already
srv.send(msg);
srv.flush();

RTserver must be running before a connection is made. The .NET library does not attempt to start an instance of RTserver.

public static TipcSrv Srv {get;}

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace |


TipcSvc Properties

The properties of the TipcSvc class are listed below. For a complete list of TipcSvc class members, see the TipcSvc Members topic.

Public Static Properties

Srv Gets the global TipcSrv RTserver connection object. Note: this method will not create a connection to RTserver. Use the create method to do this. The methods to send and receive messages will also automatically connect to RTserver. Example:
// get the instance of the connection to the RTserver
TipcSrv srv = TipcSvc.Srv;

// create a SmartSockets message to publish
TipcMsg msg = TipcSvc.createMsg(TipcMt.ALERT);
msg.setDest("/foo");
msg.appendStr("warning!");

// TipcSrv.send will automatically connect to the RTserver if not already
srv.send(msg);
srv.flush();
RTserver must be running before a connection is made. The .NET library does not attempt to start an instance of RTserver.

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace


TipcSvc Methods

The methods of the TipcSvc class are listed below. For a complete list of TipcSvc class members, see the TipcSvc Members topic.

Public Static Methods

createConnClient Creates a new peer-to-peer client connection. This method creates the client end of a peer-to-peer connection. The server end must be up and running prior to this call, so the client has something to connect to. The protocol, hostname, and port number for the connection are specified as a "logical connection name" (LCN), using the form: protocol:hostname:port. "_node" may be substituted for the local hostname. Example:
// connect to a peer listening via TCP on host foo at port 8002
TipcConnClient conn = TipcSvc.createConnClient("tcp:foo:8002");

// create a SmartSockets message and send it to the server
TipcMsg msg = TipcSvc.createMsg(TipcMt_Fields.INFO);
msg.appendStr("hello");
conn.send(msg);
conn.flush();
createConnServer Create a new peer-to-peer server connection. This method creates the server end of a peer-to-peer connection. The protocol, hostname, and port number are specified using the same "logical connection name" (LCN) as the client connection. This connection is only used to accept connections from clients. All actual communication is done with the client connection returned by accept. Example:
// create the server-side of a connection listening via TCP on port 8002
TipcConnServer srvConn = TipcSvc.createConnServer("tcp:_node:8002");

// accept a client connection
TipcConnClient conn = srvConn.accept();

// get the next message sent by the client
TipcMsg msg = conn.next(10.0);
createMsg Overloaded. Creates a new SmartSockets message of the specified message type. Example:
// look up the message type number 500
TipcMt mt = TipcSvc.lookupMt(500);

// create a message of this type
TipcMsg msg = TipcSvc.createMsg(mt);
createMt Defines a new message type. Once a message type is defined, it may be looked up with the name and number lookup functions. For example, to define a new message type named "foo", which has the number '500', and is intended to take two integer fields and a string field, you'd do this:
TipcMt mt = TipcSvc.createMt("foo", 500, "int4 int4 str");
You may use the TipcMt object directly, or look up the instance by name or number, like any other predefined message type:
// look up a message type by name
TipcMt mt = TipcSvc.lookupMt("foo");

// look up a message type by number
TipcMt mt = TipcSvc.lookupMt(500);
createSrv Creates a new TipcSrv RTserver connection object. All RTserver connections share a common set of options set by the option assessor methods in the Tut class. Option values for a particular connection object may be overridden by using the option assessor methods available to the TipcSrv object, inherited from the TipcConnClient interface. The one exception is the ss.unique_subject option. A new default unique subject will be generated for each TipcSrv object created by the this method. Note: this method will not create a connection to RTserver. Use the create method to do this. The methods to send and receive messages will also automatically connect to RTserver. Example:
// create a new connection object
TipcSrv srv = TipcSvc.createSrv();

// set the unique subject of the connection
srv.setOption("ss.unique_subject", "/publish_client");

// create the connection to the RTserver
srv.create();
RTserver must be running before a connection is made. The .NET library does not attempt to start an instance of RTserver.
lookupMt Overloaded. Returns the message type indexed by name. This message type must be one of the standard SmartSockets message types, or a type previously defined with createMt. Example:
// look up the message type named "foo"
TipcMt mt = TipcSvc.lookupMt("foo");
makeSubjectAbsolute | If the subject is not absolute (doesn't start with "/"), tack on the default subject prefix, if it exists. If the prefix isn't set to anything, it simply returns the original name untouched. This method should only be invoked when using the global RTserver connection via the Srv property. Otherwise, use makeSubjectAbsolute.
matchSubjects | Matches two subject strings, one or both of which may be wildcarded. Note: Subjects are not case sensitive.
validSubject | Checks that the subject is valid. Invalid subjects are null or empty subjects, those with only whitespace between subject delimiters.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace


TipcSvc.createConnClient Method

Creates a new peer-to-peer client connection.

This method creates the client end of a peer-to-peer connection. The server end must be up and running prior to this call, so the client has something to connect to. The protocol, hostname, and port number for the connection are specified as a "logical connection name" (LCN), using the form: protocol:hostname:port. "_node" may be substituted for the local hostname.

Example:

// connect to a peer listening via TCP on host foo at port 8002
TipcConnClient conn = TipcSvc.createConnClient("tcp:foo:8002");

// create a SmartSockets message and send it to the server
TipcMsg msg = TipcSvc.createMsg(TipcMt_Fields.INFO);
msg.appendStr("hello");
conn.send(msg);
conn.flush();

public static TipcConnClient createConnClient(
string lcn
);

Parameters

lcn
the logical connection name to use for the connection

Return Value

the connection object

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the LCN is invalid
TipcTimeoutException | For connection timeouts
TipcAssertionException | If the LCN hostname is unknown
TipcMsgException | For corrupt initialization messages
TipcIOException | For lower-level errors
TipcNotFoundException | When the protocol driver cannot be found
TipcProxyException | For errors when connecting to a proxy server
TipcException | For all other errors

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace |


TipcSvc.createConnServer Method

Create a new peer-to-peer server connection.

This method creates the server end of a peer-to-peer connection. The protocol, hostname, and port number are specified using the same "logical connection name" (LCN) as the client connection.

This connection is only used to accept connections from clients. All actual communication is done with the client connection returned by accept.

Example:

// create the server-side of a connection listening via TCP on port 8002
TipcConnServer srvConn = TipcSvc.createConnServer("tcp:_node:8002");

// accept a client connection
TipcConnClient conn = srvConn.accept();

// get the next message sent by the client
TipcMsg msg = conn.next(10.0);

public static TipcConnServer createConnServer(
string lcn
);

Parameters

lcn
the logical connection name to use for the connection

Return Value

the new connection interface

Exceptions

Exception Type | Condition
TipcBadArgumentException | If the LCN is invalid
TipcAssertionException | If the LCN hostname is unknown
TipcIOException | For lower-level errors
TipcException | For all other errors

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace | |


createMsg Method

SmartSockets .NET Class Library

TipcSvc.createMsg Method

Creates a new SmartSockets message of the specified message type number.

Example:

// create a message of the standard message type INFO
TipcMsg msg = TipcSvc.createMsg(TipcMt_Fields.INFO);

Overload List

Creates a new SmartSockets message of the specified message type number. Example:

// create a message of the standard message type INFO
TipcMsg msg = TipcSvc.createMsg(TipcMt_Fields.INFO);

public static TipcMsg createMsg(int);

Creates a new SmartSockets message by deserializing the contents of a byte array.

public static TipcMsg createMsg(sbyte[],int);

Creates a new message by deserializing the contents of a byte array.

public static TipcMsg createMsg(sbyte[],int,int,int,int);

Creates a new SmartSockets message of the specified message type. Example:

// look up the message type number 500
TipcMt mt = TipcSvc.lookupMt(500);

// create a message of this type
TipcMsg msg = TipcSvc.createMsg(mt);

public static TipcMsg createMsg(TipcMt);

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace | |


TipcSvc.createMsg Method (Int32)

Creates a new SmartSockets message of the specified message type number.

Example:

// create a message of the standard message type INFO
TipcMsg msg = TipcSvc.createMsg(TipcMt_Fields.INFO);

public static TipcMsg createMsg(
int mtNum
);

Parameters

mtNum
the message's message type number.

Return Value

the new message, or null if the message type doesn't exist.

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace | TipcSvc.createMsg Overload List | |


TipcSvc.createMsg Method (SByte[], Int32)

Creates a new SmartSockets message by deserializing the contents of a byte array.

public static TipcMsg createMsg(
sbyte[] buf,
int offset
);

Parameters

buf
a byte array containing the message to be deserialized
offset
index into buf indicating the start of the message

Exceptions

Exception Type | Condition
TipcMsgException | If there is an error deserializing the message
TipcException | For all other errors

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace | TipcSvc.createMsg Overload List |


TipcSvc.createMsg Method (SByte[], Int32, Int32, Int32, Int32)

Creates a new message by deserializing the contents of a byte array.

public static TipcMsg createMsg(
sbyte[] buf,
int offset,
int endian,
int realFormat,
int charFormat
);

Parameters

buf
a byte array containing the message to be deserialized
offset
index into buf indicating the start of the message
endian
INT_BIG_ENDIAN or INT_LITTLE_ENDIAN from TipcDefs.
realFormat
REAL_IEEE, REAL_DEC_D, REAL_DEC_G, REAL_370 from TipcDefs
charFormat
must be CHAR_US_ASCII from TipcDefs

Exceptions

Exception Type | Condition
TipcMsgException | If there is an error deserializing the message
TipcException | For all other errors

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace | TipcSvc.createMsg Overload List | |


TipcSvc.createMsg Method (TipcMt)

Creates a new SmartSockets message of the specified message type.

Example:

// look up the message type number 500
TipcMt mt = TipcSvc.lookupMt(500);

// create a message of this type
TipcMsg msg = TipcSvc.createMsg(mt);

public static TipcMsg createMsg(
TipcMt mt
);

Parameters

mt
the message's message type.

Return Value

the new message, or null if the message type doesn't exist.

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace | TipcSvc.createMsg Overload List | |


TipcSvc.createMt Method

Defines a new message type.

Once a message type is defined, it may be looked up with the name and number lookup functions.

For example, to define a new message type named "foo", which has the number '500', and is intended to take two integer fields and a string field, you'd do this:

TipcMt mt = TipcSvc.createMt("foo", 500, "int4 int4 str");

You may use the TipcMt object directly, or look up the instance by name or number, like any other predefined message type:

// look up a message type by name
TipcMt mt = TipcSvc.lookupMt("foo");

// look up a message type by number
TipcMt mt = TipcSvc.lookupMt(500);

public static TipcMt createMt(
string name,
int number,
string grammar
);

Parameters

name
name of the new message type.
number
reference number of the new message type. Numbers less than 1 are reserved for SmartSockets standard message types. A message number of 0 should not be used.
grammar
printable grammar for the new message type. The grammer identifies the type and order of fields in the message type, and is used when printing a message of this type.

Return Value

a new object implementing the TipcMt interface.

Exceptions

Exception Type | Condition
TipcAlreadyExistsException | An attempt was made to create a message type using a name or number that is already used by an existing message type.
TipcException | For all other errors

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace | | |


TipcSvc.createSrv Method

Creates a new TipcSrv RTserver connection object.

All RTserver connections share a common set of options set by the option assessor methods in the Tut class. Option values for a particular connection object may be overridden by using the option assessor methods available to the TipcSrv object, inherited from the TipcConnClient interface.

The one exception is the ss.unique_subject option. A new default unique subject will be generated for each TipcSrv object created by the this method.

Note: this method will not create a connection to RTserver. Use the create method to do this. The methods to send and receive messages will also automatically connect to RTserver.

Example:

// create a new connection object
TipcSrv srv = TipcSvc.createSrv();

// set the unique subject of the connection
srv.setOption("ss.unique_subject", "/publish_client");

// create the connection to the RTserver
srv.create();

RTserver must be running before a connection is made. The .NET library does not attempt to start an instance of RTserver.

public static TipcSrv createSrv();

Return Value

a new TipcSrv object

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace | |


lookupMt Method

SmartSockets .NET Class Library

TipcSvc.lookupMt Method

Returns a message type indexed by number.

This message type must be one of the standard SmartSockets message types, or a type previously defined with createMt. The standard SmartSockets message types have numeric constants defined in TipcMt.

Example:

// look up the message type number 500
TipcMt mt = TipcSvc.lookupMt(500);

Overload List

Returns a message type indexed by number. This message type must be one of the standard SmartSockets message types, or a type previously defined with createMt. The standard SmartSockets message types have numeric constants defined in TipcMt. Example:

// look up the message type number 500
TipcMt mt = TipcSvc.lookupMt(500);

public static TipcMt lookupMt(int);

Returns the message type indexed by name. This message type must be one of the standard SmartSockets message types, or a type previously defined with createMt. Example:

// look up the message type named "foo"
TipcMt mt = TipcSvc.lookupMt("foo");

public static TipcMt lookupMt(string);

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace | | |


TipcSvc.lookupMt Method (Int32)

Returns a message type indexed by number.

This message type must be one of the standard SmartSockets message types, or a type previously defined with createMt. The standard SmartSockets message types have numeric constants defined in TipcMt.

Example:

// look up the message type number 500
TipcMt mt = TipcSvc.lookupMt(500);

public static TipcMt lookupMt(
int number
);

Parameters

number
the number of the message type to return.

Return Value

the message type looked up, or null if the number does not refer to an existing message type.

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace | TipcSvc.lookupMt Overload List | | |


TipcSvc.lookupMt Method (String)

Returns the message type indexed by name.

This message type must be one of the standard SmartSockets message types, or a type previously defined with createMt.

Example:

// look up the message type named "foo"
TipcMt mt = TipcSvc.lookupMt("foo");

public static TipcMt lookupMt(
string name
);

Parameters

name
name of the message type to return.

Return Value

the message type looked up, or null if the name does not refer to an existing message type.

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace | TipcSvc.lookupMt Overload List | | |


TipcSvc.makeSubjectAbsolute Method

If the subject is not absolute (doesn't start with "/"), tack on the default subject prefix, if it exists. If the prefix isn't set to anything, it simply returns the original name untouched.

This method should only be invoked when using the global RTserver connection via the Srv property. Otherwise, use makeSubjectAbsolute.

public static string makeSubjectAbsolute(
string os
);

Parameters

os
the subject to make absolute.

Return Value

the absolute subject.

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace


TipcSvc.matchSubjects Method

Matches two subject strings, one or both of which may be wildcarded.

Note: Subjects are not case sensitive.

public static bool matchSubjects(
string subj1,
string subj2
);

Parameters

subj1
the first subject
subj2
the second subject

Return Value

true if they match, false otherwise

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace


TipcSvc.validSubject Method

Checks that the subject is valid. Invalid subjects are null or empty subjects, those with only whitespace between subject delimiters.

public static bool validSubject(
string subject
);

Parameters

subject
the subject to check

Return Value

true if the subject is valid, false otherwise.

See Also

TipcSvc Class | TIBCO.SMARTSOCKETS Namespace


TipcTimeoutException Class

Thrown if a timeout occurs while attempting to establish a connection.

For a list of all members of this type, see TipcTimeoutException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcTimeoutException

public class TipcTimeoutException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcTimeoutException Members | TIBCO.SMARTSOCKETS Namespace


TipcTimeoutException Members

TipcTimeoutException overview

Public Instance Constructors

TipcTimeoutException Overloaded. Initializes a new instance of the TipcTimeoutException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcTimeoutException Class | TIBCO.SMARTSOCKETS Namespace


TipcTimeoutException Constructor

Constructs a TipcTimeoutException with null as its error message string.

Overload List

Constructs a TipcTimeoutException with null as its error message string.

public TipcTimeoutException();

Constructs a TipcTimeoutException with an error message.

public TipcTimeoutException(string);

See Also

TipcTimeoutException Class | TIBCO.SMARTSOCKETS Namespace


TipcTimeoutException Constructor ()

Constructs a TipcTimeoutException with null as its error message string.

public TipcTimeoutException();

See Also

TipcTimeoutException Class | TIBCO.SMARTSOCKETS Namespace | TipcTimeoutException Constructor Overload List


TipcTimeoutException Constructor (String)

Constructs a TipcTimeoutException with an error message.

public TipcTimeoutException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcTimeoutException Class | TIBCO.SMARTSOCKETS Namespace | TipcTimeoutException Constructor Overload List


TipcUtf8Buffer Class

A holder class for return object from the Tut.convertUcs2ToUtf8Ex method

For a list of all members of this type, see TipcUtf8Buffer Members.

System.Object
TIBCO.SMARTSOCKETS.TipcUtf8Buffer

public sealed class TipcUtf8Buffer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcUtf8Buffer Members | TIBCO.SMARTSOCKETS Namespace


TipcUtf8Buffer Members

TipcUtf8Buffer overview

Public Instance Constructors

TipcUtf8Buffer Constructor Constructor for TipcUtf8Buffer

Public Instance Fields

buf | This is the buffer that contains the UTF8 information
length | This is the length (number of bytes) of UTF8 data
offset | This is the offset, or the start, of the UTF8 data in buffer

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TipcUtf8Buffer Class | TIBCO.SMARTSOCKETS Namespace


TipcUtf8Buffer Constructor

Constructor for TipcUtf8Buffer

public TipcUtf8Buffer(
sbyte[] buf,
int offset,
int length
);

See Also

TipcUtf8Buffer Class | TIBCO.SMARTSOCKETS Namespace


TipcUtf8Buffer Fields

The fields of the TipcUtf8Buffer class are listed below. For a complete list of TipcUtf8Buffer class members, see the TipcUtf8Buffer Members topic.

Public Instance Fields

buf | This is the buffer that contains the UTF8 information
length | This is the length (number of bytes) of UTF8 data
offset | This is the offset, or the start, of the UTF8 data in buffer

See Also

TipcUtf8Buffer Class | TIBCO.SMARTSOCKETS Namespace


TipcUtf8Buffer.buf Field

This is the buffer that contains the UTF8 information

public sbyte[] buf;

See Also

TipcUtf8Buffer Class | TIBCO.SMARTSOCKETS Namespace


TipcUtf8Buffer.length Field

This is the length (number of bytes) of UTF8 data

public int length;

See Also

TipcUtf8Buffer Class | TIBCO.SMARTSOCKETS Namespace


TipcUtf8Buffer.offset Field

This is the offset, or the start, of the UTF8 data in buffer

public int offset;

See Also

TipcUtf8Buffer Class | TIBCO.SMARTSOCKETS Namespace


TipcWouldBlockException Class

Thrown if an attempt to send or flush would block and the non-blocking mode is set.

For a list of all members of this type, see TipcWouldBlockException Members.

System.Object
System.Exception
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcWouldBlockException

public class TipcWouldBlockException : TipcException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcWouldBlockException Members | TIBCO.SMARTSOCKETS Namespace


TipcWouldBlockException Members

TipcWouldBlockException overview

Public Instance Constructors

TipcWouldBlockException Overloaded. Initializes a new instance of the TipcWouldBlockException class.

Public Instance Properties

ErrNum (inherited from TipcException) | Returns the error number of this TipcException object.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcWouldBlockException Class | TIBCO.SMARTSOCKETS Namespace


TipcWouldBlockException Constructor

Constructs a TipcWouldBlockException with null as its error message string.

Overload List

Constructs a TipcWouldBlockException with null as its error message string.

public TipcWouldBlockException();

Constructs a TipcWouldBlockException with an error message.

public TipcWouldBlockException(string);

See Also

TipcWouldBlockException Class | TIBCO.SMARTSOCKETS Namespace


TipcWouldBlockException Constructor ()

Constructs a TipcWouldBlockException with null as its error message string.

public TipcWouldBlockException();

See Also

TipcWouldBlockException Class | TIBCO.SMARTSOCKETS Namespace | TipcWouldBlockException Constructor Overload List


TipcWouldBlockException Constructor (String)

Constructs a TipcWouldBlockException with an error message.

public TipcWouldBlockException(
string s
);

Parameters

s
the detailed error message.

See Also

TipcWouldBlockException Class | TIBCO.SMARTSOCKETS Namespace | TipcWouldBlockException Constructor Overload List


TipcWriteBufferChangeCb Interface

The user interface for write buffer change callbacks.

Write buffer change callbacks are executed when data is either flushed from the write buffer or written into write buffer THROUGH the message interface (i.e. with send(msg)) ONLY.

The TipcDataOutput write() methods themselves are accessible throughout this package. If data is added to write buffer by calling them directly, this will NOT trigger the write buffer change callbacks. This is because the purpose of the write buffer change callback is to allow the sending of client congestion messages. When the callback is triggered, if the congestion threshold has now been met, a congestion message will be sent out. This means that triggering the callbacks may result in data being written into the write buffer.

This, of course, cannot be allowed to happen in the middle of a message write. A congestion message must only be allowed to be written into the buffer when the logical write (not just the write() method call-- a logical write can consist of more than one call to the write() method; see TipcMsgImpl.writeWire() for an example) has been completed. Therefore, the writing of a message will trigger the write buffer change callback only AFTER the full message has been written (which involves possibly mutliple calls to the write() method).

By contrast, if the write() methods are invoked directly, outside of the message writing framework, there is no way to know, at the end of the write() method, whether or not the logical write has been completed. Therefore, there is no way to know if congestion message data may be safely added to the buffer at that time.

For a list of all members of this type, see TipcWriteBufferChangeCb Members.

public interface TipcWriteBufferChangeCb

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcWriteBufferChangeCb Members | TIBCO.SMARTSOCKETS Namespace


TipcWriteBufferChangeCb Members

TipcWriteBufferChangeCb overview

Public Instance Methods

changed Method invoked by the connection when an unrecoverable error has occured.

See Also

TipcWriteBufferChangeCb Interface | TIBCO.SMARTSOCKETS Namespace


TipcWriteBufferChangeCb Methods

The methods of the TipcWriteBufferChangeCb interface are listed below. For a complete list of TipcWriteBufferChangeCb interface members, see the TipcWriteBufferChangeCb Members topic.

Public Instance Methods

changed Method invoked by the connection when an unrecoverable error has occured.

See Also

TipcWriteBufferChangeCb Interface | TIBCO.SMARTSOCKETS Namespace


TipcWriteBufferChangeCb.changed Method

Method invoked by the connection when an unrecoverable error has occured.

void changed(
TipcMt mt,
bool flushed,
object arg
);

Parameters

mt
The TipcMt for encoding
flushed
Whether the buffer was flushed (or written to)
arg
The user-defined argument.

See Also

TipcWriteBufferChangeCb Interface | TIBCO.SMARTSOCKETS Namespace


TipcWriteBufferChangeEventArgs Class

This class contains event data for the TipcWriteBufferChangeEvent.

For a list of all members of this type, see TipcWriteBufferChangeEventArgs Members.

System.Object
System.EventArgs
TIBCO.SMARTSOCKETS.TipcWriteBufferChangeEventArgs

public class TipcWriteBufferChangeEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcWriteBufferChangeEventArgs Members | TIBCO.SMARTSOCKETS Namespace


TipcWriteBufferChangeEventArgs Members

TipcWriteBufferChangeEventArgs overview

Public Instance Properties

Flushed | Return flushed value.
Mt | Return message type of WriteBuffer

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcWriteBufferChangeEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcWriteBufferChangeEventArgs Properties

The properties of the TipcWriteBufferChangeEventArgs class are listed below. For a complete list of TipcWriteBufferChangeEventArgs class members, see the TipcWriteBufferChangeEventArgs Members topic.

Public Instance Properties

Flushed | Return flushed value.
Mt | Return message type of WriteBuffer

See Also

TipcWriteBufferChangeEventArgs Class | TIBCO.SMARTSOCKETS Namespace


Flushed Property

SmartSockets .NET Class Library

TipcWriteBufferChangeEventArgs.Flushed Property

Return flushed value.

public bool Flushed {get;}

See Also

TipcWriteBufferChangeEventArgs Class | TIBCO.SMARTSOCKETS Namespace


Mt Property

SmartSockets .NET Class Library

TipcWriteBufferChangeEventArgs.Mt Property

Return message type of WriteBuffer

public TipcMt Mt {get;}

See Also

TipcWriteBufferChangeEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcWriteBufferChangeHandler Delegate

Represents the method that will handle the TipcWriteBufferChangeEvent event.

public delegate void TipcWriteBufferChangeHandler(
object sender,
TipcWriteBufferChangeEventArgs e
);

Parameters

sender
The source of the event.
e
The TipcWriteBufferChangeEventArgs that contains the event data.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TIBCO.SMARTSOCKETS Namespace


TipcWriteCb Interface

The user interface for connection write callbacks.

Connection write callbacks are executed when an outgoing message is sent to a connection (that is, copied to a connection's write buffer). Write callbacks are most commonly used for writing outgoing messages to message files.

For a list of all members of this type, see TipcWriteCb Members.

public interface TipcWriteCb

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcWriteCb Members | TIBCO.SMARTSOCKETS Namespace |


TipcWriteCb Members

TipcWriteCb overview

Public Instance Methods

write Method invoked when a message is written to the write buffer.

See Also

TipcWriteCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcWriteCb Methods

The methods of the TipcWriteCb interface are listed below. For a complete list of TipcWriteCb interface members, see the TipcWriteCb Members topic.

Public Instance Methods

write Method invoked when a message is written to the write buffer.

See Also

TipcWriteCb Interface | TIBCO.SMARTSOCKETS Namespace |


TipcWriteCb.write Method

Method invoked when a message is written to the write buffer.

void write(
TipcMsg msg,
object arg
);

Parameters

msg
The message.
arg
The user-defined argument.

See Also

TipcWriteCb Interface | TIBCO.SMARTSOCKETS Namespace


TipcWriteEventArgs Class

This class contains event data for the TipcWriteEvent.

For a list of all members of this type, see TipcWriteEventArgs Members.

System.Object
System.EventArgs
TIBCO.SMARTSOCKETS.TipcWriteEventArgs

public class TipcWriteEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TipcWriteEventArgs Members | TIBCO.SMARTSOCKETS Namespace


TipcWriteEventArgs Members

TipcWriteEventArgs overview

Public Instance Constructors

TipcWriteEventArgs Constructor Constructor for the TipcWriteHandler

Public Instance Properties

Msg Returns message of the TipcWriteHandler

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TipcWriteEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcWriteEventArgs Constructor

Constructor for the TipcWriteHandler

public TipcWriteEventArgs(
TipcMsg msg
);

See Also

TipcWriteEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcWriteEventArgs Properties

The properties of the TipcWriteEventArgs class are listed below. For a complete list of TipcWriteEventArgs class members, see the TipcWriteEventArgs Members topic.

Public Instance Properties

Msg Returns message of the TipcWriteHandler

See Also

TipcWriteEventArgs Class | TIBCO.SMARTSOCKETS Namespace


Msg Property

SmartSockets .NET Class Library

TipcWriteEventArgs.Msg Property

Returns message of the TipcWriteHandler

public TipcMsg Msg {get;}

See Also

TipcWriteEventArgs Class | TIBCO.SMARTSOCKETS Namespace


TipcWriteHandler Delegate

Represents the method that will handle the TipcWriteEvent event.

public delegate void TipcWriteHandler(
object sender,
TipcWriteEventArgs e
);

Parameters

sender
The source of the event.
e
The TipcWriteEventArgs that contains the event data.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TIBCO.SMARTSOCKETS Namespace


Trace Class

Trace encapsulates the tracing facility, allowing users to associate trace levels with their log messages.

For a list of all members of this type, see Trace Members.

System.Object
TIBCO.SMARTSOCKETS.Trace

public class Trace

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

Trace Members | TIBCO.SMARTSOCKETS Namespace


Trace Members

Trace overview

Public Static Methods

debug | Logs a message at trace_level DEBUG.
error | Logs a message at trace_level ERROR.
getTrace | The Trace singleton accessor
info | Logs a message at trace_level INFO.
verbose | Logs a message at trace_level VERBOSE.
warning | Logs a message at trace_level WARNING.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Trace Class | TIBCO.SMARTSOCKETS Namespace


Trace Methods

The methods of the Trace class are listed below. For a complete list of Trace class members, see the Trace Members topic.

Public Static Methods

debug | Logs a message at trace_level DEBUG.
error | Logs a message at trace_level ERROR.
getTrace | The Trace singleton accessor
info | Logs a message at trace_level INFO.
verbose | Logs a message at trace_level VERBOSE.
warning | Logs a message at trace_level WARNING.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Trace Class | TIBCO.SMARTSOCKETS Namespace


Trace.debug Method

Logs a message at trace_level DEBUG.

public static void debug(
object prefix,
object message
);

Parameters

prefix
The object used to generate the message prefix, most often the 'this' pointer.
message
The object used to generate the message text.

See Also

Trace Class | TIBCO.SMARTSOCKETS Namespace


Trace.error Method

Logs a message at trace_level ERROR.

public static void error(
object prefix,
object message
);

Parameters

prefix
The object used to generate the message prefix, most often the 'this' pointer.
message
The object used to generate the message text.

See Also

Trace Class | TIBCO.SMARTSOCKETS Namespace


Trace.getTrace Method

The Trace singleton accessor

public static Trace getTrace();

See Also

Trace Class | TIBCO.SMARTSOCKETS Namespace


Trace.info Method

Logs a message at trace_level INFO.

public static void info(
object prefix,
object message
);

Parameters

prefix
The object used to generate the message prefix, most often the 'this' pointer.
message
The object used to generate the message text.

See Also

Trace Class | TIBCO.SMARTSOCKETS Namespace


Trace.verbose Method

Logs a message at trace_level VERBOSE.

public static void verbose(
object prefix,
object message
);

Parameters

prefix
The object used to generate the message prefix, most often the 'this' pointer.
message
The object used to generate the message text.

See Also

Trace Class | TIBCO.SMARTSOCKETS Namespace


Trace.warning Method

Logs a message at trace_level WARNING.

public static void warning(
object prefix,
object message
);

Parameters

prefix
The object used to generate the message prefix, most often the 'this' pointer.
message
The object used to generate the message text.

See Also

Trace Class | TIBCO.SMARTSOCKETS Namespace


Tut Class

A collection of static utility methods.

All handling of settable global options is done here and in the TipcOption class. Options may also be set on a per connection basis through the TipcConnClient interface.

Options are loaded using the Properties mechanism, which requires text files containing key/value pairs. These files can either be loaded from the local filesystem, or remotely via a URL.

The keys in a property file are, by convention, stated in a heirarchy using dots as a separator. All SmartSockets options are in the "ss" hierarchy, so all of them start with "ss.". An example of an options file would be:

ss.project: sat1
ss.server_auto_connect: false
ss.unique_subject: node1
Option names and values are case-sensitive. There are methods in this class to extract values as strings, integers, doubles, booleans, and enumerated values. For enumerations, there are methods to set the list of valid values, and their corresponding int values.

For a list of all members of this type, see Tut Members.

System.Object
TIBCO.SMARTSOCKETS.Tut

public sealed class Tut

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

Tut Members | TIBCO.SMARTSOCKETS Namespace | |


Tut Members

Tut overview

Public Static Properties

CurrentTime | Gets the current SmartSockets data time. This time value only changes when the CurrentTime property is set. It may be used as a marker or unchanging reference.
CurrentTimeStr | Gets the current SmartSockets data time. This time value only changes when the CurrentTime property is set. It may be used as a marker or unchanging reference.
ExpectAborts | Boolean property that controls if expect throws an exception. When True the warning string is displayed and an exception is thrown. When False only the warning string is displayed.
Node | Return the local host name.
Properties | Returns the option values shared by all connections as TipcProperties.
WallTime | Gets the current system wall time. Wall time is defined as the number of seconds since midnight, Jan 1 1970 GMT (same as standard Unix time).
WallTimeStr | Gets the current system wall time. Wall time is defined as the number of seconds since midnight, Jan 1 1970 GMT (same as standard Unix time).

Public Static Methods

affirm | Overloaded. Tests a condition for truth, throws a TipcAssertionException if the test fails, using an explanatory message.
assert | Overloaded. Tests a condition for truth, throws a TipcAssertionException if the test fails, using an explanatory message.
convertUcs2ToUtf8 | Converts a Unicode string to a null-terminated, UTF-8 encoded, array of bytes. Note that this encoding is not the same as the default writeUTF and readUTF encoding, which is a length, data encoding. Our encoding is fully compatible with standard C ASCII strings so long as only ASCII is used. The default encoding is not only incompatible with this, but requires knowledge of the endian to swap the two-byte length.
convertUcs2ToUtf8Ex | Converts a Unicode string to a null-terminated, UTF-8 encoded, array of bytes. Note that this encoding is not the same as the default writeUTF and readUTF encoding, which is a length, data encoding. Our encoding is fully compatible with standard C ASCII strings so long as only ASCII is used. The default encoding is not only incompatible with this, but requires knowledge of the endian to swap the two-byte length. This method returns an instance of a TipcUtf8Buffer class which increases the performance. Instead of copying a the buffer, an instance of the TipcUtf8Buffer class is returned, which contains the buffer and the offset and length of the UTF8 data.
createGuid | Creates a guid.
createOption | Creates a new global option.
cvtTimeout | Converts SmartSockets second-based double timeouts to millisecond long timeouts.
exitFailure | Exits with a message and a non-zero exit code.
exitSuccess | Exits with a zero exit code. Convenience function to match exitFailure.
expect | Test a condition for truth, prints a warning message if the it fails. Will optionally throw a TipcAssertionException as well if the ExpectAborts property is set.
fatal | Prints a stack trace to the "standard" output stream, the text of the exception as a fatal error message, and exits with a non-zero exit code.
fromHexString | Convert a String containing hex numbers into a byte array containing those binary values.
getOption | Get a TipcOption.
getOptionBool | Convenience method to get a boolean value from an option by name.
getOptionDouble | Convenience method to get a double value from an option by name.
getOptionInt | Convenience method to get an integer value from an option by name.
getOptionStr | Convenience method to get a string value from a TipcOption by name.
getOut | Gets the SmartSockets "standard" output stream.
guidToStr | Converts a binary GUID into a printable String.
loadOptions | Overloaded. Loads options from the application configuration file. Loaded options override existing options with the same key. Note: If the options cannot be loaded, a warning is issued to the "Standard" output.
loadOptionsStream | Loads options from an InputStream. Loaded options override existing options with the same key. Note: If the stream cannot be loaded, a warning is issued to the "Standard" output.
msgIdToStr | Converts a binary message ID into a printable String.
Out | Prints a message to the SmartSockets "standard" output stream.
removeOption | Overloaded. Removes a global option.
setOption | Convenience method to set an option by name.
setOut | Reassigns the SmartSockets "standard" output stream. Reassigning to null suppresses SmartSockets from printing to the output stream. The default is System.out.
sleep | Sleeps for a period of time. This is a replacement for Thread.sleep(), which avoids a known problem with priorities and network connections, that makes Thread.sleep() hang a process forever. This method also follows the SmartSockets convention of using a double time in seconds, rather than a long in milliseconds.
strToGuid | Converts a String formatted like the output of guidToStr and converts it to a binary GUID.
strToMsgId | Converts a String formatted like the output of msgIdToStr and converts it to a binary message ID.
swapEight | Swaps eight bytes in place.
swapFour | Swaps four bytes in place.
swapTwo | Swaps two bytes in place.
toHexString | Returns a String containing the argument as two hex digits, using a leading zero, if necessary. Also doesn't do sign extension, as the JDK Integer method does.
warning | Overloaded. Prints a warning message to the "standard" output stream.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | |


Tut Properties

The properties of the Tut class are listed below. For a complete list of Tut class members, see the Tut Members topic.

Public Static Properties

CurrentTime | Gets the current SmartSockets data time. This time value only changes when the CurrentTime property is set. It may be used as a marker or unchanging reference.
CurrentTimeStr | Gets the current SmartSockets data time. This time value only changes when the CurrentTime property is set. It may be used as a marker or unchanging reference.
ExpectAborts | Boolean property that controls if expect throws an exception. When True the warning string is displayed and an exception is thrown. When False only the warning string is displayed.
Node | Return the local host name.
Properties | Returns the option values shared by all connections as TipcProperties.
WallTime | Gets the current system wall time. Wall time is defined as the number of seconds since midnight, Jan 1 1970 GMT (same as standard Unix time).
WallTimeStr | Gets the current system wall time. Wall time is defined as the number of seconds since midnight, Jan 1 1970 GMT (same as standard Unix time).

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | |


CurrentTime Property

SmartSockets .NET Class Library

Tut.CurrentTime Property

Gets the current SmartSockets data time. This time value only changes when the CurrentTime property is set. It may be used as a marker or unchanging reference.

public static double CurrentTime {get; set;}

Exceptions

Exception Type | Condition
TipcBadArgumentException | If time is negative

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


CurrentTimeStr Property

SmartSockets .NET Class Library

Tut.CurrentTimeStr Property

Gets the current SmartSockets data time. This time value only changes when the CurrentTime property is set. It may be used as a marker or unchanging reference.

public static string CurrentTimeStr {get;}

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


ExpectAborts Property

SmartSockets .NET Class Library

Tut.ExpectAborts Property

Boolean property that controls if expect throws an exception. When True the warning string is displayed and an exception is thrown. When False only the warning string is displayed.

public static bool ExpectAborts {get; set;}

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


Node Property

SmartSockets .NET Class Library

Tut.Node Property

Return the local host name.

public static string Node {get;}

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Properties Property

SmartSockets .NET Class Library

Tut.Properties Property

Returns the option values shared by all connections as TipcProperties.

public static TipcProperties Properties {get;}

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


WallTime Property

SmartSockets .NET Class Library

Tut.WallTime Property

Gets the current system wall time. Wall time is defined as the number of seconds since midnight, Jan 1 1970 GMT (same as standard Unix time).

public static double WallTime {get;}

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


WallTimeStr Property

SmartSockets .NET Class Library

Tut.WallTimeStr Property

Gets the current system wall time. Wall time is defined as the number of seconds since midnight, Jan 1 1970 GMT (same as standard Unix time).

public static string WallTimeStr {get;}

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Tut Methods

The methods of the Tut class are listed below. For a complete list of Tut class members, see the Tut Members topic.

Public Static Methods

affirm | Overloaded. Tests a condition for truth, throws a TipcAssertionException if the test fails, using an explanatory message.
assert | Overloaded. Tests a condition for truth, throws a TipcAssertionException if the test fails, using an explanatory message.
convertUcs2ToUtf8 | Converts a Unicode string to a null-terminated, UTF-8 encoded, array of bytes. Note that this encoding is not the same as the default writeUTF and readUTF encoding, which is a length, data encoding. Our encoding is fully compatible with standard C ASCII strings so long as only ASCII is used. The default encoding is not only incompatible with this, but requires knowledge of the endian to swap the two-byte length.
convertUcs2ToUtf8Ex | Converts a Unicode string to a null-terminated, UTF-8 encoded, array of bytes. Note that this encoding is not the same as the default writeUTF and readUTF encoding, which is a length, data encoding. Our encoding is fully compatible with standard C ASCII strings so long as only ASCII is used. The default encoding is not only incompatible with this, but requires knowledge of the endian to swap the two-byte length. This method returns an instance of a TipcUtf8Buffer class which increases the performance. Instead of copying a the buffer, an instance of the TipcUtf8Buffer class is returned, which contains the buffer and the offset and length of the UTF8 data.
createGuid | Creates a guid.
createOption | Creates a new global option.
cvtTimeout | Converts SmartSockets second-based double timeouts to millisecond long timeouts.
exitFailure | Exits with a message and a non-zero exit code.
exitSuccess | Exits with a zero exit code. Convenience function to match exitFailure.
expect | Test a condition for truth, prints a warning message if the it fails. Will optionally throw a TipcAssertionException as well if the ExpectAborts property is set.
fatal | Prints a stack trace to the "standard" output stream, the text of the exception as a fatal error message, and exits with a non-zero exit code.
fromHexString | Convert a String containing hex numbers into a byte array containing those binary values.
getOption | Get a TipcOption.
getOptionBool | Convenience method to get a boolean value from an option by name.
getOptionDouble | Convenience method to get a double value from an option by name.
getOptionInt | Convenience method to get an integer value from an option by name.
getOptionStr | Convenience method to get a string value from a TipcOption by name.
getOut | Gets the SmartSockets "standard" output stream.
guidToStr | Converts a binary GUID into a printable String.
loadOptions | Overloaded. Loads options from the application configuration file. Loaded options override existing options with the same key. Note: If the options cannot be loaded, a warning is issued to the "Standard" output.
loadOptionsStream | Loads options from an InputStream. Loaded options override existing options with the same key. Note: If the stream cannot be loaded, a warning is issued to the "Standard" output.
msgIdToStr | Converts a binary message ID into a printable String.
Out | Prints a message to the SmartSockets "standard" output stream.
removeOption | Overloaded. Removes a global option.
setOption | Convenience method to set an option by name.
setOut | Reassigns the SmartSockets "standard" output stream. Reassigning to null suppresses SmartSockets from printing to the output stream. The default is System.out.
sleep | Sleeps for a period of time. This is a replacement for Thread.sleep(), which avoids a known problem with priorities and network connections, that makes Thread.sleep() hang a process forever. This method also follows the SmartSockets convention of using a double time in seconds, rather than a long in milliseconds.
strToGuid | Converts a String formatted like the output of guidToStr and converts it to a binary GUID.
strToMsgId | Converts a String formatted like the output of msgIdToStr and converts it to a binary message ID.
swapEight | Swaps eight bytes in place.
swapFour | Swaps four bytes in place.
swapTwo | Swaps two bytes in place.
toHexString | Returns a String containing the argument as two hex digits, using a leading zero, if necessary. Also doesn't do sign extension, as the JDK Integer method does.
warning | Overloaded. Prints a warning message to the "standard" output stream.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | |


affirm Method

SmartSockets .NET Class Library

Tut.affirm Method

Tests a condition for truth, throws a TipcAssertionException if the test fails.

Overload List

Tests a condition for truth, throws a TipcAssertionException if the test fails.

public static void affirm(bool);

Tests a condition for truth, throws a TipcAssertionException if the test fails, using an explanatory message.

public static void affirm(bool,string);

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Tut.affirm Method (Boolean)

Tests a condition for truth, throws a TipcAssertionException if the test fails.

public static void affirm(
bool test
);

Parameters

test
the boolean to check

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | Tut.affirm Overload List


Tut.affirm Method (Boolean, String)

Tests a condition for truth, throws a TipcAssertionException if the test fails, using an explanatory message.

public static void affirm(
bool test,
string m
);

Parameters

test
the boolean to check
m
a String to print with the error

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | Tut.affirm Overload List


assert Method

SmartSockets .NET Class Library

Tut.assert Method

Tests a condition for truth, throws a TipcAssertionException if the test fails.

Overload List

Tests a condition for truth, throws a TipcAssertionException if the test fails.

public static void assert(bool);

Tests a condition for truth, throws a TipcAssertionException if the test fails, using an explanatory message.

public static void assert(bool,string);

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Tut.assert Method (Boolean)

Tests a condition for truth, throws a TipcAssertionException if the test fails.

public static void assert(
bool test
);

Parameters

test
the boolean to check

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | Tut.assert Overload List


Tut.assert Method (Boolean, String)

Tests a condition for truth, throws a TipcAssertionException if the test fails, using an explanatory message.

public static void assert(
bool test,
string m
);

Parameters

test
the boolean to check
m
a String to print with the error

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | Tut.assert Overload List


Tut.convertUcs2ToUtf8 Method

Converts a Unicode string to a null-terminated, UTF-8 encoded, array of bytes.

Note that this encoding is not the same as the default writeUTF and readUTF encoding, which is a length, data encoding. Our encoding is fully compatible with standard C ASCII strings so long as only ASCII is used. The default encoding is not only incompatible with this, but requires knowledge of the endian to swap the two-byte length.

public static sbyte[] convertUcs2ToUtf8(
string s
);

Parameters

s
the Unicode string to convert.

Return Value

the UTF-8 encoded byte array.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Tut.convertUcs2ToUtf8Ex Method

Converts a Unicode string to a null-terminated, UTF-8 encoded, array of bytes.

Note that this encoding is not the same as the default writeUTF and readUTF encoding, which is a length, data encoding. Our encoding is fully compatible with standard C ASCII strings so long as only ASCII is used. The default encoding is not only incompatible with this, but requires knowledge of the endian to swap the two-byte length.

This method returns an instance of a TipcUtf8Buffer class which increases the performance. Instead of copying a the buffer, an instance of the TipcUtf8Buffer class is returned, which contains the buffer and the offset and length of the UTF8 data.

public static TipcUtf8Buffer convertUcs2ToUtf8Ex(
string s
);

Parameters

s
the Unicode string to convert.

Return Value

the UTF-8 encoded byte array.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Tut.createGuid Method

Creates a guid.

public static sbyte[] createGuid();

Return Value

the new guid

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Tut.createOption Method

Creates a new global option.

public static TipcOption createOption(
string name,
string value
);

Parameters

name
the option to create.
value
the initial value of the option, which may be null.

Return Value

the new TipcOption

Exceptions

Exception Type | Condition
TipcAlreadyExistsException | If an option by that name already exists.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | | | |


Tut.cvtTimeout Method

Converts SmartSockets second-based double timeouts to millisecond long timeouts.

public static long cvtTimeout(
double timeout
);

Parameters

timeout
the timeout to convert

Return Value

the converted timeout

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Tut.exitFailure Method

Exits with a message and a non-zero exit code.

public static void exitFailure(
string s
);

Parameters

s
the message to print

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Tut.exitSuccess Method

Exits with a zero exit code.

Convenience function to match exitFailure.

public static void exitSuccess();

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


Tut.expect Method

Test a condition for truth, prints a warning message if the it fails. Will optionally throw a TipcAssertionException as well if the ExpectAborts property is set.

public static void expect(
bool test,
string m
);

Parameters

test
the boolean to check
m
an explanatory message to print with the warning. This is mandatory, since there is no other way of determining where or why the warning occurred.

Exceptions

Exception Type | Condition
TipcAssertionException | If test fails and ExpectAborts property is True. (note: TipcAssertionException is a runtime exception)

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


Tut.fatal Method

Prints a stack trace to the "standard" output stream, the text of the exception as a fatal error message, and exits with a non-zero exit code.

public static void fatal(
Exception e
);

Parameters

e
the Exception that will used to print the stack trace and the warning.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


Tut.fromHexString Method

Convert a String containing hex numbers into a byte array containing those binary values.

public static sbyte[] fromHexString(
string s,
int off,
int len
);

Parameters

s
string to convert
off
offset into the string (in single-byte characters)
len
length of the resulting data block in bytes (not the number of chars!)

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Tut.getOption Method

Get a TipcOption.

public static TipcOption getOption(
string name
);

Parameters

name
the name of the TipcOption to get

Return Value

the TipcOption

Exceptions

Exception Type | Condition
TipcNotFoundException | If the named option doesn't exist

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | |


Tut.getOptionBool Method

Convenience method to get a boolean value from an option by name.

public static bool getOptionBool(
string name
);

Parameters

name
the name of the option to get

Return Value

the value of the option as a boolean

Exceptions

Exception Type | Condition
TipcNotFoundException | If the named option doesn't exist, or if the value cannot be converted to a valid boolean.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | |


Tut.getOptionDouble Method

Convenience method to get a double value from an option by name.

public static double getOptionDouble(
string name
);

Parameters

name
the name of the option to get

Return Value

the value of the option as a double.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the named option doesn't exist, or if the value cannot be converted to a valid double.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | |


Tut.getOptionInt Method

Convenience method to get an integer value from an option by name.

public static int getOptionInt(
string name
);

Parameters

name
the name of the option to get

Return Value

the value of the option as an integer.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the named option doesn't exist, or if the value cannot be converted to a valid integer.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | |


Tut.getOptionStr Method

Convenience method to get a string value from a TipcOption by name.

public static string getOptionStr(
string name
);

Parameters

name
the name of the option to get

Return Value

the value of the option as a String

Exceptions

Exception Type | Condition
TipcNotFoundException | If the named option doesn't exist

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | |


Tut.getOut Method

Gets the SmartSockets "standard" output stream.

public static StreamWriter getOut();

Return Value

the SmartSockets standard output stream

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


Tut.guidToStr Method

Converts a binary GUID into a printable String.

public static string guidToStr(
sbyte[] buf,
int offset
);

Parameters

buf
the binary GUID
offset
the offset into the byte array

Return Value

string representing the GUID

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


loadOptions Method

SmartSockets .NET Class Library

Tut.loadOptions Method

Loads options from the application configuration file.

Loaded options override existing options with the same key.

Note: If the options cannot be loaded, a warning is issued to the "Standard" output.

Overload List

Loads options from the application configuration file. Loaded options override existing options with the same key. Note: If the options cannot be loaded, a warning is issued to the "Standard" output.

public static void loadOptions();

Loads options from the application configuration file. Loaded options override existing options with the same key. Note: If the options cannot be loaded, a warning is issued to the "Standard" output.

public static void loadOptions(string);

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


Tut.loadOptions Method ()

Loads options from the application configuration file.

Loaded options override existing options with the same key.

Note: If the options cannot be loaded, a warning is issued to the "Standard" output.

public static void loadOptions();

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | Tut.loadOptions Overload List |


Tut.loadOptions Method (String)

Loads options from the application configuration file.

Loaded options override existing options with the same key.

Note: If the options cannot be loaded, a warning is issued to the "Standard" output.

public static void loadOptions(
string location
);

Parameters

location
the file or URL to load options from.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | Tut.loadOptions Overload List |


Tut.loadOptionsStream Method

Loads options from an InputStream.

Loaded options override existing options with the same key.

Note: If the stream cannot be loaded, a warning is issued to the "Standard" output.

public static void loadOptionsStream(
Stream strm
);

Parameters

strm
the stream to load the options from.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


Tut.msgIdToStr Method

Converts a binary message ID into a printable String.

public static string msgIdToStr(
sbyte[] buf,
int offset
);

Parameters

buf
the binary GUID
offset
the offset into the byte array

Return Value

string representing the message ID

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


Tut.Out Method

Prints a message to the SmartSockets "standard" output stream.

public static void Out(
string s
);

Parameters

s
the message to print

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | |


removeOption Method

SmartSockets .NET Class Library

Tut.removeOption Method

Removes a global option.

Overload List

Removes a global option.

public static TipcOption removeOption(string);

Removes a global option.

public static TipcOption removeOption(TipcOption);

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | |


Tut.removeOption Method (String)

Removes a global option.

public static TipcOption removeOption(
string name
);

Parameters

name
the option to remove.

Return Value

the TipcOption.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the named option does not exist.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | Tut.removeOption Overload List | |


Tut.removeOption Method (TipcOption)

Removes a global option.

public static TipcOption removeOption(
TipcOption opt
);

Parameters

opt
the option to remove.

Return Value

the TipcOption.

Exceptions

Exception Type | Condition
TipcNotFoundException | If the TipcOption does not exist.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | Tut.removeOption Overload List | |


Tut.setOption Method

Convenience method to set an option by name.

public static TipcOption setOption(
string name,
string value
);

Parameters

name
the name of the option to set
value
the value of the option

Return Value

the TipcOption

Exceptions

Exception Type | Condition
TipcNotFoundException | If the named option doesn't exist
TipcReadOnlyException | If the named option is read only

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | | | | | |


Tut.setOut Method

Reassigns the SmartSockets "standard" output stream. Reassigning to null suppresses SmartSockets from printing to the output stream. The default is System.out.

public static void setOut(
StreamWriter outStream
);

Parameters

outStream
the new SmartSockets standard output stream

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


Tut.sleep Method

Sleeps for a period of time.

This is a replacement for Thread.sleep(), which avoids a known problem with priorities and network connections, that makes Thread.sleep() hang a process forever. This method also follows the SmartSockets convention of using a double time in seconds, rather than a long in milliseconds.

public static void sleep(
double t
);

Parameters

t
time to sleep (in seconds).

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Tut.strToGuid Method

Converts a String formatted like the output of guidToStr and converts it to a binary GUID.

public static sbyte[] strToGuid(
string str
);

Return Value

a byte array corresponding to the GUID

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


Tut.strToMsgId Method

Converts a String formatted like the output of msgIdToStr and converts it to a binary message ID.

public static sbyte[] strToMsgId(
string str
);

Return Value

a byte array corresponding to the Msg ID

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


Tut.swapEight Method

Swaps eight bytes in place.

public static void swapEight(
sbyte[] buf,
int offset
);

Parameters

buf
the byte array holding the bytes to be swapped.
offset
the offset into the byte array

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Tut.swapFour Method

Swaps four bytes in place.

public static void swapFour(
sbyte[] buf,
int offset
);

Parameters

buf
the byte array holding the bytes to be swapped.
offset
the offset into the byte array

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Tut.swapTwo Method

Swaps two bytes in place.

public static void swapTwo(
sbyte[] buf,
int offset
);

Parameters

buf
the byte array holding the bytes to be swapped.
offset
the offset into the byte array

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


Tut.toHexString Method

Returns a String containing the argument as two hex digits, using a leading zero, if necessary. Also doesn't do sign extension, as the JDK Integer method does.

public static string toHexString(
sbyte b
);

Parameters

b
the byte to convert

Return Value

the byte as a displayable String

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace


warning Method

SmartSockets .NET Class Library

Tut.warning Method

Prints a stack trace and a warning message to the "standard" output stream, using the text from the exception as the body of the message.

Overload List

Prints a stack trace and a warning message to the "standard" output stream, using the text from the exception as the body of the message.

public static void warning(Exception);

Prints a warning message to the "standard" output stream.

public static void warning(string);

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace |


Tut.warning Method (Exception)

Prints a stack trace and a warning message to the "standard" output stream, using the text from the exception as the body of the message.

public static void warning(
Exception e
);

Parameters

e
the Exception that will used to print the stack trace and the warning.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | Tut.warning Overload List |


Tut.warning Method (String)

Prints a warning message to the "standard" output stream.

public static void warning(
string s
);

Parameters

s
the message to print.

See Also

Tut Class | TIBCO.SMARTSOCKETS Namespace | Tut.warning Overload List |


TutXml Class

Represents an XML object that can be sent within a SmartSockets message.

For a list of all members of this type, see TutXml Members.

System.Object
TIBCO.SMARTSOCKETS.TutXml

public class TutXml : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

TutXml Members | TIBCO.SMARTSOCKETS Namespace


TutXml Members

TutXml overview

Public Instance Constructors

TutXml Constructor Creates a new XML object containing the specified string.

Public Instance Properties

Str Gets the XML string associated with this XML object

Public Instance Methods

Clone | Clones the XML object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TutXml Class | TIBCO.SMARTSOCKETS Namespace


TutXml Constructor

Creates a new XML object containing the specified string.

public TutXml(
string str
);

Parameters

str
the XML string.

See Also

TutXml Class | TIBCO.SMARTSOCKETS Namespace


TutXml Properties

The properties of the TutXml class are listed below. For a complete list of TutXml class members, see the TutXml Members topic.

Public Instance Properties

Str Gets the XML string associated with this XML object

See Also

TutXml Class | TIBCO.SMARTSOCKETS Namespace


Str Property

SmartSockets .NET Class Library

TutXml.Str Property

Gets the XML string associated with this XML object

public virtual string Str {get; set;}

See Also

TutXml Class | TIBCO.SMARTSOCKETS Namespace


TutXml Methods

The methods of the TutXml class are listed below. For a complete list of TutXml class members, see the TutXml Members topic.

Public Instance Methods

Clone | Clones the XML object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TutXml Class | TIBCO.SMARTSOCKETS Namespace


TutXml.Clone Method

Clones the XML object.

public virtual object Clone();

Return Value

a copy of the XML object.

Implements

ICloneable.Clone

See Also

TutXml Class | TIBCO.SMARTSOCKETS Namespace


Version Class

SmartSockets version class.

For a list of all members of this type, see Version Members.

System.Object
TIBCO.SMARTSOCKETS.Version

public class Version

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: TIBCO.SMARTSOCKETS

Assembly: TIBCO.SS (in TIBCO.SS.dll)

See Also

Version Members | TIBCO.SMARTSOCKETS Namespace


Version Members

Version overview

Public Static Methods

getVersion | Returns the SmartSockets version.
getVersionNumber | Returns the SmartSockets version number.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Version Class | TIBCO.SMARTSOCKETS Namespace


Version Methods

The methods of the Version class are listed below. For a complete list of Version class members, see the Version Members topic.

Public Static Methods

getVersion | Returns the SmartSockets version.
getVersionNumber | Returns the SmartSockets version number.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Version Class | TIBCO.SMARTSOCKETS Namespace


Version.getVersion Method

Returns the SmartSockets version.

public static string getVersion();

Return Value

the string representation of the SmartSockets for C# version

See Also

Version Class | TIBCO.SMARTSOCKETS Namespace


Version.getVersionNumber Method

Returns the SmartSockets version number.

public static int getVersionNumber();

Return Value

the numeric representation of the SmartSockets for C# version

See Also

Version Class | TIBCO.SMARTSOCKETS Namespace


TipcException Hierarchy

System.Object
Exception
TipcException
TipcAccessDeniedException
TipcAlreadyExistsException
TipcAlreadySubscribedException
TipcBadArgumentException
TipcFileNotFoundException
TipcInterruptedException
TipcIOException
TipcMalformedURLException
TipcMsgException
TipcNotFoundException
TipcNotSubscribedException
TipcProtocolMismatchException
TipcProxyException
TipcReadOnlyException
TipcSrvAlreadyConnectedException
TipcSrvNotConnectedException
TipcTimeoutException
TipcWouldBlockException

See Also

TipcException Class | TipcException Members | TIBCO.SMARTSOCKETS Namespace


TIBCO.SMARTSOCKETSHierarchy

SmartSockets .NET Class Library

TIBCO.SMARTSOCKETS Hierarchy

System.Object
System.Collections.Hashtable ---- System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable, System.ICloneable, System.Runtime.Serialization.IDeserializationCallback, System.Runtime.Serialization.ISerializable
TIBCO.SMARTSOCKETS.TipcProperties
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
TIBCO.SMARTSOCKETS.TipcErrorHandler
TIBCO.SMARTSOCKETS.TipcMsgHandler
TIBCO.SMARTSOCKETS.TipcQueueHandler
TIBCO.SMARTSOCKETS.TipcReadHandler
TIBCO.SMARTSOCKETS.TipcSrvCreateHandler
TIBCO.SMARTSOCKETS.TipcSrvDestroyHandler
TIBCO.SMARTSOCKETS.TipcWriteBufferChangeHandler
TIBCO.SMARTSOCKETS.TipcWriteHandler
System.EventArgs
TIBCO.SMARTSOCKETS.TipcErrorEventArgs
TIBCO.SMARTSOCKETS.TipcMsgEventArgs
TIBCO.SMARTSOCKETS.TipcQueueEventArgs
TIBCO.SMARTSOCKETS.TipcReadEventArgs
TIBCO.SMARTSOCKETS.TipcSrvCreateEventArgs
TIBCO.SMARTSOCKETS.TipcSrvDestroyEventArgs
TIBCO.SMARTSOCKETS.TipcWriteBufferChangeEventArgs
TIBCO.SMARTSOCKETS.TipcWriteEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
System.SystemException
TIBCO.SMARTSOCKETS.TipcRuntimeException
TIBCO.SMARTSOCKETS.TipcAssertionException
TIBCO.SMARTSOCKETS.TipcException
TIBCO.SMARTSOCKETS.TipcAccessDeniedException
TIBCO.SMARTSOCKETS.TipcAlreadyExistsException
TIBCO.SMARTSOCKETS.TipcAlreadySubscribedException
TIBCO.SMARTSOCKETS.TipcBadArgumentException
TIBCO.SMARTSOCKETS.TipcFileNotFoundException
TIBCO.SMARTSOCKETS.TipcInterruptedException
TIBCO.SMARTSOCKETS.TipcIOException
TIBCO.SMARTSOCKETS.TipcMalformedURLException
TIBCO.SMARTSOCKETS.TipcMsgException
TIBCO.SMARTSOCKETS.TipcMsgBadFieldException
TIBCO.SMARTSOCKETS.TipcMsgEomException
TIBCO.SMARTSOCKETS.TipcMsgUnknownFieldException
TIBCO.SMARTSOCKETS.TipcNotFoundException
TIBCO.SMARTSOCKETS.TipcNotSubscribedException
TIBCO.SMARTSOCKETS.TipcProtocolMismatchException
TIBCO.SMARTSOCKETS.TipcProxyException
TIBCO.SMARTSOCKETS.TipcReadOnlyException
TIBCO.SMARTSOCKETS.TipcSrvAlreadyConnectedException
TIBCO.SMARTSOCKETS.TipcSrvNotConnectedException
TIBCO.SMARTSOCKETS.TipcTimeoutException
TIBCO.SMARTSOCKETS.TipcWouldBlockException
System.ValueType
TIBCO.SMARTSOCKETS.TipcDefs
TIBCO.SMARTSOCKETS.TipcMsg_Fields
TIBCO.SMARTSOCKETS.TipcMt_Fields
TIBCO.SMARTSOCKETS.TipcCache
TIBCO.SMARTSOCKETS.TipcCb
TIBCO.SMARTSOCKETS.TipcConnClient
TIBCO.SMARTSOCKETS.TipcSrv
TIBCO.SMARTSOCKETS.TipcConnServer
TIBCO.SMARTSOCKETS.TipcCreateCb
TIBCO.SMARTSOCKETS.TipcDefaultCb
TIBCO.SMARTSOCKETS.TipcDestroyCb
TIBCO.SMARTSOCKETS.TipcErrorCb
TIBCO.SMARTSOCKETS.TipcMon
TIBCO.SMARTSOCKETS.TipcMonExt
TIBCO.SMARTSOCKETS.TipcMsg ---- System.ICloneable
TIBCO.SMARTSOCKETS.TipcMsgEnumerator ---- System.Collections.IEnumerator
TIBCO.SMARTSOCKETS.TipcMsgEnumeratorElement
TIBCO.SMARTSOCKETS.TipcMt
TIBCO.SMARTSOCKETS.TipcOption
TIBCO.SMARTSOCKETS.TipcProcessCb
TIBCO.SMARTSOCKETS.TipcQueueCb
TIBCO.SMARTSOCKETS.TipcReadCb
TIBCO.SMARTSOCKETS.TipcSearcher
TIBCO.SMARTSOCKETS.TipcSvc
TIBCO.SMARTSOCKETS.TipcUtf8Buffer
TIBCO.SMARTSOCKETS.TipcWriteBufferChangeCb
TIBCO.SMARTSOCKETS.TipcWriteCb
TIBCO.SMARTSOCKETS.Trace
TIBCO.SMARTSOCKETS.Tut
TIBCO.SMARTSOCKETS.TutXml ---- System.ICloneable
TIBCO.SMARTSOCKETS.Version

See Also

TIBCO.SMARTSOCKETS Namespace